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1 Introduction

About Aren Payroll

Getting Started

Aren Payroll is a payroll program that runs in the Microsoft
Windows environment. It enables you to set up a database
containing pay details of the employees in your organisation.
Data entry is interactive with income tax, loan payments, pen-
sion fund balances and other calculated amounts updated and
displayed as you work.

The system produces several payroll reports such as payslips,
payroll summary, payroll control account, cash and cheque
lists as well as monthly and annual tax returns. All reports
are formatted for A4 paper so there is no need to buy special
stationery.

Access to the system requires a username and a password.
There is one permanent user who has unrestricted access to
the entire system. Other users can be added at any time and
assigned access to those functions they need to use.

The program can be configured to suit the needs of your organ-
isation. For example, you can define an unlimited number of
payments and deductions. You can also update the tables used
for calculating statutory deductions should the need arise.

Aren Payroll supports multiple organisations which is conve-
nient if you need to run the payroll of more than one organisa-
tion on a single computer. A separate licence key is required
for each organisation.

For each organisation, four pay frequencies are supported, viz.
monthly, weekly, biweekly and irregular. The irregular pay
frequency caters for employees who are not paid after fixed
intervals.

To use Aren Payroll you must first install it and configure it
to suit your needs. The rest of this section shows you how to
begin this process.
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Installation

To install Aren Payroll:

1. Download the installation file pay10.0ent.msi from the
downloads page of our website:
https://www.aren.co.ke/payroll/download10.0.htm.

2. Double-click on the installation file to begin the instal-
lation process.

Welcome to the Aren Payroll 10.0 Enterprise Edition
Setup Wizard

The installer will quide vou through the steps required 10 install Aren Peyroll 10.0 Enterprize Editian
071001 COMmpUTEr,

WARMIMNG: This computer prograrm is pratacied by copwright law and international ireaties
Unauthorized duplicaion or distribution of tis grogram, or any partion of it may resull in seswana cid
or criminal penalies, and will be progecuted to the maxmum extent passible under the |aw.

Med > | Canca

Figure 1.1: Setup Wizard

3. Follow the on-screen instructions that appear during the
installation process (figure [L.1).

The installation process copies the files required by Aren Pay-
roll to the folder you specify on the hard disk of your computer.
It will also create a desktop icon for Aren Payroll.

Creating a Data Folder

1. Once the installation process is complete, start Aren
Payroll using the desktop icon created above.

2. In the Start dialog box that appears (figure [1.2)), click on
Data Folder to open the Data Folders dialog box (figure

13).

3. Click on Create in the Data Folders dialog to create a
new data folder in which to store Aren Payroll data.


https://www.aren.co.ke/payroll/download10.0.htm
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AREN PAYROLL

Version 10.0
Enterprise Edition for Kenya
® fren Software Lid, 1998-2025

[None]

Login | Cancel | Data Folder |

Figure 1.2: Start dialog box

Data Folders b4

Available Folders

Create... seect... || setwngs... |

Target Folder
[None]

Close I

Figure 1.3: Data Folders dialog box

You can locate your data folder anywhere you want on your
computer or on a shared folder on another computer. Make
sure you have unrestricted access to whichever location you
choose, otherwise the software may not work properly

Where the data folder is on another computer, that computer
needs to have Firebird installed and configured to work with
Aren Payroll. Appendix [A] shows you how to do this. If nec-
essary, set up Firebird before proceeding.

Setting up the Data Folder

You will need to edit the settings for the newly created data
folder.

1. Click on Settings in the Data Folders dialog to open the
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Data Folders Settings dialog (figure [1.4)).
Local Path
Ci\usersindini'\Payroll Data\Ke|10.0Payroll
Network Location
Hostname | lecalhost
Path on Host | C:\usersindiri\Payroll Data'Ke'10.0'Payrol
Firebird Server
Username | sysdba
T | zzzzzzzzz
oK | Cancel |
Figure 1.4: Data Folders Settings dialog box
2. Hostname This is initially set to localhost. Change it to
the name of the computer on which the data folder is
located.
3. Path on Host: Make sure this matches the full path of
the data folder on the computer hosting the data folder.
4. Username: This is the username the software will use to
log into the Firebird server. The default value is sysdba
but you can change it if need be.
5. Password: The default value is masterkey. Edit it to
match the username you have specified.
6. Close the Data Folder Settings dialog to return to the
Data Folders dialog.
7. Close the Data Folders dialog to return to the Start di-
alog.
Logging In

1. Within the Start dialog, click on Login to open the Login
dialog box.

[\]

. In the Login dialog box enter the username supervisor
(figure [1.5).

3. You will be prompted to enter a password for use in
subsequent logins (figure [1.6). Enter a password of your
choice.



Moving On

Moving On

(¢ Single-user mode

(™ Multiuser mode

Usemame

ok | Cancel Hep |

Figure 1.5: Login dialog box

Password [~ OK
Corfim [ Cancel |

Password

Figure 1.6: Set Password dialog box

4. A message box (figure will then appear asking if you
would like to copy sample data. Choose No to proceed
to set up your organisation.

e Would you like to copy sample data to this data folder?

Figure 1.7: Sample data message box

5. The New Organisation dialog box is displayed next (fig-
ure [1.§8)). Type in the name of your organisation and the
month from which you want to start entering data.

6. Close the New Organisation dialog box to begin using
Aren Payroll.

Before entering employee data you need to finish setting up
the program. Section [2| explains how to do this. To enter
employee data refer to Section [3| which describes the employee
data tables in Aren Payroll.
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Mame |Demo Restaurant Lid 0K

Cancel J

Month Febraary -
Year [2025

Local Curency |thr)-a Shilling

Payroll Currency |K;:—-'-ya Shilling hal

Figure 1.8: New Organisation dialog box

After entering employee data you can view the reports de-
scribed in Section With the exception of the muster roll
and payroll variance, all reports can be printed out on A4 pa-
per. Use the muster roll to export payroll data to an XML file
in Microsoft Excel format.

To close the current pay period and start a new one, run a
period or month end procedure as described in Section[5] That
section also describes how to back up and restore data and
create bank transfer files.
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Before entering details about employees, use the Organisation
and System menus to configure the program. The Organi-
sation menu options apply only to the organisation that you
are currently working with whereas those of the System menu
apply to all organisations that you define.

Setting up the System

Users

Aren Payroll supports an unlimited number of users. There is
always at least one user, supervisor. The supervisor has access
to all functions including adding and deleting other users and
assigning such users access to program functions. By restrict-
ing users to only those parts of the program they need for their
work, it is possible to enforce separation of duties.

To add new users log in as supervisor then do the following:

1. Select Users from the System Menu. This displays the
Users dialog box (figure [2.1]).

Add...

il

Password...

Close

Figure 2.1: Users dialog box

2. Click on the Add button which brings up the User Iden-
tity dialog box (figure [2.2).
3. In the User Identity dialog enter the username. You may

also enter the user’s real name to help you identify him
or her in future.
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Usermame agnes

Last Name Kilonzo

Other Names | Agnes

ok | Cancel |

Figure 2.2: User Identity dialog box

4. Close the User Identity dialog and choose Rights from
the Users dialog box. This displays the User Rights di-

alog box (figure [2.3)).

Functions
— OK
¥ Edit employee data

M Modfy payrol fields Cancel |
¥ Set up open organisation

W Close pay perod or month

[ Restore from backup

[~ Add and delete organisations

¥ Modify tax tables

Figure 2.3: User Rights dialog box

5. Use this dialog box to specify the functions that you
would like the user to have access to.

6. Close the User Rights dialog box and choose Password
from the Users dialog box. This brings up the Set Pass-
word dialog box (figure [2.4)).

Corfim [ Cancel |
Password

1% -

Figure 2.4: Set Password dialog box

7. Enter and confirm the password if you wish. If you do
not enter a password at this stage, the user will be re-
quired to enter one when logging in for the first time.
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Banks

8. Close the Set Password dialog box. You can add more
users by repeating the procedure above.

9. Click on Close in the Users dialog box.

Aren Payroll comes with a comprehensive list of banks and
their branches. You will need this list for employees paid by
bank transfer rather than in cash or by cheque. The list is
shared by all organisations that you create. To review or mod-

ify it, select Banks from the System menu which will bring up
the Bank and Branches dialog box (figure [2.5).

Absa Bank

African Banking Cop Add Bank
Bank of Africa 4
Bark of Baroda Add Branch
Bank of India

Citibank NA Dl

Consolidated Bank

Co-operative Bank Properties, |
Credit Bank

Development Bank Close |
Diamond Trust

DIB Bank

Ecobank

Equity Bank

Family Bank

Faulu Microfinance

First Community Bank

GTBank

e R I R I S I R I ]

Figure 2.5: Banks and Branches dialog box

Statutory Deductions Parameters

PAYE is calculated using brackets and rates that are stored as
a table. To view and update this table select Income Tax >
PAYE Rates from the System menu (figure . Refer to the
Kenya Revenue Authority (KRA) website for an up-to-date
PAYE table.

The calculation of PAYE depends on a number of other pa-
rameters e.g. personal relief, insurance relief and allowable
pension fund contribution. Update these parameters by se-
lecting System > Income Tax > Other Parameters to open
the Income Tax Parameters dialog box (figure . This dia-
log also allows you to edit the parameters used for calculating
fringe benefit tax.
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Lower Limit | Upper Limit | Tox Ratern) |

1 24000 10.00 Insert
24001 32333 25.00

3234 500000 30.00 Delete
500001 800000 3250 Q
800001 - Nane - 35.00 Edt

Figure 2.6: PAYE Rates dialog box

Tax Refief Tax Exemption

. - —— oK
Personal Relief 400 [asablty Fxemption 150000 Q

~ EAOn Cancal
Insurance Relief 5000
Secondary Employees
Allowable Benefits Tax Rate (%) 30.00
Meals S000
Fringe Benefit Tax
Agpregate Sene S000
—— = Market [nterest Rate (%):
M 0.00
Allowable Deductons January to March
b [ 0,00
Pension Fund Contribution 30000 April to June 0.00
30000 July to September .00
Owner Oooupier Intenest 3000
October o December .00
Corporation Tax Rate (%) 30,00

Figure 2.7: PAYE Parameters dialog box

NSSF contributions are a percentage of pensionable pay and
are divided into two tiers. To enter this percentage and the
pensionable pay limits for each tier, select NSSF Rates from
the System menu. This opens the NSSF Rates dialog box
(figure where you can also edit the maximum voluntary
contribution.

The payroll supports SHIFﬂ which replaced NHIF as the manda-
tory health insurance deduction. The parameters for calculat-
ing SHIF can be edited by selecting System > SHIF Parame-
ters to open the SHIF Parameters dialog box (figure

Finally, to change the settings for housing and NITA levies,
open the Statutory Levy Parameters dialog box (figure [2.10))

1 Social Health Insurance Fund
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SF Rates fi

Mandatory Contribution

Percentage of Pensonable Pay: oK
Employes 6.00 Cancel

Employer 6.00

Pensionable Pay Limits:

Tier 1 7000
Tier I1 36000

Voluntary Confribution

Upper Limit 600

Figure 2.8: NSSF Rates dialog box

SHIF Parameter
Employee Contribution

Percentage of Gross Salary: 2.75

Loweer Limit: 300.00

o« | cancel |

b

Figure 2.9: SHIF Parameters dialog box

by selecting System > Levy Parameters.

evy Parameter

Housing Levy oK
Percentage of Gross Salary: Cancel

Employes 1.50
Employer 1.50
MNITA Levy

Monthly Amount 50.00

ke

Figure 2.10: Statutory Levy Parameters dialog box

Working with Organisations

A single installation of Aren Payroll can support up to 99
different organisations. Each organisation requires a separate
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licence key. The name of the organisation that is currently
open is displayed in the title bar of the main window.

Adding a new Organisation

To add a new organisation select Add from the Organisation
menu. Use the New Organisation dialog box that follows (fig-
ure to enter the name of the organisation and the month
from which you want to start entering data. On closing the
dialog box, the previous organisation is closed and the new
one opened.

Mame [Demo Company Lid OK

Cancel |

Month | February -

.-r\_
Year |2025

Local Cumency  [Kenya Shilling

Payroll Curency | Kenya Shilling -

Figure 2.11: New Organisation dialog box

Opening another Organisation

To open a different organisation select Open from the Organ-
isation menu. This will bring up the Open Organisation di-
alog box (figure provided there are other organisations
defined. Select the organisation you want to open from the
dialog box.

Deleting an Organisation

You can delete any organisation that is currently not open.
Deleting an organisation causes all its data files and folders to
be deleted. It is strongly recommended that you back up the
organisation’s database file before deleting it (see Section [5).

To delete an organisation:

1. Select Delete from the Organisation menu. To minimise
the risk of accidentally deleting an organisation you will
be required to enter your password (figure 2.13)).
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Orgar
ok | Cancel |

Figure 2.12: Open Organisation dialog box
elete Organisatior

Deleting an organisation will cause all is data
files to be deleted. You are strongly advised to
l back up these fies before continuing .
4

If you are sure you want to continue, please
enter your password below.

Pasaward [

oK | Camcel | o Hep |

Figure 2.13: First Delete Organisation dialog box

2. Next, a list of all organisations in the system, exclud-
ing the one that is open, will be displayed (figure .
Select the one you want to delete. Note that it is not pos-
sible to delete the organisation that is currently open.

ok | cance |

Figure 2.14: Second Delete Organisation dialog box

3. In the two message boxes that follow, confirm that you
want to delete the selected organisation and destroy its
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data files.

4. Aren Payroll will then delete the organisation. A dia-
log box confirming that the deletion is complete will be
displayed.

Setting up an Organisation

To configure the organisation that is currently open, proceed
as follows:

Basic Organisation Information

Open the Basic Organisation Info dialog box (figure[2.15)) from
the Organisation menu and enter the organisation’s address
and telephone number.

Name | Demo Restaurant Lid
Status: Not licensed
Folder: C:\Users\ndiri\Payrol Data'¥e!10.0Payroliorgll

Month |February j Year | 2025

Address

P.0. Box | 3598 Town | Nairobi
Post Code | 00100 Telephone | 600400

oK Cancel |

Figure 2.15: Basic Organisation Info dialog box

Also, confirm that you want to start entering payroll details
in the month and year shown in the dialog box. Once you run
the first period or month end procedure you will not be able
to edit either of them.

Licensing

Select Licence from the Organisation menu to open the Licence
dialog box (figure 2.16). Type in the licence key supplied by
your dealer. If you do not have a licence key, contact your
dealer or Aren Software Ltd.
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Payroll Info

Jobs

Administrative Units

Licence Mumber: [7CEA-1A34

oK | Cancel | Help |

Figure 2.16: Licence dialog box

Open the Payroll Info dialog box (figure by selecting
Payroll Info from the Organisation menu. Enter the bank,
branch and account number for the organisation’s salary ac-
count. Also enter the organisation’s PIN, NSSF, NHIF, SHIF
and HELB numbers.

1D Mumbers Currencies
FIN [pzso1m0zia Lacal Currency ['!tf‘va Shiling
NSSF Mo, | 2365821 Payroll Currency |Kenya Shilling =]
HIF 235066
NHIF Mo, | 2350 -
SHIF Mo, | 24103100123455TABCDEI1IWI Bark |Standard Chartered Bank -
HEENo, [PP12388s Branch |Harambee Ave -
Account No. W
sendermp [22551
oK Cancel |

Figure 2.17: Payroll Info dialog box

In this dialog box, the Standard File Interchange (SFI) Sender
ID applies to those who submit their payroll to the bank in
electronic form. Leave this field blank if you do not already
have an SFI Sender ID.

To set up the jobs available in the organisation, open the Jobs
dialog box (figure 2.18) by selecting Jobs from the Organisa-

tion menu.

Set up the administrative units (departments, sections, etc) in
your organisation. To do this select Units from the Organisa-
tion menu.
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Stations

Pay Groups

fss. Restaurant Manager Add
Bartender

Bevarage Manager

Chef Delete
Chief Accountant [
Cleaner Properties

Cook

Dining Room Manager
Director Close
Executive Chef
Head Bartender
Head Cleaner

Head Securty

Head Water
Restaurant Manager
Security Guand
Waiter

Figure 2.18: Jobs dialog box

Set up the stations (branches) in your organisation. To do this
select Stations from the Organisation menu.

Pay Groups allow you to filter payment reports according to
how employees in your organisation are paid. For example,
the bank transfer report could be filtered by bank branch or
pay date.

To set up pay groups, select Pay Groups from the Organisation
menti.

Co-operatives and Pension Funds

Insurance Companies

Employee Profiles

Create co-operative societies that employees in the organisa-
tion belong to by selecting Co-operatives from the Organisa-
tion menu.

Similarly, set up pension funds by selecting Pension Funds
from the Organisation menu.

If you need to deduct and remit insurance premiums, set up
the insurance companies involved by selecting Organisation >
Insurance Companies.

An employee profile defines attributes that are common to a
group of employees. These attributes are pay frequency, basic
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General Options

pay type (i.e., salary, daily rate or hourly rate), standard work-
ing hours (per day and per pay period) and whether overtime
is payable.

To create a profile, select Profiles from the Organisation menu
to open the Employee Profiles dialog box (figure 2.19). If there
is an employee profile marked as default, all new employees
added to the payroll will be assigned this profile.

Staff Add
Delete
Properties
Close

Figure 2.19: Profiles dialog box

Selecting Options > General from the Organisation menu opens
the General Options dialog box. This dialog box is used to
specify the default pay frequency. This is the pay frequency
that the program defaults to when opening the payroll trans-
actions table or initialising dialog boxes that display pay fre-
quency.

Under data entry forms, you can choose how to sort the data
presented in employee data forms as well as activate the Open
Table dialog box. This dialog box is used for filtering form
data by administrative unit, station or pay group.

The General Options dialog box also allows you to specify
when to purge old reports. Deleting old reports saves space
on the hard disk and reduces the size of backup files.

In the PDF documents section you can edit the following pass-
words.

1. Owner Password: This password allows you to open any
PDF documents that you send by email. It should not
be disclosed to employees.
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Payroll Options

General Option

Default Pay Frequency

x|
* Monthly ™ Weekly
Cancel
" Biweekly ™ Irregular 4|
Help |
Data Entry Forms
Saort By:

* Employee Number ( LastName

[~ Show Open Table dislog box
Past Reports

Purge after |_5 years

PDF Documents

Owner Password owner

Default User Password | user

Figure 2.20: General Options dialog box

2. Default User Password: Employees use the user pass-
word to open PDF documents sent to them. It is usually
set to the last four digits of the employee’s PIN. Where
the PIN is missing, the default value you enter here is
used instead.

Selecting Options > Payroll from the Organisation menu brings
up the Payroll Options dialog box (figure [2.21]).

PAYE — oK |

NSSF ™ Tax excess employer pension on employee

Cancel
Levies [~ lgnore benefits urless total exceeds Ksh 5,000
_veo |
Net Pay
PAYE

(" Deduct exact amount
(* Round down to nearest Ksh
" Round up to nearest Ksh

™ Allow negative amount

Figure 2.21: Payroll Options dialog box
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Taxable Pay

PAYE

NSSF

Housing Levy

NITA Levy

Net Pay

If your organisation is tax-exempt you are required to treat the
employer’s pension contribution as a taxable benefit. Select
the option to tax excess employer pension on employees.

KRA’s online tax administration system, iTax, does not tax
benefits unless they total to more than Ksh 5,000. By default,
Aren Payroll taxes all non-cash benefits regardless of their
total. For it to work like iTax you must check the option
Ignore benefits unless total exceeds Ksh 5,000.

By default, PAYE is rounded down to the nearest shilling. To
match the iTax system, you should select the option to deduct
the exact amount of PAYE.

For employees who are paid more than once a month, it is
possible though unlikely for the PAYE amount for a particular
pay period to be negative. To avoid this, uncheck the option
to allow negative PAYE.

If your organisation has opted out of Tier II NSSF contribu-
tions, select whether to deduct Tier II NSSF selectively or not
all.

If you would like to turn off housing levy for the whole organi-
sation, uncheck the option to deduct housing levy. By default,
housing levy is rounded to the nearest shilling. To match the
iTax system, select the option to deduct the exact amount of
housing levy.

If your organisation pays NITA Levy for its employees, check
the option Pay NITA Levy. An annual report showing the
amount payable for each employee will be generated.

Finally, you have the option to round down net pay for em-
ployees paid in cash by an amount that you specify. The excess
amount is carried forward to the next month.
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Logos

Pay Period End Days

Selecting Options > Logos from the Organisation menu brings
up the Logos dialog box (figure [2.22). This dialog box allows
you to select image files with the organisation’s logo for use
in payslips. These files must be in the images|logos folder
located within the organisation folder.

Printed Documents

Select..

Remove I

Email Attachments
Select,.. |

Remove |

oK | Cancel Help

Figure 2.22: Logos dialog box

For printed payslips you can select a PNG or JPEG file. PNG
images are typically sharper than JPEG ones but they occupy
more space.

Select a JPEG file for payslips that are sent as email attach-
ments in PDF format. Attachments are restricted to 64 KB
so the logo file must be well below that size.

If the pay frequency is monthly, the pay period is assumed to
end on the last day of the month. For other pay frequencies
the program requires assistance from the user to determine
when each pay period ends.

For weekly and biweekly pay frequencies, the user is required
to specify the last day of the very first pay period. The pro-
gram will work out when subsequent pay periods end. In the
case of employees paid after irregular intervals, the pay period
end day must be entered for each pay period.

To initialise period end days, you need to do the following for
each pay frequency that applies to your organisation (except
monthly):
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1. Make it the default pay frequency using the General Op-
tions dialog box (Organisation > Options > General).
The pay frequency selected should appear in the status
bar.

2. Open the Pay Period dialog box (figure [2.23) from the
Organisation menu and enter the pay period end day for
this pay frequency.

Week anding

[14  February 2025

0K | Cancel

Figure 2.23: Pay Period dialog box

In any given month, the pay period end days for weekly and
biweekly employees can not be edited once the first period end
procedure for that pay frequency is run.
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3 Data Tables

Data for each employee is stored in two database tables, the
employee master table and one of the payroll transactions ta-
bles. There is a separate payroll transactions table for each
pay frequency. This data is used to create the various report
tables from which reports are printed.

Employee Master Table

The employee master table stores static information about
each employee. It is accessed by selecting Employee from the
File menu. This brings up a data entry form in which you
enter details about each employee (figure .

-

Record 1of 45 001 Asega. Stephen Lihenzero
Personal

Employment Last Mame -:«sega

Payment i

Other Names | Stephen Lihenzero

Basic Pay

Orvertime Gender -
Housng Birth Date [ 5 Aug 1977 _I
PAYE i

ID Mo, | 23545864

MNSSF & SHIF

Co-cperatives Passport Mo.

Pension Funds Work Permit No.

Other

Figure 3.1: Employee Master Table form

You can add and delete employee records using the Add, Delete
and Terminate commands in the Record menu.

e The Delete command simply deletes an employee record.
It is only available if the current record has not gone
through a period or month end procedure since it was
added.

e The Terminate command transfers an employee record
from the employee master table to the leavers report ta-
ble. This transfer takes place in the period or month end
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procedure that follows the termination date specified by
the user.

Most of the fields in this table are optional. However, Em-
ployee Number, Last Name, Other Names, Job Title, Admin-
istrative Unit and Station are mandatory. If an employee is
paid by bank transfer, then Bank, Branch and Account Num-
ber are also mandatory. The optional fields are used in various
reports and should therefore not be left blank.

Payroll Transactions Tables

Each payroll transactions table stores earnings, deductions,
benefits, lump sum payments and refunds for all employees
paid in a particular pay period.

FEarnings are those cash payments that relate to the current
pay period e.g. basic pay or leave allowance. For tax purposes,
all cash earnings for all pay periods falling in a particular cal-
endar month make up the monthly cash earnings. A pay period
is deemed to fall in a particular month if its last day falls in
that month.

Benefits are private expenses of an employee that are paid by
the employer e.g. school fees, house rent or telephone bills.
These non-cash benefits are considered as income for tax pur-
poses.

Deductions are those amounts deducted from an employee’s
pay by the employer. Some of these are called statutory de-
ductions because the law requires the employer to deduct them
from the employee’s pay. The statutory deductions are PAYE,
NSSF, SHIF, housing levy and tax on lump sum payments.

Lump sum payments are those cash payments that do not
relate to the current month alone. Some like gratuity and
bonuses have accrued over past months while others like ter-
minal benefits may relate to past or future months. We make
the distinction between lump sum payments and monthly cash
earnings because the two are treated differently when calcu-
lating income tax.

Refunds are payments made to an employee, e.g. travelling or
subsistence allowances, for business expenses incurred while
on duty. These payments are not income and are therefore
not taxable.

The default payroll transactions table is accessed by select-
ing Payroll from the File menu. This displays a data entry
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Payroll Fields

form (figure where you enter earnings, deductions, bene-
fits, lump sum payments and refunds for each employee.

Record 1 of 45 D01 Asega, Stephen Lihenzem
Eamings
Deductions Basic Pay | l
Benefiis Overtime [~ li
Lump Sum Payments =
Refunds li
Statutory Deductions
Summary
Taxable Pay
l
65,000,00

Figure 3.2: Payroll Transactions Table form

Statutory deductions and other calculated amounts such as
taxable pay, net pay and gross pay are updated as data is
entered. This makes the calculations more transparent and
helps to reduce data entry errors.

Each payroll transactions table only includes employees who
are present in the employee master table and have the required
pay frequency. Use the Remove command in the Record menu
to suspend employees from the payroll. Suspended employees
can be restored at any time using the Record > Add command.

At installation, the payroll transactions table has two earnings
(Basic Pay and Overtime), three deductions (Rent, Overdraft
Recovery and Rounding C/F), one non-cash benefit (Employer
Pension) and one refund (Rounding B/F). These fields cannot
be deleted but you can add more according to your needs.

To add, delete or edit fields, select Earnings, Deductions, Ben-
efits, Lump Sum Payments or Refunds from the File menu. A
data entry form will be displayed showing the field attributes

listed below (figure [3.3). To add or delete fields select Add or
Delete from the Field menu.

The following field attributes apply to all fields:
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Field 3 of 11

Field Name | Savers Pension

Type Pension Contribution j Parameters...
Amount |Percentage of Salary j Percentage...

[V Pre-tax deduction

Figure 3.3: Deductions form

. Field Name: The name of the field e.g. advance, shift

allowance.

. Type: This is used to indicate permanent fields (e.g. ba-

sic pay and rent). It is also used to specify fields that
are calculated in a unique way (e.g. hourly pay and
daily pay) and those that are associated with a balance
that is updated and displayed by the system (e.g. loan
repayments and co-operative contributions). The type
advance is used to indicate advance payments so that
appropriate reports can be generated.

. Amount: This attribute specifies how the amount paid

to or deducted from each employee is arrived at. It may
be keyed in, a percentage of salary, a function of the time
worked (basic pay, overtime, hourly pay and daily pay)
or amortised (loan repayments).

. Static: Static fields retain their value when a period or

month end procedure is run, whereas non-static fields
are reset to their lower limit. This is only important
for fields that are keyed in. It saves you the trouble of
having to key in the amount earned or deducted each
time a period or month end procedure is run.

. Tazable/Pre-tar deduction: For earnings, the taxable at-

tribute specifies whether or not the payment is subject
to PAYE. Unless prior permission has been given by the
KRA, all income (i.e. earnings, non-cash benefits and
lump sum payments) must be taxed. Refunds are not
taxable as they are not a form of income.

The pre-tax deduction attribute indicates those deduc-
tions to be subtracted from gross income when calculat-
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ing PAYE. In Kenya pre-tax deductions include NSSF
and other pension fund contributions, SHIF, housing
levy, and mortgage interest payments.

6. Pensionable: NSSF is calculated on the total pension-
able earnings. Uncheck the pensionable option to ex-
clude any earning from this calculation.

7. Regular: SHIF and housing levy are calculated on basic
pay plus all regular allowances. Any earnings not marked
as regular are not subjected to either deduction.

Depending on the selection for Type and Amount attributes
the following additional attributes may be available:

1. Co-operative: The name of the co-operative associated
with the field (figure [3.4).

Name: |Demo Sacea =

0K Cancel

Figure 3.4: Co-operative dialog box

2. Pension Fund: The name of the pension fund and other
details pertaining to the current field (figure [3.5).

MName |Savers | OK
Employer's Contribution
.F'c-':e"'.agc of Salary LI
Percentage 10.00
[ Apply Limits
Lower Limit [

Upper Limit

Figure 3.5: Pension Fund Parameters dialog box

3. Insurance: The name of the insurance company associ-
ated with the field.

4. Limits: The upper and lower limits that the amount
paid or deducted should be restricted to (figure [3.6).
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Lower Limit 0
Upper Limit 50000
|

oK | Cancel | |

Figure 3.6: Limits dialog box

5. Percentage: The percentage of monthly salary that should
be paid or deducted (figure [3.7)).

Percertage | 5.00 OK
HE—m— e

lowerlimt [ 0 |

UpperLimt | 30000 |

Figure 3.7: Percentage of Salary dialog box

6. Hourly Rate: The hourly rate to use for earnings that
are of the type Hourly Pay (figure |3.8)).

+ Basic Pay Ratex| 050

" HKey in rate for each employes

| oK | cawe | |

Figure 3.8: Hourly Rate dialog box

7. Daily Rate: The daily rate to use for earnings that are
of the type Daily Pay.
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Aren Payroll produces numerous reports as described below.
These reports can be viewed on the screen and printed out.
You can choose to print the entire report, a range of pages, or
just the page that you are currently viewing. Internal reports
can be sorted by either employee number or name.

You can view and print reports for current and previous pay
periods, months or years. You can also filter most reports by
administrative unit, station, pay group, bank, co-operative or
pension fund.

Reports may be printed on any printer connected to your com-
puter either directly or through a local area network. Because
all reports are formatted for A4 paper, the printer must be set
to print on A4.

1. To open a report select it from the Report menu and then
follow the on-screen instructions. For example, selecting
Report > Payslips opens the Open Payslips dialog box

(figure [4.1).

Pay Frequency

0K
Monthly -
: Cancel
Pay Pariod Next >
f+ Cumeant
™ Previous Options..

Penad end date

Figure 4.1: Open Payslips dialog box

2. To print the open report select Print from the File menu
which brings up the Print dialog box (ﬁgure. Use the
Setup button in this dialog box to configure the printer
you want to use.
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Nominal Rolls

Pay Period Reports

Printer:
oK
Epson L6570
Cancel
Pages to print:
Setup...

(o Al

(" Current Page

(" Pages: To

Mumber of Copies: 1

Figure 4.2: Print dialog box

. Choose Close from the File menu to close the report.

. Employees Roll: List of employees who are currently ac-

tive. It shows their job title, administrative unit and
station.

. Joiners Roll: List of employees who joined the organi-

sation recently. It shows their job title, administrative
unit, station and start date.

. Leavers Roll: List of employees who left in a given year.

It shows their final job title and administrative unit, the
date they left and the reason for leaving.

These are reports for a specific pay frequency and cover one
pay period. For a particular pay frequency, reports for the
current pay period are updated as you update the employee
master table and the appropriate payroll transactions table.
Reports for previous pay periods can be viewed and printed
out, but they cannot be modified in any way.

Overview Reports

1. Payroll Summary: Summarises earnings and deductions

for all employees.

2. Payroll Control Account: T-account listing total earn-

ings, deductions and net pay for all employees in the
organisation.
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3. Muster Roll: List of employees showing all earnings,
lump sum payments, refunds and deductions for the month.
Records in this report can be grouped by administrative
unit or station.

4. Payroll Variance: List of employees showing the differ-
ences in the payments and deductions made in any two
pay periods. It is essentially the difference between the
muster rolls for the two pay periods.

5. Gross Pay By Unit: List of administrative units showing
the staff count and total gross pay for each.

6. Gross Pay By Station: List of stations showing the staff
count and total gross pay for each.

The muster roll and payroll variance can be viewed on the
screen or saved to an XML file but they cannot be printed
out.

Detail Reports

1. FEarning Report: List showing, for a particular earning,
how much each employee was paid.

2. Deduction Report: List showing, for a particular non-
statutory deduction, how much each employee was de-
ducted. Depending on the type of deduction selected, a
loan or HELB report may be printed instead.

3. Loan Report: List of employees repaying a specific co-
operative or company loan. It shows the opening and
closing balances and a breakdown of the repayment amount
into interest and principal components.

4. HELB Report: List showing the HELB Repayment Sched-
ule in the format previously used for filing returns to
HELB (Higher Education Loans Board). HELB returns
should be filed on their website using the return file avail-
able under Procedure > HELB Schedule.

5. Benefit Report: List showing, for a particular non-cash
benefit, how much each employee received.

6. Lump Sum Report: List showing, for a particular lump
sum payment, how much each employee received.

7. Refund Report: List showing, for a particular refund,
how much each employee received.
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Payments to Employees

1. Payslips: Slip giving a breakdown of the earnings and

deductions of each employee separately (figure . The
employer’s pension contribution and the pension fund
balance can be shown in the payslip if required. When
the balance is shown, it includes the employer’s portion
only if the option to print the employer contribution has
been selected.

|| 4]4]v]m] x| 2]

Demo Restaurant Ltd Demo Restaurant Ltd
Payslip Payslip

g, Bephen Lihenzend g4, Biephen Lihesnenn

Mt Pay 43,674.00 Wet Pay 40571108

Page | of 45 Sngle-User  KES  |Monthly  |February 2025

Figure 4.3: Payslips

. Cash List: List of employees paid in cash showing their

employee number, name, net pay or advance payment
and a cash analysis of the payment amount.

. Cheque List: List of employees paid by cheque showing

their employee number, name and net pay or advance
payment.

. Bank Transfer Report: List of employees who are paid

by bank transfer showing their name, ID number, bank,
branch, account number and payment amount. The pay-
ment amount may be the net pay, an advance payment,
a bank loan repayment or a HOSP contribution.

. Labels: Envelope labels for employees paid in cash, by

cheque or by bank transfer. For cash employees, the net
pay can be shown on the label if required.

. Coinage Summary Report: List showing the number of

coins and notes of each denomination that are required
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Returns

for workers who are paid in cash. This information is
the same as the totals in the cash list but formatted so
that it can be used when withdrawing the cash from a
bank.

. Co-operative Report: List of members of a particular co-

operative society showing membership number, monthly
contribution and any other payroll deductions to be paid
to that co-operative.

. Pension Report: List of members of a particular pension

fund showing membership number and employer and em-
ployee contributions to that pension fund.

. Insurance Company Return: List of employee premium

deductions to be paid to a particular insurance company.

Monthly Payroll Reports

The monthly reports relate to a calendar month. They are:
1. Payroll Control Account.
2. Muster Roll.
3. PAYFE Report: List of employees showing their PAYE

deductions. To generate the equivalent iTax return file,
go to Procedure > iTax Files > Employee Details.

4. NSSF Report: List of employees showing NSSF number,

ID number and the combined employer and employee
tier I and tier II contributions. Voluntary contributions
are also shown.

The NSSF return file is available under the Procedure
menu (Procedure > NSSF return > Self Service). This
generates an XML file which should be opened with Mi-
crosoft Excel and saved again as an Excel file.

. NHIF Report: List of employees showing NHIF number,

ID number, date of birth and NHIF deduction.

. SHIF Report: List of employees showing ID number,

KRA PIN, NHIF number, contribution amount and phone
number. To generate the equivalent SHIF return file, se-
lect Procedure > SHIF Return. This saves an XML file
that should be converted into a Microsoft Excel spread-
sheet.
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7.

Housing Levy Report: List of employees showing PIN,
gross salary and housing levy payable. The equivalent
iTax return file is available under Procedure > iTax Files
> Housing Levy.

Lump Sums Tax Report: List showing tax payable on
lump sum payments for each employee.

Fringe Benefit Tax Report: List showing tax payable on
the fringe benefit arising from company loans issued at
an interest rate below the KRA prescribed market in-
terest rate. The equivalent iTax return file is available
under Procedure > iTax Files > Fringe Benefit Tax.

These reports are updated after each period end procedure
and may not be complete until the month end procedure is
run. For the current month, the information displayed covers
the pay periods that have elapsed so far.

Annual Payroll Reports

Annual payroll reports relate to a calendar year and are avail-
able throughout the year. For the current year, the informa-
tion displayed relates to the pay periods that have elapsed so
far. The reports are:

1.
2.
3.

Payroll Control Account.
Muster Roll.

Annual Pay Sheet: A report that, for each employee,
gives a summary of payments, deductions and benefits
for a whole year.

P9A: KRA form titled Tax Deduction Card. Each P9A
gives a breakdown of the income of an employee for each
month of the year and shows the amount of tax deducted.

P10: KRA form titled Employer’s Covering Certificate.
It shows the tax deducted by the employer for each
month of the year.

. P10A: KRA form titled Supporting List for End of Year

Certificate. Tt lists the annual income and total tax de-
ducted from each employee.

NITA Levy Report: List showing the NITA levy payable
for each employee in the payroll.

NSSF Statement: A summary of an employee’s standard
and voluntary contributions to NSSF for a calendar year.
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10.

Other Reports

Report Tables

NHIF Statement: A summary of an employee’s NHIF
deductions for a calendar year.

SHIF Statement: A summary of an employee’s SHIF
deductions for a calendar year.

. Bank Codes: A listing of banks, bank branches and their

sort codes drawn from the banks files.

. Audit Trail: List that shows the date and time of each

login, backup, month end procedure and any other major
event. It also shows the user responsible for each event.
This report is only available to the supervisor.

Almost all reports are printed from report tables, not directly
from the employee data tables. Briefly, the report tables are:

1.

ool L

Active employees report table
Annual leavers report tables
Pay period report tables
Monthly payroll report tables
Annual payroll report tables

Report tables are updated automatically by Aren Payroll. Use
the General Options dialog box (Organisation > Options >
General) to specify how long to keep these tables for.
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Backing Up

If your organisation database files are accidentally deleted or
corrupted you could lose all your data. Without an up-to-date
backup you would be forced to key in the data for the current
month again. It is also likely that you would be unable to recre-
ate data for previous months and years. It is therefore very
important that you make regular backups of your database
files.

To back up the database file for the organisation that is cur-
rently open, select Back Up from the Procedure menu. You
will be prompted to specify the name and location of the
backup file to be created (figure [5.1).

3

“ Payroll » backup

I
1
a

a
]
14

IR Gallery

Feb25.fbk
all Deskiop
- share
Publc
v Downloads
ndin

WebApps

File narne:

Sanve as type:  Backup Files [*.fbk)
# Hide Falders Save Cancel

Figure 5.1: Backup dialog box

The backup process copies all data relating to your organi-
sation to the backup file. Should you have set up more than
one organisation, you will need to back up each one separately.
Note that data that is shared by all organisations is not backed
up (e.g. list of banks and statutory deductions parameters).

When running a period or month end procedure you will be
prompted to back up. Though you can choose to proceed
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without doing so, it is recommended that you back up first.
To encourage regular back ups Aren Payroll prompts you to
back up each time you exit.

Restoring from Backup

In the event that your data tables are corrupted or deleted
you will need to recover them from a backup file. You can
also use backup files to revert to an earlier period. This is
especially useful if you accidentally run a period or month end
procedure.

To restore an organisation’s files from backup, select Restore
from the Procedure menu then follow the on-screen instruc-

tions (figure [5.2)).

Restoring from backup will replace all the data
for this organisation with that retrieved from the
backup file You are encouraged to back up
the organisation before continuing

\.\

if you are sure you want to continue, please
enter your password below

Password

oK J Cancel | Help J

Figure 5.2: Restore dialog box

Creating a Bank Transfer File

A bank transfer file is an electronic version of the bank transfer
report. It is used by banks to process payments for employees
paid by bank transfer in place of the printed bank transfer re-
port. Aren Payroll can create bank transfer files for numerous
banks including Absa, Co-operative, Equity, KCB and Stan-
dard Chartered.

1. To create a bank transfer file select Bank Transfer File
from the Procedure menu. The Save Bank Transfer File

dialog box appears (figure [5.3).

2. Specify the format of the bank transfer file to create
and the name of the payment field (usually net pay).
Depending on the file format, you may be able to specify
the date you want the bank transfer effected.
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Saving iTax Files

Pay Frequancy

Morit hiby il
Cance

Pay Period Next >

* Cument
Previous

Period end date

Figure 5.3: Save Bank Transfer File dialog box

3. On closing the Save Bank Transfer File dialog box, a
standard Save As dialog box will appear. Use this dialog
to specify the name and location of the file to be created.

For further details on bank transfer files please contact your
bank.

iTax files are text files containing tax details about employees
in the payroll. These files help you to fill out the iTax spread-
sheet (P10_ Return.zlsm) that is used for filing tax returns on
the KRA website.

Four formats are available—Employee Details, Disabled Em-
ployee Details, Fringe Benefit Tax Details and Housing Levy
Details. Data exported in these formats should be imported
into the corresponding tabs of the iTax spreadsheet.

1. To save the Employee Details file, select iTax File >
Employee Details from the Procedure menu.

2. In the Save Employee Details File dialog that is displayed
(figure [5.4), select the month and year you want.

3. By default only employees who have paid PAYE in the
selected month will be included in the file. If you wish
to include those with zero PAYE as well, click on Next
and select the option Include all employees.

4. On closing the Save iTax Employee Details File dialog
box, a standard Save As dialog box will appear. Use this
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0K

Year [2025
Cancel

Month | February

| 4

Next >

Figure 5.4: Save iTax Employee Details File dialog box

dialog to specify the name and location of the file to be
created.

Files in any of the other formats can be created in the same

manner. For further assistance with iTax please contact the
KRA.

Terminating an Employee

To terminate an employee, open the employee master table
and display the target employee. Next, select Terminate from
the Record menu. In the Terminate dialog box that appears
(figure , enter the termination date, the reason for leaving
and, if you like, some brief comments.

Termination Date

(0]
‘ < = Cancel
Reason for Leaving

Resignad =1

Remarks.

Figure 5.5: Terminate dialog box

The terminated employee will be removed from the employee
data tables in the next period or month end procedure that
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is later than or on the same day as the termination date.
Once the employee is deleted from the employee data tables
his record will be added to the leavers report table.

Termination can be reversed by selecting Record > Undo Ter-
mination as long as the terminated employee has not been
removed from the employee data files.

Closing a Pay Period

The period end procedure is used to close data entry for the
current pay period and begin a new one. The procedure does
the following:

1.

Saves all payroll information for the current pay period
to the period, monthly and annual report tables.

. Transfers terminated employees from the employee mas-

ter table to the leavers report table.

Deletes the current payroll transactions table and creates
a new one for the next pay period.

. Advances the period end day to the last day of the next

pay period.

This procedure should only be run after all reports for the
current pay period have been verified since, once it is run,
reports for this pay period cannot be changed.

To run the procedure:

1.

2.

Check that the correct pay frequency is set as default.

Select Period End from the Procedure menu. This option
is only available if you have licensed the organisation.

. After reading the dialog box that appears (figure [5.6),

confirm that you want to close the pay period stated by
entering your password.

. You will now be prompted to back up your data and are

strongly encouraged to do so.

Once the back up is complete, the period end procedure
will automatically follow and eventually a message box
confirming its completion will appear.
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Closing the Month

Running the perod end procedure will closs
the payroll forthe week ending 14 February
2025

\.\

if you are sure you want to continue, please
enter your password below

Password

oK J Cancel | Help J

Figure 5.6: Period End dialog box

The month end procedure is used to close data entry for the
current month and begin a new one. It applies only to the
organisation that is currently open. It does the following:

1.
2.

Runs the period end procedure for all pay frequencies.

Transfers terminated employees from the employee mas-
ter table to the leavers report table.

Deletes any report data that is older than the limit set
in the General Options dialog box.

. Advances the payroll month by one.

. If the new month is January, it creates statutory deduc-

tion tables for the new year.

The procedure can only be run if, for each (non-empty) payroll,
the forthcoming pay period ends in the next calendar month.
This is because, after the procedure is run, all pay period end
days will fall in the new month.

To run the procedure:

1.

Select Month End from the Procedure menu. This op-
tion is not available if you have not licensed the organi-
sation. It is also not available if the next pay period for
the default pay frequency does not end in the following
month.

. After reading the dialog box that appears (figure ,

confirm that you want to close the month by entering
your password.

. You will now be prompted to back up your data and are

strongly encouraged to do so.
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Running the month end procedure will close
data entry for February 2025. Subsequent
payroll entries will appear in March 2025.

T

i you are sure you want o continue, please
enter your password below.

Passwod [

Ok | Camcal | hep |

b

Figure 5.7: Month End Procedure dialog box

4. Once the back up is complete, the month end proce-
dure will automatically follow. Eventually, a message
box confirming its completion will appear.
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Appendix A Setting Up Firebird

Aren Payroll accesses payroll data through a Firebird database
server, not directly. Where the data is in a local folder, it
may be accessed through the embedded Firebird server that is
installed with the application.

To access data on a shared folder on a different computer, you
need to install the full Firebird server on that computer and
configure it to work with Aren Payroll. Even when the data
folder is local, you may prefer to install Firebird. Doing so will
allow you use Aren Payroll in true multi-user mode.

Installing Firebird

1. Insert the installation CD in the CD drive.

2. Run the program Firebird 3.0\ Installation Files|Firebird-
3.0.5.33220 0 Win32.exe on the installation CD.

3. Follow the on-screen instructions that appear during the
installation process.

4. When prompted to create a password for the Database
System Administator (sysdba) make sure you do so. Us-
ing the default password could compromise the security
of your data.

5. Accept the default settings for everything else other than
the password. See figure [A.]]

Copying the Encryption Library

1. Locate the folder Firebird 3.0\ Encryption Plugin in the
installation CD. This folder contains the encryption li-

brary that the Firebird server uses to encrypt database
files.

2. Copy the entire contents of this folder to the folder in
which you installed Firebird. This is most likely C:| Program
Files(x86) | Firebird | Firebird_3_ 0. Note that both fold-
ers have the same layout. Overwrite any files in the
destination folder if prompted to do so.
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Configuring Firebird

=]

Ready to Install -
Setup is now ready to begin installing Firebird on your computer. w

Click Install to continue wath the installation, or chick Back If you want to review or
change any settings.

Setup type:
Full installation of Server and development tools.

Seleded components:
Server components
Developer and admin togls components
Client compaonents

Additional tasks:
Choose Server Architecture:
Run Firebird In SuperServer mode
Run Firebird server as:
Run as a Service?
Start Firebird automatically everytime you boot up?
Copy Firebird client lbrary to <system> directory?

< Back Install Cancel

Figure A.1: Firebird Setup Wizard

You need to edit the file firebird.conf in the Firebird installa-
tion folder so that the Firebird server can work correctly with
Aren Payroll.

1.

5.

Locate the Notepad text editor by searching for it in the
Windows search box.

Select Run as administrator to open Notepad.

. In Notepad, locate and open firebird.conf.
. Immediately below the line #KeyHolderPlugin = add a

new line KeyHolderPlugin = Callback.

Save firebird.conf and close Notepad.

Restart the Firebird server so that the changes to firebird.conf
can take effect.

1.

Start the Services app by searching for it in the Windows
search box.

. In the list of local services select the Firebird server,

most likely listed as Firebird Server - DefaultInstance.
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Figure A.2: Services App

See figure [A.2]

3. Restart the service.
4. Close the Services app.

The Firebird server is now ready for use.
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Appendix B

Importing Data

Employee Data

File Format

Keying in new employees into the payroll can be very time
consuming especially if there are many of them. As an al-
ternative, you can import employee data into the employee
master table from a text file.

The easiest way to create the input text file is to capture em-
ployee data in a spreadsheet and then save the spreadsheet as
a text file.

The format of the input text file is as follows:

1.

Plain text with data items separated by the tab character
(i.e. a tab-separated text file).

The first row of data is a header with the data items Em-
ployee Number, Last Name, Other Names, ID Number,
Job Title, Admin Unit, Station, Pay Rate, PIN, NSSF
Number and SHIF Number.

From row two onwards, each row has data for a single
employee, i.e. employee number, last name, other names,
ID number, job title, administrative unit, station, pay
rate, PIN, NSSF number and SHIF number.

Note that:

1.

The first row (file header) is ignored. It is only included

for the convenience of the person preparing the input
file.

. A row will not be imported if the employee number

matches that of a record already in the employee master
table.

. A row will also be skipped if any of the following data

items is blank: employee number, last name, other names,
job title, administrative unit, station.
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How to Import

. Data will be imported into several tables—employee mas-

ter, payroll transactions, jobs, adminstrative units and
stations.

. Where a default profile has been defined, it will be ap-

plied to each record added to the employee master table.

. Make sure you are in single-user mode. If not, switch to

this mode by selecting System > Single-User Mode.

. Back up your data just in case you need to undo the

changes you are about to make (Procedure > Backup).

. Select Procedure > Import Employees to open the first

Import New Employees dialog box (figure |B.1)).

Impaorting employes data from a text file may
modify several data files t is advisable to
back up your data before continuing

\.\

if you are sure you want to continue, please
enter your password below

Password

oK J Cancel | Help J

Figure B.1: First Import New Employees dialog box

4. Enter your password to open the second Import New

Employees dialog box.

. Browse to the text file that you want to import data

from and click on Open.

. Aren Payroll will read the text file and update the data

tables listed above. On completion, a confirmation mes-
sage box will be displayed. Close the message box.

To see which records were updated, refer to the log file im-
port.log located in the payroll data folder. Browse through
the data tables that should have been updated to confirm that
they were updated successfully.

Time and Attendance Data

Aren Payroll can import time and attendance data from a text
file. This provides a quick way of capturing the data generated
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Employee Name Basic Normal Double
Number Pay Overtime Overtime
001 NJOROGE, James 0.5 10 3.5
002 MWINZI, Miriam O 0 8
003 OKUTOYI, Agnes 1.5 8 4
004 MUTUMA, Joe 2 0 0

Table B.1: Time and attendance data format

by a clocking system. Because the format of the input file is
standard, Aren Payroll will work with any clocking system
provided that the data it generates can be converted to the
required format. An input file can also be created by keying
in time and attendance data into a spreadsheet program and
then saving it as a text file.

File Format

The data to be imported should be saved in a text file with
the following specifications.

1.

Table

Interpretation

Plain text with data items separated by the tab character
(i.e. a tab-separated text file).

. The first row of data is a header with the data items

Employee Number, Name, Basic Pay, Normal Overtime
and Double Overtime.

From row two onwards, each row has data for a sin-
gle employee, i.e. employee number, name, basic pay
time worked, normal overtime hours and double over-
time hours.

is a simple example of the format required.

The data is interpreted as follows:

1.

The first row (file header) and the second column (em-
ployee name) are ignored. They are included for the
convenience of the person preparing the input file.

. The employee number in column one determines which

record in the payroll will be updated. It must match
the employee number in the payroll transactions table
exactly, except for the case which is ignored.

. The data in column three (basic pay) could be hours

worked, hours absent, days worked or days absent. Its
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How to Import

interpretation depends on the settings for each employee
in the employee master table. If an employee is paid a
fixed salary irrespective of the time worked, this value is
ignored.

Columns four and five contain normal and double over-
time hours, respectively. For a given employee, if over-
time is not enabled the data is ignored.

Here is how you import time and attendance data into the
default payroll transactions table.

1.

Organise « MNew folder

Make sure you are in single-user mode. If not, switch to
this mode by selecting System > Single-User Mode.

. Back up your data just in case you need to undo the

changes you are about to make.

Select Procedure > Import > Attendance to open the
Import Time and Attendance Data dialog box (figure

B2).

Browse to the text file that you want to import data
from and click on Open.

“ Payroll » imports

9

1[1]
e
' ©

IR Gallery

all Deskiop

- share
Publc

v Downloads
ndin
WebApps
10x
Pay10Ent

Ent

File name: Text Files [".bx)

Open Cancel

Figure B.2: Import Time and Attendance Data dialog box

5. Aren Payroll will read the text file and update the de-

fault payroll transactions table. On completion, a mes-
sage box showing the number of records updated will be
displayed.
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To review the imported data, open the basic pay, normal over-
time and double overtime reports (Report > Breakdown). You
should also review the log file import.log located in the payroll
data folder.
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Appendix C Emailing Reports

Aren Payroll can email payslips and P9As to each of the em-
ployees in the payroll. This provides an alternative to printing
individual payslips or P9As for each employee. The reports
are sent as password-protected PDEF files.

In this section, we explain how to email payslips. Emailing
P9As works in exactly the same way.

Entering Email Addresses
Start by capturing the email addresses to send reports to.

1. Open the Employee Master Table form (File > Em-
ployee) and select the Other tab (figure [C.1]).

Record 1 of 45 001 Asega, Stephen Lihenzem

Personal
Employment
Payment
Basic Pay

Owvertime

Mabile Phone | 0622 555001

Email reports to:

asegai@demorestaurant.co.ke

Housing
PAYE

NSSF & SHIF
Co-operatives
Pension Funds

Other

Figure C.1: Employee Master Table form

2. For each employee, enter the address to email reports to.

3. Close the Employee Master Table form.

Setting Up Email Account

In order to send email, you need to set up your email account.
For this you require details of the outgoing mail server, also
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known as the SMTP server. Consult your IT department if
necessary or check the settings in the email software you use.

1. Select System > Email Account to open the Email Ac-
count dialog box (figure [C.2)).

Genera

Email Address | info@demorestaurant.co.ke

[ Copy all emails to self
Hedp

SMTP Server
Address |mau|.oemrestumt.m.ke
Port | 587
Timeout ["-*'5 seconds

[¥ Use secure connection

Authentication

Type |Log-r -

Account Name | info@demorestaurant.co.ke

xxxxxxxxxxxx

Password |

Figure C.2: Email Account dialog box

2. Email Address: Enter your email address, say info@-
demorestaurant.co.ke or example@gmail.com.

3. SMTP Server: Enter the name of the outgoing mail
server, e.g. mail.demorestraurant.co.ke or smitp.gmail-
.com. You can also enter the server’s IP address, e.g.
192.168.0.23.

4. SMTP Port: The SMTP port is a unique number that
the mail server has set aside for outgoing mail. The most
common values are 25, 465 and 587. If your server uses
a secure (encrypted) connection, e.g. smip.gmail.com or
smip.mail.yahoo.com, try port 465 or 587. If it does not,
enter 25.

5. Timeout: This is length of time the software should wait
for a response from the mail server before giving up.

6. Use secure connection: Check this option if the mail
server uses a secure connection.
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10.

Sending Payslips

Authentication: You may select none (no account name
or password required), plain or login (requires account
name and password).

Account Name and Password: Enter the login name and
password for the mail server if you have selected login or
plain authentication.

Copy all emails to self: Check this option if you want to
receive a copy of all the reports you send.

Close the Email Account dialog box.

Now you are ready to email payslips to employees.

1.

Select Procedure > Email Payslips to open the Email
Payslips dialog box (figure |C.3)).

Pay Frequency
0K

Morthly -
Cancel

Pay Pariod Next >

f+ Cumeant
™ Previous Options..

Penad end date

Figure C.3: Email Payslips dialog box

Choose the pay period that you want then click OK. This
opens the Payslip Messages dialog box (figure |C.4)).

Click on Send to open the Message Range dialog box
(figure [03).

Use the Message Range dialog box to send the current
message, all messages or a range of them. On comple-
tion, a message box showing the number of messages sent
will be displayed.

Close the Payslip Messages dialog box when you are
through.



58 Appendix C Emailing Reports

) | Messageraras > i

Send Ta: |aseqa@demorestwraﬂ co ke

Subject: |Pa-;u|p for February 2025

e

H

Your payslip for February 2025 is attached. You can save, view and
print & at your convenience

Regards
Demo Restaurant Ltd

AMtachment: |Demo Restaurant Ltd

Payslip

Employes No.: 001

Hame: RAsega, Stephen Lihenzero
Pay Period: February 2025

Figure C.4: Payslip Messages dialog box

Send

| OK

| # Cument Message 4
™ Al Mezzages &
™ Messages

fom [ To:|

Figure C.5: Message Range dialog box

Details of the last mail session are saved in the log file email.log
located in the payroll data folder. Refer to this file if you have
any difficulty sending messages and to see which messages were
actually sent.

How to Open Payslips

Once a payslip is sent, the recipient will need a password to
open it. Each payslip has two passwords:

1. Owner Password: This password is set in the General
Options dialog box (Organisation > Options > General).
Use it to open any payslips you send out.

2. User Password: This is usually the last four digits of the
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employee’s PIN. Where the employee’s PIN is missing,
it defaults to the value set in the General Options dialog
box. This is the password that employees should use.

You can modify the message that is sent to employees to in-
clude help on the password they will use to open the payslip.

1. Go to Procedure > Email Payslips to open the Email
Payslips dialog box.

2. Click on Options to open the Electronic Payslip Options
dialog box (figure C.6).

Message Print
[~ Include password help [~ Job Title OK I
™ 1D numbers Cancel
Sort By
) [ Payment mode
{* Employee number
[¥ PAYE breakdown
" Name
[ Loan breakdown
Layout [V Employer pension
[ Full page

¥ Extended header
Headings

" Black  Red
G Geen C Bue

[ Pension balance
[¥ Coop balance
¥ Loan balance

Figure C.6: Electronic Payslip Options dialog box

3. Check the option Include password help.
4. Close the Electronic Payslip Options dialog box.
5. Close the Email Payslips dialog box.
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