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1 Introduction

About Aren Payroll

Getting Started

Installation

Aren Payroll is a payroll program that runs in the Microsoft
Windows environment. It enables you to set up a database
containing pay details of the employees in your organisation.
Data entry is interactive with income tax, loan payments, pen-
sion fund balances and other calculated amounts updated and
displayed as you work.

The system produces several payroll reports such as payslips,
payroll summary, payroll control account, cash and cheque
lists as well as monthly and annual tax returns. All reports
are formatted for A4 paper so there is no need to buy special
stationery.

Access to the system requires a username and a password.
There is one permanent user who has unrestricted access to
the entire system. Other users can be added at any time and
assigned access to those functions they need to use.

The program can be configured to suit the needs of your organ-
isation. For example, you can define an unlimited number of
payments and deductions. You can also update the tables used
for calculating statutory deductions should the need arise.

Aren Payroll supports multiple organisations which is conve-
nient if you need to run the payroll of more than one organisa-
tion on a single computer. A separate licence key is required
for each organisation.

To use Aren Payroll you must first install it and configure it
to suit your needs. The rest of this section shows you how to
begin this process.

To install Aren Payroll:
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1. Download the installation file pay10.0std.msi from the
downloads page of our website:
https://www.aren.co.ke/payroll/download10.0.htm.

2. Double-click on the installation file to begin the instal-
lation process.

M Aren Payroll 10.0 Standard Edition = X

Welcome to the Aren Payroll 10.0 Standard Edition
Setup Wizard

The installar will guide vou through the steps reguined 10 install Aren Payroll 10.0 Standerd Edition on
WOUF COMpUter

WARMIMG: This computer pragram is pratected by coprright lay and international treaties
Unauthorized duplication or distibution of this program, oF &y partion of it rmaw result in sesarne chd
of criminal penalies, and will be prosacutad o the maxinum extant possible under the 2w

e > | Canca

Figure 1.1: Setup Wizard

3. Follow the on-screen instructions that appear during the
installation process (figure [L.1).

The installation process copies the files required by Aren Pay-
roll to the folder you specify on the hard disk of your computer.
It will also create a desktop icon for Aren Payroll.

Creating a Data Folder

1. Once the installation process is complete, start Aren
Payroll using the desktop icon created above.

2. In the Start dialog box that appears (figure[1.2)), click on
Data Folder to open the Data Folders dialog box (figure

13).

3. Click on Create in the Data Folders dialog to create a
new data folder in which to store Aren Payroll data. The
data folder must be located on the computer running
Aren Payroll, not on a network drive.

Make sure you have unrestricted access to whichever lo-
cation you choose, otherwise the software may not work


https://www.aren.co.ke/payroll/download10.0.htm

Getting Started

Logging In

AREN PAYROLL

Version 10.0
Standard Edition for Kenya
® fren Software Ltd, 1998-2025

[None]

logn. |  Cancel |  DataFoder |

Figure 1.2: Start dialog box

Data Folders b4

Available Folders

Create... seect... || setwngs... |

Target Folder

Figure 1.3: Data Folders dialog box

properly.

. Close the Data Folders dialog to return to the Start di-

alog.

. Within the Start dialog, click on Login to open the Login

dialog box.

. In the Login dialog box enter the username supervisor

(figure [1.4)).

. You will be prompted to enter a password for use in

subsequent logins (figure . Enter a password of your
choice.

. A message box (ﬁgure will then appear asking if you
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| lsamame |3LrD'é|'\'SE."
oK | Cancel | Help ]
Figure 1.4: Login dialog box
Password [~ OK
Confim [ Cancel
Password
Figure 1.5: Set Password dialog box
would like to copy sample data. Choose No to proceed
to set up your organisation.
9 Would you like to copy sample data to this data folder?
Yes | Mo |
Figure 1.6: Sample data message box
5. The New Organisation dialog box is displayed next (fig-
ure[1.7). Type in the name of your organisation and the
month from which you want to start entering data.
6. Close the New Organisation dialog box to begin using
Aren Payroll.
Moving On

Before entering employee data you need to finish setting up
the program. Section [2 explains how to do this. To enter
employee data refer to Section [3| which describes the employee
data tables in Aren Payroll.

After entering employee data you can view the reports de-
scribed in Section With the exception of the muster roll
and payroll variance, all reports can be printed out on A4 pa-



Moving On

Mame |Demo Restaurant Lid
Cancel

i

Month Febraary -
Year [2025

Local Curency |Kefr)-a Shilling

Payroll Curency |Kenya Shilling

Figure 1.7: New Organisation dialog box

per. Use the muster roll to export payroll data to an XML file
in Microsoft Excel format.

To close the current pay period and start a new one, run the
month end procedure described in Section That section
also describes how to back up and restore data and create
bank transfer files.
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Before entering details about employees, use the Organisation
and System menus to configure the program. The Organi-
sation menu options apply only to the organisation that you
are currently working with whereas those of the System menu
apply to all organisations that you define.

Setting up the System

Users

Aren Payroll supports an unlimited number of users. There is
always at least one user, supervisor. The supervisor has access
to all functions including adding and deleting other users and
assigning such users access to program functions. By restrict-
ing users to only those parts of the program they need for their
work, it is possible to enforce separation of duties.

If you wish to add new users at this stage, do the following:

1. Select Users from the System Menu. This displays the
Users dialog box (figure [2.1]).

Add...

il

Password...

Close

Figure 2.1: Users dialog box

2. Click on the Add button which brings up the User Iden-
tity dialog box (figure [2.2).
3. In the User Identity dialog enter the username. You may

also enter the user’s real name to help you identify him
or her in future.
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Usermame agnes

Last Name Kilonzo

Other Names | Agnes

ok | Cancel |

Figure 2.2: User Identity dialog box

4. Close the User Identity dialog and choose Rights from
the Users dialog box. This displays the User Rights di-

alog box (figure [2.3)).

Functions
— OK
¥ Edit employee data

M Modfy payrol fields Cancel |
¥ Set up open organisation

W Close pay perod or month

[ Restore from backup

[~ Add and delete organisations

¥ Modify tax tables

Figure 2.3: User Rights dialog box

5. Use this dialog box to specify the functions that you
would like the user to have access to.

6. Close the User Rights dialog box and choose Password
from the Users dialog box. This brings up the Set Pass-
word dialog box (figure [2.4)).

Corfim [ Cancel |
Password

1% -

Figure 2.4: Set Password dialog box

7. Enter and confirm the password if you wish. If you do
not enter a password at this stage, the user will be re-
quired to enter one when logging in for the first time.
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Banks

8. Close the Set Password dialog box. You can add more
users by repeating the procedure above.

9. Click on Close in the Users dialog box.

Aren Payroll comes with a comprehensive list of banks and
their branches. You will need this list for employees paid by
bank transfer rather than in cash or by cheque. The list is
shared by all organisations that you create. To review or mod-

ify it, select Banks from the System menu which will bring up
the Bank and Branches dialog box (figure [2.5).

Absa Bank

African Banking Cop Add Bank
Bank of Africa 4
Bark of Baroda Add Branch
Bank of India

Citibank NA Dl

Consolidated Bank

Co-operative Bank Properties, |
Credit Bank

Development Bank Close |
Diamond Trust

DIB Bank

Ecobank

Equity Bank

Family Bank

Faulu Microfinance

First Community Bank

GTBank

e R I R I S I R I ]

Figure 2.5: Banks and Branches dialog box

Statutory Deductions Parameters

PAYE is calculated using brackets and rates that are stored as
a table. To view and update this table select Income Tax >
PAYE Rates from the System menu (figure . Refer to the
Kenya Revenue Authority (KRA) website for an up-to-date
PAYE table.

The calculation of PAYE depends on a number of other pa-
rameters e.g. personal relief, insurance relief and allowable
pension fund contribution. Update these parameters by se-
lecting System > Income Tax > Other Parameters to open
the Income Tax Parameters dialog box (figure . This dia-
log also allows you to edit the parameters used for calculating
fringe benefit tax.
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Lower Limit | Upper Limit | Tox Ratern) |

1 24000 10.00 Insert
24001 32333 25.00

3234 500000 30.00 Delete
500001 800000 3250 Q
800001 - Nane - 35.00 Edt

Figure 2.6: PAYE Rates dialog box

Tax Refief Tax Exemption

. - —— oK
Personal Relief 400 [asablty Fxemption 150000 Q

~ EAOn Cancal
Insurance Relief 5000
Secondary Employees
Allowable Benefits Tax Rate (%) 30.00
Meals S000
Fringe Benefit Tax
Agpregate Sene S000
—— = Market [nterest Rate (%):
M 0.00
Allowable Deductons January to March
b [ 0,00
Pension Fund Contribution 30000 April to June 0.00
30000 July to September .00
Owner Oooupier Intenest 3000
October o December .00
Corporation Tax Rate (%) 30,00

Figure 2.7: PAYE Parameters dialog box

NSSF contributions are a percentage of pensionable pay and
are divided into two tiers. To enter this percentage and the
pensionable pay limits for each tier, select NSSF Rates from
the System menu. This opens the NSSF Rates dialog box
(figure where you can also edit the maximum voluntary
contribution.

The payroll supports SHIFﬂ which replaced NHIF as the manda-
tory health insurance deduction. The parameters for calculat-
ing SHIF can be edited by selecting System > SHIF Parame-
ters to open the SHIF Parameters dialog box (figure

Finally, to change the settings for housing and NITA levies,
open the Statutory Levy Parameters dialog box (figure [2.10))

1 Social Health Insurance Fund
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SF Rates fi

Mandatory Contribution

Percentage of Pensonable Pay: oK
Employes 6.00 Cancel

Employer 6.00

Pensionable Pay Limits:

Tier 1 7000
Tier I1 36000

Voluntary Confribution

Upper Limit 600

Figure 2.8: NSSF Rates dialog box

SHIF Parameter
Employee Contribution

Percentage of Gross Salary: 2.75

Loweer Limit: 300.00

o« | cancel |

b

Figure 2.9: SHIF Parameters dialog box

by selecting System > Levy Parameters.

evy Parameter

Housing Levy oK
Percentage of Gross Salary: Cancel

Employes 1.50
Employer 1.50
MNITA Levy

Monthly Amount 50.00

ke

Figure 2.10: Statutory Levy Parameters dialog box

Working with Organisations

A single installation of Aren Payroll can support up to 99
different organisations. Each organisation requires a separate
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licence key. The name of the organisation that is currently
open is displayed in the title bar of the main window.

Adding a new Organisation

To add a new organisation select Add from the Organisation
menu. Use the New Organisation dialog box that follows (fig-
ure to enter the name of the organisation and the month
from which you want to start entering data. On closing the
dialog box, the previous organisation is closed and the new
one opened.

Mame [Demo Company Lid OK

Cancel |

Month | February -

.-r\_
Year |2025

Local Cumency  [Kenya Shilling

Payroll Curency |Kenya Shiling

Figure 2.11: New Organisation dialog box

Opening another Organisation

To open a different organisation select Open from the Organ-
isation menu. This will bring up the Open Organisation di-
alog box (figure provided there are other organisations
defined. Select the organisation you want to open from the
dialog box.

Deleting an Organisation

You can delete any organisation that is currently not open.
Deleting an organisation causes all its data files and folders to
be deleted. It is strongly recommended that you back up the
organisation’s database file before deleting it (see Section [5).

To delete an organisation:

1. Select Delete from the Organisation menu. To minimise
the risk of accidentally deleting an organisation you will
be required to enter your password (figure 2.13)).
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Orgar
ok | Cancel |

Figure 2.12: Open Organisation dialog box
elete Organisatior

Deleting an organisation will cause all is data
files to be deleted. You are strongly advised to
l back up these fies before continuing .
4

If you are sure you want to continue, please
enter your password below.

Pasaward [

oK | Camcel | o Hep |

Figure 2.13: First Delete Organisation dialog box

2. Next, a list of all organisations in the system, exclud-
ing the one that is open, will be displayed (figure .
Select the one you want to delete. Note that it is not pos-
sible to delete the organisation that is currently open.

ok | cance |

Figure 2.14: Second Delete Organisation dialog box

3. In the two message boxes that follow, confirm that you
want to delete the selected organisation and destroy its
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data files.

4. Aren Payroll will then delete the organisation. A dia-
log box confirming that the deletion is complete will be
displayed.

Setting up an Organisation

To configure the organisation that is currently open, proceed
as follows:

Basic Organisation Information

Open the Basic Organisation Info dialog box (figure[2.15)) from
the Organisation menu and enter the organisation’s address
and telephone number.

Name | Demo Restaurant Lid
Status: Not licensed
Folder: C:\Users\ndiri\Payrol Data'¥e!10.0Payroliorgll

Month |February j Year | 2025

Address

P.0. Box | 3598 Town | Nairobi
Post Code | 00100 Telephone | 600400

oK Cancel |

Figure 2.15: Basic Organisation Info dialog box

Also, confirm that you want to start entering payroll details
in the month and year shown in the dialog box. Once you
run the first month end procedure you will not be able to edit
either of them.

Licensing

Select Licence from the Organisation menu to open the Licence
dialog box (figure 2.16). Type in the licence key supplied by
your dealer. If you do not have a licence key, contact your
dealer or Aren Software Ltd.
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Licence Mumber: [0E0S-2822

oK | Cancel | Help |

Figure 2.16: Licence dialog box

Payroll Info

Open the Payroll Info dialog box (figure by selecting
Payroll Info from the Organisation menu. FEnter the bank,
branch and account number for the organisation’s salary ac-
count. Also enter the organisation’s PIN, NSSF, NHIF, SHIF
and HELBP numbers.

1D Numbers Currencies

P [P2s0110213 Lacal Currency | Kemya Shiling
NsSF Mo, |2363821 Payroll Currency |Kevashling

T -
NHIF Mo, | 23505 Bn
SHIF No, | 2410310123456 TABCDE] 1WI Bank [Standard Chartered Bark =
HELB No, | EMP12345 Branch |Harambee Ave -

Account No. | 01013325
Sender ID | 22551
oK Cancel |

Figure 2.17: Payroll Info dialog box

In this dialog box, the Standard File Interchange (SFI) Sender
ID applies to those who submit their payroll to the bank in
electronic form. Leave this field blank if you do not already
have an SFI Sender ID.

Jobs

To set up the jobs available in the organisation, open the Jobs
dialog box (figure [2.18) by selecting Jobs from the Organisa-

tion menu.

2 Higher Education Loans Board
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Administrative Units

Stations

Pay Groups

fss. Restaurant Manager Add
Bartender

Bevarage Manager

Chef Delete
Chief Accountant [
Cleaner Properties

Cook

Dining Room Manager
Director Close
Executive Chef
Head Bartender
Head Cleaner

Head Securty

Head Water
Restaurant Manager
Security Guand
Waiter

Figure 2.18: Jobs dialog box

Set up the administrative units (departments, sections, etc) in
your organisation. To do this select Units from the Organisa-
tion menu.

Set up the stations (branches) in your organisation. To do this
select Stations from the Organisation menu.

Pay Groups allow you to filter payment reports according to
how employees in your organisation are paid. For example,
the bank transfer report could be filtered by bank branch or
pay date.

To set, up pay groups, select Pay Groups from the Organisation
menti.

Co-operatives and Pension Funds

Insurance Companies

Create co-operative societies that employees in the organisa-
tion belong to by selecting Co-operatives from the Organisa-
tion menu.

Similarly, set up pension funds by selecting Pension Funds
from the Organisation menu.

If you need to deduct and remit insurance premiums, set up
the insurance companies involved by selecting Organisation >
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Employee Profiles

General Options

Insurance Companies.

An employee profile defines attributes that are common to
a group of employees. These attributes are pay frequency,
basic pay type (i.e., salary, daily rate or hourly rate), standard
working hours (per day and per month) and whether overtime
is payable.

To create a profile, select Profiles from the Organisation menu
to open the Profiles dialog box (figure 2.19). If there is an
employee profile marked as default, all new employees added
to the payroll will be assigned this profile.

Staff Add
Delete
Properties
Close

Figure 2.19: Profiles dialog box

Selecting Options > General from the Organisation menu opens
the General Options dialog box (figure [2.20). This dialog box
allows you to choose the sort order for employee data entry
forms. It also allows you to activate the Open Table dialog
box used for filtering form data by administrative unit, sta-
tion or pay group.

You can also specify when to purge old reports. Deleting old
reports saves space on the hard disk and reduces the size of
backup files.

In the PDF documents section you can edit the following pass-
words.

1. Owner Password: This password allows you to open any
PDF documents that you send by email. It should not
be disclosed to employees.
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Data Entry Forms
x|
Sort By:
+ Employes Mumber " Last Name Cancel
[~ Show Open Table dialog box Help |
Past Reports

Purge after |_5 years

PDF Documents

Owmner Password owner

Default User Password | user

Figure 2.20: General Options dialog box

2. Default User Password: Employees use the user pass-
word to open PDF documents sent to them. It is usually
set to the last four digits of the employee’s PIN. Where
the PIN is missing, the default value you enter here is
used instead.

Payroll Options

Selecting Options > Payroll from the Organisation menu brings
up the Payroll Options dialog box (figure [2.21)).

== Taxable Pay oK

NSSF [ Tax excess employer pension on employee Cancel
Levies [~ lgnore benefits unless total exceeds Ksh 5,000 J
Help
Net Pay
PAYE

(" Deduct exact amount
(% Round down to nearest Ksh

" Round up to nearest Ksh

[ Allow negative amount

Figure 2.21: Payroll Options dialog box

Taxable Pay

If your organisation is tax-exempt you are required to treat the
employer’s pension contribution as a taxable benefit. Select
the option to tax excess employer pension on employees.
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PAYE

NSSF

Housing Levy

NITA Levy

Net Pay

Logos

KRA’s online tax administration system, iTax, does not tax
benefits unless they total to more than Ksh 5,000. By default,
Aren Payroll taxes all non-cash benefits regardless of their
total. For it to work like iTax you must check the option
Ignore benefits unless total exceeds Ksh 5,000.

By default, PAYE is rounded down to the nearest shilling. To
match the iTax system, you should select the option to deduct
the exact amount of PAYE.

For employees who are paid more than once a month, it is
possible though unlikely for the PAYE amount for a particular
pay period to be negative. To avoid this, uncheck the option
to allow negative PAYE.

If your organisation has opted out of Tier IT NSSF contribu-
tions, select whether to deduct Tier IT NSSF selectively or not
all.

If you would like to turn off housing levy for the whole organi-
sation, uncheck the option to deduct housing levy. By default,
housing levy is rounded to the nearest shilling. To match the
iTax system, select the option to deduct the exact amount of
housing levy.

If your organisation pays NITA Levy for its employees, check
the option Pay NITA Levy. An annual report showing the
amount payable for each employee will be generated.

Finally, you have the option to round down net pay for em-
ployees paid in cash by an amount that you specify. The excess
amount is carried forward to the next month.

Selecting Options > Logos from the Organisation menu brings
up the Logos dialog box (figure [2.22]). This dialog box allows
you to select image files with the organisation’s logo for use
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in payslips. These files must be in the images|logos folder
located within the organisation folder.

Printed Documents

Select..
Remaove

Email Attachments

Select...

Remove |

oK J Cancel | Help |

Figure 2.22: Logos dialog box

For printed payslips you can select a PNG or JPEG file. PNG
images are typically sharper than JPEG ones but they occupy
more space.

Select a JPEG file for payslips that are sent as email attach-
ments in PDF format. Attachments are restricted to 64 KB
so the logo file must be well below that size.
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Data for each employee is stored in two database tables, the
employee master table and the payroll transactions table. This
data is used to create the various report tables from which
reports are printed.

Employee Master Table

The employee master table stores static information about
each employee. It is accessed by selecting Employee from the
File menu. This brings up a data entry form in which you
enter details about each employee (figure .

-

Record 1 of 45 001 Asega. Stephen Lihenzer
Personal
Employment Last Name [ Asega
Payment .
Other Names | Stephen Lihenzero
Basic Pay
Crvertime Gender -
Housng Birth Date | 5 Aug 1977 _I
PAYE ;
ID Mo, | 23545864
NSSF & S5HIF )
Co-cperatives Passport No.
Pension Funds Work Permit No.
Other

Figure 3.1: Employee Master Table form

You can add and delete employee records using the Add, Delete
and Terminate commands in the Record menu.

e The Delete command simply deletes an employee record.
It is only available if no month end procedure has been
run since the current employee was added.

e The Terminate command transfers an employee record
from the employee master table to the leavers report ta-
ble. This transfer takes place in the month end procedure
that follows the termination date specified by the user.
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Most of the fields in this table are optional. However, Em-
ployee Number, Last Name, Other Names, Job Title, Admin-
istrative Unit and Station are mandatory. If an employee is
paid by bank transfer, then Bank, Branch and Account Num-
ber are also mandatory. The optional fields are used in various
reports and should therefore not be left blank.

Payroll Transactions Table

The payroll transactions table stores earnings, deductions, ben-
efits, lump sum payments and refunds for each employee for
the current month.

FEarnings (or monthly cash earnings) are those cash payments
that relate to the current month e.g. basic pay or leave al-
lowance.

Benefits are private expenses of an employee that are paid by
the employer e.g. school fees, house rent or telephone bills.
These non-cash benefits are considered as income for tax pur-
poses.

Deductions are those amounts deducted from an employee’s
pay by the employer. Some of these are called statutory de-
ductions because the law requires the employer to deduct them
from the employee’s pay. The statutory deductions are PAYE,
NSSF, SHIF, housing levy and tax on lump sum payments.

Lump sum payments are those cash payments that do not
relate to the current month alone. Some like gratuity and
bonuses have accrued over past months while others like ter-
minal benefits may relate to past or future months. We make
the distinction between lump sum payments and monthly cash
earnings because the two are treated differently when calcu-
lating income tax.

Refunds are payments made to an employee, e.g. travelling or
subsistence allowances, for business expenses incurred while
on duty. These payments are not income and are therefore
not taxable.

The payroll transactions table is accessed by selecting Payroll
from the File menu. This displays a data entry form (figure
3.2) where you enter earnings, deductions, benefits, lump sum
payments and refunds for each employee.

Statutory deductions and other calculated amounts such as
taxable pay, net pay and gross pay are updated as data is
entered. This makes the calculations more transparent and
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Payroll Fields

Record 1 of 45 D01 Asega, Stephen Lihenzem
Eamings
Deductions Basic Pay | l
Benefiis Overtime [~ li
Lump Sum Payments =
Refunds
Statutory Deductions
Summary
Taxable Pay
l
65,000,00

Figure 3.2: Payroll Transactions Table form

helps to reduce data entry errors. The payroll transactions ta-
ble can only include employees present in the employee master
table. Use the Remove command in the Record menu to sus-
pend employees from the payroll. Suspended employees can
be restored at any time using the Record > Add command.

At installation, the payroll transactions table has two earnings
(Basic Pay and Overtime), three deductions (Rent, Overdraft
Recovery and Rounding C/F), one non-cash benefit (Employer
Pension) and one refund (Rounding B/F). These fields cannot
be deleted but you can add more according to your needs.

To add, delete or edit fields, select Earnings, Deductions, Ben-
efits, Lump Sum Payments or Refunds from the File menu. A
data entry form will be displayed showing the field attributes

listed below (figure [3.3). To add or delete fields select Add or
Delete from the Field menu.

The following field attributes apply to all fields:

1. Field Name: The name of the field e.g. advance, shift
allowance.

2. Type: This is used to indicate permanent fields (e.g. ba-
sic pay and rent). It is also used to specify fields that
are calculated in a unique way (e.g. hourly pay and
daily pay) and those that are associated with a balance
that is updated and displayed by the system (e.g. loan
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Field 3 of 11

Field Name | Savers Pension

Type Pension Contribution j Parameters...
Amount |Percentage of Salary j Percentage...

[V Pre-tax deduction

Figure 3.3: Deductions form

repayments and co-operative contributions). The type
advance is used to indicate advance payments so that
appropriate reports can be generated.

. Amount: This attribute specifies how the amount paid

to or deducted from each employee is arrived at. It may
be keyed in, a percentage of salary, a function of the time
worked (basic pay, overtime, hourly pay and daily pay)
or amortised (loan repayments).

. Static: Static fields retain their value when the month

end procedure is run, whereas non-static fields are reset
to their lower limit. This is only important for fields that
are keyed in. It saves you the trouble of having to key
in the amount earned or deducted each time the month
end procedure is run.

. Tazable/Pre-tax deduction: For earnings, the taxable at-

tribute specifies whether or not the payment is subject
to PAYE. Unless prior permission has been given by the
KRA, all income (i.e. earnings, non-cash benefits and
lump sum payments) must be taxed. Refunds are not
taxable as they are not a form of income.

The pre-tax deduction attribute indicates those deduc-
tions to be subtracted from gross income when calculat-
ing PAYE. In Kenya pre-tax deductions include NSSF
and other pension fund contributions, SHIF, housing
levy, and mortgage interest payments.

. Pensionable: NSSF is calculated on the total pension-

able earnings. Uncheck the pensionable option to ex-
clude any earning from this calculation.

. Regular: SHIF and housing levy are calculated on basic
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pay plus all regular allowances. Any earnings not marked
as regular are not subjected to either deduction.

Depending on the selection for Type and Amount attributes
the following additional attributes may be available:

1. Co-operative: The name of the co-operative associated
with the field (figure [3.4).

Name: |Demo Saces =]

0K Cancel |

Figure 3.4: Co-operative dialog box

2. Pension Fund: The name of the pension fund and other
details pertaining to the current field (figure [3.5).

MName |Savers | OK

Cancel |
Employer's Contribution

.F’c-'ce'r'.agc of Salary 3

-

Percentage 10.00
[ Apply Limits
Lower Limt |

Upper Limit

Figure 3.5: Pension Fund Parameters dialog box

3. Insurance: The name of the insurance company associ-
ated with the field.

4. Limits: The upper and lower limits that the amount
paid or deducted should be restricted to (figure [3.6).

5. Percentage: The percentage of monthly salary that should
be paid or deducted (figure [3.7).

6. Hourly Rate: The hourly rate to use for earnings that
are of the type Hourly Pay (figure [3.8)).

7. Daily Rate: The daily rate to use for earnings that are
of the type Daily Pay.
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Limits
Lower Limit I 0 |
Upperlmt [ 50000

ok | Cancel |

Figure 3.6: Limits dialog box

| Percentage of Salary > |

Percentage | 5.00 oK j
| | ¥ PApply Limts

Lower Limit | 0
| | UpperLimt | 30000

d

Figure 3.7: Percentage of Salary dialog box

Hourly Rate

(* Basic Pay Ratex| 050
|

" HKey in rate for each employes

IDKJCmch

Figure 3.8: Hourly Rate dialog box
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Aren Payroll produces numerous reports as described below.
These reports can be viewed on the screen and printed out.
You can choose to print the entire report, a range of pages, or
just the page that you are currently viewing. Internal reports
can be sorted by either employee number or name.

You can view and print reports for current as well as past
months and years. You can also filter most reports by ad-
ministrative unit, station, pay group, bank, co-operative or
pension fund.

Reports may be printed on any printer connected to your com-
puter either directly or through a local area network. Because
all reports are formatted for A4 paper, the printer must be set
to print on A4.

1. To open a report select it from the Report menu and then
follow the on-screen instructions. For example, selecting
Report > Payslips opens the Open Payslips dialog box

(figure [4.1).

Pay Period

0K

Year (2025 Cancel

Month |February i Next >

Options._.

Figure 4.1: Open Payslips dialog box

2. To print the open report select Print from the File menu
which brings up the Print dialog box (ﬁgure. Use the
Setup button in this dialog box to configure the printer
you want to use.
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Printer:
oK
Epson L6570
Cancel
Pages to print:
Setup...

(o Al

(" Current Page

(" Pages: To

Mumber of Copies: 1

Figure 4.2: Print dialog box

3. Choose Close from the File menu to close the report.

Nominal Rolls

1. Employees Roll: List of employees who are currently ac-
tive. It shows their job title, administrative unit and
station.

2. Joiners Roll: List of employees who joined the organi-
sation recently. It shows their job title, administrative
unit, station and start date.

3. Leavers Roll: List of employees who left in a given year.
It shows their final job title and administrative unit, the
date they left and the reason for leaving.

Monthly Payroll Reports

The monthly payroll reports relate to a single month. Reports
for the current month are updated as you update the employee
master table and the payroll transactions table. Reports for
previous months can be viewed and printed out, but they can-
not be modified in any way.

Overview Reports

1. Payroll Summary: Summarises earnings and deductions
for all employees.

2. Payroll Control Account: T-account listing total earn-
ings, deductions and net pay for all employees in the
organisation.
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3. Muster Roll: List of employees showing all earnings,
lump sum payments, refunds and deductions for the month.
Records in this report can be grouped by administrative
unit or station.

4. Payroll Variance: List of employees showing the differ-
ences in the payments and deductions made in any two
pay periods. It is essentially the difference between the
muster rolls for the two pay periods.

5. Gross Pay By Unit: List of administrative units showing
the staff count and total gross pay for each.

6. Gross Pay By Station: List of stations showing the staff
count and total gross pay for each.

The muster roll and payroll variance can be viewed on the
screen or saved to an XML file but they cannot be printed
out.

Detail Reports

1. FEarning Report: List showing, for a particular earning,
how much each employee was paid.

2. Deduction Report: List showing, for a particular non-
statutory deduction, how much each employee was de-
ducted. Depending on the type of deduction selected, a
loan or HELB report may be printed instead.

3. Loan Report: List of employees repaying a specific co-
operative or company loan. It shows the opening and
closing balances and a breakdown of the repayment amount
into interest and principal components.

4. HELB Report: List showing the HELB Repayment Sched-
ule in the format previously used for filing returns to
HELB. HELB returns should be filed on their website
using the return file available under Procedure > HELB
Schedule.

5. Benefit Report: List showing, for a particular non-cash
benefit, how much each employee received.

6. Lump Sum Report: List showing, for a particular lump
sum payment, how much each employee received.

7. Refund Report: List showing, for a particular refund,
how much each employee received.
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Payments to Employees

. Payslips: Slip giving a breakdown of the earnings and

deductions of each employee separately (figure . The
employer’s pension contribution and the pension fund
balance can be shown in the payslip if required. When
the balance is shown, it includes the employer’s portion
only if the option to print the employer contribution has
been selected.

[d|a] «[«|v[m]| x| ¥

Demo Restaurant Ltd Demo Restaurant Ltd
Fayslip Payslip

NSSF (Terl)
HESF (Teer i

Mel Pay 4067100 Mel Pay AT

Page | of 45 KES February 2025

Figure 4.3: Payslips

. Cash List: List of employees paid in cash showing their

employee number, name, net pay or advance payment
and a cash analysis of the payment amount.

. Cheque List: List of employees paid by cheque showing

their employee number, name and net pay or advance
payment.

. Bank Transfer Report: List of employees who are paid

by bank transfer showing their name, ID number, bank,
branch, account number and payment amount. The pay-
ment amount may be the net pay, an advance payment,
a bank loan repayment or a HOSP contribution.

. Coinage Summary Report: List showing the number of

coins and notes of each denomination that are required
for workers who are paid in cash. This information is
the same as the totals in the cash list but formatted so

that it can be used when withdrawing the cash from a
bank.
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Statutory Returns

Other Returns

. PAYE Report: List of employees showing their PAYE

deductions. To generate the equivalent iTax return file,
go to Procedure > iTax Files > Employee Details.

. NSSF Report: List of employees showing NSSF number,

ID number and the combined employer and employee
tier I and tier IT contributions. Voluntary contributions
are also shown.

The NSSF return file is available under the Procedure
menu (Procedure > NSSF Return > Self-Service). This
generates an XML file which should be opened with Mi-
crosoft Excel and saved again as an Fxcel file.

. NHIF Report: List of employees showing NHIF number,

ID number, date of birth and NHIF deduction.

. SHIF Report: List of employees showing ID number,

KRA PIN, NHIF number, contribution amount and phone
number. To generate the equivalent SHIF return file, se-
lect Procedure > SHIF Return. This saves an XML file
that should be converted into a Microsoft Excel spread-
sheet.

. Housing Levy Report: List of employees showing PIN,

gross salary and housing levy payable. The equivalent
iTax return file is available under Procedure > iTax Files
> Housing Levy.

. Lump Sums Tax Report: List showing tax payable on

lump sum payments for each employee.

. Fringe Benefit Tax Report: List showing tax payable on

the fringe benefit arising from company loans issued at
an interest rate below the KRA prescribed market in-
terest rate. The equivalent iTax return file is available
under Procedure > iTax Files > Fringe Benefit Tax.

. Co-operative Report: List of members of a particular co-

operative society showing membership number, monthly
contribution and any other payroll deductions to be paid
to that co-operative.

. Pension Report: List of members of a particular pension

fund showing membership number and employer and em-
ployee contributions to that pension fund.



32

4 Reports

3.

Annual Payroll Reports

Insurance Company Return: List of employee premium
deductions to be paid to a particular insurance company.

Annual payroll reports relate to a calendar year and are avail-
able throughout the year. For the current year, the informa-
tion displayed relates to the months that have elapsed so far.
The reports are:

1.
2.
3.

10.

Other Reports

Payroll Control Account.
Muster Roll.

Annual Pay Sheet: A report that, for each employee,
gives a summary of payments, deductions and benefits
for a whole year.

P9A: KRA form titled Tax Deduction Card. Each P9A
gives a breakdown of the income of an employee for each
month of the year and shows the amount of tax deducted.

P10: KRA form titled Employer’s Covering Certificate.
It shows the tax deducted by the employer for each
month of the year.

P10A: KRA form titled Supporting List for End of Year
Certificate. Tt lists the annual income and total tax de-
ducted from each employee.

NITA Levy Report: List showing the NITA levy payable
for each employee in the payroll.

NSSF Statement: A summary of an employee’s standard
and voluntary contributions to NSSF for a calendar year.

NHIF Statement: A summary of an employee’s NHIF
deductions for a calendar year.

SHIF Statement: A summary of an employee’s SHIF
deductions for a calendar year.

. Bank Codes: A listing of banks, bank branches and their

sort codes drawn from the bank data tables.

Audit Trail: List that shows the date and time of each
login, backup, month end procedure and any other major
event. It also shows the user responsible for each event.
This report is only available to the supervisor.
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Report Tables

Almost all reports are printed from report tables, not directly
from the employee data tables. Briefly, the report tables are:

1. Active employees report table
2. Annual leavers report tables
3. Monthly payroll report tables
4. Annual payroll report tables

Report tables are updated automatically by Aren Payroll. Use
the General Options dialog box (Organisation > Options >
General) to specify how long to keep these tables for.
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Backing Up

If any of your organisation database files is accidentally deleted
or corrupted you could lose all the data for that organisation.
Without an up-to-date backup you would be forced to key in
the data for the current month again. It is also likely that
you would be unable to recreate data for previous months and
years. It is therefore very important that you make regular
backups of your database files.

To back up the database file for the organisation that is cur-
rently open, select Back Up from the Procedure menu. You
will be prompted to specify the name and location of the
backup file to be created (figure [5.1).

3

“ Payroll » backup

I
1
g

a

]

14

P Gallery

Feb25.fbk
all Deskiop
- share
Publc
v Downloads
ndin

WebApps

File narne:

Sanve as type:  Backup Files [*.fbk)

» Hide Folders Save Cancel

Figure 5.1: Backup dialog box

The backup process copies all data relating to your organi-
sation to the backup file. Should you have set up more than
one organisation, you will need to back up each one separately.
Note that data that is shared by all organisations is not backed
up (e.g. list of banks and statutory deductions parameters).

When running the month end procedure you will be prompted
to back up. Though you can choose to proceed without doing
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so, it is recommended that you back up first. To encourage
regular back ups Aren Payroll prompts you to back up each
time you exit.

Restoring from Backup

In the event that an organisation database file is corrupted or
deleted, you will need to replace it from backup. You can also
use backup files to revert to an earlier month. This is especially
useful if you accidentally run the month end procedure.

To restore an organisation database file from backup, select
Restore from the Procedure menu then follow the on-screen

instructions (figure [5.2)).

Restoring from backup will replace all the data
fior this organisation with that retrieved from the
backup file. You are encouraged to back up
the arganisation before continuing

\.\

If you are sure you want to continue, please
enter your password below

Password

oK ] Cancel | Hel ]

Figure 5.2: Restore dialog box

Creating a Bank Transfer File

A bank transfer file is an electronic version of the bank transfer
report. It is used by banks to process payments for employees
paid by bank transfer in place of the printed bank transfer
report. Aren Payroll can create bank transfer files for numer-
ous banks e.g Absa, Co-operative, Equity, KCB and Standard
Chartered.

1. To create a bank transfer file select Bank Transfer File
from the Procedure menu. The Save Bank Transfer File

dialog box appears (figure [5.3).

2. Specify the format of the bank transfer file to create
and the name of the payment field (usually net pay).
Depending on the file format, you may be able to specify
the date you want the bank transfer effected.
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Saving iTax Files

Pay Period

Year (2025 Cancel

Month | February v Next >

Figure 5.3: Save Bank Transfer File dialog box

3. On closing the Save Bank Transfer File dialog box, a
standard Save As dialog box will appear. Use this dialog
to specify the name and location of the file to be created.

For further details on bank transfer files please contact your
bank.

iTax files are text files containing tax details for employees in
the payroll. These files help you to fill out the iTax spreadsheet
(P10_ Return.xzlsm) that is used for filing tax returns on the
KRA website.

Four formats are available—Employee Details, Disabled Em-
ployee Details, Fringe Benefit Tax Details and Housing Levy
Details. Data exported in these formats should be imported
into the corresponding tabs of the iTax spreadsheet.

1. To save the Employee Details file, select iTax File >
Employee Details from the Procedure menu.

2. In the Save Employee Details File dialog that is displayed
(figure [5.4), select the month and year you want.

3. By default only employees who have paid PAYE in the
selected month will be included in the file. If you wish
to include those with zero PAYE as well, click on Next
and select the option Include all employees.

4. On closing the Save iTax Employee Details File dialog
box, a standard Save As box will appear. Use this dialog
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oK
Year [2025
Cancel

Month | February

| 4

Next >

Figure 5.4: Save iTax Employee Details File dialog box

to specify the name and location of the file to be created.

Files in any of the other formats can be created in the same

manner. For further assistance with iTax please contact the
KRA.

Terminating an Employee

To terminate an employee, open the employee master table
and display the target employee. Next, select Terminate from
the Record menu. In the Terminate dialog box that appears
(figure , enter the termination date, the reason for leaving
and, if you like, some brief comments.

Temination Date 0K
2o/UL 2025 L —

Reason for Leaving
Resigned =

Remarks:

Figure 5.5: Terminate dialog box

The terminated employee will be removed from the employee
data tables in the next month end procedure that is later than
or on the same day as the termination date. Once the employee



Closing the Month

39

is deleted from the employee data tables his record will be
added to the leavers report table.

Termination can be reversed by selecting Record > Undo Ter-
mination as long as the terminated employee has not been
removed from the employee data tables.

Closing the Month

The month end procedure is used to close data entry for the
current month and begin a new one. It applies only to the
organisation that is currently open. It does the following:

1.

Saves all payroll information for the current month to
the monthly and annual report tables.

. Transfers terminated employees from the employee mas-

ter table to the leavers report table.

Deletes the current payroll transactions table and creates
a new one for the coming month.

Deletes any report data that is older than the limit set
in the General Options dialog box.

. Advances the pay period by one month.

. If the new month is January, it creates statutory deduc-

tion tables for the new year.

The month end procedure should only be run after all reports
for the current month have been verified since, once it is run,
reports for that month cannot be changed.

To run the procedure:

1.

Select Month End from the Procedure menu. This op-
tion is only available if you have licensed the organisa-
tion.

. After reading the dialog box that appears (figure ,

confirm that you want to close the month by entering
your password.

. You will now be prompted to back up your data and are

strongly encouraged to do so.

Once the back up is complete, the month end proce-
dure will automatically follow. Eventually, a message
box confirming its completion will appear.
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Month End Procedure X

! payroll enries wil appearin March 2025,

enter your password below .
Passwod [
ok | Cancel | Hep |

Figure 5.6: Month End Procedure dialog box
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File Format

Keying in new employees into the payroll can be very time
consuming especially if there are many of them. As an al-
ternative, you can import employee data into the employee
master table from a text file.

The easiest way to create the input text file is to capture em-
ployee data in a spreadsheet and then save the spreadsheet as
a text file.

The format of the input text file is as follows:

1.

Plain text with data items separated by the tab character
(i.e. a tab-separated text file).

The first row of data is a header with the data items Em-
ployee Number, Last Name, Other Names, 1D Number,
Job Title, Admin Unit, Station, Pay Rate, PIN, NSSF
Number and SHIF Number.

From row two onwards, each row has data for a single
employee, i.e. employee number, last name, other names,
ID number, job title, administrative unit, station, pay
rate, PIN, NSSF number and SHIF number.

Note that:

1.

The first row (file header) is ignored. It is only included
for the convenience of the person preparing the input
file.

A row will not be imported if the employee number
matches that of a record already in the employee master
table.

. A row will also be skipped if any of the following data

items is blank: employee number, last name, other names,
job title, administrative unit, station.

Data will be imported into several data tables—employee
master, payroll transactions, jobs, adminstrative units
and stations.
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How to Import

5. Where a default profile has been defined, it will be ap-
plied to each record added to the employee master table.

1. Back up your data just in case you need to undo the
changes you are about to make (Procedure > Backup).

2. Select Procedure > Import Employees to open the first
Import New Employees dialog box (figure [A.1]).

Impaorting employes data from a text file may
modify several data files t is advisable to
back up your data before continuing

\.\

if you are sure you want to continue, please
enter your password below

Password

oK J Cancel | Help J

Figure A.1: First Import New Employees dialog box

3. Enter your password to open the second Import New
Employees dialog box.

4. Browse to the text file that you want to import data
from and click on Open.

5. Aren Payroll will read the text file and update the data
tables listed above. On completion, a confirmation mes-
sage box will be displayed. Close the message box.

To see which records were updated, refer to the log file im-
port.log located in the payroll data folder. Browse through
the data tables that should have been updated to confirm that
they were updated successfully.
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Aren Payroll can email payslips and P9As to each of the em-
ployees in the payroll. This provides an alternative to printing
individual payslips or P9As for each employee. The reports
are sent as password-protected PDEF files.

In this section, we explain how to email payslips. Emailing
P9As works in exactly the same way.

Entering Email Addresses
Start by capturing the email addresses to send reports to.

1. Open the Employee Master Table form (File > Em-
ployee) and select the Other tab (figure [B.1)).

Record 1 of 45 001 Asega, Stephen Lihenzem

Personal
Employment
Payment
Basic Pay

Owvertime

Mabile Phone | 0622 555001

Email reports to:

asegai@demorestaurant.co.ke

Housing
PAYE

NSSF & SHIF
Co-operatives
Pension Funds

Other

Figure B.1: Employee Master Table form

2. For each employee, enter the address to email reports to.

3. Close the Employee Master Table form.

Setting Up Email Account

In order to send email, you need to set up your email account.
For this you require details of the outgoing mail server, also
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known as the SMTP server. Consult your IT department if
necessary or check the settings in the email software you use.

1. Select System > Email Account to open the Email Ac-
count dialog box (figure [B.2)).

Genera

Email Address | info@demorestaurant.co.ke

[ Copy all emails to self
Hedp

SMTP Server
Address |mau|.oemrestumt.m.ke
Port | 587
Timeout ["-*'5 seconds

[¥ Use secure connection

Authentication

Type |Log-r -

Account Name | info@demorestaurant.co.ke

xxxxxxxxxxxx

Password |

Figure B.2: Email Account dialog box

2. Email Address: Enter your email address, say info@-
demorestaurant.co.ke or example@gmail.com.

3. SMTP Server: Enter the name of the outgoing mail
server, e.g. mail.demorestraurant.co.ke or smitp.gmail-
.com. You can also enter the server’s IP address, e.g.
192.168.0.23.

4. SMTP Port: The SMTP port is a unique number that
the mail server has set aside for outgoing mail. The most
common values are 25, 465 and 587. If your server uses
a secure (encrypted) connection, e.g. smip.gmail.com or
smip.mail.yahoo.com, try port 465 or 587. If it does not,
enter 25.

5. Timeout: This is length of time the software should wait
for a response from the mail server before giving up.

6. Use secure connection: Check this option if the mail
server uses a secure connection.
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10.

Sending Payslips

Authentication: You may select none (no account name
or password required), plain or login (requires account
name and password).

Account Name and Password: Enter the login name and
password for the mail server if you have selected login or
plain authentication.

Copy all emails to self: Check this option if you want to
receive a copy of all the reports you send.

Close the Email Account dialog box.

Now you are ready to email payslips to employees.

1.

Select Procedure > Email Payslips to open the Email
Payslips dialog box (figure [B.3)).

Pay Period
oK

Year (2025 Cancel

Month |February i Next >

Options._.

Figure B.3: Email Payslips dialog box

Choose the pay period that you want then click OK. This
opens the Payslip Messages dialog box (figure [B.4)).

Click on Send to open the Message Range dialog box
(figure [53).

Use the Message Range dialog box to send the current
message, all messages or a range of them. On comple-
tion, a message box showing the number of messages sent
will be displayed.

Close the Payslip Messages dialog box when you are
through.
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Send To:

Subject:

Wessage,

Attachment

) | Messageraras > i

|aseqa@demorestwraﬂ co ke

|Pa-;u|p for February 2025

e

H
Dear Stephen,

Your payslip for February 2025 is attached. You can save, view and
print & at your convenience

Regards
Demo Restaurant Ltd

Demo Restaurant Ltd

Payslip

Employes No.: 001

Hame: RAsega, Stephen Lihenzero
Pay Period: February 2025

Figure B.4: Payslip Messages dialog box

Send
| OK
| * Cument Message 4
Cancel
™ Al Messages 4
™ Messages

Fom: [ To:[

Figure B.5: Message Range dialog box

Details of the last mail session are saved in the log file email.log
located in the payroll data folder. Refer to this file if you have
any difficulty sending messages and to see which messages were
actually sent.

How to Open Payslips

Once a payslip is sent, the recipient will need one of the fol-
lowing passwords to open it.

1. Owner Password: This password is set in the General
Options dialog box (Organisation > Options > General).
Use it to open any payslips you send out.

2. User Password: This is usually the last four digits of the
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employee’s PIN. Where the employee’s PIN is missing,
it defaults to the value set in the General Options dialog
box. This is the password that employees should use.

You can modify the message that is sent to employees to in-
clude help on the password they will use to open the payslip.

1. Go to Procedure > Email Payslips to open the Email
Payslips dialog box.

2. Click on Options to open the Electronic Payslip Options

dialog box (figure [B.6).

Message Print

[ Include password help [~ Job Title

OK
o

™ ID numbers Cancel

Sort By
~ [~ Paymert mode
f+ Employes number

== [# PAYE breakdown
(" MName

[™ Loan breakdown

Layout ¥ Employer pension
[~ Full page

¥ Estended header

Headngs

[V Pension balance
[¥ Coop balance
v Loan balance

(" Black ( Red

 Green [ Blue

Figure B.6: Electronic Payslip Options dialog box

3. Check the option Include password help.
4. Close the Electronic Payslip Options dialog box.
5. Close the Email Payslips dialog box.
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