
Aren Register

Version 7.0

Standard Kenya Edition

User Guide

Aren Software Ltd



Copyright c©Aren Software Limited, 2018

All rights reserved. No part of this manual may be reproduced, stored in a retrieval sys-
tem, or transmitted in any form or by any means, electronic, mechanical, photocopying,
recording, or otherwise, without prior written permission of Aren Software Limited.

Produced by Aren Software Ltd, P.O. Box 10083 Nairobi 00100, Kenya. Phone 0722 861553,
0733 861553.



Contents

1 Introduction 1

About Aren Register . . . . . . . . . . . . . . . . . . 1

Getting Started . . . . . . . . . . . . . . . . . . . . . 1

Moving On . . . . . . . . . . . . . . . . . . . . . . . 4

2 Setting Up 7

Setting up the System . . . . . . . . . . . . . . . . . 7

Working with Organisations . . . . . . . . . . . . . . 10

Setting up an Organisation . . . . . . . . . . . . . . . 13

3 Data Files 21

Personnel File . . . . . . . . . . . . . . . . . . . . . . 21

Payroll Master File . . . . . . . . . . . . . . . . . . . 22

Payroll Transactions File . . . . . . . . . . . . . . . . 22

Absence and Leave File . . . . . . . . . . . . . . . . 27

4 Reports 29

Personnel Reports . . . . . . . . . . . . . . . . . . . 30

Monthly Payroll Reports . . . . . . . . . . . . . . . . 31

Quarterly Payroll Reports . . . . . . . . . . . . . . . 34

Annual Payroll Reports . . . . . . . . . . . . . . . . 35

Other Reports . . . . . . . . . . . . . . . . . . . . . . 35

Report Files . . . . . . . . . . . . . . . . . . . . . . . 35

5 Procedures 37

Backing Up . . . . . . . . . . . . . . . . . . . . . . . 37

Restoring from Backup . . . . . . . . . . . . . . . . . 38



iv Contents

Creating a Bank Transfer File . . . . . . . . . . . . . 38

Saving iTax Files . . . . . . . . . . . . . . . . . . . . 39

Terminating an Employee . . . . . . . . . . . . . . . 40

Closing the Month . . . . . . . . . . . . . . . . . . . 41

A Importing Data 43

File Format . . . . . . . . . . . . . . . . . . . . . . . 43

How to Import . . . . . . . . . . . . . . . . . . . . . 44

B Emailing Payslips 45

Entering Email Addresses . . . . . . . . . . . . . . . 45

Setting Up Email Account . . . . . . . . . . . . . . . 45

Sending Payslips . . . . . . . . . . . . . . . . . . . . 47

How to Open Payslips . . . . . . . . . . . . . . . . . 48

C Formulae 51

Loans . . . . . . . . . . . . . . . . . . . . . . . . . . 51



1 Introduction

About Aren Register

Aren Register is an extension of the traditional payroll system
to include some features normally found in personnel systems.
It runs in the Microsoft Windows environment.

Aren Register lets you specify the posts available in your or-
ganisation and then assign existing employees to these posts.
As new employees join they are assigned to the posts you have
speci�ed. Employees are retained in the system until they
leave the organisation. Reports on current and former em-
ployees are provided.

The system will help you to keep track of annual leave days
earned and taken by employees. You will also be able to record
all absence from work. Annual reports on leave and absence
are available.

Aren Register makes it easy to process employee pay. It en-
ables you to specify all payments and deductions that apply
to each employee. Several reports are derived from this data,
including payslips, payroll summary, payroll control account,
monthly and annual returns for PAYE as well as monthly re-
turns to NHIF, NSSF and user-de�ned co-operatives and pen-
sion funds.

Access to the system requires a username and a password.
There is one permanent user who has unrestricted access to
the entire system. Other users can be added at any time and
assigned access to those functions they need to use.

A single installation of Aren Register will support multiple
organisations though a separate licence is required for each of
them. A comprehensive backup system is also provided.

Getting Started

To use Aren Register you need to install it and con�gure it
to suit your needs. The rest of this section shows you how to
begin this process.
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Installation

To install Aren Register:

1. Insert the installation CD in the CD drive.

2. Run the program setup.exe on the installation CD.

Figure 1.1: Setup Wizard

3. Follow the on-screen instructions that appear during the
installation process (�gure 1.1).

The installation process copies the �les required by Aren Reg-
ister to the folder you specify on the hard disk of your com-
puter. It will also add Aren Register and its Help �le to the
Start menu.

Creating a Data Folder

1. Once the installation process is complete, run Aren Reg-
ister by selecting it from the Start menu.

2. In the Start dialog box that appears (�gure 1.2), click on
Data Folder to open the Data Folders dialog box (�gure
1.3).

3. Click on Create in the Data Folders dialog to create a
new data folder in which to store Aren Register data.

You can locate your data folder anywhere you want on
your computer or on a shared folder on another com-
puter. Make sure you have unrestricted access to whichever
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Figure 1.2: Start dialog box

Figure 1.3: Data Folders dialog box

location you choose, otherwise the software may not work
properly.

4. Close the Data Folders dialog to return to the Start di-
alog.

5. Within the Start dialog, click on Login to open the Login
dialog box.

Logging In

1. In the Login dialog box enter the username supervisor
(�gure 1.4).

2. You will be prompted to enter a password for use in
subsequent logins (�gure 1.5). Enter a password of your
choice.
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Figure 1.4: Login dialog box

Figure 1.5: Set Password dialog box

3. The New Organisation dialog box is displayed next (�g-
ure 1.6). Type in the name of your organisation and the
month from which you want to start entering data.

Figure 1.6: New Organisation dialog box

4. Close the New Organisation dialog box to begin using
Aren Register.

Moving On

Before entering employee data you need to �nish setting up
the program. Section 2 explains how to do this. To enter
employee data refer to Section 3 which describes the employee
data �les in Aren Register.
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After entering employee data you can view the reports de-
scribed in Section 4. With the exception of the muster roll
and payroll variance, all reports can be printed out on A4
paper. Use the muster roll to export payroll data to a text
�le.

To close the current data entry period and start a new one,
run the month end procedure as described in Section 5. That
section also describes how to back up and restore data and
create bank transfer �les.
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2 Setting Up

Before entering details about employees, use the Organisation
and System menus to con�gure the program. The Organi-
sation menu options apply only to the organisation that you
are currently working with whereas those of the System menu
apply to all organisations that you de�ne.

Setting up the System

Users

Aren Register supports an unlimited number of users. There
is always at least one user, supervisor. The supervisor has ac-
cess to all functions including adding and deleting other users
and assigning such users access to program functions. By re-
stricting users to only those parts of the program they need
for their work, it is possible to enforce separation of duties.

If you wish to add new users at this stage, do the following:

1. Select Users from the System Menu. This displays the
Users dialog box (�gure 2.1).

Figure 2.1: Users dialog box

2. Click on the Add button which brings up the User Iden-
tity dialog box (�gure 2.2).

3. In the User Identity dialog enter the username. Enter
and con�rm the password if you wish. If you do not
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Figure 2.2: User Identity dialog box

enter a password at this stage, the user will be required
to enter one when logging in for the �rst time. You may
also enter the user's real name to help you identify him
or her in future.

4. Close the User Identity dialog and choose Rights from
the Users dialog box. This displays the User Rights di-
alog box (�gure 2.3).

Figure 2.3: User Rights dialog box

5. Use this dialog box to select which menu the user should
see: full menu, personnel only or payroll only. Also spec-
ify the functions within the selected menu that you would
like the user to have access to.

6. Close the User Rights dialog box. You can add more
users by repeating the procedure above.
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7. Click on Close in the Users dialog box.

Banks

Aren Register comes with a comprehensive list of banks and
their branches. You will need this list for employees paid by
bank transfer rather than in cash or by cheque. The list is
shared by all organisations that you create. To review or mod-
ify it, select Banks from the System menu which will bring up
the Bank and Branches dialog box (�gure 2.4).

Figure 2.4: Banks and Branches dialog box

Statutory Deductions Parameters

PAYE and NHIF are calculated using brackets and rates that
are stored as tables. To view and update these tables select
Income Tax > PAYE Rates or NHIF Rates from the System
menu (�gure 2.5). Refer to the current P7 booklet from the
Kenya Revenue Authority (KRA) for an up-to-date PAYE ta-
ble.

The calculation of PAYE depends on a number of other pa-
rameters e.g. personal relief, insurance relief and allowable
pension fund contribution. Update these parameters by se-
lecting System > Income Tax > Other Parameters to open
the Income Tax Parameters dialog box (�gure 2.6). This dia-
log also allows you to edit the parameters used for calculating
fringe bene�t tax.

Mandatory NSSF contributions are a percentage of pension-
able pay and are divided into two tiers. To enter this percent-
age and the limits of pensionable pay for each tier, select NSSF
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Figure 2.5: PAYE Rates dialog box

Figure 2.6: PAYE Parameters dialog box

Rates from the System menu. This opens the NSSF Rates di-
alog box (�gure 2.7) where you can also edit the maximum
voluntary contribution.

Working with Organisations

A single installation of Aren Register can support up to 99
di�erent organisations. Each organisation requires a separate
licence. The name of the organisation that is currently open
is displayed in the title bar of the main window.
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Figure 2.7: NSSF Rates dialog box

Adding a new Organisation

To add a new organisation select Add from the Organisation
menu. Use the New Organisation dialog box that follows (�g-
ure 2.8) to enter the name of the organisation and the month
from which you want to start entering data. On closing the
dialog box, the previous organisation is closed and the new
one opened.

Figure 2.8: New Organisation dialog box

Opening another Organisation

To open a di�erent organisation select Open from the Organi-
sation menu. This will bring up the Open Organisation dialog
box (�gure 2.9) provided there are other organisations de�ned.
Select the organisation you want to open from the dialog box.
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Figure 2.9: Open Organisation dialog box

Deleting an Organisation

You can delete any organisation that is currently not open.
Deleting an organisation causes all its data �les and folders to
be deleted. It is strongly recommended that you back up the
organisation's data �les before deleting it (see Section 5).

To delete an organisation:

1. Select Delete from the Organisation menu. To minimise
the risk of accidentally deleting an organisation you will
be required to enter your password (�gure 2.10).

Figure 2.10: First Delete Organisation dialog box

2. Next, a list of all organisations in the system, exclud-
ing the one that is open, will be displayed (�gure 2.11).
Select the one you want to delete. Note that it is not pos-
sible to delete the organisation that is currently open.

3. In the two message boxes that follow, con�rm that you
want to delete the selected organisation and destroy its
data �les.
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Figure 2.11: Second Delete Organisation dialog box

4. Aren Register will then delete the organisation. A dia-
log box con�rming that the deletion is complete will be
displayed.

Setting up an Organisation

To con�gure the organisation that is currently open, proceed
as follows:

Basic Organisation Information

Open the Basic Organisation Info dialog box (�gure 2.12) from
the Organisation menu and enter the organisation's address
and telephone number.

Figure 2.12: Basic Organisation Info dialog box
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Also, con�rm that you want to start entering payroll and leave
details in the month and year shown in the dialog box. Once
you run the �rst month end procedure you will not be able to
edit either of them.

Licensing

Select Licence from the Organisation menu to open the Licence
dialog box (�gure 2.13). Type in the licence number supplied
by your dealer. If you do not have a licence number, contact
your dealer or Aren Software Ltd.

Figure 2.13: Licence dialog box

Payroll Info

Open the Payroll Info dialog box (�gure 2.14) by selecting
Payroll Info from the Organisation menu. Enter the bank,
branch and account number for the organisation's salary ac-
count. Also enter the organisation's PIN, NSSF, NHIF and
HELB numbers.

In this dialog box, the Standard File Interchange (SFI) Sender
ID applies to those who submit their payroll to the bank in
electronic form. Leave this �eld blank if you do not already
have an SFI Sender ID.

Grades

Aren Register assumes that all jobs that employees may be
assigned to are graded or ranked. To set up the grades for
your organisation select Grade from the Organisation menu.
The Grades dialog box that follows (�gure 2.15) allows you to
specify the name, rank and salary range for each grade.

If your organisation has no grades, create only one grade called
(None) and enter a salary range that will cater for all employ-
ees.

Jobs

To set up the jobs available in the organisation, open the Jobs
dialog box by selecting Jobs from the Organisation menu. For
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Figure 2.14: Payroll Info dialog box

Figure 2.15: Grades dialog box

each job you must enter the name of the job and its grade.
You may also enter a brief description of the job for future
reference.

Administrative Units

Set up the administrative units (departments, sections, etc) in
your organisation. To do this select Units from the Organisa-
tion menu.
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Posts

A post is a job that is attached to a speci�c administrative
unit. Aren Register does not accept new employees unless
they are attached to previously vacant posts.

In order to create posts you must create grades, jobs and ad-
ministrative units �rst. To add posts select Posts from the
Organisation menu which opens the Posts dialog box (�gure
2.16). For each administrative unit and job you will need to
specify how many permanent, contract, temporary and casual
posts to allow.

Figure 2.16: Posts dialog box

Stations

Set up the stations (branches) in your organisation. To do this
select Stations from the Organisation menu.

Pay Groups

Pay Groups allow you to �lter payment reports according to
how employees in your organisation are paid. For example,
the bank transfer report could be �ltered by bank branch or
pay date.

To set up pay groups, select Pay Groups from the Organisation
menu.

Co-operatives and Pension Funds

Create co-operative societies that employees in the organisa-
tion belong to by selecting Co-operatives from the Organisa-
tion menu.
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Similarly, set up pension funds by selecting Pension Funds
from the Organisation menu.

Insurance Companies

If you need to deduct and remit insurance premiums, set up
the insurance companies involved by selecting Organisation >
Insurance Companies.

Employee Pro�les

An employee pro�le de�nes attributes that are common to a
group of employees. These attributes are leave entitlement,
pay frequency, basic pay type (i.e., salary, daily rate or hourly
rate), standard working hours (per day and per pay period)
and whether overtime is payable.

To create a pro�le, select Pro�les from the Organisation menu
to open the Employee Pro�les dialog box (�gure 2.17). If there
is an employee pro�le marked as default, all new employees
added to the payroll will be assigned this pro�le.

Figure 2.17: Pro�les dialog box

General Options

Selecting Options > General from the Organisation menu opens
the General Options dialog (�gure 2.18). This dialog allows
you to choose the sort order for employee data entry forms.

You can also specify when to purge old reports. Deleting old
reports saves space on the hard disk and reduces the size of
backup �les.

In the logo section, you can select a bitmap �le that contains
the company's logo. This logo will be printed at the top of
each payslip.
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Figure 2.18: General Options dialog box

Payroll Options

Selecting Options > Payroll from the Organisation menu brings
up the Payroll Options dialog (�gure 2.19). If your organisa-
tion is tax-exempt you are required to treat the employer's
pension contribution as a taxable bene�t. Select the option to
tax excess employer pension on employees.

Figure 2.19: Payroll Options dialog box

KRA's online tax administration system, iTax, does not tax
bene�ts unless they total to more than Ksh 3,000. By default,
Aren Register taxes all non-cash bene�ts regardless of their
total. For it to work like iTax you must check the option
Ignore bene�ts unless total exceeds Ksh 3,000.
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By default, PAYE is rounded down to the nearest shilling.
However, for compatibility with the iTax system, you should
select the option to deduct the exact amount of PAYE.

If your organisation has opted out of tier II NSSF contribu-
tions, uncheck the option to deduct tier II NSSF. This option
is enabled by default.

You can choose to have NHIF calculated on the �xed monthly
salary or on the gross pay earned in a given month. The former
option is included for backward compatibility and you should
always compute NHIF on gross pay.

If your organisation pays industrial training levy for its em-
ployees, check the option to pay industrial training levy. A
report will be generated each month for this purpose.

Finally, you have the option to round down net pay for em-
ployees paid in cash by an amount that you specify. The excess
amount is carried forward to the next month.
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3 Data Files

Data for each employee is stored in four database �les�personnel,
payroll master, payroll transactions and absence and leave.
This data is used to create various personnel and payroll report
�les which are then used for report generation.

Personnel File

The personnel �le stores personal information about each em-
ployee, for example name, national ID number, date of birth
and nationality. It also stores information about employees'
jobs such as job title, grade, administrative unit, station and
leave entitlement.

Employees can only be added and removed from the system
through the personnel �le. The employees in this �le automat-
ically appear in the payroll master, payroll transactions and
absence and leave �les.

The personnel �le is accessed by selecting Personnel from the
File menu. This brings up a data entry form in which you enter
data for each employee (�gure 3.1). For easy access the data
entry form is divided into �ve pages, i.e., Personal Details,
Employment Details, Contact Info, Family and Photo.

Figure 3.1: Personnel File form

Most of the �elds in the �le are optional. However, Em-
ployee Number, Last Name, Other Names, Post and Station
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are mandatory. The optional �elds are used in various reports
and should therefore not be left blank.

Adding and Deleting Employees

Employee records are added and removed from the personnel
�le using the Add, Delete and Terminate commands in the
Record menu.

Deleting an employee record is only possible if no month end
procedure has been run since it was added. After deleting
a record, no report will retain information relating to that
employee. This option is provided to allow records added by
mistake to be expunged.

Terminating an employee will cause his record to be removed
from the personnel �le in due course. However, various person-
nel and payroll reports will retain details of that employee for
future reference. Section 5 describes the termination process
in detail.

Payroll Master File

Both the payroll master and payroll transaction �les store pay-
roll information about each employee. The former maintains
information that tends to remain the same over time while the
latter maintain information for a single pay period and this
tends to change more frequently.

The data in the payroll master �le includes pay frequency, ba-
sic pay, bank account number, PIN, co-operative membership
and housing status.

To open the payroll master �le, select Payroll Master from
the File menu. This brings up the Payroll Master File data
entry form which is divided into nine pages, i.e., Payment,
Basic Pay, Overtime, Housing, PAYE, NSSF & NHIF, Co-
operatives, Pension Funds and Options (�gure 3.2).

Payroll Transactions File

The payroll transactions �le stores earnings, deductions, ben-
e�ts, lump sums payments and refunds for each employee for
the current month.

Earnings (or monthly cash earnings) are those cash payments
that relate to the current month e.g. basic pay or leave al-
lowance.



Payroll Transactions File 23

Figure 3.2: Payroll Master File form

Bene�ts refers to private expenditure of an employee paid by
the employer e.g. school fees, house rent or telephone bills.
These non-cash bene�ts are considered as income for tax pur-
poses.

Deductions are those amounts deducted from an employee's
cash earnings by the employer. Some of these are called statu-
tory deductions because the law requires the employer to deduct
them from the employee's pay. The statutory deductions are
PAYE, NSSF, NHIF and tax on lump sum payments.

Lump sum payments are those cash payments that do not
relate to the current month alone. Some like gratuity and
bonuses have accrued over past months while others like ter-
minal bene�ts may relate to past or future months. We make
the distinction between lump sum payments and monthly cash
earnings because the two are treated di�erently when calcu-
lating income tax.

Refunds are payments made to an employee, e.g. travelling or
subsistence allowances, for business expenses incurred while
on duty. These payments are not income and are therefore
not taxable.

The payroll transactions �le is accessed by selecting Payroll
Transactions from the File menu. This displays a data entry
form (�gure 3.3) where you enter earnings, deductions, bene-
�ts, lump sum payments and refunds for each employee.

Statutory deductions and other calculated amounts such as



24 3 Data Files

Figure 3.3: Payroll Transactions File form

taxable pay, net pay and gross pay are updated as data is
entered. This makes the calculations more transparent and
helps to reduce data entry errors.

You can suspend employees from the payroll by deleting them
from the payroll transactions �le (Record > Remove). To
restore a suspended employee use the Record > Add command.

Payroll Fields

At installation, each payroll transactions �le has two earnings
(Basic Pay and Overtime), three deductions (Rent, Overdraft
Recovery and Rounding C/F), one non-cash bene�t (Employer
Pension) and one refund (Rounding B/F). These �elds cannot
be deleted but you can add more according to your needs.

To add, delete or edit �elds, select Earnings, Deductions, Ben-
e�ts, Lump Sum Payments or Refunds from the File menu. A
data entry form will be displayed showing the �eld attributes
listed below (�gure 3.4). To add or delete �elds select Add or
Delete from the Field menu.

The following �eld attributes apply to all �elds:

1. Field Name: The name of the �eld e.g. advance, shift
allowance.

2. Type: This is used to indicate permanent �elds (e.g. ba-
sic pay and rent). It is also used to specify �elds that
are calculated in a unique way (e.g. hourly pay and
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Figure 3.4: Deductions form

daily pay) and those that are associated with a balance
that is updated and displayed by the system (e.g. loan
repayments and co-operative contributions). The type
advance is used to indicate advance payments so that
appropriate reports can be generated.

3. Amount: This attribute speci�es how the amount paid
to or deducted from each employee is arrived at. It may
be keyed in, a percentage of salary, a function of the time
worked (basic pay, overtime, hourly pay and daily pay)
or amortised (loan repayments).

4. Static: Static �elds retain their value when the month
end procedure is run, whereas non-static �elds are reset
to their lower limit. This is only important for �elds that
are keyed in. It saves you the trouble of having to key
in the amount earned or deducted each time the month
end procedure is run.

5. Taxable/Pre-tax deduction: For earnings the taxable at-
tribute speci�es whether or not the payment is subject
to PAYE. Unless prior permission has been given by the
KRA, all income (i.e. earnings, non-cash bene�ts and
lump sum payments) must be taxed. Refunds are not
taxable as they are not a form of income.

The pre-tax deduction attribute indicates those deduc-
tions to be subtracted from gross income when calcu-
lating PAYE. In Kenya the only pre-tax deductions are
mortgage interest payments and contributions to regis-
tered pension/provident funds and to registered home
ownership saving plans (HOSPs).

6. Pensionable: NSSF is calculated on the total pension-
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able earnings. Uncheck the pensionable option to ex-
clude any earning from this calculation.

Depending on the selection for Type and Amount attributes
the following additional attributes may be available:

1. Co-operative: The name of the co-operative associated
with the �eld (�gure 3.5).

Figure 3.5: Co-operative dialog box

2. Pension Fund: The name of the pension fund and other
details pertaining to the current �eld (�gure 3.6).

Figure 3.6: Pension Fund Parameters dialog box

3. Insurance: The name of the insurance company associ-
ated with the �eld.

4. Limits: The upper and lower limits that the amount
paid or deducted should be restricted to (�gure 3.7).

5. Percentage: The percentage of monthly salary that should
be paid or deducted (�gure 3.8).

6. Hourly Rate: The hourly rate to use for earnings that
are of the type Hourly Pay (�gure 3.9).

7. Daily Rate: The daily rate to use for earnings that are
of the type Daily Pay.
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Figure 3.7: Limits dialog box

Figure 3.8: Percentage of Salary dialog box

Figure 3.9: Hourly Rate dialog box

Absence and Leave File

The absence and leave �le stores details about employees' ab-
sence from work in the current year. This information is ex-
pressed in terms of absence event records.

In addition, the �le keeps an account of annual leave earned
and used up by each employee during the year. It uses leave
event records to track the leave days brought forward from the
previous year and leave days earned, sold and forfeited since
then. Leave taken is treated as an absence event.

The absence and leave �le can also be used to track employees'
leave bookings.

To edit this �le select Absence and Leave from the File menu
(�gure 3.10). The Absence and Leave window has three pages,
i.e., Absence, Annual Leave and Leave Bookings. To edit or
delete an event in any page, �rst select it and then click on
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the Edit or Delete button. To add a new event, switch to the
appropriate page and then click on Add.

Figure 3.10: Absence and Leave window

If you do not wish to track absence and leave for a particular
employee, you can remove them from the abscence and leave
�le. Open the personnel �le and select the employement tab.
Uncheck the option to track abscence and leave.



4 Reports

Aren Register produces several personnel and payroll reports
as described below. These reports can be viewed on the screen
and printed out. You can choose to print the entire report, a
range of pages, or just the page that you are currently viewing.
Internal reports can be sorted by either employee number or
name.

You can view and print reports for current as well as past
months and years. You can also �lter most reports by ad-
ministrative unit, station, pay group, bank, co-operative or
pension fund.

Reports may be printed on any printer connected to your com-
puter either directly or through a local area network. Because
all reports are formatted for A4 paper, the printer must be set
to print on A4.

1. To open a report select it from the Report menu and then
follow the on-screen instructions. For example, selecting
Report > Payslips opens the Open Payslips dialog box
(�gure 4.1).

Figure 4.1: Open Payslips dialog box

2. To print the open report select Print from the File menu
which brings up the Print dialog box (�gure 4.2). Use the
Setup button in this dialog box to con�gure the printer
you want to use.

3. Choose Close from the File menu to close the report.
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Figure 4.2: Print dialog box

Personnel Reports

1. Posts By Type: List that shows the number of perma-
nent, contract, temporary and casual posts in each ad-
ministrative unit of the organisation.

2. Posts By Status: List that shows the number of occu-
pied and vacant posts in each administrative unit of the
organisation.

3. Employees Roll: List of employees who are currently ac-
tive. It shows their job title, administrative unit and
station.

4. Joiners Roll: List of employees who joined the organi-
sation recently. It shows their job title, administrative
unit, station and start date.

5. Leavers Roll: List of employees who left in a given year.
It shows their �nal job title and administrative unit, the
date they left and the reason for leaving.

6. Employee Hierarchy Report: List of employees grouped
according to whom they report to. Employee names are
indented to show the reporting hierarchy. The report
also displays the job tile, administrative unit and station
for each employee.

7. Length of Service Report: List of current employees show-
ing their job title, age and length of service.

8. Emergency Contact Report: List showing each employee's
next of kin, their relationship and the contact details.

9. Master Report: Report that shows the details of a single
employee as entered in the personnel and payroll master
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�les. It is available for both current and former employ-
ees.

10. Absence by Employee: List of actual and planned ab-
sences from work grouped by employee.

11. Absence by Date: List of actual and planned absences
from work in chronological order.

12. Absence Sheet: This report lists, for a single employee,
all absence from work in a given year.

13. Annual Leave Sheet: This report gives, for a single em-
ployee, a detailed account of leave earned and used up
in a given year.

14. Absence Analysis: List of employees that gives a sum-
mary of all absence from work for a speci�ed year.

15. Leave Analysis: List of employees that gives a sum-
marised account of leave earned and used up in a given
year.

Reports on former employees, absence and leave cover a calen-
dar year. Reports for previous years can be viewed and printed
out, but they cannot be modi�ed in any way. Before running
the month end for December make sure that you verify these
reports.

The remaining reports, i.e. those on posts and current em-
ployees, indicate the state of the organisation at the time of
printing.

Monthly Payroll Reports

The monthly payroll reports relate to a single month. Reports
for the current month are updated as you update the employee
data �les. Reports for previous months can be viewed and
printed out, but they cannot be modi�ed in any way.

Overview Reports

1. Payroll Summary: Summarises earnings and deductions
for all employees.

2. Payroll Control Account: T-account listing total earn-
ings, deductions and net pay for all employees in the
organisation.

3. Muster Roll: List of employees showing all earnings,
lump sum payments, refunds and deductions for the month.
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Records in this report can be grouped by administrative
unit or station.

4. Payroll Variance: List of employees showing the di�er-
ences in the payments and deductions made in any two
pay periods. It is essentially the di�erence between the
muster rolls for the two pay periods.

5. Gross Pay By Unit: List of administrative units showing
the sta� count and total gross pay for each.

6. Gross Pay By Station: List of stations showing the sta�
count and total gross pay for each.

The muster roll and payroll variance can be viewed on the
screen or saved to a text �le but they cannot be printed out.

Detail Reports

1. Earning Report: List showing, for a particular earning,
how much each employee was paid.

2. Deduction Report: List showing, for a particular non-
statutory deduction, how much each employee was de-
ducted. Depending on the type of deduction selected, a
loan or HELB report may be printed instead.

3. Loan Report: List of employees repaying a speci�c co-
operative or company loan. It shows the opening and
closing balances and a breakdown of the repayment amount
into interest and principal components.

4. HELB Report: List showing the HELB Repayment Sched-
ule in the format required by HELB (Higher Education
Loans Board).

5. Bene�t Report: List showing, for a particular non-cash
bene�t, how much each employee received.

6. Lump Sum Report: List showing, for a particular lump
sum payment, how much each employee received.

7. Refund Report: List showing, for a particular refund,
how much each employee received.

Payments to Employees

1. Payslips: Slip giving a breakdown of the earnings and
deductions of each employee separately (�gure 4.3). The
employer's pension contribution and the pension fund
balance can be shown in the payslip if required. When
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the balance is shown, it includes the employer's portion
only if the option to print the employer contribution has
been selected.

Figure 4.3: Payslips

2. Cash List: List of employees paid in cash showing their
employee number, name, net pay or advance payment
and a cash analysis of the payment amount.

3. Cheque List: List of employees paid by cheque showing
their employee number, name and net pay or advance
payment.

4. Bank Transfer Report: List of employees who are paid
by bank transfer showing their name, ID number, bank,
branch, account number and payment amount. The pay-
ment amount may be the net pay, an advance payment,
a bank loan repayment or a HOSP contribution.

5. Coinage Summary Report: List showing the number of
coins and notes of each denomination that are required
for workers who are paid in cash. This information is
the same as the totals in the cash list but formatted so
that it can be used when withdrawing the cash from a
bank.

Statutory Returns

1. PAYE Report: List of employees showing their PAYE
deductions.

2. NSSF Report: List of employees showing NSSF number,
ID number and the combined employer and employee
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tier I and tier II contributions. Voluntary contributions
are also shown.

The NSSF return �le is available under the Procedure
menu (Procedure > NSSF return). This generates a text
�le which should be opened with Microsoft Excel and
saved again as an Excel �le.

3. NHIF Report: List of employees showing NHIF number,
ID number, date of birth and NHIF deduction.

To generate the NHIF return �le, select Procedure >
NHIF Return. This saves a text �le that should be con-
verted into a Microsoft Excel spreadsheet.

4. Industrial Training Levy Report: List showing the in-
dustrial training levy payable to the National Industrial
Training Authority for each employee in the payroll.

5. Lump Sums Tax Report: List showing tax payable on
lump sum payments for each employee.

6. Fringe Bene�t Tax Report: List showing tax payable on
the fringe bene�t arising from company loans issued at
an interest rate below the KRA prescribed market inter-
est rate.

Other Returns

1. Co-operative Report: List of members of a particular co-
operative society showing membership number, monthly
contribution and any other payroll deductions to be paid
to that co-operative.

2. Pension Report: List of members of a particular pension
fund showing membership number and employer and em-
ployee contributions to that pension fund.

3. Insurance Company Return: List of employee premium
deductions to be paid to a particular insurance company.

Quarterly Payroll Reports

These are payroll reports relating to a particular quarter of
the year.

1. P10D: Quarterly tax return. It lists each employee's
quarterly taxable income and the tax deducted.
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Annual Payroll Reports

Annual payroll reports relate to a calendar year and are avail-
able throughout the year. For the current year, the informa-
tion displayed relates to the months that have elapsed so far.
The reports are:

1. Payroll Control Account.

2. Muster Roll.

3. Annual Pay Sheet: A report that, for each employee,
gives a summary of payments, deductions and bene�ts
for a whole year.

4. P9A: KRA form titled Tax Deduction Card. Each P9A
gives a breakdown of the income of an employee for each
month of the year and shows the amount of tax deducted.

5. P10: KRA form titled Employer's Covering Certi�cate.
It shows the tax deducted by the employer for each
month of the year.

6. P10A: KRA form titled Supporting List for End of Year
Certi�cate. It lists the annual income and total tax de-
ducted for each employee.

7. NSSF Statement: A report that shows the standard and
voluntary monthly contributions to NSSF for a single
employee for a calendar year.

8. NHIF Statement: A report that shows an employee's
monthly NHIF deductions for a calendar year.

The P9A, P10 and P10A have been approved by the KRA
(approval reference number CIT/1037/2/98/20).

Other Reports

1. Bank Codes: A listing of banks, bank branches and their
sort codes drawn from the banks �les.

2. Audit Trail: List that shows the date and time of each
login, backup, month end procedure and any other major
event. It also shows the user responsible for each event.
This report is only available to the supervisor.

Report Files

Almost all reports are printed from report �les, not directly
from the employee data �les. Brie�y, the report �les are:
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1. Active employees report �le

2. Annual leavers report �les

3. Annual absence and leave report �les

4. Monthly payroll report �les

5. Annual payroll report �les

Report �les are updated automatically by Aren Register. Use
the General Options dialog box (Organisation > Options >
General) to specify how long to keep these �les for.
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Backing Up

If your data �les are accidentally deleted or corrupted you
could lose all your data. Without an up-to-date backup you
would be forced to key in the data for the current month again.
It is also likely that you would be unable to recreate data for
previous months and years. It is therefore very important that
you make regular backups of your data �les.

To back up �les for the organisation that is currently open, se-
lect Backup from the Procedure menu. You will be prompted
to specify the name and location of the backup �le to be cre-
ated (�gure 5.1).

Figure 5.1: Backup dialog box

The backup process copies all data relating to the organisation
to the backup �le. Should you have set up more than one
organisation, you will need to back up each one separately.
Note that data that is shared by all organisations is not backed
up (e.g. list of banks and statutory deductions parameters).

When running the month end procedure you will be prompted
to back up. Though you can choose to proceed without doing
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so, it is recommended that you back up �rst. To encourage
regular back ups Aren Register prompts you to back up each
time you exit.

Restoring from Backup

In the event that your data �les are corrupted or deleted you
will need to recover them from a backup �le. You can also use
backup �les to revert to an earlier month. This is especially
useful if you accidentally run the month end procedure.

To restore an organisation's �les from backup, select Restore
from the Procedure menu then follow the on-screen instruc-
tions (�gure 5.2).

Figure 5.2: Restore dialog box

Creating a Bank Transfer File

A bank transfer �le is an electronic version of the bank transfer
report. It is used by banks to process payments for employees
paid by bank transfer in place of the printed bank transfer
report. Aren Register can create bank transfer �les for numer-
ous banks including Barclays, Co-operative, Equity, KCB and
Standard Chartered.

1. To create a bank transfer �le select Bank Transfer File
from the Procedure menu.

2. In the Bank Transfer File dialog box that appears (�gure
5.3), specify the format of the bank transfer �le to create
and the name of the payment �eld (usually net pay).
Depending on the �le format, you may be able to specify
the date you want the bank transfer e�ected.
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Figure 5.3: Save Bank Transfer File dialog box

3. After closing the Bank Transfer File dialog box, a new
dialog box appears. Use this dialog to specify the name
and location of the �le to be created.

For further details on bank transfer �les please contact your
bank.

Saving iTax Files

iTax �les are text �les containing tax details about employees
in the payroll. These �les help you to �ll out the iTax spread-
sheet (P10_Return.xlsm) that is used for �ling tax returns
on the KRA website. Two formats are available�Employee
Details and Fringe Bene�t Tax. In the iTax spreadsheet,
data in these two formats should be imported into the tabs
B_Employee_Dtls and J_FBT_Dtls, respectively.

1. To save the Employee Details �le, select iTax File >
Employee Details from the Procedure menu.

2. In the Save Employee Details File dialog that is displayed
(�gure 5.4), select the month and year you want.

3. By default only employees who have paid PAYE in the
selected month will be included in the �le. If you wish
to include those with zero PAYE as well, click on Next
and select the option Include all employees.

4. After closing the Save iTax Employee Details File dialog
box, a new dialog box appears. Use this dialog to specify
the name and location of the �le to be created.

5. To save the Fringe Bene�t Tax �le, select Procedure
> iTax File > Fringe Bene�t Tax and then proceed as
above.
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Figure 5.4: Save iTax Employee Details File dialog box

For assistance with iTax please contact the KRA.

Terminating an Employee

To terminate an employee, open the personnel �le and display
the target employee. Next, select Terminate from the Record
menu. In the Terminate dialog box that appears (�gure 5.5),
enter the termination date, the reason for leaving and, if you
like, some brief comments.

Figure 5.5: Terminate dialog box

The terminated employee will be removed from the employee
data �les in the next month end procedure that is later than or
on the same day as his termination date. Once the employee
is deleted from the employee data �les his record will be added
to the leavers report �le.

Termination can be reversed by selecting Record > Undo Ter-
mination as long as the terminated employee has not been
removed from the employee data �les.
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Closing the Month

The month end procedure is used to close data entry for the
current month and begin a new one. It applies only to the
organisation that is currently open. It does the following:

1. Saves payroll information for the current month to the
monthly and annual payroll report �les.

2. Deletes the current payroll transactions �le and creates
a new one for the coming month.

3. Advances the date by one month.

4. If the new month is January, it creates statutory deduc-
tion �les for the new year, deletes the existing absence
and leave �le and creates a new one for the new year.
The leave balance from the previous year is brought for-
ward.

5. Adds leave earned in the new month to the absence and
leave �le.

6. Transfers terminated employees from the personnel �le
to the leavers report �le.

7. Deletes any report �les that have exceeded the maximum
age set in the General Options dialog box.

Note that in December the month end procedure cannot be
run if there are outstanding leave bookings for the year that
is ending.

To run the procedure:

1. Select Month End from the Procedure menu. This op-
tion is only available if you have licensed the organisa-
tion.

2. After reading the dialog box that appears (�gure 5.6),
con�rm that you want to close the month by entering
your password.

3. You will now be prompted to back up your data and are
strongly encouraged to do so.

4. Once the back up is complete, the month end proce-
dure will automatically follow. Eventually, a message
box con�rming its completion will appear.

The Month End Procedure should be run with care since it
cannot be reversed except by restoring from backup. This is
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Figure 5.6: Month End Procedure dialog box

especially true in December when it will close entry of absence
and leave data for the year that is ending.



Appendix A Importing Data

Keying in new employees into the payroll can be very time
consuming especially if there are many of them. As an alter-
native, you can import employee data into the personnel �le
from a text �le.

The easiest way to create the input text �le is to capture em-
ployee data in a spreadsheet and then save the spreadsheet as
a text �le.

File Format

The format of the input text �le is as follows:

1. Plain text with data items separated by the tab character
(i.e. a tab-separated text �le).

2. The �rst row of data is a header with the data items Em-
ployee Number, Last Name, Other Names, ID Number,
Job Title, Admin Unit, Station, Pay Rate, PIN, NSSF
Number and NHIF Number.

3. From row two onwards, each row has data for a single
employee, i.e. employee number, last name, other names,
ID number, job title, administrative unit, station, pay
rate, PIN, NSSF number and NHIF number.

Note that:

1. The �rst row (�le header) is ignored. It is only included
for the convenience of the person preparing the input
�le.

2. A row will not be imported if the employee number
matches that of a record already in the personnel �le.

3. A row will also be skipped if any of the following data
items is blank: employee number, last name, other names,
job title, administrative unit, station.

4. Data will be imported into several �les�personnel, pay-
roll master, payroll transactions, leave, jobs, adminstra-
tive units and stations.
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5. Where a default pro�le has been de�ned, it will be ap-
plied to each record added to the personnel �le.

How to Import

1. Back up your data just in case you need to undo the
changes you are about to make (Procedure > Backup).

2. Select Procedure > Import > Employees to open the
�rst Import Employees dialog box (�gure A.1).

Figure A.1: First Import Employees dialog box

3. Enter your password to open the second Import Employ-
ees dialog box.

4. Browse to the text �le that you want to import data
from and click on Open.

5. Aren Register will read the text �le and update sev-
eral data �les�jobs, administrative units, stations, per-
sonnel, payroll master, payroll transactions and leave.
On completion, a con�rmation message box will be dis-
played. Close the message box.

6. To see which records were updated, refer to the log �le
import.log located in the payroll data folder. Browse
through the data �les that should have been updated to
con�rm that they were updated successfully.



Appendix B Emailing Payslips

Aren Register can email payslips to each of the employees in
the payroll. This provides an alternative to printing individual
payslips for each employee. Payslips are sent as password-
protected PDF �les.

Entering Email Addresses

Start by capturing the email addresses to send employee payslips
to.

1. Open the payroll master �le (File > Payroll Master) and
select the options tab (�gure B.1).

Figure B.1: Payroll Master File form

2. For each employee, enter the address to email payslips
to.

3. Close the payroll master �le.

Setting Up Email Account

In order to send email, you need to set up your email account.
For this you require details of the outgoing mail server, also
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known as the SMTP server. Consult your IT department if
necessary or check the settings in the email software you use.

1. Select System > Email Account to open the Email Ac-
count dialog box (�gure B.2).

Figure B.2: Email Account dialog box

2. Email Address: Enter your email address, say info@-
demorestaurant.co.ke or example@gmail.com.

3. SMTP Server: Enter the name of the outgoing mail
server, e.g. mail.demorestraurant.co.ke or smtp.gmail-
.com. You can also enter the server's IP address, e.g.
192.168.0.23.

4. SMTP Port: The SMTP port is a unique number that
the mail server has set aside for outgoing mail. The most
common values are 25, 465 and 587. If your server uses
a secure (encrypted) connection, e.g. smtp.gmail.com or
smtp.mail.yahoo.com, try port 465 or 587. If it does not,
enter 25.

5. Timeout: This is length of time the software should wait
for a response from the mail server before giving up.

6. Use secure connection: Check this option if the mail
server uses a secure connection.
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7. Authentication: You may select none (no account name
or password required), plain or login (requires account
name and password).

8. Account Name and Password: Enter the login name and
password for the mail server if you have selected login or
plain authentication.

9. Copy all emails to self: Check this option if you want to
receive a copy of all the payslips you send.

10. Close the Email Account dialog box.

Sending Payslips

Now you are ready to email payslips to employees.

1. Select Procedure > Email Payslips to open the Email
Payslips dialog box (�gure B.3).

Figure B.3: First Email Payslips dialog box

2. Choose the pay period that you want then click OK. This
opens another dialog box with the same title (�gure B.4).

3. Click on Send to open the Message Range dialog box
(�gure B.5).

4. Use the Message Range dialog box to send the current
message, all messages or a range of them. On comple-
tion, a message box showing the number of messages sent
will be displayed.

5. Close the Email Payslips dialog box when you are through.

Details of the last mail session are saved in the log �le email.log
located in the payroll data folder. Refer to this �le if you have
any di�culty sending messages and to see which messages were
actually sent.
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Figure B.4: Second Email Payslips dialog box

Figure B.5: Message Range dialog box

How to Open Payslips

Once a payslip is sent, the recipient will need a password to
open it. Each payslip has two passwords:

1. Owner Password: The last four digits of the organi-
sation's PIN. For instance, if the organisation's PIN is
P012345678Q, the owner password will be 5678. Should
the organisation's PIN be blank, the default password is
owner.

2. User Password: The last four digits of the employee's
PIN. Where the employee's PIN is missing, the default
password is user. This is the password that employees
should use.

You can modify the message that is sent to employees to in-
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clude help on the password they will use to open the payslip.

1. Go to Procedure > Email Payslips to open the Email
Payslips dialog box.

2. Click on Options to open the Electronic Payslip Options
dialog box (�gure B.6).

Figure B.6: Electronic Payslips Options dialog box

3. Check the option Include password help.

4. Close the Electronic Payslip Options dialog box.

5. Close the Email Payslip dialog box.
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Appendix C Formulae

Loans

Amortisation

The loan payment amount is uniform throughout the repay-
ment period. The portion of the payment amount that goes
towards repaying the principal increases with time as interest
payments reduce.

Payment =
W[

1− (1 + r)−n

r

]

where W = principal amount, n = total number of payments,
r = monthly interest rate (e.g. if annual interest rate is 15%,
r = (15/100)/12 = 0.0125).

Reducing Balance

The amount paid towards the principal is �xed throughout the
loan duration while interest payments reduce with time. Thus
the total payment amount reduces with time.

Payment = W ′
(
1

n′
+ r

)

where W ′ = outstanding balance, n′ = number of payments
outstanding, r = monthly interest rate.


