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1 Introduction

About Aren Register

Aren Register is an extension of the traditional payroll system
to include some features normally found in HR software. It
runs in the Microsoft Windows environment.

Aren Register lets you specify the posts available in your or-
ganisation and then assign existing employees to these posts.
As new employees join they are assigned to the posts you have
speci�ed. Employees are retained in the system until they
leave the organisation. Reports on current and former em-
ployees are provided.

The system will help you to keep track of annual leave days
earned and taken by employees. You will also be able to record
all absence from work. Annual reports on leave and absence
are available.

Aren Register makes it easy to process employee pay. It en-
ables you to specify all payments and deductions that apply
to each employee. Several reports are derived from this data,
including payslips, payroll summary, payroll control account,
monthly and annual returns for PAYE as well as monthly re-
turns to NHIF, NSSF and user-de�ned co-operatives and pen-
sion funds.

Access to the system requires a username and a password.
There is one permanent user who has unrestricted access to
the entire system. Other users can be added at any time and
assigned access to those functions they need to use.

A single installation of Aren Register will support multiple or-
ganisations though a separate licence key is required for each
of them. For each organisation, four pay frequencies are sup-
ported, viz. monthly, weekly, biweekly and irregular. The
irregular pay frequency caters for employees who are not paid
after �xed intervals. A comprehensive backup system is also
provided.



2 1 Introduction

Getting Started

To use Aren Register you need to install it and con�gure it
to suit your needs. The rest of this section shows you how to
begin this process.

Installation

To install Aren Register:

1. Download the installation �le reg90etp.msi from the down-
loads page of our website:
https://www.aren.co.ke/payroll/download90.htm.

2. Double-click on the installation �le to begin the instal-
lation process.

Figure 1.1: Setup Wizard

3. Follow the on-screen instructions that appear during the
installation process (�gure 1.1).

The installation process copies the �les required by Aren Reg-
ister to the folder you specify on the hard disk of your com-
puter. It will also create a desktop icon for Aren Register.

Creating a Data Folder

1. Once the installation process is complete, start Aren
Register using the desktop icon created above.

https://www.aren.co.ke/payroll/download90.htm
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Figure 1.2: Start dialog box

2. In the Start dialog box that appears (�gure 1.2), click on
Data Folder to open the Data Folders dialog box (�gure
1.3).

Figure 1.3: Data Folders dialog box

3. Click on Create in the Data Folders dialog to create a
new data folder in which to store Aren Register data.

You can locate your data folder anywhere you want on your
computer or on a shared folder on another computer. Make
sure you have unrestricted access to whichever location you
choose, otherwise the software may not work properly.

Where the data folder is on another computer, that computer
needs to have Firebird installed and con�gured to work with
Aren Register. Appendix A shows you how to do this. If
necessary, set up Firebird before proceeding.
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Setting up the Data Folder

You will need to edit the settings for the newly created data
folder.

1. Click on Settings in the Data Folders dialog to open the
Data Folders Settings dialog (�gure 1.4).

Figure 1.4: Data Folders Settings dialog box

2. Hostname This is initially set to localhost. Change it to
the name of the computer on which the data folder is
located.

3. Path on Host : Make sure this matches the full path of
the data folder on the computer hosting the data folder.

4. Username: This is the username the software will use to
log into the Firebird server. The default value is sysdba
but you can change it if need be.

5. Password : The default value is masterkey. Edit it to
match the username you have speci�ed.

6. Close the Data Folder Settings dialog to return to the
Data Folders dialog.

7. Close the Data Folders dialog to return to the Start di-
alog.

Logging In

1. Within the Start dialog, click on Login to open the Login
dialog box.
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2. In the Login dialog box enter the username supervisor
(�gure 1.5).

Figure 1.5: Login dialog box

3. You will be prompted to enter a password for use in
subsequent logins (�gure 1.6). Enter a password of your
choice.

Figure 1.6: Set Password dialog box

4. The New Organisation dialog box is displayed next (�g-
ure 1.7). Type in the name of your organisation and the
month from which you want to start entering data.

Figure 1.7: New Organisation dialog box

5. Close the New Organisation dialog box to begin using
Aren Register.
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Moving On

Before entering employee data you need to �nish setting up
the program. Section 2 explains how to do this. To enter
employee data refer to Section 3 which describes the employee
data tables in Aren Register.

After entering employee data you can view the reports de-
scribed in Section 4. With the exception of the muster roll
and payroll variance, all reports can be printed out on A4 pa-
per. Use the muster roll to export payroll data to an XML �le
in Microsoft Excel format.

To close the current data entry period and start a new one,
run a period or month end procedure as described in Section
5. That section also describes how to back up and restore data
and create bank transfer �les.
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Before entering details about employees, use the Organisation
and System menus to con�gure the program. The Organi-
sation menu options apply only to the organisation that you
are currently working with whereas those of the System menu
apply to all organisations that you de�ne.

Setting up the System

Users

Aren Register supports an unlimited number of users. There
is always at least one user, supervisor. The supervisor has ac-
cess to all functions including adding and deleting other users
and assigning such users access to program functions. By re-
stricting users to only those parts of the program they need
for their work, it is possible to enforce separation of duties.

If you wish to add new users at this stage, do the following:

1. Select Users from the System Menu. This displays the
Users dialog box (�gure 2.1).

Figure 2.1: Users dialog box

2. Click on the Add button which brings up the User Iden-
tity dialog box (�gure 2.2).

3. In the User Identity dialog enter the username. You may
also enter the user's real name to help you identify him
or her in future.



8 2 Setting Up

Figure 2.2: User Identity dialog box

4. Close the User Identity dialog and choose Rights from
the Users dialog box. This displays the User Rights di-
alog box (�gure 2.3).

Figure 2.3: User Rights dialog box

5. Use this dialog box to select which menu the user should
see: full menu, personnel only or payroll only. Also spec-
ify the functions within the selected menu that you would
like the user to have access to.

6. Close the User Rights dialog box and choose Password
from the Users dialog box. This brings up the Set Pass-
word dialog box (�gure 2.4).

7. Enter and con�rm the password if you wish. If you do
not enter a password at this stage, the user will be re-
quired to enter one when logging in for the �rst time.

8. Close the Set Password dialog box. You can add more
users by repeating the procedure above.
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Figure 2.4: Set Password dialog box

9. Click on Close in the Users dialog box.

Banks

Aren Register comes with a comprehensive list of banks and
their branches. You will need this list for employees paid by
bank transfer rather than in cash or by cheque. The list is
shared by all organisations that you create. To review or mod-
ify it, select Banks from the System menu which will bring up
the Bank and Branches dialog box (�gure 2.5).

Figure 2.5: Banks and Branches dialog box

Statutory Deductions Parameters

PAYE and NHIF are calculated using brackets and rates that
are stored as tables. To view and update these tables select
Income Tax > PAYE Rates or NHIF Rates from the System
menu (�gure 2.6). Refer to the Kenya Revenue Authority
(KRA) website for an up-to-date PAYE table.

The calculation of PAYE depends on a number of other pa-
rameters e.g. personal relief, insurance relief and allowable
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Figure 2.6: PAYE Rates dialog box

pension fund contribution. Update these parameters by se-
lecting System > Income Tax > Other Parameters to open
the Income Tax Parameters dialog box (�gure 2.7). This dia-
log also allows you to edit the parameters used for calculating
fringe bene�t tax.

Figure 2.7: PAYE Parameters dialog box

NSSF contributions are a percentage of pensionable pay and
are divided into two tiers. To enter this percentage and the
pensionable pay limits for each tier, select NSSF Rates from
the System menu. This opens the NSSF Rates dialog box
(�gure 2.8) where you can also edit the maximum voluntary
contribution.
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Figure 2.8: NSSF Rates dialog box

The payroll supports SHIF1 which is set to replace NHIF as
the mandatory health insurance deduction. The parameters
for calculating SHIF can be edited by selecting System > SHIF
Parameters to open the SHIF Parameters dialog box (�gure
2.9)

Figure 2.9: SHIF Parameters dialog box

Finally, to change the settings for housing and NITA levies,
open the Statutory Levy Parameters dialog box (�gure 2.10)
by selecting System > Levy Parameters.

Working with Organisations

A single installation of Aren Register can support up to 99
di�erent organisations. Each organisation requires a separate
licence key. The name of the organisation that is currently
open is displayed in the title bar of the main window.

1 Social Health Insurance Fund
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Figure 2.10: Statutory Levy Parameters dialog box

Adding a new Organisation

To add a new organisation select Add from the Organisation
menu. Use the New Organisation dialog box that follows (�g-
ure 2.11) to enter the name of the organisation and the month
from which you want to start entering data. On closing the
dialog box, the previous organisation is closed and the new
one opened.

Figure 2.11: New Organisation dialog box

Opening another Organisation

To open a di�erent organisation select Open from the Organ-
isation menu. This will bring up the Open Organisation di-
alog box (�gure 2.12) provided there are other organisations
de�ned. Select the organisation you want to open from the
dialog box.
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Figure 2.12: Open Organisation dialog box

Deleting an Organisation

You can delete any organisation that is currently not open.
Deleting an organisation causes all its data �les and folders to
be deleted. It is strongly recommended that you back up the
organisation's data �les before deleting it (see Section 5).

To delete an organisation:

1. Select Delete from the Organisation menu. To minimise
the risk of accidentally deleting an organisation you will
be required to enter your password (�gure 2.13).

Figure 2.13: First Delete Organisation dialog box

2. Next, a list of all organisations in the system, exclud-
ing the one that is open, will be displayed (�gure 2.14).
Select the one you want to delete. Note that it is not pos-
sible to delete the organisation that is currently open.

3. In the two message boxes that follow, con�rm that you
want to delete the selected organisation and destroy its
data �les.
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Figure 2.14: Second Delete Organisation dialog box

4. Aren Register will then delete the organisation. A dia-
log box con�rming that the deletion is complete will be
displayed.

Setting up an Organisation

To con�gure the organisation that is currently open, proceed
as follows:

Basic Organisation Information

Open the Basic Organisation Info dialog box (�gure 2.15) from
the Organisation menu and enter the organisation's address
and telephone number.

Figure 2.15: Basic Organisation Info dialog box
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Also, con�rm that you want to start entering payroll and leave
details in the month and year shown in the dialog box. Once
you run the �rst period or month end procedure you will not
be able to edit either of them.

Licensing

Select Licence from the Organisation menu to open the Licence
dialog box (�gure 2.16). Type in the licence key supplied by
your dealer. If you do not have a licence key, contact your
dealer or Aren Software Ltd.

Figure 2.16: Licence dialog box

Payroll Info

Open the Payroll Info dialog box (�gure 2.17) by selecting
Payroll Info from the Organisation menu. Enter the bank,
branch and account number for the organisation's salary ac-
count. Also enter the organisation's PIN, NSSF, NHIF, SHIF
and HELB numbers.

In this dialog box, the Standard File Interchange (SFI) Sender
ID applies to those who submit their payroll to the bank in
electronic form. Leave this �eld blank if you do not already
have an SFI Sender ID.

Grades

Aren Register assumes that all jobs that employees may be
assigned to are graded or ranked. To set up the grades for
your organisation select Grade from the Organisation menu.
The Grades dialog box that follows (�gure 2.18) allows you to
specify the name, rank and salary range for each grade.

If your organisation has no grades, create only one grade called
(None) and enter a salary range that will cater for all employ-
ees.

Jobs

To set up the jobs available in the organisation, open the Jobs
dialog box by selecting Jobs from the Organisation menu. For
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Figure 2.17: Payroll Info dialog box

Figure 2.18: Grades dialog box

each job you must enter the name of the job and its grade.
You may also enter a brief description of the job for future
reference.

Administrative Units

Set up the administrative units (departments, sections, etc) in
your organisation. To do this select Units from the Organisa-
tion menu.
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Posts

A post is a job that is attached to a speci�c administrative
unit. Aren Register does not accept new employees unless
there are vacant posts available.

In order to create posts you must create grades, jobs and ad-
ministrative units �rst. To add posts select Posts from the
Organisation menu which opens the Posts dialog box (�gure
2.19). For each administrative unit and job you will need to
specify how many permanent, contract, temporary and casual
posts to allow.

Figure 2.19: Posts dialog box

Stations

Set up the stations (branches) in your organisation. To do this
select Stations from the Organisation menu.

Pay Groups

Pay Groups allow you to �lter payment reports according to
how employees in your organisation are paid. For example,
the bank transfer report could be �ltered by bank branch or
pay date.

To set up pay groups, select Pay Groups from the Organisation
menu.

Co-operatives and Pension Funds

Create co-operative societies that employees in the organisa-
tion belong to by selecting Co-operatives from the Organisa-
tion menu.
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Similarly, set up pension funds by selecting Pension Funds
from the Organisation menu.

Insurance Companies

If you need to deduct and remit insurance premiums, set up
the insurance companies involved by selecting Organisation >
Insurance Companies.

Employee Pro�les

An employee pro�le de�nes attributes that are common to a
group of employees. These attributes are leave entitlement,
pay frequency, basic pay type (i.e., salary, daily rate or hourly
rate), standard working hours (per day and per pay period)
and whether overtime is payable.

To create a pro�le, select Pro�les from the Organisation menu
to open the Employee Pro�les dialog box (�gure 2.20). If there
is an employee pro�le marked as default, all new employees
added to the payroll will be assigned this pro�le.

Figure 2.20: Pro�les dialog box

General Options

Selecting Options > General from the Organisation menu opens
the General Options dialog box (�gure 2.21). This dialog box
is used to specify the default pay frequency. This is the pay
frequency that the program defaults to when opening the pay-
roll transactions table or initialising dialog boxes that display
pay frequency.

Under data entry forms, you can choose how to sort the data
presented in employee data forms as well as activate the Open
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Figure 2.21: General Options dialog box

Table dialog box. This dialog box is used for �ltering form
data by administrative unit, station or pay group.

The General Options dialog box also allows you to specify
when to purge old reports. Deleting old reports saves space
on the hard disk and reduces the size of backup �les.

In the PDF documents section you can edit the following pass-
words.

1. Owner Password: This password allows you to open any
PDF documents that you send by email. It should not
be disclosed to employees.

2. Default User Password: Employees use the user pass-
word to open PDF documents sent to them. It is usually
set to the last four digits of the employee's PIN. Where
the PIN is missing, the default value you enter here is
used instead.

Payroll Options

Selecting Options > Payroll from the Organisation menu brings
up the Payroll Options dialog box (�gure 2.22).
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Figure 2.22: Payroll Options dialog box

Taxable Pay

If your organisation is tax-exempt you are required to treat the
employer's pension contribution as a taxable bene�t. Select
the option to tax excess employer pension on employees.

KRA's online tax administration system, iTax, does not tax
bene�ts unless they total to more than Ksh 3,000. By default,
Aren Register taxes all non-cash bene�ts regardless of their
total. For it to work like iTax you must check the option
Ignore bene�ts unless total exceeds Ksh 3,000.

PAYE

By default, PAYE is rounded down to the nearest shilling. To
match the iTax system, you should select the option to deduct
the exact amount of PAYE.

For employees who are paid more than once a month, it is
possible though unlikely for the PAYE amount for a particular
pay period to be negative. To avoid this, uncheck the option
to allow negative PAYE.
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Housing Levy

If you would like to turn o� housing levy for the whole organi-
sation, uncheck the option to deduct housing levy. By default,
housing levy is rounded to the nearest shilling. To match the
iTax system, select the option to deduct the exact amount of
housing levy.

NITA Levy

If your organisation pays NITA Levy for its employees, check
the option Pay NITA Levy. An annual report showing the
amount payable for each employee will be generated.

NHIF

You can choose to have NHIF calculated on the �xed monthly
salary or on the gross pay earned in a given month. The former
option is included for backward compatibility and you should
always compute NHIF on gross pay.

NHIF contributions qualify for insurance relief starting Jan-
uary 2022, hence the option Allow insurance relief should be
checked. When it is checked 15% of the NHIF contribution is
deducted from PAYE as insurance relief.

Once SHIF deductions replace NHIF, remember to check the
option Deduct SHIF instead.

NSSF

If your organisation has opted out of Tier II NSSF contribu-
tions, select whether to deduct Tier II NSSF selectively or not
all.

Net Pay

Finally, you have the option to round down net pay for em-
ployees paid in cash by an amount that you specify. The excess
amount is carried forward to the next month.

Logos

Selecting Options > Logos from the Organisation menu brings
up the Logos dialog box (�gure 2.23). This dialog box allows
you to select image �les with the organisation's logo for use
in payslips. These �les must be in the images\logos folder
located within the organisation folder.
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Figure 2.23: Logos dialog box

For printed payslips you can select a PNG or JPEG �le. PNG
images are typically sharper than JPEG ones but they occupy
more space.

Select a JPEG �le for payslips that are sent as email attach-
ments in PDF format. Attachments are restricted to 64 KB
so the logo �le must be well below that size.

Pay Period End Days

If the pay frequency is monthly, the pay period is assumed to
end on the last day of the month. For other pay frequencies
the program requires assistance from the user to determine
when each pay period ends.

For weekly and biweekly pay frequencies, the user is required
to specify the last day of the very �rst pay period. The pro-
gram will work out when subsequent pay periods end. In the
case of employees paid after irregular intervals, the pay period
end day must be entered for each pay period.

To initialise period end days, you need to do the following for
each pay frequency that applies to your organisation (except
monthly):

1. Make it the default pay frequency using the General Op-
tions dialog box (Organisation > Options > General).
The pay frequency selected should appear in the status
bar.

2. Open the Pay Period dialog box (�gure 2.24) from the
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Organisation menu and enter the pay period end day for
this pay frequency.

Figure 2.24: Pay Period dialog box

In any given month, the pay period end days for weekly and
biweekly employees can not be edited once the �rst period end
procedure for that pay frequency is run.
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3 Data Tables

Data for each employee is stored in four data tables�personnel,
payroll master, payroll transactions and absence and leave.
There is a separate payroll transactions table for each pay
frequency. This data is used to create various personnel and
payroll report tables which are then used for report generation.

Personnel Table

The personnel table stores personal information about each
employee, for example name, national ID number, date of birth
and nationality. It also stores information about employees'
jobs such as job title, grade, administrative unit, station and
leave entitlement.

Employees can only be added and removed from the system
through the personnel table. The employees in this table au-
tomatically appear in the payroll master, payroll transactions
and absence and leave tables.

The personnel table is accessed by selecting Personnel from
the File menu. This brings up a data entry form in which you
enter data for each employee (�gure 3.1).

Figure 3.1: Personnel Table form

Most of the �elds in the table are optional. However, Em-
ployee Number, Last Name, Other Names, Post and Station
are mandatory. The optional �elds are used in various reports
and should therefore not be left blank.
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Adding and Deleting Employees

Employee records are added and removed from the personnel
table using the Add, Delete and Terminate commands in the
Record menu.

Deleting an employee record is only possible if it has not gone
through a period or month end procedure since it was added.
After deleting a record, no report will retain information relat-
ing to that employee. This option is provided to allow records
added by mistake to be expunged.

Terminating an employee will cause his record to be removed
from the personnel table in due course. However, various per-
sonnel and payroll reports will retain details of that employee
for future reference. Section 5 describes the termination pro-
cess in detail.

Payroll Master Table

The payroll master and the four payroll transaction tables
store employee payroll information. The former maintains in-
formation that tends to remain the same over time while the
latter maintain information for a single pay period and this
tends to change more frequently.

The data in the payroll master table includes pay frequency,
basic pay, bank account number, PIN, co-operative member-
ship and housing status.

To open the payroll master table, select Payroll Master from
the File menu. This brings up the Payroll Master Table data
entry form (�gure 3.2).

Payroll Transactions Tables

Each payroll transactions table stores earnings, deductions,
bene�ts, lump sum payments and refunds for all employees
paid in a particular pay period.

Earnings are those cash payments that relate to the current
pay period, e.g. basic pay or leave allowance. For tax pur-
poses, all cash earnings for all pay periods falling in a partic-
ular calendar month make up the monthly cash earnings. A
pay period is deemed to fall in a particular month if its last
day falls in that month.

Bene�ts refers to private expenditure of an employee paid by
the employer e.g. school fees, house rent or telephone bills.
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Figure 3.2: Payroll Master Table form

These non-cash bene�ts are considered as income for tax pur-
poses.

Deductions are those amounts deducted from an employee's
cash earnings by the employer. Some of these are called statu-
tory deductions because the law requires the employer to deduct
them from the employee's pay. The statutory deductions are
PAYE, NSSF, NHIF, housing levy and tax on lump sum pay-
ments.

Lump sum payments are those cash payments that do not
relate to the current month alone. Some like gratuity and
bonuses have accrued over past months while others like ter-
minal bene�ts may relate to past or future months. We make
the distinction between lump sum payments and monthly cash
earnings because the two are treated di�erently when calcu-
lating income tax.

Refunds are payments made to an employee, e.g. travelling or
subsistence allowances, for business expenses incurred while
on duty. These payments are not income and are therefore
not taxable.

The payroll transactions table is accessed by selecting Pay-
roll Transactions from the File menu. This displays a data
entry form (�gure 3.3) where you enter earnings, deductions,
bene�ts, lump sum payments and refunds for each employee.

Statutory deductions and other calculated amounts such as
taxable pay, net pay and gross pay are updated as data is



28 3 Data Tables

Figure 3.3: Payroll Transactions Table form

entered. This makes the calculations more transparent and
helps to reduce data entry errors.

You can suspend employees from the payroll by deleting them
from the payroll transactions table (Record > Remove). To
restore a suspended employee use the Record > Add command.

Payroll Fields

At installation, each payroll transactions table has two earn-
ings (Basic Pay and Overtime), three deductions (Rent, Over-
draft Recovery and Rounding C/F), one non-cash bene�t (Em-
ployer Pension) and one refund (Rounding B/F). These �elds
cannot be deleted but you can add more according to your
needs.

To add, delete or edit �elds, select Earnings, Deductions, Ben-
e�ts, Lump Sum Payments or Refunds from the File menu. A
data entry form will be displayed showing the �eld attributes
listed below (�gure 3.4). To add or delete �elds select Add or
Delete from the Field menu.

The following �eld attributes apply to all �elds:

1. Field Name: The name of the �eld e.g. advance, shift
allowance.

2. Type: This is used to indicate permanent �elds (e.g. ba-
sic pay and rent). It is also used to specify �elds that
are calculated in a unique way (e.g. hourly pay and
daily pay) and those that are associated with a balance
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Figure 3.4: Deductions form

that is updated and displayed by the system (e.g. loan
repayments and co-operative contributions). The type
advance is used to indicate advance payments so that
appropriate reports can be generated.

3. Amount: This attribute speci�es how the amount paid
to or deducted from each employee is arrived at. It may
be keyed in, a percentage of salary, a function of the time
worked (basic pay, overtime, hourly pay and daily pay)
or amortised (loan repayments).

4. Static: Static �elds retain their value when a period or
month end procedure is run, whereas non-static �elds
are reset to their lower limit. This is only important
for �elds that are keyed in. It saves you the trouble of
having to key in the amount earned or deducted each
time a period or month end procedure is run.

5. Taxable/Pre-tax deduction: For earnings the taxable at-
tribute speci�es whether or not the payment is subject
to PAYE. Unless prior permission has been given by the
KRA, all income (i.e. earnings, non-cash bene�ts and
lump sum payments) must be taxed. Refunds are not
taxable as they are not a form of income.

The pre-tax deduction attribute indicates those deduc-
tions to be subtracted from gross income when calcu-
lating PAYE. In Kenya the only pre-tax deductions are
mortgage interest payments, contributions to registered
pension/provident funds and contributions that qualify
for a�ordable housing relief.

6. Pensionable: NSSF is calculated on the total pension-
able earnings. Uncheck the pensionable option to ex-
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clude any earning from this calculation.

7. Regular: Housing levy is calculated on basic pay plus all
regular allowances. Any earnings not marked as regular
are not subjected to housing levy.

Depending on the selection for Type and Amount attributes
the following additional attributes may be available:

1. Co-operative: The name of the co-operative associated
with the �eld (�gure 3.5).

Figure 3.5: Co-operative dialog box

2. Pension Fund: The name of the pension fund and other
details pertaining to the current �eld (�gure 3.6).

Figure 3.6: Pension Fund Parameters dialog box

3. Insurance: The name of the insurance company associ-
ated with the �eld.

4. Limits: The upper and lower limits that the amount
paid or deducted should be restricted to (�gure 3.7).

5. Percentage: The percentage of monthly salary that should
be paid or deducted (�gure 3.8).

6. Hourly Rate: The hourly rate to use for earnings that
are of the type Hourly Pay (�gure 3.9).
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Figure 3.7: Limits dialog box

Figure 3.8: Percentage of Salary dialog box

Figure 3.9: Hourly Rate dialog box

7. Daily Rate: The daily rate to use for earnings that are
of the type Daily Pay.

Absence and Leave Table

The absence and leave table stores details about employees'
absence from work in the current year. This information is
expressed in terms of absence event records.

In addition, the table keeps an account of annual leave earned
and used up by each employee during the year. It uses leave
event records to track the leave days brought forward from the
previous year and leave days earned, sold and forfeited since
then. Leave taken is treated as an absence event.

The absence and leave table can also be used to track employ-
ees' leave bookings.
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To edit this table select Absence and Leave from the File menu
(�gure 3.10). The Absence and Leave window has three pages,
i.e., Absence, Annual Leave and Leave Bookings. To edit or
delete an event in any page, �rst select it and then click on
the Edit or Delete button. To add a new event, switch to the
appropriate page and then click on Add.

Figure 3.10: Absence and Leave window

If you do not wish to track absence and leave for a particular
employee, you can remove them from the absence and leave
table. Open the Personnel Table form and select the Employ-
ment tab. Uncheck the option to track abscence and leave.
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Aren Register produces numerous reports as described below.
These reports can be viewed on the screen and printed out.
You can choose to print the entire report, a range of pages, or
just the page that you are currently viewing. Internal reports
can be sorted by either employee number or name.

You can view and print reports for current and previous pay
periods, months or years. You can also �lter most reports by
administrative unit, station, pay group, bank, co-operative or
pension fund.

Reports may be printed on any printer connected to your com-
puter either directly or through a local area network. Because
all reports are formatted for A4 paper, the printer must be set
to print on A4.

1. To open a report select it from the Report menu and then
follow the on-screen instructions. For example, selecting
Report > Payslips opens the Open Payslips dialog box
(�gure 4.1).

Figure 4.1: Open Payslips dialog box

2. To print the open report select Print from the File menu
which brings up the Print dialog box (�gure 4.2). Use the
Setup button in this dialog box to con�gure the printer
you want to use.
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Figure 4.2: Print dialog box

3. Choose Close from the File menu to close the report.

Personnel Reports

1. Posts By Type: List that shows the number of perma-
nent, contract, temporary and casual posts in each ad-
ministrative unit of the organisation.

2. Posts By Status: List that shows the number of occu-
pied and vacant posts in each administrative unit of the
organisation.

3. Employees Roll: List of employees who are currently ac-
tive. It shows their job title, administrative unit and
station.

4. Joiners Roll: List of employees who joined the organi-
sation recently. It shows their job title, administrative
unit, station and start date.

5. Leavers Roll: List of employees who left in a given year.
It shows their �nal job title and administrative unit, the
date they left and the reason for leaving.

6. Employee Hierarchy Report: List of employees grouped
according to whom they report to. Employee names are
indented to show the reporting hierarchy. The report
also displays the job tile, administrative unit and station
for each employee.

7. Length of Service Report: List of current employees show-
ing their job title, age and length of service.

8. Employment Status: List of current employees showing
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their job title, start date, contract end date and employ-
ment status.

9. Emergency Contact Report: List showing each employee's
next of kin, their relationship and the contact details.

10. Master Report: Report that shows the details of a single
employee as entered in the personnel and payroll mas-
ter tables. It is available for both current and former
employees.

11. Absence by Employee: List of actual and planned ab-
sences from work grouped by employee.

12. Absence by Date: List of actual and planned absences
from work in chronological order.

13. Absence Sheet: This report lists, for a single employee,
all absence from work in a given year.

14. Annual Leave Sheet: This report gives, for a single em-
ployee, a detailed account of leave earned and used up
in a given year.

15. Absence Analysis: List of employees that gives a sum-
mary of all absence from work for a speci�ed year.

16. Leave Analysis: List of employees that gives a sum-
marised account of leave earned and used up in a given
year.

17. Leave Liability: List of employees showing their out-
standing annual leave days and the cash equivalent.

Reports on former employees, absence and leave cover a calen-
dar year. Reports for previous years can be viewed and printed
out, but they cannot be modi�ed in any way. Before running
the month end for December make sure that you verify these
reports.

The remaining reports, i.e. those on posts and current em-
ployees, indicate the state of the organisation at the time of
printing.

Pay Period Reports

These are reports for a speci�c pay frequency and cover one
pay period. For a particular pay frequency, reports for the
current pay period are updated as you update the employee
data tables. Reports for previous pay periods can be viewed
and printed out, but they cannot be modi�ed in any way.
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Overview Reports

1. Payroll Summary: Summarises earnings and deductions
for all employees.

2. Payroll Control Account: T-account listing total earn-
ings, deductions and net pay for all employees in the
organisation.

3. Muster Roll: List of employees showing all earnings,
lump sum payments, refunds and deductions for the pay
period. Records in this report can be grouped by admin-
istrative unit or station.

4. Payroll Variance: List of employees showing the di�er-
ences in the payments and deductions made in any two
pay periods. It is essentially the di�erence between the
muster rolls for the two pay periods.

5. Gross Pay By Unit: List of administrative units showing
the sta� count and total gross pay for each.

6. Gross Pay By Station: List of stations showing the sta�
count and total gross pay for each.

The muster roll and payroll variance can be viewed on the
screen or saved to an XML �le but they cannot be printed
out.

Detail Reports

1. Earning Report: List showing, for a particular earning,
how much each employee was paid.

2. Deduction Report: List showing, for a particular non-
statutory deduction, how much each employee was de-
ducted. Depending on the type of deduction selected, a
loan or HELB (Higher Education Loans Board) report
may be printed instead.

3. Loan Report: List of employees repaying a speci�c co-
operative or company loan. It shows the opening and
closing balances and a breakdown of the repayment amount
into interest and principal components.

4. HELB Report: List showing the HELB Repayment Sched-
ule in the format previously used for �ling returns to
HELB. HELB returns should be �led on their website
using the return �le available under Procedure > HELB
Schedule.
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5. Bene�t Report: List showing, for a particular non-cash
bene�t, how much each employee received.

6. Lump Sum Report: List showing, for a particular lump
sum payment, how much each employee received.

7. Refund Report: List showing, for a particular refund,
how much each employee received.

Payments to Employees

1. Payslips: Slip giving a breakdown of the earnings and
deductions of each employee separately (�gure 4.3). The
employer's pension contribution and the pension fund
balance can be shown in the payslip if required. When
the balance is shown, it includes the employer's portion
only if the option to print the employer contribution has
been selected.

Figure 4.3: Payslips

2. Cash List: List of employees paid in cash showing their
employee number, name, net pay or advance payment
and a cash analysis of the payment amount.

3. Cheque List: List of employees paid by cheque showing
their employee number, name and net pay or advance
payment.

4. Bank Transfer Report: List of employees who are paid
by bank transfer showing their name, ID number, bank,
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branch, account number and payment amount. The pay-
ment amount may be the net pay, an advance payment,
a bank loan repayment or a HOSP contribution.

5. Labels: Envelope labels for employees paid in cash, by
cheque or by bank transfer. For cash employees, the net
pay can be shown on the label if required.

6. Coinage Summary Report: List showing the number of
coins and notes of each denomination that are required
for workers who are paid in cash. This information is
the same as the totals in the cash list but formatted so
that it can be used when withdrawing the cash from a
bank.

Returns

1. Co-operative Report: List of members of a particular co-
operative society showing membership number, monthly
contribution and any other payroll deductions to be paid
to that co-operative.

2. Pension Report: List of members of a particular pension
fund showing membership number and employer and em-
ployee contributions to that pension fund.

3. Insurance Company Return: List of employee premium
deductions to be paid to a particular insurance company.

Monthly Payroll Reports

The monthly reports relate to a calendar month. They are:

1. Payroll Control Account.

2. Muster Roll.

3. PAYE Report: List of employees showing their PAYE
deductions. To generate the equivalent iTax return �le,
go to Procedure > iTax Files > Employee Details.

4. NSSF Report: List of employees showing NSSF number,
ID number and the combined employer and employee
tier I and tier II contributions. Voluntary contributions
are also shown.

The NSSF return �le is available under the Procedure
menu (Procedure > NSSF return). This generates an
XML �le which should be opened with Microsoft Excel
and saved again as an Excel �le.
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5. NHIF Report: List of employees showing NHIF number,
ID number, date of birth and NHIF deduction.

To generate the NHIF return �le, select Procedure >
NHIF Return. This saves an XML �le that should be
converted into a Microsoft Excel spreadsheet.

6. SHIF Report: List of employees showing SHIF number,
ID number, date of birth and SHIF deduction.

7. Housing Levy Report: List of employees showing PIN,
gross salary and housing levy payable.

8. Lump Sums Tax Report: List showing tax payable on
lump sum payments for each employee.

9. Fringe Bene�t Tax Report: List showing tax payable on
the fringe bene�t arising from company loans issued at
an interest rate below the KRA prescribed market in-
terest rate. The equivalent iTax return �le is available
under Procedure > iTax Files > Fringe Bene�t Tax.

These reports are updated after each period end procedure
and may not be complete until the month end procedure is
run. For the current month, the information displayed covers
the pay periods that have elapsed so far.

Annual Payroll Reports

Annual payroll reports relate to a calendar year and are avail-
able throughout the year. For the current year, the informa-
tion displayed relates to the pay periods that have elapsed so
far. The reports are:

1. Payroll Control Account.

2. Muster Roll.

3. Annual Pay Sheet: A report that, for each employee,
gives a summary of payments, deductions and bene�ts
for a whole year.

4. P9A: KRA form titled Tax Deduction Card. Each P9A
gives a breakdown of the income of an employee for each
month of the year and shows the amount of tax deducted.

5. P10: KRA form titled Employer's Covering Certi�cate.
It shows the tax deducted by the employer for each
month of the year.
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6. P10A: KRA form titled Supporting List for End of Year
Certi�cate. It lists the annual income and total tax de-
ducted for each employee.

7. NITA Levy Report: List showing the NITA levy payable
for each employee in the payroll.

8. NSSF Statement: A report that shows the standard and
voluntary monthly contributions to NSSF for a single
employee for a calendar year.

9. NHIF Statement: A report that shows an employee's
monthly NHIF deductions for a calendar year.

The P9A, P10 and P10A have been approved by the KRA
(approval reference number CIT/1037/2/98/20).

Other Reports

1. Bank Codes: A listing of banks, bank branches and their
sort codes drawn from the banks tables.

2. Audit Trail: List that shows the date and time of each
login, backup, month end procedure and any other major
event. It also shows the user responsible for each event.
This report is only available to the supervisor.

Report Tables

Almost all reports are printed from report tables, not directly
from the employee data tables. Brie�y, the report tables are:

1. Active employees report table

2. Annual leavers report tables

3. Annual absence and leave report tables

4. Pay period report tables

5. Monthly payroll report tables

6. Annual payroll report tables

Report tables are updated automatically by Aren Register.
Use the General Options dialog box (Organisation > Options
> General) to specify how long to keep these tables for.
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Backing Up

If any of your organisation database �les is accidentally deleted
or corrupted you could lose all the data for that organisation.
Without an up-to-date backup you would be forced to key in
the data for the current month again. It is also likely that
you would be unable to recreate data for previous months and
years. It is therefore very important that you make regular
backups of your database �les.

To back up the database �le for the organisation that is cur-
rently open, select Back Up from the Procedure menu. You
will be prompted to specify the name and location of the
backup �le to be created (�gure 5.1).

Figure 5.1: Backup dialog box

The backup process copies all data relating to the organisation
to the backup �le. Should you have set up more than one
organisation, you will need to back up each one separately.
Note that data that is shared by all organisations is not backed
up (e.g. list of banks and statutory deductions parameters).

When running a period or month end procedure you will be
prompted to back up. Though you can choose to proceed
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without doing so, it is recommended that you back up �rst.
To encourage regular back ups Aren Register prompts you to
back up each time you exit.

Restoring from Backup

In the event that an organisation database �le is corrupted
or deleted, you will need to replace it from backup. You can
also use backup �les to revert to an earlier month. This is
especially useful if you accidentally run the period or month
end procedure.

To restore an organisation database �le from backup, select
Restore from the Procedure menu then follow the on-screen
instructions (�gure 5.2).

Figure 5.2: Restore dialog box

Creating a Bank Transfer File

A bank transfer �le is an electronic version of the bank transfer
report. It is used by banks to process payments for employees
paid by bank transfer in place of the printed bank transfer
report. Aren Register can create bank transfer �les for numer-
ous banks e.g. Absa, Co-operative, Equity, KCB and Standard
Chartered.

1. To create a bank transfer �le select Bank Transfer File
from the Procedure menu.

2. In the Bank Transfer File dialog box that appears (�gure
5.3), specify the format of the bank transfer �le to create
and the name of the payment �eld (usually net pay).
Depending on the �le format, you may be able to specify
the date you want the bank transfer e�ected.
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Figure 5.3: Save Bank Transfer File dialog box

3. On closing the Bank Transfer File dialog box, a standard
Save As dialog box will appear. Use this dialog to specify
the name and location of the �le to be created.

For further details on bank transfer �les please contact your
bank.

Saving iTax Files

iTax �les are text �les containing tax details about employees
in the payroll. These �les help you to �ll out the iTax spread-
sheet (P10_Return.xlsm) that is used for �ling tax returns on
the KRA website.

Four formats are available�Employee Details, Disabled Em-
ployee Details, Fringe Bene�t Tax Details and Housing Levy
Details. Data exported in these formats should be imported
into the corresponding tabs of the iTax spreadsheet.

1. To save the Employee Details �le, select iTax File >
Employee Details from the Procedure menu.

2. In the Save Employee Details File dialog that is displayed
(�gure 5.4), select the month and year you want.

3. By default only employees who have paid PAYE in the
selected month will be included in the �le. If you wish
to include those with zero PAYE as well, click on Next
and select the option Include all employees.

4. On closing the Save iTax Employee Details File dialog
box, a standard Save As box will appear. Use this dialog
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Figure 5.4: Save iTax Employee Details File dialog box

to specify the name and location of the �le to be created.

Files in any of the other formats can be created in the same
manner. For further assistance with iTax please contact the
KRA.

Terminating an Employee

To terminate an employee, open the personnel table and dis-
play the target employee. Next, select Terminate from the
Record menu. In the Terminate dialog box that appears (�g-
ure 5.5), enter the termination date, the reason for leaving
and, if you like, some brief comments.

Figure 5.5: Terminate dialog box

The terminated employee will be removed from the employee
data tables in the next month end procedure that is later than
or on the same day as his termination date. Once the employee
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is deleted from the employee data tables his record will be
added to the leavers report table.

Termination can be reversed by selecting Record > Undo Ter-
mination as long as the terminated employee has not been
removed from the employee data tables.

Period End Procedure

The period end procedure is used to close data entry for the
current pay period and begin a new one. The procedure does
the following:

1. Saves all payroll information for the current pay period
to the period, monthly and annual payroll report tables.

2. Deletes the existing payroll transactions table and cre-
ates a new one for the next pay period.

3. Advances the period end day to the last day of the next
pay period.

This procedure should only be run after all reports for the
current pay period have been veri�ed since, once it is run,
reports for this pay period cannot be changed.

To run the procedure:

1. Check that the correct pay frequency is set as default.

2. Select Period End from the Procedure menu. This option
is only available if you have licensed the organisation.

3. After reading the dialog box that appears (�gure 5.6),
con�rm that you want to close the pay period stated by
entering your password.

Figure 5.6: Period End Procedure dialog box
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4. You will now be prompted to back up your data and are
strongly encouraged to do so.

5. Once the back up is complete, the period end procedure
will automatically follow and eventually a message box
con�rming its completion will appear.

Month End Procedure

The month end procedure is used to close data entry for the
current month and begin a new one. It applies only to the
organisation that is currently open. It does the following:

1. Runs the period end procedure for each pay frequency.

2. Advances the date by one month such that all pay peri-
ods end in the following month.

3. If the new month is January, it creates statutory deduc-
tion tables for the new year.

4. If the new month is January, it deletes all events in the
absence and leave table for the previous year. A new
event for leave days brought forward is also added to the
table.

5. Adds leave earned in the new month to the absence and
leave table.

6. Transfers terminated employees from the personnel table
to the leavers report table.

7. Deletes any report tables that have exceeded the maxi-
mum age set in the General Options dialog box.

The procedure can only be run if, for each payroll that has
data, the forthcoming pay period ends in the next calendar
month. This is because, after the procedure is run, all pay
period end days will fall in the new month. In December the
month end procedure cannot be run if there are outstanding
leave bookings for the year that is ending.

To run the procedure:

1. Select Month End from the Procedure menu. This op-
tion is not available if you have not licensed the organi-
sation. It is also not available if the next pay period for
the default pay frequency does not end in the following
month.
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2. After reading the dialog box that appears (�gure 5.7),
con�rm that you want to close the month by entering
your password.

Figure 5.7: Month End Procedure dialog box

3. You will now be prompted to back up your data and are
strongly encouraged to do so.

4. Once the back up is complete, the month end proce-
dure will automatically follow. Eventually, a message
box con�rming its completion will appear.

The Month End Procedure should be run with care since it
cannot be reversed except by restoring from backup. This is
especially true in December when it will close entry of absence
and leave data for the year that is ending.



48 5 Procedures



Appendix A Setting Up Firebird

Aren Register accesses payroll data through a Firebird database
server, not directly. Where the data is in a local folder, it may
be accessed through the embedded Firebird server that is in-
stalled with the application.

To access data on a shared folder on a di�erent computer, you
need to install the full Firebird server on that computer and
con�gure it to work with Aren Register. Even when the data
folder is local, you may prefer to install Firebird. Doing so will
allow you use Aren Register in true multi-user mode.

Installing Firebird

1. Insert the installation CD in the CD drive.

2. Run the program Firebird 3.0\Installation Files\Firebird-
3.0.5.33220_0_Win32.exe on the installation CD.

3. Follow the on-screen instructions that appear during the
installation process.

4. When prompted to create a password for the Database
System Administator (sysdba) make sure you do so. Us-
ing the default password could compromise the security
of your data.

5. Accept the default settings for everything else other than
the password. See �gure A.1.

Copying the Encryption Library

1. Locate the folder Firebird 3.0\Encryption Plugin in the
installation CD. This folder contains the encryption li-
brary that the Firebird server uses to encrypt database
�les.

2. Copy the entire contents of this folder to the folder in
which you installed Firebird. This is most likely C:\Program
Files(x86)\Firebird\Firebird_3_0. Note that both fold-
ers have the same layout. Overwrite any �les in the
destination folder if prompted to do so.
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Figure A.1: Firebird Setup Wizard

Con�guring Firebird

You need to edit the �le �rebird.conf in the Firebird installa-
tion folder so that the Firebird server can work correctly with
Aren Register.

1. Locate the Notepad text editor by searching for it in the
Windows search box.

2. Select Run as administrator to open Notepad.

3. In Notepad, locate and open �rebird.conf.

4. Immediately below the line #KeyHolderPlugin = add a
new line KeyHolderPlugin = Callback.

5. Save �rebird.conf and close Notepad.

Restart the Firebird server so that the changes to �rebird.conf
can take e�ect.

1. Start the Services app by searching for it in the Windows
search box.
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Figure A.2: Services App

2. In the list of local services select the Firebird server,
most likely listed as Firebird Server - DefaultInstance.
See �gure A.2.

3. Restart the service.

4. Close the Services app.

The Firebird server is now ready for use.
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Appendix B Importing Data

Employee Data

Keying in new employees into the payroll can be very time
consuming especially if there are many of them. As an alter-
native, you can import employee data into the personnel table
from a text �le.

The easiest way to create the input text �le is to capture em-
ployee data in a spreadsheet and then save the spreadsheet as
a text �le.

File Format

The format of the input text �le is as follows:

1. Plain text with data items separated by the tab character
(i.e. a tab-separated text �le).

2. The �rst row of data is a header with the data items Em-
ployee Number, Last Name, Other Names, ID Number,
Job Title, Admin Unit, Station, Pay Rate, PIN, NSSF
Number and NHIF Number.

3. From row two onwards, each row has data for a single
employee, i.e. employee number, last name, other names,
ID number, job title, administrative unit, station, pay
rate, PIN, NSSF number and NHIF number.

Note that:

1. The �rst row (�le header) is ignored. It is only included
for the convenience of the person preparing the input
�le.

2. A row will not be imported if the employee number
matches that of a record already in the personnel table.

3. A row will also be skipped if any of the following data
items is blank: employee number, last name, other names,
job title, administrative unit, station.

4. Data will be imported into several data tabes�personnel,
payroll master, payroll transactions, leave, jobs, admin-
strative units and stations.
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5. Where a default pro�le has been de�ned, it will be ap-
plied to each record added to the personnel table.

How to Import

1. Make sure you are in single-user mode. If not, switch to
this mode by selecting System > Single-User Mode.

2. Back up your data just in case you need to undo the
changes you are about to make (Procedure > Backup).

3. Select Procedure > Import > Employees to open the
�rst Import New Employees dialog box (�gure B.1).

Figure B.1: First Import New Employees dialog box

4. Enter your password to open the second Import New
Employees dialog box.

5. Browse to the text �le that you want to import data
from and click on Open.

6. Aren Register will read the text �le and update the data
tables listed above. On completion, a con�rmation mes-
sage box will be displayed. Close the message box.

To see which records were updated, refer to the log �le im-
port.log located in the payroll data folder. Browse through
the data tables that should have been updated to con�rm that
they were updated successfully.

Time and Attendance Data

Aren Register can import time and attendance data from a
text �le. This provides a quick way of capturing the data gen-
erated by a clocking system. Because the format of the input
�le is standard, Aren Register will work with any clocking sys-
tem provided that the data it generates can be converted to
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Employee Name Basic Normal Double

Number Pay Overtime Overtime

001 NJOROGE, James 0.5 10 3.5

002 MWINZI, Miriam 0 0 8

003 OKUTOYI, Agnes 1.5 8 4

004 MUTUMA, Joe 2 0 0

Table B.1: Time and attendance data format

the required format. An input �le can also be created by key-
ing in time and attendance data into a spreadsheet and then
saving it as a text �le.

File Format

The input text �le should have the following format:

1. Plain text with data items separated by the tab charac-
ter.

2. The �rst row of data is a header with the data items
Employee Number, Name, Basic Pay, Normal Overtime
and Double Overtime.

3. From row two onwards, each row has data for a sin-
gle employee, i.e. employee number, name, basic pay
time worked, normal overtime hours and double over-
time hours.

Table B.1 is a simple example of the format required.

Interpretation

The data is interpreted as follows:

1. The �rst row (�le header) and the second column (em-
ployee name) are ignored. They are included for the
convenience of the person preparing the input �le.

2. The employee number in column one determines which
record in the payroll will be updated. It must match
the employee number in the payroll transactions table
exactly, except for the case which is ignored.

3. The data in column three (basic pay) could be hours
worked, hours absent, days worked or days absent. Its
interpretation depends on the settings for each employee
in the payroll master table. If an employee is paid a
�xed salary irrespective of the time worked, this value is
ignored.
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4. Columns four and �ve contain normal and double over-
time hours, respectively. For a given employee, if over-
time is not enabled the data is ignored.

How to Import

Here is how you import time and attendance data into the
default payroll transactions table.

1. Make sure you are in single-user mode. If not, switch to
this mode by selecting System > Single-User Mode.

2. Back up your data just in case you need to undo the
changes you are about to make.

3. Select Procedure > Import > Attendance to open the
Import Time and Attendance Data dialog box (�gure
B.2).

4. Browse to the text �le that you want to import data
from and click on Open.

Figure B.2: Import Time and Attendance Data dialog box

5. Aren Register will read the text �le and update the de-
fault payroll transactions table. On completion, a mes-
sage box showing the number of records updated will be
displayed.

To review the imported data, open the basic pay, normal over-
time and double overtime reports (Report > Breakdown). You
should also review the log �le import.log located in the payroll
data folder.
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Aren Register can email payslips and P9As to each of the em-
ployees in the payroll. This provides an alternative to printing
individual payslips or P9As for each employee. The reports
are sent as password-protected PDF �les.

In this section, we explain how to email payslips. Emailing
P9As works in exactly the same way.

Entering Email Addresses

Start by capturing the email addresses to send reports to.

1. Open the Payroll Master Table form (File > Payroll Mas-
ter) and select the Other tab (�gure C.1).

Figure C.1: Payroll Master Table form

2. For each employee, enter the address to email reports to.

3. Close the Payroll Master Table form.

Setting Up Email Account

In order to send email, you need to set up your email account.
For this you require details of the outgoing mail server, also
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known as the SMTP server. Consult your IT department if
necessary or check the settings in the email software you use.

1. Select System > Email Account to open the Email Ac-
count dialog box (�gure C.2).

Figure C.2: Email Account dialog box

2. Email Address: Enter your email address, say info@-
demorestaurant.co.ke or example@gmail.com.

3. SMTP Server: Enter the name of the outgoing mail
server, e.g. mail.demorestraurant.co.ke or smtp.gmail-
.com. You can also enter the server's IP address, e.g.
192.168.0.23.

4. SMTP Port: The SMTP port is a unique number that
the mail server has set aside for outgoing mail. The most
common values are 25, 465 and 587. If your server uses
a secure (encrypted) connection, e.g. smtp.gmail.com or
smtp.mail.yahoo.com, try port 465 or 587. If it does not,
enter 25.

5. Timeout: This is length of time the software should wait
for a response from the mail server before giving up.

6. Use secure connection: Check this option if the mail
server uses a secure connection.
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7. Authentication: You may select none (no account name
or password required), plain or login (requires account
name and password).

8. Account Name and Password: Enter the login name and
password for the mail server if you have selected login or
plain authentication.

9. Copy all emails to self: Check this option if you want to
receive a copy of all the reports you send.

10. Close the Email Account dialog box.

Sending Payslips

Now you are ready to email payslips to employees.

1. Select Procedure > Email Payslips to open the Email
Payslips dialog box (�gure C.3).

Figure C.3: Email Payslips dialog box

2. Choose the pay period that you want then click OK. This
opens the Payslip Messages dialog box (�gure C.4).

3. Click on Send to open the Message Range dialog box
(�gure C.5).

4. Use the Message Range dialog box to send the current
message, all messages or a range of them. On comple-
tion, a message box showing the number of messages sent
will be displayed.

5. Close the Payslip Messages dialog box when you are
through.
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Figure C.4: Payslip Messages dialog box

Figure C.5: Message Range dialog box

Details of the last mail session are saved in the log �le email.log
located in the payroll data folder. Refer to this �le if you have
any di�culty sending messages and to see which messages were
actually sent.

How to Open Payslips

Once a payslip is sent, the recipient will need one of the fol-
lowing passwords to open it.

1. Owner Password: This password is set in the General
Options dialog box (Organisation > Options > General).
Use it to open any payslips you send out.

2. User Password: This is usually the last four digits of the
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employee's PIN. Where the employee's PIN is missing,
it defaults to the value set in the General Options dialog
box. This is the password that employees should use.

You can modify the message that is sent to employees to in-
clude help on the password they will use to open the payslip.

1. Go to Procedure > Email Payslips to open the Email
Payslips dialog box.

2. Click on Options to open the Electronic Payslip Options
dialog box (�gure C.6).

Figure C.6: Electronic Payslip Options dialog box

3. Check the option Include password help.

4. Close the Electronic Payslip Options dialog box.

5. Close the Email Payslips dialog box.
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Appendix D Formulae

Loans

Amortisation

The loan payment amount is uniform throughout the repay-
ment period. The portion of the payment amount that goes
towards repaying the principal increases with time as interest
payments reduce.

Payment =
W[

1− (1 + r)−n

r

]

where W = principal amount, n = total number of payments,
r = monthly interest rate (e.g. if annual interest rate is 15%,
r = (15/100)/12 = 0.0125).

Reducing Balance

The amount paid towards the principal is �xed throughout the
loan duration while interest payments reduce with time. Thus
the total payment amount reduces with time.

Payment = W ′
(
1

n′ + r
)

where W ′ = outstanding balance, n′ = number of payments
outstanding, r = monthly interest rate.
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