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1 Introduction

About Aren Register

Getting Started

Aren Register is an extension of the traditional payroll system
to include some features normally found in HR software. It
runs in the Microsoft Windows environment.

Aren Register lets you specify the posts available in your or-
ganisation and then assign existing employees to these posts.
As new employees join they are assigned to the posts you have
specified. Employees are retained in the system until they
leave the organisation. Reports on current and former em-
ployees are provided.

The system will help you to keep track of annual leave days
earned and taken by employees. You will also be able to record
all absence from work. Annual reports on leave and absence
are available.

Aren Register makes it easy to process employee pay. It en-
ables you to specify all payments and deductions that apply
to each employee. Several reports are derived from this data,
including payslips, payroll summary, payroll control account,
monthly and annual returns for PAYE as well as monthly re-
turns to NHIF, NSSF and user-defined co-operatives and pen-
sion funds.

Access to the system requires a username and a password.
There is one permanent user who has unrestricted access to
the entire system. Other users can be added at any time and
assigned access to those functions they need to use.

A single installation of Aren Register will support multiple
organisations though a separate licence key is required for each
of them. A comprehensive backup system is also provided.

To use Aren Register you need to install it and configure it
to suit your needs. The rest of this section shows you how to
begin this process.
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Installation

To install Aren Register:

1. Download the installation file reg90std.msi from the down-
loads page of our website:
https://www.aren.co.ke/payroll/download90.htm.

2. Double-click on the installation file to begin the instal-
lation process.

+2 Aren Register 5.0 Standard Edition - O *

Walcome to the Aren Register 9.0 Standard |
Edition Setup Wizard

Thea inztallar wall guide pou theough the sheps iequired bo inskal Aren Registar 9.0 Standard E dition on
wour camplies

WARNING: Thiz compubes program it protectad by coppight law and inbemational beaties
Urnauthonzed duplicaton or disiibubion of this program, or ary portion of ik, may result in sevane civil
or cimnal penakes, and vl be prosecuted fo the maamum extent possible under the law,

==
Figure 1.1: Setup Wizard

3. Follow the on-screen instructions that appear during the
installation process (figure [L.1).

The installation process copies the files required by Aren Reg-
ister to the folder you specify on the hard disk of your com-
puter. It will also create a desktop icon for Aren Register.

Creating a Data Folder

1. Once the installation process is complete, start Aren
Register using the desktop icon created above.

2. In the Start dialog box that appears (figure , click on
Data Folder to open the Data Folders dialog box (figure

13).

3. Click on Create in the Data Folders dialog to create a
new data folder in which to store Aren Register data.


https://www.aren.co.ke/payroll/download90.htm

Getting Started

Logging In

Version 5.0
Standard Bdtion for Kerya
& Aren Sofiware Lid. 1958-2023

[None]

Login... Cancel | Data Folder.. |

Figure 1.2: Start dialog box

—Avalable Folders

Create... Select... I Saltings. .. REmwve

Target Folder

Figure 1.3: Data Folders dialog box

The data folder must be located on the computer running
Aren Register, not on a network drive.

Make sure you have unrestricted access to whichever lo-
cation you choose, otherwise the software may not work

properly.

. Close the Data Folders dialog to return to the Start di-

alog.

. Within the Start dialog, click on Login to open the Login

dialog box.

. In the Login dialog box enter the username supervisor

(figure [1.4)).
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Lagin x

Usemame |Supenvisar

0K | Cancel | belp |

Figure 1.4: Login dialog box

3. You will be prompted to enter a password for use in
subsequent logins (figure [L.5). Enter a password of your
choice.

Set Password x

Corfim [ Cancel
Papsward —

Figure 1.5: Set Password dialog box

4. A message box (figure will then appear asking if you
would like to copy sample data. Choose No to proceed
to set up your organisation.

firen Register

9' Would you like to copy sample daks ta this data folder?

Figure 1.6: Sample data message box

5. The New Organisation dialog box is displayed next (fig-
ure [1.7). Type in the name of your organisation and the
month from which you want to start entering data.

6. Close the New Organisation dialog box to begin using
Aren Register.
Moving On

Before entering employee data you need to finish setting up
the program. Section [2] explains how to do this. To enter
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5
Hew Organisation x
Mame |_‘I|:rn Restaurart Lid oK
Cancel

Morth |J-un.|.:r,' ﬂ

Year [2024

Lecal Cumency |'::.':":m Shiling

Payrall Cumency |':IL"":|'G Shiling

Figure 1.7: New Organisation dialog box

employee data refer to Section [3| which describes the employee
data tables in Aren Register.

After entering employee data you can view the reports de-
scribed in Section With the exception of the muster roll
and payroll variance, all reports can be printed out on A4 pa-
per. Use the muster roll to export payroll data to an XML file
in Microsoft Excel format.

To close the current data entry period and start a new one,
run the month end procedure as described in Section |5 That
section also describes how to back up and restore data and
create bank transfer files.
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Before entering details about employees, use the Organisation
and System menus to configure the program. The Organi-
sation menu options apply only to the organisation that you
are currently working with whereas those of the System menu
apply to all organisations that you define.

Setting up the System

Users

Aren Register supports an unlimited number of users. There
is always at least one user, supervisor. The supervisor has ac-
cess to all functions including adding and deleting other users
and assigning such users access to program functions. By re-
stricting users to only those parts of the program they need
for their work, it is possible to enforce separation of duties.

If you wish to add new users at this stage, do the following:

1. Select Users from the System Menu. This displays the
Users dialog box (figure [2.1]).

Users X

Password, .,

il

Claze

Figure 2.1: Users dialog box

2. Click on the Add button which brings up the User Iden-
tity dialog box (figure [2.2).
3. In the User Identity dialog enter the username. You may

also enter the user’s real name to help you identify him
or her in future.
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User Identity ®

Lis=rmame aEneEs

Last Mamea L

Other Mames |-"§l"'f‘L
QK I Caniel |

Figure 2.2: User Identity dialog box

4. Close the User Identity dialog and choose Rights from
the Users dialog box. This displays the User Rights di-

alog box (figure [2.3).

User Rights for agnes x

Menu
* Full menu

" Persarnd anly Cancel

0K

™ Payrol anly

Functions
¥ Edt employes data fies
¥ Modiy payml fidds
¥ Sef up apen organisation
v Close pay perad or mortth
[ Restore files
[ Add and delets angarisatons
¥ Modfy tax tables

Figure 2.3: User Rights dialog box

5. Use this dialog box to select which menu the user should
see: full menu, personnel only or payroll only. Also spec-
ify the functions within the selected menu that you would
like the user to have access to.

6. Close the User Rights dialog box and choose Password
from the Users dialog box. This brings up the Set Pass-

word dialog box (figure [2.4).

7. Enter and confirm the password if you wish. If you do
not enter a password at this stage, the user will be re-
quired to enter one when logging in for the first time.

8. Close the Set Password dialog box. You can add more
users by repeating the procedure above.
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Banks

9
Set Password for agnes *
Passward | OK
Corfim  [oees Cancel
Papsward —_—

Figure 2.4: Set Password dialog box

9. Click on Close in the Users dialog box.

Aren Register comes with a comprehensive list of banks and
their branches. You will need this list for employees paid by
bank transfer rather than in cash or by cheque. The list is
shared by all organisations that you create. To review or mod-
ify it, select Banks from the System menu which will bring up

the Bank and Branches dialog box (figure .

Banks and Branches »
"
+ Arican Banking Corp Add Bank
+ Bank of fnca
+ Bank of Baroda Add Brarch,
+ Bank of India
« Cobank NA [elete
+ Conachdated Bank
+ Coopemtive Bank Properties...
# Credr Bark
+ Development Bank Clse |
# Dsamond Trust
+ DIB Bank
# Ecobank
# Equity Bank
# Famiy Bank
# Faulu Microfinance
+ First Community Bank
# GTBank v

Figure 2.5: Banks and Branches dialog box

Statutory Deductions Parameters

PAYE and NHIF are calculated using brackets and rates that
are stored as tables. To view and update these tables select
Income Tax > PAYE Rates or NHIF Rates from the System
menu (figure . Refer to the Kenya Revenue Authority
(KRA) website for an up-to-date PAYE table.

The calculation of PAYE depends on a number of other pa-
rameters e.g. personal relief, insurance relief and allowable
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PAYE Rates for 2024 *
Lower Limit [ Lipper Limi [ Tax Rate (%)
i 24000 10,00
24001 32333 25.00
323 500000 .00 Dielete
500001 500000 32.50
BODON - None - 3500 Edt

]
]
s

Figure 2.6: PAYE Rates dialog box

pension fund contribution. Update these parameters by se-
lecting System > Income Tax > Other Parameters to open
the Income Tax Parameters dialog box (figure . This dia-
log also allows you to edit the parameters used for calculating
fringe benefit tax.

Inconne Tae Paramieters far 2034 b
Ahel Seconda y Exployees
TS 4 Tax Rabe {%H) Iﬁ Il
Mz im nm&n& 00 » - Cancel
Fringe Benefik Tax
*awimum Alowable Deducsons Market Tnitereat Rate (S4):
Person Fund 20000 January to March m
H"‘;;_‘:‘:‘;’:_";Lp [ aprl o June | 2.0
alwahic Dwnor Doapier ntorest by tn September A
Oefobeer o December | .00

Jaraaary bo Hovemier 2500
Checieamiecy 15000 Comporabon Tax Rate (%) 3000

Tax Exemphon

Disability ExempZon 150030
Figure 2.7: PAYE Parameters dialog box

NSSF contributions are a percentage of pensionable pay and
are divided into two tiers. To enter this percentage and the
pensionable pay limits for each tier, select NSSE' Rates from
the System menu. This opens the NSSF Rates dialog box
(figure where you can also edit the maximum voluntary
contribution.
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MSSF Rate for 2024 x
Mandatory Cantributian
Percentage of Pensonable Pay:
Employes G.00 i |
Emalaver G6.00
Pensionable Pay Limits;
Tier 1 EODO
Teer 11 1E000

Woluntary Contribution

Lipper Limit 600

Figure 2.8: NSSF Rates dialog box

The payroll supports SHIFfY] which is set to replace NHIF as
the mandatory health insurance deduction. The parameters
for calculating SHIF can be edited by selecting System > SHIF
Parameters to open the SHIF Parameters dialog box (figure

29

SHIF Pararmeters for 2024 X
Employes Contribution
Percentage of Gross Salary: [ 275

Lower Limil: | 300,00
e Cancel
Figure 2.9: SHIF Parameters dialog box

Finally, to change the settings for housing and NITA levies,
open the Statutory Levy Parameters dialog box (figure [2.10))
by selecting System > Levy Parameters.

Adding a new Organisation

To add a new organisation select Add from the Organisation
menu. Use the New Organisation dialog box that follows (fig-
ure to enter the name of the organisation and the month
from which you want to start entering data. On closing the
dialog box, the previous organisation is closed and the new
one opened.

1 Social Health Insurance Fund



12 2 Setting Up

Statutory Levy Parameters for 2024 x

Housng Levy oK |
= all < ropey
Percentage of Gross Salary: Canosl

Emplayes 1.50
Evgloyer | L.50

NITA Levy
Monthly Amount 50,00

Figure 2.10: Statutory Levy Parameters dialog box

Hew Organisation e
Mame |:'ﬂ'h'.- Campary Lid OK
Cance=l

Momth |J-=|n.|ar,' j

Year [2024

Leed Cumerncy |'irr:.'a Shilng

Payrall Cumeney |'§€-‘"5‘EI Shiling

Figure 2.11: New Organisation dialog box

Opening another Organisation

To open a different organisation select Open from the Organ-
isation menu. This will bring up the Open Organisation di-
alog box (figure provided there are other organisations
defined. Select the organisation you want to open from the
dialog box.

Deleting an Organisation

You can delete any organisation that is currently not open.
Deleting an organisation causes all its data files and folders to
be deleted. It is strongly recommended that you back up the
organisation’s database file before deleting it (see Section [f]).

To delete an organisation:

1. Select Delete from the Organisation menu. To minimise
the risk of accidentally deleting an organisation you will



Setting up the System 13

OK Cancel
| I

Figure 2.12: Open Organisation dialog box

be required to enter your password (figure [2.13]).

Deleting an anganaation wil cause al ks data
fies i be delsted . You are strongly advised to
! back up thess files before continung,

i you are suns you want fo conbinue, please
erfler your password below.

Pamword [~
ok | cwed | e |

Figure 2.13: First Delete Organisation dialog box

2. Next, a list of all organisations in the system, exclud-
ing the one that is open, will be displayed (figure .
Select the one you want to delete. Note that it is not pos-
sible to delete the organisation that is currently open.

OK Cancel
| |

Figure 2.14: Second Delete Organisation dialog box
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3. In the two message boxes that follow, confirm that you
want to delete the selected organisation and destroy its
data files.

4. Aren Register will then delete the organisation. A dia-
log box confirming that the deletion is complete will be
displayed.

Setting up an Organisation

To configure the organisation that is currently open, proceed
as follows:

Basic Organisation Information

Open the Basic Organisation Info dialog box (figure[2.15)) from
the Organisation menu and enter the organisation’s address
and telephone number.

Basic Organization Info x

Mame | Demo Restaurant Lid
Stabus: Mot icens=d

Folder: :\Payroll Data‘\Rega05tdiorgol

Fonth | Jerwary - Year ..-JJ.-L"I
Address
P.C. Box | 3638 Town | Hairchi
Paost Cade | Q0100 Teleshons | S00400

Figure 2.15: Basic Organisation Info dialog box

Also, confirm that you want to start entering payroll and leave
details in the month and year shown in the dialog box. Once
you run the first month end procedure you will not be able to
edit either of them.

Licensing

Select Licence from the Organisation menu to open the Licence
dialog box (figure 2.16). Type in the licence key supplied by
your dealer. If you do not have a licence key, contact your
dealer or Aren Software Ltd.
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Payroll Info

Licence X
Licence Mumber: |3044-3034

| ok | cacd | Heo |

Figure 2.16: Licence dialog box

Open the Payroll Info dialog box (figure by selecting
Payroll Info from the Organisation menu. Enter the bank,
branch and account number for the organisation’s salary ac-
count. Also enter the organisation’s PIN, NSSF, NHIF, SHIF
and HELB? numbers.

Payroll Infa x
10 Numbers
PIN [AzSO10ZIA oK I
MSSF Mo, [23saziozz Cancel |
NHIF Mo, [ 2350660195
siFme [ 0
HELB Mo. [12385
Currendes

Lacal Currency | Kenya Shiling

Payral Currency | Kerya Shiling

Earking

Bank |Standard Chartered Bark |

Branch |Harambee Ave |

Account Ma. | 01013325

Sender I | 22551

Figure 2.17: Payroll Info dialog box

In this dialog box, the Standard File Interchange (SFI) Sender
ID applies to those who submit their payroll to the bank in

electronic form. Leave this field blank if you do not already
have an SFI Sender ID.

2 Higher Education Loans Board
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Grades

Jobs

Administrative Units

Posts

Aren Register assumes that all jobs that employees may be
assigned to are graded or ranked. To set up the grades for
your organisation select Grade from the Organisation menu.

The Grades dialog box that follows (figure [2.18)) allows you to
specify the name, rank and salary range for each grade.

Grades x

durpor Staff
Meanager
Professional Stafl
Senior Staf Dislete
Propeiies...

Closa

Figure 2.18: Grades dialog box

If your organisation has no grades, create only one grade called
(None) and enter a salary range that will cater for all employ-
ees.

To set up the jobs available in the organisation, open the Jobs
dialog box by selecting Jobs from the Organisation menu. For
each job you must enter the name of the job and its grade.
You may also enter a brief description of the job for future
reference.

Set up the administrative units (departments, sections, etc) in
your organisation. To do this select Units from the Organisa-
tion menu.

A post is a job that is attached to a specific administrative
unit. Aren Register does not accept new employees unless
there are vacant posts available.

In order to create posts you must create grades, jobs and ad-
ministrative units first. To add posts select Posts from the
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Stations

Pay Groups

Organisation menu which opens the Posts dialog box (figure
2.19). For each administrative unit and job you will need to
specify how many permanent, contract, temporary and casual
posts to allow.

Posts b4

Administrative Unts: Poats in Accounts
_m Accountant (2
Housekeeping Ed
Kitchean
Ianagament
Securty
Service

Figure 2.19: Posts dialog box

Set up the stations (branches) in your organisation. To do this
select Stations from the Organisation menu.

Pay Groups allow you to filter payment reports according to
how employees in your organisation are paid. For example,
the bank transfer report could be filtered by bank branch or
pay date.

To set up pay groups, select Pay Groups from the Organisation
menu.

Co-operatives and Pension Funds

Insurance Companies

Create co-operative societies that employees in the organisa-
tion belong to by selecting Co-operatives from the Organisa-
tion menu.

Similarly, set up pension funds by selecting Pension Funds
from the Organisation menu.

If you need to deduct and remit insurance premiums, set up
the insurance companies involved by selecting Organisation >
Insurance Companies.
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Employee Profiles

General Options

An employee profile defines attributes that are common to a
group of employees. These attributes are leave entitlement,
pay frequency, basic pay type (i.e., salary, daily rate or hourly
rate), standard working hours (per day and per month) and
whether overtime is payable.

To create a profile, select Profiles from the Organisation menu
to open the Employee Profiles dialog box (figure 2.20). If there
is an employee profile marked as default, all new employees
added to the payroll will be assigned this profile.

Ernpleyee Prafiles x
Sttt Add
Diglete
Properties...
ol

Figure 2.20: Profiles dialog box

Selecting Options > General from the Organisation menu opens
the General Options dialog box (figure 2.21]). This dialog box
allows you to choose the sort order for employee data entry
forms. It also allows you to activate the Open Table dialog
box used for filtering form data by administrative unit, sta-
tion or pay group.

You can also specify when to purge old reports. Deleting old
reports saves space on the hard disk and reduces the size of
backup files.

In the PDF documents section you can edit the following pass-
words.

1. Owner Password: This password allows you to open any
PDF documents that you send by email. It should not
be disclosed to employees.

2. Default User Password: Employees use the user pass-
word to open PDF documents sent to them. It is usually
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Payroll Options

Diata Entry Forms
Sark By:
{* Employes Mumber

™ Last pame
[ show Open Table dialog box

[ o |

Canesl

Help

—Past Reports
Purpe IﬂH'|_5 years

PDF Douments

Owireer Pasgword

Immu'
Defaull Ussr Passeaord Iusl:r

Figure 2.21: General Options dialog box

set to the last four digits of the employee’s PIN. Where
the PIN is missing, the default value you enter here is

used instead.

Selecting Options > Payroll from the Organisation menu brings
up the Payroll Options dialog box (figure [2.22]).

Taxable Pay

[T Tax excess emplayer persion on employes
[ Ignore benefits uniess total exceeds Ksh 3,000

PAYE

T Deduct exact amount
% Round down to nearest Ksh
" Round up o nearest Ksh

[ allow negative amount

Hausing Levy

I Deduct housing levy
™ Deduct exact amount
* Reund ta nearest Keh

MITA Levy
[ Pay NITA Levy

NHIF

Caloulate NHIF on:

¥ Gross pay (recommended)
™ Salary er basic pay

I~ Alow inzurance refief

™ Deduct SHIF instead

Tier II NGSF

% Deduct from al

" Don't deduct, opted out for all

" Deduct salactively, opted out for some

HNet Pay

Far employes paid in cash:
(¥ Pay exact smount
™ Round down to nearest Ksh

[ |

Figure 2.22: Payroll Options dialog box
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Taxable Pay

PAYE

Housing Levy

NITA Levy

NHIF

If your organisation is tax-exempt you are required to treat the
employer’s pension contribution as a taxable benefit. Select
the option to tax excess employer pension on employees.

KRA’s online tax administration system, iTax, does not tax
benefits unless they total to more than Ksh 3,000. By default,
Aren Payroll taxes all non-cash benefits regardless of their
total. For it to work like iTax you must check the option
Ignore benefits unless total exceeds Ksh 3,000.

By default, PAYE is rounded down to the nearest shilling. To
match the iTax system, you should select the option to deduct
the exact amount of PAYE.

For employees who are paid more than once a month, it is
possible though unlikely for the PAYE amount for a particular
pay period to be negative. To avoid this, uncheck the option
to allow negative PAYE.

If you would like to turn off housing levy for the whole organi-
sation, uncheck the option to deduct housing levy. By default,
housing levy is rounded to the nearest shilling. To match the
iTax system, select the option to deduct the exact amount of
housing levy.

If your organisation pays NITA Levy for its employees, check
the option Pay NITA Levy. An annual report showing the
amount payable for each employee will be generated.

You can choose to have NHIF calculated on the fixed monthly
salary or on the gross pay earned in a given month. The former
option is included for backward compatibility and you should
always compute NHIF on gross pay.

NHIF contributions qualify for insurance relief starting Jan-
uary 2022, hence the option Allow insurance relief should be

checked. When it is checked 15% of the NHIF contribution is
deducted from PAYE as insurance relief.
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NSSF

Net Pay

Logos

Once SHIF deductions replace NHIF, remember to check the
option Deduct SHIF instead.

If your organisation has opted out of Tier IT NSSF contribu-
tions, select whether to deduct Tier IT NSSF selectively or not
all.

Finally, you have the option to round down net pay for em-
ployees paid in cash by an amount that you specify. The excess
amount is carried forward to the next month.

Selecting Options > Logos from the Organisation menu brings
up the Logos dialog box (figure . This dialog box allows
you to select image files with the organisation’s logo for use
in payslips. These files must be in the images|logos folder
located within the organisation folder.

Loges »

Printed Doouments

Remawe

Email Attachments
=T

HEmdWe

0K | Cancel Help

Figure 2.23: Logos dialog box

For printed payslips you can select a PNG or JPEG file. PNG
images are typically sharper than JPEG ones but they occupy
more space.

Select a JPEG file for payslips that are sent as email attach-
ments in PDF format. Attachments are restricted to 64 KB
so the logo file must be well below that size.
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Personnel Table

Data for each employee is stored in four data tables—personnel,
payroll master, payroll transactions and absence and leave.
This data is used to create various personnel and payroll report
tables which are then used for report generation.

The personnel table stores personal information about each
employee, for example name, national ID number, date of birth
and nationality. It also stores information about employees’
jobs such as job title, grade, administrative unit, station and
leave entitlement.

Employees can only be added and removed from the system
through the personnel table. The employees in this table au-
tomatically appear in the payroll master, payroll transactions
and absence and leave tables.

The personnel table is accessed by selecting Personnel from
the File menu. This brings up a data entry form in which you

enter data for each employee (figure [3.1)).

Persanemd Tahli

Heoore T od 45 O Mzega, Slephien Uhenaes

Parznnal

Emgl . Last Maree | Asoca Titie | Kr =]
Cordasd

[ ————
Fambe Other Names | Stephen Uhenzern

B= Gencer [beaie - 10 b, [2355E04

it e [ 5 awg 157 - sacmport o, |
Hirial o (Famisd il | "Wark Poreik Mo
Hatanaity [Kevyan =]

Figure 3.1: Personnel Table form

Most of the fields in the table are optional. However, Em-
ployee Number, Last Name, Other Names, Post and Station
are mandatory. The optional fields are used in various reports
and should therefore not be left blank.
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Adding and Deleting Employees

Employee records are added and removed from the personnel
table using the Add, Delete and Terminate commands in the
Record menu.

Deleting an employee record is only possible if no month end
procedure has been run since it was added. After deleting
a record, no report will retain information relating to that
employee. This option is provided to allow records added by
mistake to be expunged.

Terminating an employee will cause his record to be removed
from the personnel table in due course. However, various per-
sonnel and payroll reports will retain details of that employee
for future reference. Section [5| describes the termination pro-
cess in detail.

Payroll Master Table

Both the payroll master and payroll transaction tables store
payroll information about each employee. The former main-
tains information that tends to remain the same over time
while the latter maintains information for a single pay period
and this tends to change more frequently.

The data in the payroll master table includes pay frequency,
basic pay, bank account number, PIN, co-operative member-
ship and housing status.

To open the payroll master table, select Payroll Master from
the File menu. This brings up the Payroll Master Table data

entry form (figure [3.2)).

Payroll Transactions Table

The payroll transactions table stores earnings, deductions, ben-
efits, lump sum payments and refunds for each employee for
the current month.

FEarnings (or monthly cash earnings) are those cash payments
that relate to the current month e.g. basic pay or leave al-
lowance.

Benefits refers to private expenditure of an employee paid by
the employer e.g. school fees, house rent or telephone bills.
These non-cash benefits are considered as income for tax pur-
poses.
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Payrall Macter Table
Record 1 of 45 001 Asega. Stephen Lihenzern

[ Fayment

— Pay Freguency | Monthly

Crvertime

Housing Payment Mode lm
PAYE Pay Group |- None - -]
NS5F & NHIF

Co-operatives Zank | Absa Bark

Persion Funda

Other

Brandh | Fale Selasmis

Acpount Mg, | 0825892301

Figure 3.2: Payroll Master Table form

Deductions are those amounts deducted from an employee’s
cash earnings by the employer. Some of these are called statu-
tory deductions because the law requires the employer to deduct
them from the employee’s pay. The statutory deductions are
PAYE, NSSF, NHIF, housing levy and tax on lump sum pay-
ments.

Lump sum payments are those cash payments that do not
relate to the current month alone. Some like gratuity and
bonuses have accrued over past months while others like ter-
minal benefits may relate to past or future months. We make
the distinction between lump sum payments and monthly cash
earnings because the two are treated differently when calcu-
lating income tax.

Refunds are payments made to an employee, e.g. travelling or
subsistence allowances, for business expenses incurred while
on duty. These payments are not income and are therefore
not taxable.

The payroll transactions table is accessed by selecting Pay-
roll Transactions from the File menu. This displays a data
entry form (figure where you enter earnings, deductions,
benefits, lump sum payments and refunds for each employee.

Statutory deductions and other calculated amounts such as
taxable pay, net pay and gross pay are updated as data is
entered. This makes the calculations more transparent and
helps to reduce data entry errors.
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Payroll Fields

Payroll Transactsons Table

Record 1 of 45 001 Asega. Stephen Lihenzero
[Eamings
Deductions Basic Pay [ [ J
Benefita Crvertime |

Lump Sum Payments
Refunds

House Allowance [

Srabutary Deductions
Summary

Taxabla Pay

74, 750.00

Figure 3.3: Payroll Transactions Table form

You can suspend employees from the payroll by deleting them
from the payroll transactions table (Record > Remove). To
restore a suspended employee use the Record > Add command.

At installation, each payroll transactions table has two earn-
ings (Basic Pay and Overtime), three deductions (Rent, Over-
draft Recovery and Rounding C/F), one non-cash benefit (Em-
ployer Pension) and one refund (Rounding B/F). These fields
cannot be deleted but you can add more according to your
needs.

To add, delete or edit fields, select Earnings, Deductions, Ben-
efits, Lump Sum Payments or Refunds from the File menu. A
data entry form will be displayed showing the field attributes
listed below (figure [3.4). To add or delete fields select Add or
Delete from the Field menu.

The following field attributes apply to all fields:

1. Field Name: The name of the field e.g. advance, shift
allowance.

2. Type: This is used to indicate permanent fields (e.g. ba-
sic pay and rent). It is also used to specify fields that
are calculated in a unique way (e.g. hourly pay and
daily pay) and those that are associated with a balance
that is updated and displayed by the system (e.g. loan
repayments and co-operative contributions). The type
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Deduchions

Feld 3 of 11

Field Hame | Savers Pension

Type Penson Contnbuton - | Farameters...
Amount .P.-frrr"..-v;r of Salary - | Percentage...

¥ Pre-tax deduction

Figure 3.4: Deductions form

advance is used to indicate advance payments so that
appropriate reports can be generated.

. Amount: This attribute specifies how the amount paid

to or deducted from each employee is arrived at. It may
be keyed in, a percentage of salary, a function of the time
worked (basic pay, overtime, hourly pay and daily pay)
or amortised (loan repayments).

. Static: Static fields retain their value when the month

end procedure is run, whereas non-static fields are reset
to their lower limit. This is only important for fields that
are keyed in. It saves you the trouble of having to key
in the amount earned or deducted each time the month
end procedure is run.

. Tazable/Pre-tax deduction: For earnings the taxable at-

tribute specifies whether or not the payment is subject
to PAYE. Unless prior permission has been given by the
KRA, all income (i.e. earnings, non-cash benefits and
lump sum payments) must be taxed. Refunds are not
taxable as they are not a form of income.

The pre-tax deduction attribute indicates those deduc-
tions to be subtracted from gross income when calcu-
lating PAYE. In Kenya the only pre-tax deductions are
mortgage interest payments, contributions to registered
pension /provident funds and contributions that qualify
for affordable housing relief.

. Pensionable: NSSF is calculated on the total pension-

able earnings. Uncheck the pensionable option to ex-
clude any earning from this calculation.

. Regular: Housing levy is calculated on basic pay plus all
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regular allowances. Any earnings not marked as regular
are not subjected to housing levy.

Depending on the selection for Type and Amount attributes
the following additional attributes may be available:

1. Co-operative: The name of the co-operative associated
with the field (figure [3.5).

Co-operative »

Name A

Figure 3.5: Co-operative dialog box

2. Pension Fund: The name of the pension fund and other
details pertaining to the current field (figure [3.6).

Pension Fund Parameters b
MName: | Savers = OK
Carcel

Employers Contnbution

|Peorcontage of Salay = |
Percartage | 1000
[ Aoply Limis

Lower Limi {
Upperlimt [ 0

Figure 3.6: Pension Fund Parameters dialog box

3. Insurance: The name of the insurance company associ-
ated with the field.

4. Limits: The upper and lower limits that the amount
paid or deducted should be restricted to (figure [3.7).

5. Percentage: The percentage of monthly salary that should
be paid or deducted (figure [3.8)).

6. Hourly Rate: The hourly rate to use for earnings that
are of the type Hourly Pay (figure [3.9).

7. Daily Rate: The daily rate to use for earnings that are
of the type Daily Pay.
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Limits b
Lawer Limit ]
Upper Limi 20000
[ ox | Cancel |

Figure 3.7: Limits dialog box

Percentage of Salary x

Percentage | 00 DK

Cancel
W Apply Limis

Lpraver Lt | i

Upper Limit 20000

Figure 3.8: Percentage of Salary dialog box

Haurly Rate »

% Baskc Pay Ratex| 050

7 Hey in rabe far 2ach emplayee

T Concd |

Figure 3.9: Hourly Rate dialog box

Absence and Leave Table

The absence and leave table stores details about employees’
absence from work in the current year. This information is
expressed in terms of absence event records.

In addition, the table keeps an account of annual leave earned
and used up by each employee during the year. It uses leave
event records to track the leave days brought forward from the
previous year and leave days earned, sold and forfeited since
then. Leave taken is treated as an absence event.

The absence and leave table can also be used to track employ-
ees’ leave bookings.

To edit this table select Absence and Leave from the File menu
(figure[3.10). The Absence and Leave window has three pages,
i.e., Absence, Annual Leave and Leave Bookings. To edit or
delete an event in any page, first select it and then click on
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the Edit or Delete button. To add a new event, switch to the
appropriate page and then click on Add.

Absence and Leave Table

Recond 1 of 45 001 Asega, Stephen Lihenzer
Wiew |F'.I:~9=n:|: ﬂ
Fram Ta Curation | Type
5 May 2021 T May 201 .00 Sick Leawe
20 5ep 2021 24 5ep 2021 500 Aorual Leave

o

Figure 3.10: Absence and Leave window

If you do not wish to track absence and leave for a particular
employee, you can remove them from the absence and leave
table. Open the Personnel Table form and select the Employ-
ment tab. Uncheck the option to track abscence and leave.
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Aren Register produces several personnel and payroll reports
as described below. These reports can be viewed on the screen
and printed out. You can choose to print the entire report, a
range of pages, or just the page that you are currently viewing.
Internal reports can be sorted by either employee number or
name.

You can view and print reports for current as well as past
months and years. You can also filter most reports by ad-
ministrative unit, station, pay group, bank, co-operative or
pension fund.

Reports may be printed on any printer connected to your com-
puter either directly or through a local area network. Because
all reports are formatted for A4 paper, the printer must be set
to print on A4.

1. To open a report select it from the Report menu and then
follow the on-screen instructions. For example, selecting
Report > Payslips opens the Open Payslips dialog box

(figure [4.1).

Open Payslips b
Pay Penod _
O I
Year |2024 Canced
Maomth |,.a-u=r_. Il Neat > |

Oiptions

fi

Figure 4.1: Open Payslips dialog box

2. To print the open report select Print from the File menu
which brings up the Print dialog box (ﬁgure. Use the
Setup button in this dialog box to configure the printer
you want to use.
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Personnel Reports

Print X

Prirker:

HF Color Lasarlet MFP oK
M&TFdw (435382) on
WSD-2E500dET-1106-248-a 128

Cancel
Fages o pant:
ol :IS&VD
" Curenl Page
™ Pages
From: To:
Mumber of Copies: 1

Figure 4.2: Print dialog box

. Choose Close from the File menu to close the report.

. Posts By Type: List that shows the number of perma-

nent, contract, temporary and casual posts in each ad-
ministrative unit of the organisation.

. Posts By Status: List that shows the number of occu-

pied and vacant posts in each administrative unit of the
organisation.

. Employees Roll: List of employees who are currently ac-

tive. It shows their job title, administrative unit and
station.

. Joiners Roll: List of employees who joined the organi-

sation recently. It shows their job title, administrative
unit, station and start date.

. Leavers Roll: List of employees who left in a given year.

It shows their final job title and administrative unit, the
date they left and the reason for leaving.

. Employee Hierarchy Report: List of employees grouped

according to whom they report to. Employee names are
indented to show the reporting hierarchy. The report
also displays the job tile, administrative unit and station
for each employee.

. Length of Service Report: List of current employees show-

ing their job title, age and length of service.

. Employment Status: List of current employees showing
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10.

11.

12.

13.

14.

15.

16.

17.

their job title, start date, contract end date and employ-
ment status.

Emergency Contact Report: List showing each employee’s
next of kin, their relationship and the contact details.

Master Report: Report that shows the details of a single
employee as entered in the personnel and payroll mas-
ter tables. It is available for both current and former
employees.

Absence by Employee: List of actual and planned ab-
sences from work grouped by employee.

Absence by Date: List of actual and planned absences
from work in chronological order.

Absence Sheet: This report lists, for a single employee,
all absence from work in a given year.

Annual Leave Sheet: This report gives, for a single em-
ployee, a detailed account of leave earned and used up
in a given year.

Absence Analysis: List of employees that gives a sum-
mary of all absence from work for a specified year.

Leave Analysis: List of employees that gives a sum-
marised account of leave earned and used up in a given
year.

Leave Liability: List of employees showing their out-
standing annual leave days and the cash equivalent.

Reports on former employees, absence and leave cover a calen-
dar year. Reports for previous years can be viewed and printed
out, but they cannot be modified in any way. Before running
the month end for December make sure that you verify these
reports.

The remaining reports, i.e. those on posts and current em-
ployees, indicate the state of the organisation at the time of
printing.

Monthly Payroll Reports

The monthly payroll reports relate to a single month. Reports
for the current month are updated as you update the employee
data tables. Reports for previous months can be viewed and
printed out, but they cannot be modified in any way.
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Overview Reports

1. Payroll Summary: Summarises earnings and deductions
for all employees.

2. Payroll Control Account: T-account listing total earn-
ings, deductions and net pay for all employees in the
organisation.

3. Muster Roll: List of employees showing all earnings,
lump sum payments, refunds and deductions for the month.
Records in this report can be grouped by administrative
unit or station.

4. Payroll Variance: List of employees showing the differ-
ences in the payments and deductions made in any two
pay periods. It is essentially the difference between the
muster rolls for the two pay periods.

5. Gross Pay By Unit: List of administrative units showing
the staff count and total gross pay for each.

6. Gross Pay By Station: List of stations showing the staff
count and total gross pay for each.

The muster roll and payroll variance can be viewed on the
screen or saved to an XML file but they cannot be printed
out.

Detail Reports

1. Earning Report: List showing, for a particular earning,
how much each employee was paid.

2. Deduction Report: List showing, for a particular non-
statutory deduction, how much each employee was de-
ducted. Depending on the type of deduction selected, a
loan or HELB report may be printed instead.

3. Loan Report: List of employees repaying a specific co-
operative or company loan. It shows the opening and
closing balances and a breakdown of the repayment amount
into interest and principal components.

4. HELB Report: List showing the HELB Repayment Sched-
ule in the format previously used for filing returns to
HELB. HELB returns should be filed on their website
using the return file available under Procedure > HELB
Schedule.
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Payments to Employees

. Benefit Report: List showing, for a particular non-cash

benefit, how much each employee received.

. Lump Sum Report: List showing, for a particular lump

sum payment, how much each employee received.

. Refund Report: List showing, for a particular refund,

how much each employee received.

. Payslips: Slip giving a breakdown of the earnings and

deductions of each employee separately (figure[d.3). The
employer’s pension contribution and the pension fund
balance can be shown in the payslip if required. When
the balance is shown, it includes the employer’s portion
only if the option to print the employer contribution has
been selected.

#8 Ay Baginbsss - Duaras Sbaweant Lid - Pagabps] - a| S
hile Baqe Repoet Orgamisshor awhem Procedure Help
lsn| @] nla|S| 1le]viv] x| 2
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Payalip Payalip

L R | Ernphspee by 201
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2y Fenat oy 2054 Fay Pariod Ramwary 2004

Aujrmn, M el Fdamn Ll tlarea o ey

Curmascy E4 LUy L]
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Figure 4.3: Payslips

2. Cash List: List of employees paid in cash showing their

employee number, name, net pay or advance payment
and a cash analysis of the payment amount.

. Cheque List: List of employees paid by cheque showing

their employee number, name and net pay or advance
payment.

. Bank Transfer Report: List of employees who are paid

by bank transfer showing their name, ID number, bank,
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Statutory Returns

branch, account number and payment amount. The pay-
ment amount may be the net pay, an advance payment,
a bank loan repayment or a HOSP contribution.

. Coinage Summary Report: List showing the number of

coins and notes of each denomination that are required
for workers who are paid in cash. This information is
the same as the totals in the cash list but formatted so
that it can be used when withdrawing the cash from a
bank.

. PAYE Report: List of employees showing their PAYE

deductions. To generate the equivalent iTax return file,
go to Procedure > iTax Files > Employee Details.

. NSSF Report: List of employees showing NSSF number,

ID number and the combined employer and employee
tier I and tier II contributions. Voluntary contributions
are also shown.

The NSSF return file is available under the Procedure
menu (Procedure > NSSF return > Self Service). This
generates an XML file which should be opened with Mi-
crosoft Excel and saved again as an Excel file.

. NHIF Report: List of employees showing NHIF number,

ID number, date of birth and NHIF deduction.

To generate the NHIF return file, select Procedure >
NHIF Return. This saves an XML file that should be
converted into a Microsoft FExcel spreadsheet.

. SHIF Report: List of employees showing SHIF number,

ID number, date of birth and SHIF deduction.

. Housing Levy Report: List of employees showing PIN,

gross salary and housing levy payable.

. Lump Sums Tax Report: List showing tax payable on

lump sum payments for each employee.

. Fringe Benefit Tax Report: List showing tax payable on

the fringe benefit arising from company loans issued at
an interest rate below the KRA prescribed market in-
terest rate. The equivalent iTax return file is available
under Procedure > iTax Files > Fringe Benefit Tax.
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Other Returns

Annual Payroll Reports

. Co-operative Report: List of members of a particular co-

operative society showing membership number, monthly
contribution and any other payroll deductions to be paid
to that co-operative.

Pension Report: List of members of a particular pension
fund showing membership number and employer and em-
ployee contributions to that pension fund.

Insurance Company Return: List of employee premium
deductions to be paid to a particular insurance company.

Annual payroll reports relate to a calendar year and are avail-
able throughout the year. For the current year, the informa-
tion displayed relates to the months that have elapsed so far.
The reports are:

1.
2.

Payroll Control Account.
Muster Roll.

Annual Pay Sheet: A report that, for each employee,
gives a summary of payments, deductions and benefits
for a whole year.

P9A: KRA form titled Tax Deduction Card. Each P9A
gives a breakdown of the income of an employee for each
month of the year and shows the amount of tax deducted.

P10: KRA form titled Employer’s Covering Certificate.
It shows the tax deducted by the employer for each
month of the year.

P10A: KRA form titled Supporting List for End of Year
Certificate. 1t lists the annual income and total tax de-
ducted for each employee.

NITA Levy Report: List showing the NITA levy payable
for each employee in the payroll.

NSSF Statement: A report that shows the standard and
voluntary monthly contributions to NSSF for a single
employee for a calendar year.

NHIF Statement: A report that shows an employee’s
monthly NHIF deductions for a calendar year.
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The P9A, P10 and P10A have been approved by the KRA
(approval reference number CIT/1037/2/98/20).

Other Reports

1. Bank Codes: A listing of banks, bank branches and their
sort codes drawn from the bank data tables.

2. Audit Trail: List that shows the date and time of each
login, backup, month end procedure and any other major
event. It also shows the user responsible for each event.
This report is only available to the supervisor.

Report Tables

Almost all reports are printed from report tables, not directly
from the employee data tables. Briefly, the report tables are:

Active employees report table
Annual leavers report tables
Annual absence and leave report tables

Monthly payroll report tables

DA

Annual payroll report tables

Report tables are updated automatically by Aren Register.
Use the General Options dialog box (Organisation > Options
> General) to specify how long to keep these tables for.



5 Procedures

Backing Up

If any of your organisation database files is accidentally deleted
or corrupted you could lose all the data for that organisation.
Without an up-to-date backup you would be forced to key in
the data for the current month again. It is also likely that
you would be unable to recreate data for previous months and
years. It is therefore very important that you make regular
backups of your database files.

To back up the database file for the organisation that is cur-
rently open, select Back Up from the Procedure menu. You
will be prompted to specify the name and location of the
backup file to be created (figure [5.1).

A3 Backup W
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X 3
File marnes
Seveastype  Beckup Fles (*5bk]
# Hide Foldess Cance

Figure 5.1: Backup dialog box

The backup process copies all data relating to the organisation
to the backup file. Should you have set up more than one
organisation, you will need to back up each one separately.
Note that data that is shared by all organisations is not backed
up (e.g. list of banks and statutory deductions parameters).

When running the month end procedure you will be prompted
to back up. Though you can choose to proceed without doing
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so, it is recommended that you back up first. To encourage
regular back ups Aren Register prompts you to back up each
time you exit.

Restoring from Backup

In the event that an organisation database file is corrupted or
deleted, you will need to replace it from backup. You can also
use backup files to revert to an earlier month. This is especially
useful if you accidentally run the month end procedure.

To restore an organisation database file from backup, select
Restore from the Procedure menu then follow the on-screen

instructions (figure [5.2)).

Restare »

Resgtoring from backup wil replace al the data
for this argarisation with that retreved from the
backup fil=. You are encouraged to back up
lhe argarisaion befare sartinuing

e

i you ane surs you want io conbinue, please
erfler your password below

FPaspword

oK I Caneel Hel

Figure 5.2: Restore dialog box

Creating a Bank Transfer File

A bank transfer file is an electronic version of the bank transfer
report. It is used by banks to process payments for employees
paid by bank transfer in place of the printed bank transfer
report. Aren Register can create bank transfer files for numer-
ous banks e.g. Absa, Co-operative, Equity, KCB and Standard
Chartered.

1. To create a bank transfer file select Bank Transfer File
from the Procedure menu.

2. In the Bank Transfer File dialog box that appears (figure
, specify the format of the bank transfer file to create
and the name of the payment field (usually net pay).
Depending on the file format, you may be able to specify
the date you want the bank transfer effected.
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Figure 5.3: Save Bank Transfer File dialog box

3. On closing the Bank Transfer File dialog box, a standard
Save As dialog box will appear. Use this dialog to specify
the name and location of the file to be created.

For further details on bank transfer files please contact your
bank.

iTax files are text files containing tax details for employees in
the payroll. These files help you to fill out the iTax spreadsheet
(P10_ Return.zlsm) that is used for filing tax returns on the
KRA website.

Four formats are available—Employee Details, Disabled Em-
ployee Details, Fringe Benefit Tax Details and Housing Levy
Details. Data exported in these formats should be imported
into the corresponding tabs of the iTax spreadsheet.

1. To save the Employee Details file, select iTax File >
Employee Details from the Procedure menu.

2. In the Save Employee Details File dialog that is displayed
(figure [5.4), select the month and year you want.

3. By default only employees who have paid PAYE in the
selected month will be included in the file. If you wish
to include those with zero PAYE as well, click on Next
and select the option Include all employees.

4. On closing the Save iTax Employee Details File dialog
box, a standard Save As box will appear. Use this dialog
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Figure 5.4: Save iTax Employee Details File dialog box

to specify the name and location of the file to be created.

Files in any of the other formats can be created in the same

manner. For further assistance with iTax please contact the
KRA.

Terminating an Employee

To terminate an employee, open the personnel table and dis-
play the target employee. Next, select Terminate from the
Record menu. In the Terminate dialog box that appears (fig-
ure , enter the termination date, the reason for leaving
and, if you like, some brief comments.

Terrminate Aseqa, Stephen Likenzero o
3012024 - ol
Reason far Leaving
.Fengrled d
Remarks

Figure 5.5: Terminate dialog box

The terminated employee will be removed from the employee
data tables in the next month end procedure that is later than
or on the same day as his termination date. Once the employee
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is deleted from the employee data tables his record will be
added to the leavers report table.

Termination can be reversed by selecting Record > Undo Ter-
mination as long as the terminated employee has not been
removed from the employee data tables.

Closing the Month

The month end procedure is used to close data entry for the
current month and begin a new one. It applies only to the
organisation that is currently open. It does the following:

1.

Saves payroll information for the current month to the
monthly and annual payroll report tables.

Deletes the current payroll transactions table and creates
a new one for the coming month.

Advances the date by one month.

. If the new month is January, it creates statutory deduc-

tion tables for the new year, deletes the existing absence
and leave table and creates a new one for the new year.
The leave balance from the previous year is brought for-
ward.

. Adds leave earned in the new month to the absence and

leave table.

. Transfers terminated employees from the personnel table

to the leavers report table.

Deletes any report tables that have exceeded the maxi-
mum age set in the General Options dialog box.

Note that in December the month end procedure cannot be
run if there are outstanding leave bookings for the year that
is ending.

To run the procedure:

1.

Select Month End from the Procedure menu. This op-
tion is only available if you have licensed the organisa-
tion.

. After reading the dialog box that appears (figure ,

confirm that you want to close the month by entering
your password.

. You will now be prompted to back up your data and are

strongly encouraged to do so.
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Figure 5.6: Month End Procedure dialog box

4. Once the back up is complete, the month end proce-
dure will automatically follow. Eventually, a message
box confirming its completion will appear.

The Month End Procedure should be run with care since it
cannot be reversed except by restoring from backup. This is
especially true in December when it will close entry of absence
and leave data for the year that is ending.
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File Format

Keying in new employees into the payroll can be very time
consuming especially if there are many of them. As an alter-
native, you can import employee data into the personnel table
from a text file.

The easiest way to create the input text file is to capture em-
ployee data in a spreadsheet and then save the spreadsheet as
a text file.

The format of the input text file is as follows:

1.

Plain text with data items separated by the tab character
(i.e. a tab-separated text file).

. The first row of data is a header with the data items Em-

ployee Number, Last Name, Other Names, 1D Number,
Job Title, Admin Unit, Station, Pay Rate, PIN, NSSF
Number and NHIF Number.

From row two onwards, each row has data for a single
employee, i.e. employee number, last name, other names,
ID number, job title, administrative unit, station, pay
rate, PIN, NSSF number and NHIF number.

Note that:

1.

The first row (file header) is ignored. It is only included
for the convenience of the person preparing the input
file.

. A row will not be imported if the employee number

matches that of a record already in the personnel table.

. A row will also be skipped if any of the following data

items is blank: employee number, last name, other names,
job title, administrative unit, station.

Data will be imported into several data tables—personnel,
payroll master, payroll transactions, leave, jobs, admin-
strative units and stations.
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How to Import

5. Where a default profile has been defined, it will be ap-
plied to each record added to the personnel table.

1. Back up your data just in case you need to undo the
changes you are about to make (Procedure > Backup).

2. Select Procedure > Import > Employees to open the
first Import New Employees dialog box (figure [A.1)).
Impart Mew Employees b4

mparting employee data from a text file may
modfy several data filea. | is advisable to
!' back up your dats befors cortinuing
o

i you ane surs you want io conbinue, please
erfler your password below

Fasword

ok | Cared Help

Figure A.1: First Import New Employees dialog box

3. Enter your password to open the second Import New
Employees dialog box.

4. Browse to the text file that you want to import data
from and click on Open.

5. Aren Register will read the text file and update the data
tables listed above. On completion, a confirmation mes-
sage box will be displayed. Close the message box.

To see which records were updated, refer to the log file im-
port.log located in the payroll data folder. Browse through
the data tables that should have been updated to confirm that
they were updated successfully.
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Aren Register can email payslips and P9As to each of the em-
ployees in the payroll. This provides an alternative to printing
individual payslips or P9As for each employee. The reports
are sent as password-protected PDF files.

In this section, we explain how to email payslips. Emailing
P9As works in exactly the same way.

Entering Email Addresses

Start by capturing the email addresses to send reports to.

1. Open the Payroll Master Table form (File > Payroll Mas-
ter) and select the Other tab (figure B.1)).

Payrall Master Table
Record 1 of 45 01 Asaga, Stephan Lienzern

Fayment
Bamc Pay Email reports to:
Orenrtmes asegafdemorestaurant. oo ke
Housing

PAYE

NS5F & NHIF

Co-operatives

Persion Funida

Other

Figure B.1: Payroll Master Table form

2. For each employee, enter the address to email reports to.

3. Close the Payroll Master Table form.

Setting Up Email Account

In order to send email, you need to set up your email account.
For this you require details of the outgoing mail server, also
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known as the SMTP server. Consult your IT department if
necessary or check the settings in the email software you use.

1. Select System > Email Account to open the Email Ac-

count dialog box (figure |B.2)).

Ernail Account x

General

Email Address | nfo@demorestaurant. o ke
Cancel

™ Copy all emails to self

adi

SMTF Server
Address | mail, demarestEurant. co.be
Part [ 25
Timeout |l“] seconds

b Use s=oure cormection

Buthertication
Type |L-:~;r' T|

Account Hame | nfo@demorestaurant. oo ke

EEEEEEEEEEEEEEE

Password |

Figure B.2: Email Account dialog box

. Email Address: Enter your email address, say info@-

demorestaurant.co.ke or example@gmail.com.

. SMTP Server: Enter the name of the outgoing mail

server, e.g. mail.demorestraurant.co.ke or smitp.gmail-
.com. You can also enter the server’s [P address, e.g.
192.168.0.23.

. SMTP Port: The SMTP port is a unique number that

the mail server has set aside for outgoing mail. The most
common values are 25, 465 and 587. If your server uses
a secure (encrypted) connection, e.g. smip.gmail.com or
smip.mail.yahoo.com, try port 465 or 587. If it does not,
enter 25.

. Timeout: This is length of time the software should wait

for a response from the mail server before giving up.

. Use secure connection: Check this option if the mail

server uses a secure connection.
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10.

Sending Payslips

Authentication: You may select none (no account name
or password required), plain or login (requires account
name and password).

Account Name and Password: Enter the login name and
password for the mail server if you have selected login or
plain authentication.

Copy all emails to self: Check this option if you want to
receive a copy of all the reports you send.

Close the Email Account dialog box.

Now you are ready to email payslips to employees.

1.

Select Procedure > Email Payslips to open the Email
Payslips dialog box (figure [B.3]).

Ermnail Payslips x
Pay Perod _
OK I
Year |2024 Canced
Month [laruary =) Wt > |

Il

Options

Figure B.3: Email Payslips dialog box

Choose the pay period that you want then click OK. This
opens the Payslip Messages dialog box (figure |B.4]).

Click on Send to open the Message Range dialog box
(figure [B.5)).

Use the Message Range dialog box to send the current
message, all messages or a range of them. On comple-
tion, a message box showing the number of messages sent
will be displayed.

Close the Payslip Messages dialog box when you are
through.
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PadpMemes X
] ] deerass ]

Send To: Fw@dmmmmm

Subject: |Paysip for Jaruary 2024

e

Hmm; Dwar Stephen.

Tour paysip for Jaruary 2024 is sttached. You can save, view and
print i al your conveniance.

Regards,
Demo Restaurant Lbd

Aitachment; |Demo Rescaurant Lod

Payslip

Employes No.: 001

Hama - Asaga, Scephen Lihenzaro
Pay Peciod: January 2024

Figure B.4: Payslip Messages dialog box

Send:

P
™ Al Mesgages ﬂ

™ Messages

Fram: I_ Tn:l_

Figure B.5: Message Range dialog box

Details of the last mail session are saved in the log file email.log
located in the payroll data folder. Refer to this file if you have
any difficulty sending messages and to see which messages were
actually sent.

How to Open Payslips

Once a payslip is sent, the recipient will need one of the fol-
lowing passwords to open it.

1. Owner Password: This password is set in the General
Options dialog box (Organisation > Options > General).
Use it to open any payslips you send out.

2. User Password: This is usually the last four digits of the



How to Open Payslips ol

employee’s PIN. Where the employee’s PIN is missing,
it defaults to the value set in the General Options dialog
box. This is the password that employees should use.

You can modify the message that is sent to employees to in-
clude help on the password they will use to open the payslip.

1. Go to Procedure > Email Payslips to open the Email
Payslips dialog box.

2. Click on Options to open the Electronic Payslip Options

dialog box (figure [B.6).

Electranic Payslip Options *
Message Print
¥ Include pasaword help B Jab Tite ok I
o Cancel
Son By numbers

o [ Payment mode
i*  Einpyes Mimber
k¥ PAYE breakdown

N

e W Loan breakdown
Layout W Employer pension
[ Ful page

[ Pension balance
[™ Edended header [ Coop balance
Haadngs W Loan balance
(" Back % Red

-

™ Green Blue

Figure B.6: Electronic Payslip Options dialog box

3. Check the option Include password help.
4. Close the Electronic Payslip Options dialog box.
5. Close the Email Payslips dialog box.
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Appendix C Formulae

Loans

Amortisation

Reducing Balance

The loan payment amount is uniform throughout the repay-
ment period. The portion of the payment amount that goes
towards repaying the principal increases with time as interest
payments reduce.

]
I—(1+r)"

Payment = l

where W = principal amount, n = total number of payments,
r = monthly interest rate (e.g. if annual interest rate is 15%,
r = (15/100)/12 = 0.0125).

The amount paid towards the principal is fixed throughout the
loan duration while interest payments reduce with time. Thus
the total payment amount reduces with time.

1
Payment = W' (/ + 7’)
n

where W’ = outstanding balance, n’ = number of payments
outstanding, » = monthly interest rate.
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