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1 Introduction

About Aren Payroll

Aren Payroll is a payroll program that runs in the Microsoft
Windows environment. It enables you to set up a database
containing pay details of the employees in your organisation.
Data entry is interactive with income tax, loan payments, pen-
sion fund balances and other calculated amounts updated and
displayed as you work.

The system produces several payroll reports such as payslips,
payroll summary, payroll control account, cash and cheque
lists, as well as monthly and annual tax returns. All reports
are formatted for A4 paper so there is no need to buy special
stationery.

Access to the system requires a username and a password.
There is one permanent user who has unrestricted access to
the entire system. Other users can be added at any time and
assigned access to those functions they need to use.

The program can be con�gured to suit the needs of your organ-
isation. For example, you can de�ne an unlimited number of
payments and deductions. You can also update the tables used
for calculating statutory deductions should the need arise.

Aren Payroll supports multiple organisations which is conve-
nient if you need to run the payroll of more than one organi-
sation on a single computer. A separate licence is required for
each organisation.

Getting Started

To use Aren Payroll you must �rst install it and con�gure it
to suit your needs. The rest of this section shows you how to
begin this process.

Installation

To install Aren Payroll:

1. Insert the installation CD in the CD drive.
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Figure 1.1: Setup Wizard

2. Run the program setup.exe on the installation CD.

3. Follow the on-screen instructions that appear during the
installation process (�gure 1.1).

The installation process copies the �les required by Aren Pay-
roll to the folder you specify on the hard disk of your com-
puter. It will also add Aren Payroll and its Help �le to the
Start menu.

Creating a Data Folder

1. Once the installation process is complete, run Aren Pay-
roll by selecting it from the Start menu.

Figure 1.2: Start dialog box
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2. In the Start dialog box that appears (�gure 1.2), click on
Data Folder to open the Data Folders dialog box (�gure
1.3).

Figure 1.3: Data Folders dialog box

3. Click on Create in the Data Folders dialog to create a
new data folder in which to store Aren Payroll data.

You can locate your data folder anywhere you want on
your computer or on a shared folder on another com-
puter. Make sure you have unrestricted access to whichever
location you choose, otherwise the software may not work
properly.

4. Close the Data Folders dialog to return to the Start di-
alog.

5. Within the Start dialog, click on Login to open the Login
dialog box.

Logging In

1. In the Login dialog box enter the username supervisor
(�gure 1.4).

2. You will be prompted to enter a password for use in
subsequent logins (�gure 1.5). Enter a password of your
choice.

3. The New Organisation dialog box is displayed next (�g-
ure 1.6). Type in the name of your organisation and the
month from which you want to start entering data.
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Figure 1.4: Login dialog box

Figure 1.5: Set Password dialog box

Figure 1.6: New Organisation dialog box

4. Close the New Organisation dialog box to begin using
Aren Payroll.

Moving On

Before entering employee data you need to �nish setting up
the program. Section 2 explains how to do this. To enter
employee data refer to Section 3 which describes the employee
data �les in Aren Payroll.

After entering employee data you can view the reports de-
scribed in Section 4. With the exception of the muster roll
and payroll variance, all reports can be printed out on A4
paper. Use the muster roll to export payroll data to a text
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�le.

To close the current pay period and start a new one, run the
month end procedure described in Section 5. That section
also describes how to back up and restore data and create
bank transfer �les.
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Before entering details about employees, use the Organisation
and System menus to con�gure the program. The Organi-
sation menu options apply only to the organisation that you
are currently working with whereas those of the System menu
apply to all organisations that you de�ne.

Setting up the System

Users

Aren Payroll supports an unlimited number of users. There is
always at least one user, supervisor. The supervisor has access
to all functions including adding and deleting other users and
assigning such users access to program functions. By restrict-
ing users to only those parts of the program they need for their
work, it is possible to enforce separation of duties.

If you wish to add new users at this stage, do the following:

1. Select Users from the System Menu. This displays the
Users dialog box (�gure 2.1).

Figure 2.1: Users dialog box

2. Click on the Add button which brings up the User Iden-
tity dialog box (�gure 2.2).

3. In the User Identity dialog enter the username. Enter
and con�rm the password if you wish. If you do not
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Figure 2.2: User Identity dialog box

enter a password at this stage, the user will be required
to enter one when logging in for the �rst time. You may
also enter the user's real name to help you identify him
or her in future.

4. Close the User Identity dialog and choose Rights from
the Users dialog box. This displays the User Rights di-
alog box (�gure 2.3).

Figure 2.3: User Rights dialog box

5. Use this dialog box to specify the functions that you
would like the user to have access to.

6. Close the User Rights dialog box. You can add more
users by repeating the procedure above.

7. Click on Close in the Users dialog box.

Banks

Aren Payroll comes with a comprehensive list of banks and
their branches. You will need this list for employees paid by
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bank transfer rather than in cash or by cheque. The list is
shared by all organisations that you create. To review or mod-
ify it, select Banks from the System menu which will bring up
the Bank and Branches dialog box (�gure 2.4).

Figure 2.4: Banks and Branches dialog box

Statutory Deductions Parameters

PAYE is calculated using brackets and rates that are stored
in a table. To view and update this table select PAYE Rates
from the System menu (�gure 2.5). Refer to the current P.38
from the Tanzania Revenue Authority (TRA) for an up-to-
date PAYE table.

Figure 2.5: PAYE Rates dialog box

The calculation of PAYE depends on two other parameters, al-
lowable pension fund contribution and statutory interest rate.
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Update these parameters by selecting System > PAYE Param-
eters to open the PAYE Parameters dialog box (�gure 2.6).

Figure 2.6: PAYE Parameters dialog box

Employer and employee contributions to NSSF are percentages
of gross pay. To modify these percentages select NSSF Rates
from the System menu. This opens the NSSF Rate dialog box
(�gure 2.7).

Figure 2.7: NSSF Rates dialog box

Other Parameters

The employer's contribution to the Skills Development Levy
(SDL) is a percentage of gross pay. To edit this percentage
open the SDL Rate dialog by selecting SDL Rate from the
System menu (�gure 2.8).

Figure 2.8: SDL Rate dialog box

You should also review the income brackets that will appear in
the P.10 report by selecting System > Income Brackets (�gure
2.9).
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Figure 2.9: Income Brackets dialog box

Working with Organisations

A single installation of Aren Payroll can support up to 99
di�erent organisations. Each organisation requires a separate
licence. The name of the organisation that is currently open
is displayed in the title bar of the main window.

Adding a new Organisation

To add a new organisation select Add from the Organisation
menu. Use the New Organisation dialog box that follows (�g-
ure 2.10) to enter the name of the organisation and the month
from which you want to start entering data. On closing the
dialog box, the previous organisation is closed and the new
one opened.

Figure 2.10: New Organisation dialog box
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Opening another Organisation

To open a di�erent organisation select Open from the Organ-
isation menu. This will bring up the Open Organisation di-
alog box (�gure 2.11) provided there are other organisations
de�ned. Select the organisation you want to open from the
dialog box.

Figure 2.11: Open Organisation dialog box

Deleting an Organisation

You can delete any organisation that is currently not open.
Deleting an organisation causes all its data �les and folders to
be deleted. It is strongly recommended that you back up the
organisation's data �les before deleting it (see Section 5).

To delete an organisation:

1. Select Delete from the Organisation menu. To minimise
the risk of accidentally deleting an organisation you will
be required to enter your password (�gure 2.12).

Figure 2.12: First Delete Organisation dialog box
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2. Next, a list of all organisations in the system, exclud-
ing the one that is open, will be displayed (�gure 2.13).
Select the one you want to delete. Note that it is not pos-
sible to delete the organisation that is currently open.

Figure 2.13: Second Delete Organisation dialog box

3. In the two message boxes that follow, con�rm that you
want to delete the selected organisation and destroy its
data �les.

4. Aren Payroll will then delete the organisation. A dia-
log box con�rming that the deletion is complete will be
displayed.

Setting up an Organisation

To con�gure the organisation that is currently open, proceed
as follows:

Basic Organisation Information

Open the Basic Organisation Info dialog box (�gure 2.14) from
the Organisation menu and enter the organisation's address
and telephone number.

Also, con�rm that you want to start entering payroll details
in the month and year shown in the dialog box. Once you
run the �rst month end procedure you will not be able to edit
either of them.

Licensing

Select Licence from the Organisation menu to open the Licence
dialog box (�gure 2.15). Type in the licence number supplied
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Figure 2.14: Basic Organisation Info dialog box

by your dealer. If you do not have a licence number, contact
your dealer or Aren Software Ltd.

Figure 2.15: Licence dialog box

Payroll Info

Open the Payroll Info dialog box (�gure 2.16) by selecting
Payroll Info from the Organisation menu. Enter the bank,
branch and account number for the organisation's salary ac-
count. Also enter the organisation's IT number, NSSF number
and regional code.

In this dialog box, the Standard File Interchange (SFI) Sender
ID applies to those who submit their payroll to the bank in
electronic form. Leave this �eld blank if you do not already
have an SFI Sender ID.

Jobs

To set up the jobs available in the organisation, open the Jobs
dialog box (�gure 2.17) by selecting Jobs from the Organisa-
tion menu.

.
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Figure 2.16: Payroll Info dialog box

Figure 2.17: Jobs dialog box

Administrative Units

Set up the administrative units (departments, sections, etc) in
your organisation. To do this select Units from the Organisa-
tion menu.

Stations

Set up the stations (branches) in your organisation. To do this
select Stations from the Organisation menu.
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Pay Groups

Pay Groups allow you to �lter payment reports according to
how employees in your organisation are paid. For example,
the bank transfer report could be �ltered by bank branch or
pay date.

To set up pay groups, select Pay Groups from the Organisation
menu.

Co-operatives and Pension Funds

Create co-operative societies that employees in the organisa-
tion belong to by selecting Co-operatives from the Organisa-
tion menu.

Similarly, set up pension funds by selecting Pension Funds
from the Organisation menu.

Employee Pro�les

An employee pro�le de�nes attributes that are common to a
group of employees. These attributes are pay frequency, basic
pay type (i.e., salary, daily rate or hourly rate), standard work-
ing hours (per day and per pay period) and whether overtime
is payable.

To create a pro�le, select Pro�les from the Organization menu
to open the Employee Pro�les dialog box (�gure 2.18). If there
is an employee pro�le marked as default, all new employees
added to the payroll will be assigned this pro�le.

Figure 2.18: Pro�les dialog box

General Options

Selecting Options > General from the Organisation menu opens
the General Options dialog (�gure 2.19). This dialog allows
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you to choose the sort order for employee data entry forms.

Figure 2.19: General Options dialog box

You can also specify when to purge old reports. Deleting old
reports saves space on the hard disk and reduces the size of
backup �les.

In the logo section, you can select a bitmap �le that contains
the company's logo. This logo will be printed at the top of
each payslip.

Payroll Options

Selecting Options > Payroll from the Organisation menu brings
up the Payroll Options dialog (�gure 2.20). By default PAYE
is calculated on the average taxable pay in each half of the
year. Uncheck the option Tax average monthly pay if you pre-
fer to tax each month's pay independently.

Selecting the option Tax employer pension on employee will
cause pension fund contributions made by the employer to be
added to the employee's taxable pay. It is advisable to check
this option.

When computing taxable pay, an employee's pension fund con-
tribution is an allowable deduction, but up to a statutory limit.
This limit is set in the PAYE Parameters dialog box (System
> PAYE Parameters). Select the option Ignore allowable pen-
sion limit if you wish to ignore this limit.

With the option to tax average monthly pay set, it is possible
for PAYE to be negative. This indicates that the employee
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Figure 2.20: Payroll Options dialog box

has already paid more tax than is due and is entitled to a
refund. Switch the option Allow negative PAYE o� to limit
the minimum PAYE to zero.

You can also specify whether the employer contributes to SDL.
Checking the Pay Skills Development Levy option turns on the
SDL report (Report > Monthly Returns > SDL).

Finally, you can choose to round down net pay for employ-
ees paid in cash by an amount that you specify. The excess
amount is carried forward to the next month.

Report Options

Selecting Options > Reports from the Organisation menu opens
the Report Options dialog box (�gure 2.21). This enables you
to choose the report options you prefer. You need not specify
them each time you open a report.
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Figure 2.21: Report Options dialog box
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3 Data Files

Data for each employee is stored in two database �les, the em-
ployee master �le and the payroll transactions �le. This data
is used to create the various report �les from which reports are
printed.

Employee Master File

The employee master �le stores static information about each
employee. It is accessed by selecting Employee from the File
menu (�gure 3.1). This brings up a data entry form in which
you enter details about each employee.

Figure 3.1: Employee Master File form

You can add and delete employee records using the Add, Delete
and Terminate commands in the Record menu.

• The Delete command simply deletes an employee record.
It is only available if no month end procedure has been
run since the current employee was added.

• The Terminate command transfers an employee record
from the employee master �le to the leavers report �le.
This transfer takes place in the month end procedure
that follows the termination date speci�ed by the user.
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For easy access the data entry form is divided into ten pages,
i.e., Personal Details, Employment Details, Payment, Basic
Pay, Overtime, Housing, Statutory Deductions, Co-operatives,
Pension Funds and Options.

Most of the �elds in this �le are optional. However, Employee
Number, Last Name, Other Names, Job Title, Administrative
Unit and Station are mandatory. If an employee is paid by
bank transfer, then Bank, Branch and Account Number are
also mandatory. The optional �elds are used in various reports
and should therefore not be left blank.

Payroll Transactions File

The payroll transactions �le stores earnings, deductions, ben-
e�ts, lump sums payments and refunds for each employee for
the current month.

Earnings (or monthly cash earnings) are those cash payments
that relate to the current month e.g. basic pay or leave al-
lowance.

Bene�ts are private expenses of an employee that are paid by
the employer e.g. school fees, house rent or telephone bills.
These non-cash bene�ts are considered as income for tax pur-
poses.

Deductions are those amounts deducted from an employee's
cash earnings by the employer. Some of these are called statu-
tory deductions because the law requires the employer to deduct
them from the employee's pay. The statutory deductions are
PAYE, NSSF and tax on lump sum payments.

Lump sum payments are those cash payments that do not
relate to the current month alone. Some like gratuity and
bonuses have accrued over past months while others like ter-
minal bene�ts may relate to past or future months. We make
the distinction between lump sum payments and monthly cash
earnings because the two are treated di�erently when calcu-
lating income tax.

Refunds are payments made to an employee, e.g. travelling or
subsistence allowances, for business expenses incurred while
on duty. These payments are not income and are therefore
not taxable.

The payroll transactions �le is accessed by selecting Payroll
from the File menu. This displays a data entry form (�gure
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3.2) where you enter earnings, deductions, bene�ts, lump sum
payments and refunds for each employee.

Figure 3.2: Payroll Transactions File form

Statutory deductions and other calculated amounts such as
taxable pay, net pay and gross pay are updated as data is
entered. This makes the calculations more transparent and
helps to reduce data entry errors.

The payroll transactions �le can only include employees present
in the employee master �le. Use the Delete command in the
Record menu to suspend employees from the payroll. Sus-
pended employees can be restored at any time using the Record
> Add command.

Payroll Fields

At installation, the payroll transactions �le has two earnings
(Basic Pay and Overtime), three deductions (Rent, Overdraft
Recovery and Rounding C/F), two non-cash bene�ts (Em-
ployer Pension and Low Interest Bene�t) and one refund (Round-
ing B/F). These �elds cannot be deleted but you can add more
according to your needs.

To add, delete or edit �elds, select Earnings, Deductions, Ben-
e�ts, Lump Sum Payments or Refunds from the File menu. A
data entry form will be displayed showing the �eld attributes
listed below (�gure 3.3). To add or delete �elds select Add or
Delete from the Field menu.

The following �eld attributes apply to all �elds:
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Figure 3.3: Deductions form

1. Field Name: The name of the �eld e.g. advance, shift
allowance.

2. Type: This is used to indicate permanent �elds (e.g. ba-
sic pay and rent). It is also used to specify �elds that
are calculated in a unique way (e.g. hourly pay and
daily pay) and those that are associated with a balance
that is updated and displayed by the system (e.g. loan
repayments and co-operative contributions). The type
advance is used to indicate advance payments so that
appropriate reports can be generated.

3. Amount: This attribute speci�es how the amount paid
to or deducted from each employee is arrived at. It may
be keyed in, a percentage of salary, a function of the time
worked (basic pay, overtime, hourly pay and daily pay)
or amortised (loan repayments).

4. Static: Static �elds retain their value when the month
end procedure is run, whereas non-static �elds are reset
to their lower limit. This is only important for �elds that
are keyed in. It saves you the trouble of having to key
in the amount earned or deducted each time the month
end procedure is run.

5. Taxable/Pre-tax deduction: For earnings the taxable at-
tribute speci�es whether or not the payment is subject to
PAYE. In general, all cash earnings and most non-cash
bene�ts are taxable. Refunds are not taxable as they are
not a form of income.

The pre-tax deduction attribute indicates those deduc-
tions to be subtracted from gross income when calculat-
ing PAYE. In Tanzania the only pre-tax deductions are
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contributions to registered pension funds.

Refer to the P.7 (Employer's Guide to Pay As You Earn)
for further information.

Depending on the selection for Type and Amount attributes
the following additional attributes may be available:

1. Co-operative: The name of the co-operative associated
with the �eld (�gure 3.4).

Figure 3.4: Co-operative dialog box

2. Pension Fund: The name of the pension fund and other
details pertaining to the current �eld (�gure 3.5).

Figure 3.5: Pension Fund Parameters dialog box

3. Limits: The upper and lower limits that the amount
paid or deducted should be restricted to (�gure 3.6).

Figure 3.6: Limits dialog box
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4. Percentage: The percentage of monthly salary that should
be paid or deducted (�gure 3.7).

Figure 3.7: Percentage of Salary dialog box

5. Hourly Rate: The hourly rate to use for earnings that
are of the type Hourly Pay (�gure 3.8).

Figure 3.8: Hourly Rate dialog box

6. Daily Rate: The daily rate to use for earnings that are
of the type Daily Pay.
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Aren Payroll produces numerous reports as described below.
These reports can be viewed on the screen and printed out.
You can choose to print the entire report, a range of pages, or
just the page that you are currently viewing. Internal reports
can be sorted by either employee number or name.

You can view and print reports for current as well as past
months and years. You can also �lter most reports by ad-
ministrative unit, station, pay group, bank, co-operative or
pension fund.

Reports may be printed on any printer connected to your com-
puter either directly or through a local area network. Because
all reports are formatted for A4 paper, the printer must be set
to print on A4.

1. To open a report select it from the Report menu and then
follow the on-screen instructions. For example, selecting
Report > Payslips opens the Open Payslips dialog box
(�gure 4.1).

Figure 4.1: Open Payslips dialog box

2. To print the open report select Print from the File menu
which brings up the Print dialog box (�gure 4.2). Use the
Setup button in this dialog box to con�gure the printer
you want to use.

3. Choose Close from the File menu to close the report.
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Figure 4.2: Print dialog box

Nominal Rolls

1. Employees Roll: List of employees who are currently ac-
tive. It shows their job title, administrative unit and
station.

2. Joiners Roll: List of employees who joined the organi-
sation recently. It shows their job title, administrative
unit, station and start date.

3. Leavers Roll: List of employees who left in a given year.
It shows their �nal job title and administrative unit, the
date they left and the reason for leaving.

Monthly Payroll Reports

The monthly payroll reports relate to a single month. Reports
for the current month are updated as you update the employee
master �le and the payroll transactions �le. Reports for pre-
vious months can be viewed and printed out, but they cannot
be modi�ed in any way.

Overview Reports

1. Payroll Summary: Summarises earnings and deductions
for all employees.

2. Payroll Control Account: T-account listing total earn-
ings, deductions and net pay for all employees in the
organisation.

3. Muster Roll: List of employees showing all earnings,
lump sum payments, refunds and deductions for the month.
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Records in this report can be grouped by administrative
unit or station.

4. Payroll Variance: List of employees showing the di�er-
ences in the payments and deductions made in any two
pay periods. It is essentially the di�erence between the
muster rolls for the two pay periods.

The muster roll and payroll variance can be viewed on the
screen or saved to a text �le but they cannot be printed out.

Detail Reports

1. Earning Report: List showing, for a particular earning,
how much each employee was paid.

2. Deduction Report: List showing, for a particular non-
statutory deduction, how much each employee was de-
ducted. If the deduction selected is a loan repayment, a
loan report is printed instead.

3. Loan Report: List of employees repaying a speci�c co-
operative or company loan. It shows the opening and
closing balances and a breakdown of the repayment amount
into interest and principal components.

4. Bene�t Report: List showing, for a particular non-cash
bene�t, how much each employee received.

5. Lump Sum Report: List showing, for a particular lump
sum payment, how much each employee received.

6. Refund Report: List showing, for a particular refund,
how much each employee received.

Payments to Employees

1. Payslips: Slip giving a breakdown of the earnings and
deductions of each employee separately (�gure 4.3). The
employer's pension contribution and the pension fund
balance can be shown in the payslip if required. When
the balance is shown, it includes the employer's portion
only if the option to print the employer contribution has
been selected.

2. Cash List: List of employees paid in cash showing their
employee number, name, net pay or advance payment
and a cash analysis of the payment amount.
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Figure 4.3: Payslips

3. Cheque List: List of employees paid by cheque showing
their employee number, name and net pay or advance
payment.

4. Bank Transfer Report: List of employees who are paid
by bank transfer showing their name, ID number, bank,
branch, account number and payment amount. The pay-
ment amount may be the net pay, an advance payment
or a bank loan repayment.

5. Coinage Summary Report: List showing the number of
coins and notes of each denomination that are required
for workers who are paid in cash. This information is
the same as the totals in the cash list but formatted so
that it can be used when withdrawing the cash from a
bank.

Returns

1. PAYE Report: List of employees showing their PAYE
deductions.

2. NSSF Report: List of employees showing the total em-
ployee and employer NSSF contributions.

3. SDL Report: List showing the SDL payable to the TRA
for each employee.

4. Co-operative Report: List of members of a particular co-
operative society showing membership number, monthly
contribution and any other payroll deductions to be paid
to that co-operative.
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5. Pension Report: List of members of a particular pension
fund showing membership number and employer and em-
ployee contributions to that pension fund.

6. Lump Sums Tax Report: List showing tax payable on
lump sum payments for each employee.

Annual Payroll Reports

Annual payroll reports relate to a calendar year and are avail-
able throughout the year. For the current year, the informa-
tion displayed relates to the months that have elapsed so far.
The reports are:

1. Payroll Control Account.

2. Muster Roll.

3. Annual Pay Sheet: A report that, for each employee,
gives a summary of payments, deductions and bene�ts
for a whole year.

4. P.9: TRA form titled Tax Deduction Card. Each P.9
gives a breakdown of the income of an employee for each
month of the year and shows the amount of tax deducted.

At the end of each tax year, the employer should sub-
mit to the TRA a P.9 for each and every employee from
whom PAYE was deducted.

5. P.10: TRA form titled Employer's End of Year Cov-
ering Certi�cate. It shows the total tax deducted by
the employer for each month of the year. The employer
should submit it to the TRA at the end of each year,
together with the P.9s.

6. ITX215: TRA form titled PAYE Statement. It lists the
tax deducted for each employee who has paid PAYE in a
given six or twelve month period. It also shows taxable
cash earnings, non-cash bene�ts, pre-tax deductions and
taxable pay.

7. NSSF Statement: A report that shows the monthly em-
ployee and employer contributions to NSSF for a single
employee for a calendar year.

Other Reports

1. Bank Codes: A listing of banks, bank branches and their
sort codes drawn from the banks �les.
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2. Audit Trail: List that shows the date and time of each
login, backup, month end procedure and any other major
event. It also shows the user responsible for each event.
This report is only available to the supervisor.

Report Files

Almost all reports are printed from report �les, not directly
from the employee data �les. Brie�y, the report �les are:

1. Active employees report �le

2. Annual leavers report �les

3. Monthly payroll report �les

4. Annual payroll report �les

Report �les are updated automatically by Aren Payroll. Use
the General Options dialog box (Organisation > Options >
General) to specify how long to keep these �les for.
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Backing Up

If your data �les are accidentally deleted or corrupted you
could lose all your data. Without an up-to-date backup you
would be forced to key in the data for the current month again.
It is also likely that you would be unable to recreate data for
previous months and years. It is therefore very important that
you make regular backups of your data �les.

To back up �les for the organisation that is currently open, se-
lect Backup from the Procedure menu. You will be prompted
to specify the name and location of the backup �le to be cre-
ated (�gure 5.1).

Figure 5.1: Backup dialog box

The backup process copies all data relating to your organi-
sation to the backup �le. Should you have set up more than
one organisation, you will need to back up each one separately.
Note that data that is shared by all organisations is not backed
up (e.g. list of banks and statutory deductions parameters).

When running the month end procedure you will be prompted
to back up. Though you can choose to proceed without doing
so, it is recommended that you back up �rst. To encourage
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regular back ups Aren Payroll prompts you to back up each
time you exit.

Restoring from Backup

In the event that your data �les are corrupted or deleted you
will need to recover them from a backup �le. You can also use
backup �les to revert to an earlier month. This is especially
useful if you accidentally run the month end procedure.

To restore an organisation's �les from backup, select Restore
from the Procedure menu then follow the on-screen instruc-
tions (�gure 5.2).

Figure 5.2: Restore dialog box

Creating a Bank Transfer File

A bank transfer �le is an electronic version of the bank transfer
report. It is used by banks to process payments for employees
paid by bank transfer in place of the printed bank transfer
report. Aren Payroll can create bank transfer �les for numer-
ous banks including Barclays, Citibank, Stanbic and Standard
Chartered.

1. To create a bank transfer �le select Bank Transfer File
from the Procedure menu. The Save Bank Transfer File
dialog box appears (�gure 5.3).

2. Specify the format of the bank transfer �le to create
and the name of the payment �eld (usually net pay).
Depending on the �le format, you may be able to specify
the date you want the bank transfer e�ected.

3. After closing the Save Bank Transfer File dialog box, a
standard Save As dialog box appears. Use this dialog to
specify the name and location of the �le to be created.
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Figure 5.3: Save Bank Transfer File dialog box

For further details on bank transfer �les please contact your
bank.

Terminating an Employee

To terminate an employee, open the employee master �le and
display the target employee. Next, select Terminate from the
Record menu. In the Terminate dialog box that appears (�gure
5.4), enter the termination date, the reason for leaving and, if
you like, some brief comments.

Figure 5.4: Terminate dialog box

The terminated employee will be removed from the employee
data �les in the next month end procedure that is later than or
on the same day as the termination date. Once the employee
is deleted from the employee data �les his record will be added
to the leavers report �le.

Termination can be reversed by selecting Record > Undo Ter-
mination as long as the terminated employee has not been
removed from the employee data �les.
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Closing the Month

The month end procedure is used to close data entry for the
current month and begin a new one. It applies only to the
organisation that is currently open. It does the following:

1. Saves all payroll information for the current month to
the monthly and annual report �les.

2. Transfers terminated employees from the employee mas-
ter �le to the leavers report �le.

3. Deletes the current payroll transactions �le and creates
a new one for the coming month.

4. Deletes any report �les that have exceeded the maximum
age set in the General Options dialog box.

5. Advances the pay period by one month.

6. If the new month is July, it creates statutory deduction
�les for the new year.

The month end procedure should only be run after all reports
for the current month have been veri�ed since, once it is run,
reports for that month cannot be changed.

To run the procedure:

1. Select Month End from the Procedure menu. This op-
tion is only available if you have licensed the organisa-
tion.

2. After reading the dialog box that appears (�gure 5.5),
con�rm that you want to close the month by entering
your password.

Figure 5.5: Month End Procedure dialog box

3. You will now be prompted to back up your data and are
strongly encouraged to do so.
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4. Once the back up is complete, the month end proce-
dure will automatically follow. Eventually, a message
box con�rming its completion will appear.
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Appendix A Importing Data

Keying in new employees into the payroll can be very time
consuming especially if there are many of them. As an al-
ternative, you can import employee data into the employee
master �le from a text �le.

The easiest way to create the input text �le is to capture em-
ployee data in a spreadsheet and then save the spreadsheet as
a text �le.

File Format

The format of the input text �le is as follows:

1. Plain text with data items separated by the tab character
(i.e. a tab-separated text �le).

2. The �rst row of data is a header with the data items
Employee Number, Last Name, Other Names, ID Num-
ber, Job Title, Admin Unit, Station, Pay Rate, TIN and
NSSF Number.

3. From row two onwards, each row has data for a single
employee, i.e. employee number, last name, other names,
ID number, job title, administrative unit, station, pay
rate, TIN and NSSF number.

Note that:

1. The �rst row (�le header) is ignored. It is only included
for the convenience of the person preparing the input
�le.

2. A row will not be imported if the employee number
matches that of a record already in the employee master
�le.

3. A row will also be skipped if any of the following data
items is blank: employee number, last name, other names,
job title, administrative unit, station.

4. Data will be imported into several �les�employee mas-
ter, payroll transactions, jobs, adminstrative units and
stations.
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5. Where a default pro�le has been de�ned, it will be ap-
plied to each record added to the employee master �le.

How to Import

1. Back up your data just in case you need to undo the
changes you are about to make (Procedure > Backup).

2. Select Procedure > Import Employees to open the �rst
Import Employees dialog box (�gure A.1).

Figure A.1: First Import Employees dialog box

3. Enter your password to open the second Import Employ-
ees dialog box.

4. Browse to the text �le that you want to import data
from and click on Open.

5. Aren Payroll will read the text �le and update several
data �les�jobs, administrative units, stations, employee
master and payroll transactions. On completion, a con-
�rmation message box will be displayed. Close the mes-
sage box.

6. To see which records were updated, refer to the log �le
import.log located in the payroll data folder. Browse
through the data �les that should have been updated to
con�rm that they were updated successfully.
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Aren Payroll can email payslips to each of the employees in the
payroll. This provides an alternative to printing individual
payslips for each employee. Payslips are sent as password-
protected PDF �les.

Entering Email Addresses

Start by capturing the email addresses to send employee payslips
to.

1. Open the employee master �le (File > Employee) and
select the options tab (�gure B.1).

Figure B.1: Employee Master File form

2. For each employee, enter the address to email payslips
to.

3. Close the employee master �le.

Setting Up Email Account

In order to send email, you need to set up your email account.
For this you require details of the outgoing mail server, also
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known as the SMTP server. Consult your IT department if
necessary or check the settings in the email software you use.

1. Select System > Email Account to open the Email Ac-
count dialog box (�gure B.2).

Figure B.2: Email Account dialog box

2. Email Address: Enter your email address, say info@-
demorestaurant.co.tz or example@gmail.com.

3. SMTP Server: Enter the name of the outgoing mail
server, e.g. mail.demorestraurant.co.tz or smtp.gmail-
.com. You can also enter the server's IP address, e.g.
192.168.0.23.

4. SMTP Port: The SMTP port is a unique number that
the mail server has set aside for outgoing mail. The most
common values are 25, 465 and 587. If your server uses
a secure (encrypted) connection, e.g. smtp.gmail.com or
smtp.mail.yahoo.com, try port 465 or 587. If it does not,
enter 25.

5. Use secure connection: Check this option if the mail
server uses a secure connection.

6. Authentication: You may select none (no account name
or password required), plain or login (requires account
name and password).

7. Account Name and Password: Enter the login name and
password for the mail server if you have selected login or
plain authentication.
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8. Copy all emails to self: Check this option if you want to
receive a copy of all the payslips you send.

9. Close the Email Account dialog box.

Sending Payslips

Now you are ready to email payslips to employees.

1. Select Procedure > Email Payslips to open the Email
Payslips dialog box (�gure B.3).

Figure B.3: First Email Payslips dialog box

2. Choose the pay period that you want then click OK. This
opens another dialog box with the same title (�gure B.4).

Figure B.4: Second Email Payslips dialog box
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3. Click on Send to open the Message Range dialog box
(�gure B.5).

Figure B.5: Message Range dialog box

4. Use the Message Range dialog box to send the current
message, all messages or a range of them. On comple-
tion, a message box showing the number of messages sent
will be displayed.

5. Close the Email Payslips dialog box when you are through.

Details of the last mail session are saved in the log �le email.log
located in the payroll data folder. Refer to this �le if you have
any di�culty sending messages and to see which messages were
actually sent.

How to Open Payslips

Once a payslip is sent, the recipient will need a password to
open it. Each payslip has two passwords:

1. Owner Password: The last four digits of the organisa-
tion's TIN. For instance, if the organisation's TIN is
0123456789, the owner password will be 6789. Should
the organisation's TIN be blank, the default password is
owner.

2. User Password: The last four digits of the employee's
TIN. Where the employee's TIN is missing, the default
password is user. This is the password that employees
should use.

You can modify the message that is sent to employees to in-
clude help on the password they will use to open the payslip.

1. Go to Organistion > Options > Reports to open the
Report Options dialog box (�gure B.6).
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Figure B.6: Report Options dialog box

2. Select Electronic Payslips and click on Options. This
opens the Electronic Payslips Options dialog box (�gure
B.7).

Figure B.7: Electronic Payslips dialog box

3. Check the option Include password help.

4. Close the Electronic Payslip Options dialog box.

5. Close the Report Options dialog box.
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Appendix C Formulae

Loans

Amortisation

The loan payment amount is uniform throughout the repay-
ment period. The portion of the payment amount that goes
towards repaying the principal increases with time as interest
payments reduce.

Payment =
W[

1− (1 + r)−n

r

]

where W = principal amount, n = total number of payments,
r = monthly interest rate (e.g. if annual interest rate is 15%,
r = (15/100)/12 = 0.0125).

Reducing Balance

The amount paid towards the principal is �xed throughout the
loan duration while interest payments reduce with time. Thus
the total payment amount reduces with time.

Payment = W ′
(
1

n′
+ r

)

where W ′ = outstanding balance, n′ = number of payments
outstanding, r = monthly interest rate.


