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1 Introduction

About Aren Payroll

Getting Started

Aren Payroll is a payroll program that runs in the Microsoft
Windows environment. It enables you to set up a database
containing pay details of the employees in your organisation.
Data entry is interactive with income tax, loan payments, pen-
sion fund balances and other calculated amounts updated and
displayed as you work.

The system produces several payroll reports such as payslips,
payroll summary, payroll control account, cash and cheque
lists as well as monthly and annual tax returns. All reports
are formatted for A4 paper so there is no need to buy special
stationery.

Access to the system requires a username and a password.
There is one permanent user who has unrestricted access to
the entire system. Other users can be added at any time and
assigned access to those functions they need to use.

The program can be configured to suit the needs of your organ-
isation. For example, you can define an unlimited number of
payments and deductions. You can also update the tables used
for calculating statutory deductions should the need arise.

Aren Payroll supports multiple organisations which is conve-
nient if you need to run the payroll of more than one organisa-
tion on a single computer. A separate licence key is required
for each organisation.

For each organisation, four pay frequencies are supported, viz.
monthly, weekly, biweekly and irregular. The irregular pay
frequency caters for employees who are not paid after fixed
intervals.

To use Aren Payroll you must first install it and configure it
to suit your needs. The rest of this section shows you how to
begin this process.
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Installation

To install Aren Payroll:
1. Insert the installation CD in the CD drive.

2. Run the program Pay82FEtp | Install|setup.eze on the in-
stallation CD.
2 Aren Payroll 3.2 Enterprice Edition - O *
Welcome to the Aren Payroll 8.2 Enterprise Edition
Setup Wizard

Thea inztallar wall guide pou thiough the sheps iequined bo irstal Aren Pagroll 8.2 Ervenprize Edition on
wOur campliten

WARMNING: Thiz compubes program it protectad by coppight law and inbematonal bealies
Unauthonzed duplication or distnbwtion of tis program, or ang pordion of it, masy result in severe civil
ar cimnal penakbes, and vl be prozecuted fo the maamum extent possible under the law

Figure 1.1: Setup Wizard

3. Follow the on-screen instructions that appear during the
installation process (figure 1.1).

The installation process copies the files required by Aren Pay-
roll to the folder you specify on the hard disk of your com-
puter. It will also add Aren Payroll and its Help file to the
Start menu.

Creating a Data Folder

1. Once the installation process is complete, run Aren Pay-
roll by selecting it from the Start menu.

2. In the Start dialog box that appears (figure 1.2), click on
Data Folder to open the Data Folders dialog box (figure
1.3).

3. Click on Create in the Data Folders dialog to create a
new data folder in which to store Aren Payroll data.

You can locate your data folder anywhere you want on your
computer or on a shared folder on another computer. Make
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Start P
AREN PAYROLL
Version 8.2

Ertemiss Edbion for Tanzania
S Aren Software: Lid. 1998-2022

[None]

Login... | Cancel || Data Folder... I

Figure 1.2: Start dialog box

Data Folders X

Avallable Folders

Creale. .. Select... Sattings. ..

Target Folder
[Man=]

Figure 1.3: Data Folders dialog box

sure you have unrestricted access to whichever location you
choose, otherwise the software may not work properly

Where the data folder is on another computer, that computer
needs to have Firebird installed and configured to work with
Aren Payroll. Appendix A shows you how to do this. If nec-
essary, set up Firebird before proceeding.

Setting up the Data Folder

You will need to edit the settings for the newly created data
folder.

1. Click on Settings in the Data Folders dialog to open the
Data Folders Settings dialog (figure 1.4).

2. Hostname This is initially set to localhost. Change it to
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Logging In

Data Folder Settings x
Local Path

\TEMBO\Payroll Data'PaydZEnt

Metwark Location

Hies Irsmes [ TE-BO

Path on Host | D:'Payrol Data\PayE2Ent

Finebird Server

Lisermaims |“‘H'|!?~'|

Password | -

K I Cancel

Figure 1.4: Data Folders Settings dialog box

the name of the computer on which the data folder is
located.

. Path on Host: Make sure this matches the full path of

the data folder on the computer hosting the data folder.

. Username: This is the username the software will use to

log into the Firebird server. The default value is sysdba
but you can change it if need be.

. Password: The default value is masterkey. Edit it to

match the username you have specified.

. Close the Data Folder Settings dialog to return to the

Data Folders dialog.

. Close the Data Folders dialog to return to the Start di-

alog.

. Within the Start dialog, click on Login to open the Login

dialog box.

. In the Login dialog box enter the username supervisor

(figure 1.5).

. You will be prompted to enter a password for use in

subsequent logins (figure 1.6). Enter a password of your
choice.

. A message box (figure 1.7) will then appear asking if you
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Moving On

Lagin x

* Sngleuser mode
7 Muili-user mads

Usemame |[SUDETIBIC

ok | caca | Hep |

Figure 1.5: Login dialog box

Set Password x

Faszaard li Ok

Carfim [ Cancel
Papsward —

Figure 1.6: Set Password dialog box

would like to copy sample data. Choose No to proceed
to set up your organisation.

fren Register

9' Would you like to copy sample data to this data folder?

Figure 1.7: Sample data message box

5. The New Organisation dialog box is displayed next (fig-
ure 1.8). Type in the name of your organisation and the
month from which you want to start entering data.

6. Close the New Organisation dialog box to begin using
Aren Payroll.

Before entering employee data you need to finish setting up
the program. Section 2 explains how to do this. To enter
employee data refer to Section 3 which describes the employee
data tables in Aren Payroll.
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Hew Organisation x
[lame |:lcn'_| Restaurant Lid DK
Cancel
Maonth [ Jure |
Year [2022

Lecd Cumency |T.-|':nn|.-| Shiling

Payroll Cumency |Tanz='n a Shiling ;l

Figure 1.8: New Organisation dialog box

After entering employee data you can view the reports de-
scribed in Section 4. With the exception of the muster roll
and payroll variance, all reports can be printed out on A4 pa-
per. Use the muster roll to export payroll data to an XML file
in Microsoft Excel format.

To close the current pay period and start a new one, run a
period or month end procedure as described in Section 5. That
section also describes how to back up and restore data and
create bank transfer files.
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Before entering details about employees, use the Organisation
and System menus to configure the program. The Organi-
sation menu options apply only to the organisation that you
are currently working with whereas those of the System menu
apply to all organisations that you define.

Setting up the System

Users

Aren Payroll supports an unlimited number of users. There is
always at least one user, supervisor. The supervisor has access
to all functions including adding and deleting other users and
assigning such users access to program functions. By restrict-
ing users to only those parts of the program they need for their
work, it is possible to enforce separation of duties.

To add new users log in as supervisor then do the following:

1. Select Users from the System Menu. This displays the
Users dialog box (figure 2.1).

Users X

Add,..

i

Password, .,

il

Claze

Figure 2.1: Users dialog box

2. Click on the Add button which brings up the User Iden-
tity dialog box (figure 2.2).

3. In the User Identity dialog enter the username. You may
also enter the user’s real name to help you identify him
or her in future.
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User Identity ®

Lis=rmame uma

Last Mame Mwanzhamisi

Other Names | Juma
QK I Caniel |

Figure 2.2: User Identity dialog box

4. Close the User Identity dialog and choose Rights from
the Users dialog box. This displays the User Rights di-
alog box (figure 2.3).

User Rights for jurna x
Funchicns
[V Edi emplves dala
¥ Modiy payrol fields Carel

¥ Set up apen organization

¥ Close pay period or morth
[ Aestore from backup

[ Add and delete orgarsabons

¥ Modiy tax tables

Figure 2.3: User Rights dialog box

5. Use this dialog box to specify the functions that you
would like the user to have access to.

6. Close the User Rights dialog box and choose Password
from the Users dialog box. This brings up the Set Pass-
word dialog box (figure 2.4).

Set Password for juma 4
Iﬂsmrd ......... D_{
Canfim [ Cancel
Papsward —

Figure 2.4: Set Password dialog box

7. Enter and confirm the password if you wish. If you do
not enter a password at this stage, the user will be re-
quired to enter one when logging in for the first time.
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8. Close the Set Password dialog box. You can add more
users by repeating the procedure above.

9. Click on Close in the Users dialog box.

Banks

Aren Payroll comes with a comprehensive list of banks and
their branches. You will need this list for employees paid by
bank transfer rather than in cash or by cheque. The list is
shared by all organisations that you create. To review or mod-
ify it, select Banks from the System menu which will bring up
the Bank and Branches dialog box (figure 2.5).

Banks and Branches

: -

+ Akba Commeroal Bank Add Bark...
« Amana Bank

# Azara Bark Add Branch
+ BancABC

+ Bank of Afnca
+ Bank of Baroda
+ Bank of India Fraperteag,.,
+ Canara Bank
# Chira Dasheng Bark Close
# Cribark

+ CRDE Bank

+ DCB Commerdal Bank

+ Diamond Trust Bank

# Ecobank

# Equity Bank

# Exim Bank

+ First National Bank v

x

10T

Figure 2.5: Banks and Branches dialog box

Statutory Deductions Parameters

PAYE is calculated using brackets and rates that are stored in
a table. To view and update this table select PAYE Rates from
the System menu (figure 2.6). Refer to the Tanzania Revenue
Authority (TRA) website for the latest PAYE table.

The calculation of PAYE depends on a number of other parameters—
non-resident tax rate, allowable pension fund contribution and
statutory interest rate. Update these parameters by selecting
System > PAYE Parameters to open the PAYE Parameters
dialog box (figure 2.7).

NSSF and NHIF contributions are percentages of employee
income. To modify these percentages select NSSF Rates or
NHIF Rates from the System menu (figure 2.8).
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| Lower Limt | Upper Limt | Tax Ratery |
) 270000 000 [ et |
7000 520000 800
520001 Te0000 20.00 Dieleta
TED00 1000000 25.00 —J
1000001 - Nane - 30.00 Bt

_ O |

Figure 2.6: PAYE Rates dialog box

Maximum Allwable Pension Fund 200000 IE
Cancel I
Statutory Interest Rate {9
July to December 0.00
Jaruary to June .00
Mon-Resident Tax Rate (%) 15,00

Figure 2.7: PAYE Parameters dialog box

Contribution
Percentage of pensonable pay: %I
Employee 10,00

Emphayer 10.00

Figure 2.8: NSSF Rates dialog box
Working with Organisations

A single installation of Aren Payroll can support up to 99
different organisations. Each organisation requires a separate
licence key. The name of the organisation that is currently
open is displayed in the title bar of the main window.
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Adding a new Organisation

To add a new organisation select Add from the Organisation
menu. Use the New Organisation dialog box that follows (fig-
ure 2.9) to enter the name of the organisation and the month
from which you want to start entering data. On closing the
dialog box, the previous organisation is closed and the new
one opened.

Cancel

»
Mame |:I¢r\-:- Campary Lid OK I
__Cenedl |

Morth [re =]

Year |21:-::'2

Leed Cumerncy |T.-|';'an|.-| Shiling

Payrall Cumeney |Tanz.;na Shiling ll

Figure 2.9: New Organisation dialog box

Opening another Organisation

To open a different organisation select Open from the Organ-
isation menu. This will bring up the Open Organisation di-
alog box (figure 2.10) provided there are other organisations
defined. Select the organisation you want to open from the

dialog box.
Open Organisation x
ok | Caneel

Figure 2.10: Open Organisation dialog box



12 2 Setting Up

Deleting an Organisation

You can delete any organisation that is currently not open.
Deleting an organisation causes all its data files and folders to
be deleted. It is strongly recommended that you back up the
organisation’s database file before deleting it (see Section 5).

To delete an organisation:

1. Select Delete from the Organisation menu. To minimise
the risk of accidentally deleting an organisation you will
be required to enter your password (figure 2.11).

Delete Organisation by

Dieleting an anganeaton wil cause al s data
fies i be deleted . You are strongly advised to
l‘ back up thess fil=s before continung
o

i you ane sure you want jo continue, please
erfler your password below

Pasmpword |

Figure 2.11: First Delete Organisation dialog box

2. Next, a list of all organisations in the system, exclud-
ing the one that is open, will be displayed (figure 2.12).
Select the one you want to delete. Note that it is not pos-
sible to delete the organisation that is currently open.

Dielete Organisstion o

Derna Camparry Lid

ok | Caneel

Figure 2.12: Second Delete Organisation dialog box

3. In the two message boxes that follow, confirm that you
want to delete the selected organisation and destroy its
data files.
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4. Aren Payroll will then delete the organisation. A dia-
log box confirming that the deletion is complete will be
displayed.

Setting up an Organisation

To configure the organisation that is currently open, proceed
as follows:

Basic Organisation Information
Open the Basic Organisation Info dialog box (figure 2.13) from

the Organisation menu and enter the organisation’s address
and telephone number.

Basic Organisation Info »

Mame |Demo Restaurant Lid
Status: Mot icersed
Falder: "“TEMBIO'Payrol Data’\PayZ2Ent argll

Morth | June - Year [2022
Addreas
PO Box [123456 Town [Dar 23 Salaam
Pag Cade Telephone (022 555 555
[ ok | Cancel

Figure 2.13: Basic Organisation Info dialog box

Also, confirm that you want to start entering payroll details
in the month and year shown in the dialog box. Once you run
the first period or month end procedure you will not be able
to edit either of them.

Licensing

Select Licence from the Organisation menu to open the Licence
dialog box (figure 2.14). Type in the licence key supplied by
your dealer. If you do not have a licence key, contact your
dealer or Aren Software Ltd.
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Payroll Info

Jobs

Administrative Units

Licence X

Licence Mumber: [047E-4606

[ ok |  Cance Hep |

Figure 2.14: Licence dialog box

Open the Payroll Info dialog box (figure 2.15) by selecting
Payroll Info from the Organisation menu. FEnter the bank,
branch and account number for the organisation’s salary ac-
count. Also enter the organisation’s I'T, NSSF, NHIF, HESLB,
WCF and regional code numbers.

Payrell Info
ID Mumberg Curmencies
m [mizess Lecal Curranmcy |Ta“zama shiling
MSSF Mg, | 35F-3333 Payroll Currency |Tanzania Shiling |

NHIF Mo, | S06789
Banking

HESLE Mg, | 323008 Bank |!'1:mr..-|f: Chartered Bank ﬂ

WO Mo, [800348 Branch |CSC Dar es Salaam hd

Regional Code Mg, | 200055 Aocount Mo, | 0101253331

Sender ID | 22522

Figure 2.15: Payroll Info dialog box

In this dialog box, the Standard File Interchange (SFI) Sender
ID applies to those who submit their payroll to the bank in

electronic form. Leave this field blank if you do not already
have an SFI Sender ID.

To set up the jobs available in the organisation, open the Jobs
dialog box (figure 2.16) by selecting Jobs from the Organisa-
tion menu.

Set up the administrative units (departments, sections, etc) in
your organisation. To do this select Units from the Organisa-
tion menu.
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Stations

Pay Groups

lobs X

~

Asa. Restauram Manager 4
Badender

Bevarage Manager

Chaf Diglets
Cheef Accountant -
Cleaner

Ciok,

Oinng Room Manager
Dimctor Cliosa
Execubive Chef

Head Batender

Head Cleaner

Head Secunty

Head Wailer o

Meaa Sy | —

Praperies...

Figure 2.16: Jobs dialog box

Set up the stations (branches) in your organisation. To do this
select Stations from the Organisation menu.

Pay Groups allow you to filter payment reports according to
how employees in your organisation are paid. For example,
the bank transfer report could be filtered by bank branch or
pay date.

To set up pay groups, select Pay Groups from the Organisation
ment.

Co-operatives and Pension Funds

Insurance Companies

Employee Profiles

Create co-operative societies that employees in the organisa-
tion belong to by selecting Co-operatives from the Organisa-
tion menu.

Similarly, set up pension funds by selecting Pension Funds
from the Organisation menu.

If you need to deduct and remit insurance premiums, set up
the insurance companies involved by selecting Organisation >
Insurance Companies.

An employee profile defines attributes that are common to a
group of employees. These attributes are pay frequency, basic
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General Options

pay type (i.e., salary, daily rate or hourly rate), standard work-
ing hours (per day and per pay period) and whether overtime
is payable.

To create a profile, select Profiles from the Organisation menu
to open the Employee Profiles dialog box (figure 2.17). If there
is an employee profile marked as default, all new employees
added to the payroll will be assigned this profile.

Employee Profiles x
Staft Acd
Dislete
Properties...
Cloma

Figure 2.17: Profiles dialog box

Selecting Options > General from the Organisation menu opens
the General Options dialog box. This dialog box is used to
specify the default pay frequency. This is the pay frequency
that the program defaults to when opening the payroll trans-
actions table or initialising dialog boxes that display pay fre-
quency.

Under data entry forms, you can choose how to sort the data
presented in employee data forms as well as activate the Open
Table dialog box. This dialog box is used for filtering form
data by administrative unit, station or pay group.

The General Options dialog box also allows you to specify
when to purge old reports. Deleting old reports saves space
on the hard disk and reduces the size of backup files.

In the PDF documents section you can edit the following pass-
words.

1. Owner Password: This password allows you to open any
PDF documents that you send by email. It should not
be disclosed to employees.

2. Default User Password: Employees use the user pass-
word to open PDF documents sent to them. It is usually
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Payroll Options

General Options

Default Pay Fraguency

= Monthly 7 Weskdy
Canisl

" Biweekly " Irregular
Ha

adi

Data Entry Farms
Sort By:
0 Erplayee Murber ™ Lagt Name

[ Show Open Table dialog box

Fast Reports

Purge after | 5 yeBrs

POF Documents

Ownier Pasavord QWS

Default User Password | user

Figure 2.18: General Options dialog box

set to the last four digits of the employee’s TIN. Where
the TIN is missing, the default value you enter here is
used instead.

Selecting Options > Payroll from the Organisation menu brings
up the Payroll Options dialog box (figure 2.19). Check the op-
tion Taz average monthly pay if you prefer to calculate PAYE
on the average taxable pay in each half of the year.

Selecting the option Tazx employer pension on employee will
cause pension fund contributions made by the employer to be
added to the employee’s taxable pay. It is advisable to check
this option.

When computing taxable pay, an employee’s pension fund con-
tribution is an allowable deduction, but up to a statutory limit.
This limit is set in the PAYE Parameters dialog box (System
> PAYE Parameters). Select the option Ignore allowable pen-
ston limat if you wish to ignore this limit.

With the option to tax average monthly pay set, it is possible
for PAYE to be negative. This indicates that the employee
has already paid more tax than is due and is entitled to a
refund. Switch the option Allow negative PAYE off to limit
the minimum PAYE to zero.
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Fayroll Options x
PAYE
Lo |
¥ Tax average manthly pay
¥ Tant emplover pension on emplyas &
¥ Ignore allovwsble pension bmit —
[ Alow negative amourit
Levies
I Pay Skils Development Levy
l_ Pay Workers Compensabon Fund
et Pay
For employes paid in cash:
(+ Pay exact amount
™ Round down ta nearest Tsh l_
Figure 2.19: Payroll Options dialog box
You can also specify whether the employer contributes to SDL
and WCF. Checking the Pay Skills Development Levy option
turns on the SDL report (Report > Monthly Returns > SDL).
Similarly, checking the Pay Workers Compensation Fund op-
tion turns on the WCF report (Report > Monthly Returns
>WCF).
Finally, you can choose to round down net pay for employ-
ees paid in cash by an amount that you specify. The excess
amount is carried forward to the next month.
Logos

Selecting Options > Logos from the Organisation menu brings
up the Logos dialog box (figure 2.20). This dialog box allows
you to select image files with the organisation’s logo for use
in payslips. These files must be in the images|logos folder
located within the organisation folder.

For printed payslips you can select a PNG or JPEG file. PNG
images are typically sharper than JPEG ones but they occupy
more space.

Select a JPEG file for payslips that are sent as email attach-
ments in PDF format. Attachments are restricted to 64 KB
so the logo file must be well below that size.
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Pay Period End Days

Logos x

Printed Daouments

Remave

Email Attachments
Select...

Hemove

0K | Cancel Help

Figure 2.20: Logos dialog box

If the pay frequency is monthly, the pay period is assumed to
end on the last day of the month. For other pay frequencies
the program requires assistance from the user to determine
when each pay period ends.

For weekly and biweekly pay frequencies, the user is required
to specify the last day of the very first pay period. The pro-
gram will work out when subsequent pay periods end. In the
case of employees paid after irregular intervals, the pay period
end day must be entered for each pay period.

To initialise period end days, you need to do the following for
each pay frequency that applies to your organisation (except
monthly):

1. Make it the default pay frequency using the General Op-
tions dialog box (Organisation > Options > General).
The pay frequency selected should appear in the status
bar.

2. Open the Pay Period dialog box (figure 2.21) from the
Organisation menu and enter the pay period end day for
this pay frequency.

In any given month, the pay period end days for weekly and
biweekly employees can not be edited once the first period end
procedure for that pay frequency is run.
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Figure 2.21: Pay Period dialog box



3 Data Tables

Data for each employee is stored in two database tables, the
employee master table and one of the payroll transactions ta-
bles. There is a separate payroll transactions table for each
pay frequency. This data is used to create the various report
tables from which reports are printed.

Employee Master Table

The employee master table stores static information about
each employee. It is accessed by selecting Employee from the
File menu. This brings up a data entry form in which you
enter details about each employee (figure 3.1).

Employee Master Table

Record 1 of 45 001 Mbwdou, Chardes Shusho
[ Femonal
R Last Name | Mbuku
Payment
Other Names |Cha'||:-s-‘5|'l.|u"u
Basic Pay
Creertime Gender hd
Housing Birth Date [ § Aug 1577 =
PAYE
MIDA Card Ma.
Stabutary Deductions |
Co-operatives
Persion Funds Passport Mo.
Dther Werk Permit Ma.

Figure 3.1: Employee Master Table form

You can add and delete employee records using the Add, Delete
and Terminate commands in the Record menu.

e The Delete command simply deletes an employee record.
It is only available if the current record has not gone
through a period or month end procedure since it was
added.
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e The Terminate command transfers an employee record
from the employee master table to the leavers report ta-
ble. This transfer takes place in the period or month end
procedure that follows the termination date specified by
the user.

Most of the fields in this table are optional. However, Em-
ployee Number, Last Name, Other Names, Job Title, Admin-
istrative Unit and Station are mandatory. If an employee is
paid by bank transfer, then Bank, Branch and Account Num-
ber are also mandatory. The optional fields are also used in
various reports and should therefore not be left blank.

Payroll Transactions Tables

Each payroll transactions table stores earnings, deductions,
benefits, lump sum payments and refunds for all employees
paid in a particular pay period.

FEarnings are those cash payments that relate to the current
pay period e.g. basic pay or leave allowance. For tax purposes,
all cash earnings for all pay periods falling in a particular cal-
endar month make up the monthly cash earnings. A pay period
is deemed to fall in a particular month if its last day falls in
that month.

Benefits are private expenses of an employee that are paid by
the employer e.g. school fees, house rent or telephone bills.
These non-cash benefits are considered as income for tax pur-
poses.

Deductions are those amounts deducted from an employee’s
pay by the employer. Some of these are called statutory de-
ductions because the law requires the employer to deduct them
from the employee’s pay. The statutory deductions are PAYE,
NSSF, NHIF and tax on lump sum payments.

Lump sum payments are those cash payments that do not
relate to the current month alone. Some like gratuity and
bonuses have accrued over past months while others like ter-
minal benefits may relate to past or future months. We make
the distinction between lump sum payments and monthly cash
earnings because the two are treated differently when calcu-
lating income tax.

Refunds are payments made to an employee, e.g. travelling or
subsistence allowances, for business expenses incurred while
on duty. These payments are not income and are therefore
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not taxable.

The default payroll transactions table is accessed by select-
ing Payroll from the File menu. This displays a data entry
form (figure 3.2) where you enter earnings, deductions, bene-
fits, lump sum payments and refunds for each employee.

F'a}rrnll Transactions Table

Record 1 of 45 001 Mbuku, Charles Shugha
Earinga

Deductions Basic Pay [+ | 1 J
Benefia Overtme [~ | |

Lump Sum Fayments
House Allawance [ |

Refunds
Stabutory Deductions l
Summary l
Tanabla Pay |
1,435,000

Figure 3.2: Payroll Transactions Table form

Statutory deductions and other calculated amounts such as
taxable pay, net pay and gross pay are updated as data is
entered. This makes the calculations more transparent and
helps to reduce data entry errors.

Each payroll transactions table only includes employees who
are present in the employee master table and have the required
pay frequency. Use the Remove command in the Record menu
to suspend employees from the payroll. Suspended employees
can be restored at any time using the Record > Add command.

At installation, the payroll transactions table has two earn-
ings (Basic Pay and Overtime), three deductions (Rent, Over-
draft Recovery and Rounding C/F), two non-cash benefits
(Employer Pension and Low Interest Loan) and one refund
(Rounding B/F). These fields cannot be deleted but you can
add more according to your needs.

To add, delete or edit fields, select Earnings, Deductions, Ben-
efits, Lump Sum Payments or Refunds from the File menu. A
data entry form will be displayed showing the field attributes
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listed below (figure 3.3). To add or delete fields select Add or
Delete from the Field menu.

Deduchions

Field 2of 2

Field Hame | Savers Pension

Type |P|:115n:n Cantnbuton ;l Parameters.,, |
Amount |Percentage of Salery  v|  PEMCENEE...

I W Pre-tax deduchon
™ cens

Figure 3.3: Deductions form

The following field attributes apply to all fields:

1.

Field Name: The name of the field e.g. advance, shift
allowance.

. Type: This is used to indicate permanent fields (e.g. ba-

sic pay and rent). It is also used to specify fields that
are calculated in a unique way (e.g. hourly pay and
daily pay) and those that are associated with a balance
that is updated and displayed by the system (e.g. loan
repayments and co-operative contributions). The type
advance is used to indicate advance payments so that
appropriate reports can be generated.

Amount: This attribute specifies how the amount paid
to or deducted from each employee is arrived at. It may
be keyed in, a percentage of salary, a function of the time
worked (basic pay, overtime, hourly pay and daily pay)
or amortised (loan repayments).

Static: Static fields retain their value when a period or
month end procedure is run, whereas non-static fields
are reset to their lower limit. This is only important
for fields that are keyed in. It saves you the trouble of
having to key in the amount earned or deducted each
time a period or month end procedure is run.

Tazxable/Pre-tax deduction: For earnings the taxable at-
tribute specifies whether or not the payment is subject to
PAYE. In general, all cash earnings and most non-cash
benefits are taxable. Refunds are not taxable as they are
not a form of income.



Payroll Fields 25

The pre-tax deduction attribute indicates those deduc-
tions to be subtracted from gross income when calculat-
ing PAYE. In Tanzania the only pre-tax deductions are
contributions to registered pension funds.

Refer to the P.7 (Employer’s Guide to Pay As You Earn)
for further information.

6. Pensionable: NSSF is calculated on the total pension-
able earnings. Uncheck the pensionable option to ex-
clude any earning from this calculation.

Depending on the selection for Type and Amount attributes
the following additional attributes may be available:

1. Co-operative: The name of the co-operative associated
with the field (figure 3.4).

Ce-operative *

Name B

Figure 3.4: Co-operative dialog box

2. Pension Fund: The name of the pension fund and other
details pertaining to the current field (figure 3.5).

Pension Fund Pararmeters x
MName | Savers d 0K
Cancel

Employers Contnbution

|:aﬂ:ertsq—; aof Salary ;l
Percantage liﬂ
[ Aoply Limke

Lower Limi ]
Upperlmt [ 0

Figure 3.5: Pension Fund Parameters dialog box

3. Insurance: The name of the insurance company associ-

ated with the field.

4. Limits: The upper and lower limits that the amount
paid or deducted should be restricted to (figure 3.6).
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Lawer Limi I o

Upper Limk 1000000

[ ok |  canca |

Figure 3.6: Limits dialog box

5. Percentage: The percentage of monthly salary that should
be paid or deducted (figure 3.7).

parcertage [ 10

Cancel
W Aopiy Limita =

Loswer Limit I ]
Upper Lirt [ 500000

Figure 3.7: Percentage of Salary dialog box

6. Hourly Rate: The hourly rate to use for earnings that
are of the type Hourly Pay (figure 3.8).

¥ Basic Pay Ratex| 0.50

7 Key in reb= far sach emplayee

o] ome |

Figure 3.8: Hourly Rate dialog box

7. Daily Rate: The daily rate to use for earnings that are
of the type Daily Pay.
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Aren Payroll produces numerous reports as described below.
These reports can be viewed on the screen and printed out.
You can choose to print the entire report, a range of pages, or
just the page that you are currently viewing. Internal reports
can be sorted by either employee number or name.

You can view and print reports for current and previous pay
periods, months or years. You can also filter most reports by
administrative unit, station, pay group, bank, co-operative or
pension fund.

Reports may be printed on any printer connected to your com-
puter either directly or through a local area network. Because
all reports are formatted for A4 paper, the printer must be set
to print on A4.

1. To open a report select it from the Report menu and then
follow the on-screen instructions. For example, selecting
Report > Payslips opens the Open Payslips dialog box

(figure 4.1).
Open Payslips b

Pay Freouency _ o
Morety |
T - | ot

Pay Penod Mt |
* Cument Q
™ Previous Olplions....
Period end dals
S

Figure 4.1: Open Payslips dialog box

2. To print the open report select Print from the File menu
which brings up the Print dialog box (figure 4.2). Use the
Setup button in this dialog box to configure the printer
you want to use.
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Print X

Prirker:

HF Color Lasarlet MFP oK
M&TFdw (435382) on
WSD-2E500dET-1106-248-a 128

Cancel
Fages o pant:
ol :IS&VD
" Curenl Page
™ Pages
From: To:
Mumber of Copies: 1

Figure 4.2: Print dialog box

3. Choose Close from the File menu to close the report.

Nominal Rolls

1. Employees Roll: List of employees who are currently ac-
tive. It shows their job title, administrative unit and
station.

2. Joiners Roll: List of employees who joined the organi-
sation recently. It shows their job title, administrative
unit, station and start date.

3. Leavers Roll: List of employees who left in a given year.
It shows their final job title and administrative unit, the
date they left and the reason for leaving.

Pay Period Reports

These are reports for a specific pay frequency and cover one
pay period. For a particular pay frequency, reports for the
current pay period are updated as you update the employee
master table and the appropriate payroll transactions table.
Reports for previous pay periods can be viewed and printed
out, but they cannot be modified in any way.

Overview Reports

1. Payroll Summary: Summarises earnings and deductions
for all employees.

2. Payroll Control Account: T-account listing total earn-
ings, deductions and net pay for all employees in the
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Detail Reports

organisation.

. Muster Roll: List of employees showing all earnings,

lump sum payments, refunds and deductions for the month.
Records in this report can be grouped by administrative
unit or station.

. Payroll Variance: List of employees showing the differ-

ences in the payments and deductions made in any two
pay periods. It is essentially the difference between the
muster rolls for the two pay periods.

. Gross Pay By Unit: List of administrative units showing

the staff count and total gross pay for each.

. Gross Pay By Station: List of stations showing the staff

count and total gross pay for each.

The muster roll and payroll variance can be viewed on the
screen or saved to an XML file but they cannot be printed

. Earning Report: List showing, for a particular earning,

how much each employee was paid.

. Deduction Report: List showing, for a particular non-

statutory deduction, how much each employee was de-
ducted. Depending on the type of deduction selected, a
loan or HESLB report may be printed instead.

. Loan Report: List of employees repaying a specific co-

operative or company loan. It shows the opening and
closing balances and a breakdown of the repayment amount
into interest and principal components.

. HESLB Report: List showing the HESLB Repayment

Schedule in the required format.

. Benefit Report: List showing, for a particular non-cash

benefit, how much each employee received.

. Lump Sum Report: List showing, for a particular lump

sum payment, how much each employee received.

. Refund Report: List showing, for a particular refund,

how much each employee received.
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Payments to Employees

1. Payslips: Slip giving a breakdown of the earnings and

deductions of each employee separately (figure 4.3). The
employer’s pension contribution and the pension fund
balance can be shown in the payslip if required. When
the balance is shown, it includes the employer’s portion
only if the option to print the employer contribution has
been selected.

<0 Ao Foyall Deeres Retawant L [Paysips] = a
Fie Pags Feport Oigarisalion  Sptam Prozedirs Hls

| || | 4]w]m] | ®
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oy by 09 ez by 00

Marne Miwra), Charkes Bvesne Yamx My, Chores SaiEhs
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Adrein. Unit Managomen e, Linie: Managcneest

Suminy ] fumanzy

Exnings Exrangs

eck Py 13000300 Sk ey i 1]

Houme Abrarroe b House AbTATN 153,005

146200 5 0

Deductions Drductions

SAYE THEED AaYFE 1 A3

MEEF B0 HEEF 183500

Zaaath Fersion 11,300 Eyasis Feren 131002
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Figure 4.3: Payslips
2. Cash List: List of employees paid in cash showing their

employee number, name, net pay or advance payment
and a cash analysis of the payment amount.

Cheque List: List of employees paid by cheque showing
their employee number, name and net pay or advance
payment.

Bank Transfer Report: List of employees who are paid
by bank transfer showing their name, ID number, bank,
branch, account number and payment amount. The pay-
ment amount may be the net pay, an advance payment
or a bank loan repayment.

Labels: Envelope labels for employees paid in cash, by
cheque or by bank transfer. For cash employees, the net
pay can be shown on the label if required.

Coinage Summary Report: List showing the number of
coins and notes of each denomination that are required
for workers who are paid in cash. This information is
the same as the totals in the cash list but formatted so
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Returns

that it can be used when withdrawing the cash from a
bank.

. Co-operative Report: List of members of a particular co-

operative society showing membership number, monthly
contribution and any other payroll deductions to be paid
to that co-operative.

Pension Report: List of members of a particular pension
fund showing membership number and employer and em-
ployee contributions to that pension fund.

Insurance Company Return: List of employee premium
deductions to be paid to a particular insurance company.

Monthly Payroll Reports

The monthly reports relate to a calendar month. They are:

1.
2.
3.

Payroll Control Account.
Muster Roll.

PAYE Report: List of employees showing their PAYE
deductions.

NSSF Report: List of employees showing the total em-
ployee and employer NSSF contributions.

The NSSF return file is available under the Procedure
menu (Procedure > NSSF Return). This generates an
XML file which should be opened with Microsoft Excel
and saved again as an Excel file.

NHIF Report: List of employees showing NHIF number,
employee contribution, employer contribution and the
total NHIF deduction.

SDL Report: List showing the SDL payable to the TRA
for each employee.

WCF Report List showing the monthly return to the
Workers Compensation Fund (WCF). For each employee
it shows WCF number, ID number, basic pay and gross

pay.

Lump Sums Tax Report: List showing tax payable on
lump sum payments for each employee.
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Annual Payroll Reports

Other Reports

9.

Low Interest Benefit Report: List of employees who have
received a particular company loan at an interest rate be-
low the statutory rate. It shows the low interest benefit
these employees have received as a result.

These reports are updated after each period end procedure
and may not be complete until the month end procedure is
run. For the current month, the information displayed covers
the pay periods that have elapsed so far.

Annual payroll reports relate to a calendar year and are avail-
able throughout the year. For the current year, the informa-
tion displayed relates to the pay periods that have elapsed so
far. The reports are:

1.
2.
3.

Payroll Control Account.
Muster Roll.

Annual Pay Sheet: A report that, for each employee,
gives a summary of payments, deductions and benefits
for a whole year.

P.9: TRA form titled Tax Deduction Card. Each P.9
gives a breakdown of the income of an employee for each
month of the year and shows the amount of tax deducted.

P.10: TRA form titled Employer’s End of Year Cover-
ing Certificate. It shows the total tax deducted by the
employer for each month of the year.

. ITX215: TRA form titled PAYE Statement. It lists the

tax deducted for each employee who has paid PAYE in a
given six or twelve month period. It also shows taxable
cash earnings, non-cash benefits, pre-tax deductions and
taxable pay.

NSSF Statement: A report that shows the monthly em-
ployee and employer contributions to NSSF for a single
employee for a calendar year.

NHIF Statement: A report that shows an employee’s
monthly NHIF deductions for a calendar year.

. Bank Codes: A listing of banks, bank branches and their

sort codes drawn from the bank data tables.
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2.

Report Tables

Audit Trail: List that shows the date and time of each
login, backup, month end procedure and any other major
event. It also shows the user responsible for each event.
This report is only available to the supervisor.

Almost all reports are printed from report tables, not directly
from the employee data tables. Briefly, the report tables are:

1.

ool

Active employees report table
Annual leavers report tables
Pay period report tables
Monthly payroll report tables
Annual payroll report tables

Report tables are updated automatically by Aren Payroll. Use
the General Options dialog box (Organisation > Options >
General) to specify how long to keep these tables for.
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Backing Up

If your organisation database files are accidentally deleted or
corrupted you could lose all your data. Without an up-to-date
backup you would be forced to key in the data for the current
month again. It is also likely that you would be unable to recre-
ate data for previous months and years. It is therefore very
important that you make regular backups of your database
files.

To back up the database file for the organisation that is cur-
rently open, select Back Up from the Procedure menu. You
will be prompted to specify the name and location of the
backup file to be created (figure 5.1).

G Backup et
= i =« PayBiEnl ¢ Backas e o qearsh Back
Chegganize = M Teliier =~ 8
lerme [iztz modified vpe
3 Quick 2coass

o fems makch your sezrch
i Onclirere - Person

L3 This PC
¥ Metaxnrk
. »
File marnes
Seve astype  Beckup Files (kK]
# Hide Foldess Cance

Figure 5.1: Backup dialog box

The backup process copies all data relating to your organi-
sation to the backup file. Should you have set up more than
one organisation, you will need to back up each one separately.
Note that data that is shared by all organisations is not backed
up (e.g. list of banks and statutory deductions parameters).

When running a period or month end procedure you will be
prompted to back up. Though you can choose to proceed
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without doing so, it is recommended that you back up first.
To encourage regular back ups Aren Payroll prompts you to
back up each time you exit.

Restoring from Backup

In the event that your data tables are corrupted or deleted
you will need to recover them from a backup file. You can
also use backup files to revert to an earlier period. This is
especially useful if you accidentally run a period or month end
procedure.

To restore an organisation’s files from backup, select Restore
from the Procedure menu then follow the on-screen instruc-
tions (figure 5.2).

Restare »

Reataring fram backup wil replace al the data
for thes argarisation with that retneved from the
backup file. You are encouraged to back up
lhe argarisaion befare sartinuing

L

i wou ane sune you want io conbirue, please
erler your password below

Fassvwiord

ol | Caneel Hel

Figure 5.2: Restore dialog box

Creating a Bank Transfer File

A bank transfer file is an electronic version of the bank transfer
report. It is used by banks to process payments for employees
paid by bank transfer in place of the printed bank transfer re-
port. Aren Payroll can create bank transfer files for numerous
banks including Absa, Citibank, Stanbic and Standard Char-
tered.

1. To create a bank transfer file select Bank Transfer File
from the Procedure menu. The Save Bank Transfer File
dialog box appears (figure 5.3).

2. Specify the format of the bank transfer file to create
and the name of the payment field (usually net pay).
Depending on the file format, you may be able to specify
the date you want the bank transfer effected.
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Figure 5.3: Save Bank Transfer File dialog box

3. On closing the Save Bank Transfer File dialog box, a
standard Save As dialog box will appear. Use this dialog
to specify the name and location of the file to be created.

For further details on bank transfer files please contact your
bank.

Terminating an Employee

To terminate an employee, open the employee master table
and display the target employee. Next, select Terminate from
the Record menu. In the Terminate dialog box that appears
(figure 5.4), enter the termination date, the reason for leaving
and, if you like, some brief comments.

Terrminate Mbuku, Charles Shusha

Temination Diate
3006/ 2022 - Cancel

Reason far Leawving

=
x

.Fen'g'led ad
Remarks

Figure 5.4: Terminate dialog box

The terminated employee will be removed from the employee
data tables in the next period or month end procedure that
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is later than or on the same day as the termination date.
Once the employee is deleted from the employee data tables
his record will be added to the leavers report table.

Termination can be reversed by selecting Record > Undo Ter-
mination as long as the terminated employee has not been
removed from the employee data tables.

Closing a Pay Period

The period end procedure is used to close data entry for the
current pay period and begin a new one. The procedure does
the following:

1.

Saves all payroll information for the current pay period
to the period, monthly and annual report tables.

. Transfers terminated employees from the employee mas-

ter table to the leavers report table.

Deletes the current payroll transactions table and creates
a new one for the next pay period.

. Advances the period end day to the last day of the next

pay period.

This procedure should only be run after all reports for the
current pay period have been verified since, once it is run,
reports for this pay period cannot be changed.

To run the procedure:

1.

2.

Check that the correct pay frequency is set as default.

Select Period End from the Procedure menu. This option
is only available if you have licensed the organisation.

. After reading the dialog box that appears (figure 5.5),

confirm that you want to close the pay period stated by
entering your password.

. You will now be prompted to back up your data and are

strongly encouraged to do so.

Once the back up is complete, the period end procedure
will automatically follow and eventually a message box
confirming its completion will appear.
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Figure 5.5: Period End dialog box

Closing the Month

The month end procedure is used to close data entry for the
current month and begin a new one. It applies only to the
organisation that is currently open. It does the following:

1. Runs the period end procedure for all pay frequencies.

2. Transfers terminated employees from the employee mas-
ter table to the leavers report table.

3. Deletes any report data that is older than the limit set
in the General Options dialog box.

4. Advances the payroll month by one.

5. If the new month is July, it creates statutory deduction
tables for the new tax year.

The procedure can only be run if, for each (non-empty) payroll,
the forthcoming pay period ends in the next calendar month.
This is because, after the procedure is run, all pay period end
days will fall in the new month.

To run the procedure:

1. Select Month End from the Procedure menu. This op-
tion is not available if you have not licensed the organi-
sation. It is also not available if the next pay period for
the default pay frequency does not end in the following
month.

2. After reading the dialog box that appears (figure 5.6),
confirm that you want to close the month by entering
your password.

3. You will now be prompted to back up your data and are
strongly encouraged to do so.
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Figure 5.6: Month End Procedure dialog box

4. Once the back up is complete, the month end proce-
dure will automatically follow. Eventually, a message
box confirming its completion will appear.
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Aren Payroll accesses payroll data through a Firebird database
server, not directly. Where the data is in a local folder, it
may be accessed through the embedded Firebird server that is
installed with the application.

To access data on a shared folder on a different computer, you
need to install the full Firebird server on that computer and
configure it to work with Aren Payroll. Even when the data
folder is local, you may prefer to install Firebird. Doing so will
allow you use Aren Payroll in true multi-user mode.

Installing Firebird

1. Insert the installation CD in the CD drive.

2. Run the program Firebird 3.0\ Installation Files|Firebird-
3.0.5.33220 0 Win32.exe on the installation CD.

3. Follow the on-screen instructions that appear during the
installation process.

4. When prompted to create a password for the Database
System Administator (sysdba) make sure you do so. Us-
ing the default password could compromise the security
of your data.

5. Accept the default settings for everything else other than
the password. See figure A.1.

Copying the Encryption Library

1. Locate the folder Firebird 3.0\ Encryption Plugin in the
installation CD. This folder contains the encryption li-

brary that the Firebird server uses to encrypt database
files.

2. Copy the entire contents of this folder to the folder in
which you installed Firebird. This is most likely C:| Program
Files(x86) | Firebird | Firebird_3_ 0. Note that both fold-
ers have the same layout. Overwrite any files in the
destination folder if prompted to do so.
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Configuring Firebird

Figure A.1: Firebird Setup Wizard

You need to edit the file firebird.conf in the Firebird installa-
tion folder so that the Firebird server can work correctly with
Aren Payroll.

1.

Locate the Notepad text editor by searching for it in the
Windows search box.

. Select Run as administrator to open Notepad.
. In Notepad, locate and open firebird.conf.

. Immediately below the line #KeyHolderPlugin = add a

new line KeyHolderPlugin = Callback.

Save firebird.conf and close Notepad.

Restart the Firebird server so that the changes to firebird. conf
can take effect.

1.

Start the Services app by searching for it in the Windows
search box.
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Figure A.2: Services App

2. In the list of local services select the

Firebird server,

most likely listed as Firebird Server - DefaultInstance.

See figure A.2.
3. Restart the service.
4. Close the Services app.

The Firebird server is now ready for use.
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Appendix B

Importing Data

Employee Data

File Format

Keying in new employees into the payroll can be very time
consuming especially if there are many of them. As an al-
ternative, you can import employee data into the employee
master table from a text file.

The easiest way to create the input text file is to capture em-
ployee data in a spreadsheet and then save the spreadsheet as
a text file.

The format of the input text file is as follows:

1.

Plain text with data items separated by the tab character
(i.e. a tab-separated text file).

The first row of data is a header with the data items Em-
ployee Number, Last Name, Other Names, ID Number,
Job Title, Admin Unit, Station, Pay Rate, TIN, NSSF
Number and NHIF Number.

From row two onwards, each row has data for a single
employee, i.e. employee number, last name, other names,
ID number, job title, administrative unit, station, pay
rate, TIN, NSSF number and NHIF number.

Note that:

1.

The first row (file header) is ignored. It is only included

for the convenience of the person preparing the input
file.

. A row will not be imported if the employee number

matches that of a record already in the employee master
table.

. A row will also be skipped if any of the following data

items is blank: employee number, last name, other names,
job title, administrative unit, station.
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How to Import

. Data will be imported into several tables—employee mas-

ter, payroll transactions, jobs, adminstrative units and
stations.

. Where a default profile has been defined, it will be ap-

plied to each record added to the employee master table.

. Make sure you are in single-user mode. If not, switch to

this mode by selecting System > Single-User Mode.

. Back up your data just in case you need to undo the

changes you are about to make (Procedure > Backup).

. Select Procedure > Import Employees to open the first

Import New Employees dialog box (figure B.1).
Impart Hew Employess ®

mparting employes data from a tew file may
modfy several data filea. | is advisable to
j back up your data before cortinuing

-

i wou ane sune you want io conbirue, please
erler your password below

Fassvwiord

ol | Caneel Hel

Figure B.1: First Import New Employees dialog box

4. Enter your password to open the second Import New

Employees dialog box.

. Browse to the text file that you want to import data

from and click on Open.

. Aren Payroll will read the text file and update the data

tables listed above. On completion, a confirmation mes-
sage box will be displayed. Close the message box.

To see which records were updated, refer to the log file im-
port.log located in the payroll data folder. Browse through
the data tables that should have been updated to confirm that
they were updated successfully.

Time and Attendance Data

Aren Payroll can import time and attendance data from a text
file. This provides a quick way of capturing the data generated



Time and Attendance Data 47
Employee Name Basic Normal Double
Number Pay Overtime Overtime
001 MROSHO, James 0.5 10 3.5
002 MWIJUMA, Miriam O 0 8
003 JAKAYA, Agnes 1.5 8 4
004 BAKARI, Joe 2 0 0

Table B.1: Time and attendance data format

by a clocking system. Because the format of the input file is
standard, Aren Payroll will work with any clocking system
provided that the data it generates can be converted to the
required format. An input file can also be created by keying
in time and attendance data into a spreadsheet program and
then saving it as a text file.

File Format

The data to be imported should be saved in a text file with
the following specifications.

1. Plain text with data items separated by the tab character

(i.e. a tab-separated text file).

. The first row of data is a header with the data items

Employee Number, Name, Basic Pay, Normal Overtime
and Double Overtime.

. From row two onwards, each row has data for a sin-

gle employee, i.e. employee number, name, basic pay
time worked, normal overtime hours and double over-
time hours.

Table B.1 is a simple example of the format required.

Interpretation

The data is interpreted as follows:

1. The first row (file header) and the second column (em-

ployee name) are ignored. They are included for the
convenience of the person preparing the input file.

. The employee number in column one determines which

record in the payroll will be updated. It must match
the employee number in the payroll transactions table
exactly, except for the case which is ignored.

. The data in column three (basic pay) could be hours

worked, hours absent, days worked or days absent. Its
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How to Import

interpretation depends on the settings for each employee
in the employee master table. If an employee is paid a
fixed salary irrespective of the time worked, this value is
ignored.

Columns four and five contain normal and double over-
time hours, respectively. For a given employee, if over-
time is not enabled the data is ignored.

Here is how you import time and attendance data into the
default payroll transactions table.

1.

Make sure you are in single-user mode. If not, switch to
this mode by selecting System > Single-User Mode.

Back up your data just in case you need to undo the
changes you are about to make.

. Select Procedure > Import > Attendance to open the

Import Time and Attendance Data dialog box (figure
B.2).

Browse to the text file that you want to import data
from and click on Open.

3 kel Time and Altendares Dalu X
¢ PayBIE P -
Drganie: = M toidey L ] ﬁ
Flarne - Teks o hisd bl
B ik poces:
imooit bt
- Onclive - P
B ThaFC
b Plersene
L3 ¥
Flr name: | [t i 1t -

Figure B.2: Import Time and Attendance Data dialog box

5. Aren Payroll will read the text file and update the de-

fault payroll transactions table. On completion, a mes-
sage box showing the number of records updated will be
displayed.
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To review the imported data, open the basic pay, normal over-
time and double overtime reports (Report > Breakdown). You
should also review the log file import.log located in the payroll
data folder.
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Appendix C Emailing Reports

Aren Payroll can email payslips and P.9s to each of the em-
ployees in the payroll. This provides an alternative to printing
individual payslips or P.9s for each employee. The reports are
sent as password-protected PDF files.

In this section, we explain how to email payslips. Emailing
P.9s works in exactly the same way.

Entering Email Addresses
Start by capturing the email addresses to send reports to.

1. Open the Employee Master Table form (File > Em-
ployee) and select the Other tab (figure C.1).

Employes Master Table
Record 1 of 45 001 Mbukou, Charles Shusho

Personal

Emaloyment Email reports to:

Payment shushoi@demorestaurant.co. iz
Basic Pay

Creertima

Housing

PAYE

Satutary Deductions

Coroperatives

Persion Funids

Cither

Figure C.1: Employee Master Table form

2. For each employee, enter the address to email reports to.

3. Close the Employee Master Table form.

Setting Up Email Account

In order to send email, you need to set up your email account.
For this you require details of the outgoing mail server, also
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known as the SMTP server. Consult your IT department if
necessary or check the settings in the email software you use.

1. Select System > Email Account to open the Email Ac-
count dialog box (figure C.2).

Ernail Account 4

GeEnera

Email Address | nfo@demorestaurant. co.tz
Cance|

™ Copy all emails to self

adi

SMTF Server
Address | mail, demarestaurant. oo, tz
Part [ 25
Timeout |5‘] secands

k¥ Use s=cure cormection

Buthertication
Type |L|:~;r' T|

Account Hame | nfo@demorestaurant.ca.tz

Passvord |‘ -

Figure C.2: Email Account dialog box

2. Email Address: Enter your email address, say info@-
demorestaurant.co.tz or example@gmail.com.

3. SMTP Server: Enter the name of the outgoing mail
server, e.g. mail.demorestraurant.co.tz or smtp.gmail-
.com. You can also enter the server’s IP address, e.g.
192.168.0.23.

4. SMTP Port: The SMTP port is a unique number that
the mail server has set aside for outgoing mail. The most
common values are 25, 465 and 587. If your server uses
a secure (encrypted) connection, e.g. smip.gmail.com or
smip.mail.yahoo.com, try port 465 or 587. If it does not,
enter 25.

5. Timeout: This is length of time the software should wait
for a response from the mail server before giving up.

6. Use secure connection: Check this option if the mail
server uses a secure connection.
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10.

Sending Payslips

Authentication: You may select none (no account name
or password required), plain or login (requires account
name and password).

Account Name and Password: Enter the login name and
password for the mail server if you have selected login or
plain authentication.

Copy all emails to self: Check this option if you want to
receive a copy of all the reports you send.

Close the Email Account dialog box.

Now you are ready to email payslips to employees.

1.

Select Procedure > Email Payslips to open the Email
Payslips dialog box (figure C.3).

Ermnail Payslips x
Pay Freguency .
0K I
=
L J Cangel
Pay Period Mt |

™ Previous Clptions
Pediod ard dales

I

Figure C.3: Email Payslips dialog box

Choose the pay period that you want then click OK. This
opens the Payslip Messages dialog box (figure C.4).

Click on Send to open the Message Range dialog box
(figure C.5).

Use the Message Range dialog box to send the current
message, all messages or a range of them. On comple-
tion, a message box showing the number of messages sent
will be displayed.

Close the Payslip Messages dialog box when you are
through.
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Payslip Messages x
] ] et 3]

Send Te:  [shusho @&demorestaurant ootz Send

|

Subject: |Paysip for June 2022

Hedp
Message: |Dwear Chares,

Tour paysip for June 2022 is afached. You can save, view and print
il &l your convensnoe.

Regards,
Demo Restaurant Lbd

Aitachment; |Demo Rescaurant Lod

Payslip

Employss Mo, ool

Hama - Hbul, Charles Shasho
Pay Peciod: Jine 2023

Figure C.4: Payslip Messages dialog box

Meszage Range

K
% Curreril Massage

Cancel

0l

™ Al Messages

" Messages

Fram: I_ T I_

Figure C.5: Message Range dialog box

Details of the last mail session are saved in the log file email.log
located in the payroll data folder. Refer to this file if you have
any difficulty sending messages and to see which messages were
actually sent.

How to Open Payslips

Once a payslip is sent, the recipient will need a password to
open it. Each payslip has two passwords:

1. Owner Password: This password is set in the General
Options dialog box (Organisation > Options > General).
Use it to open any payslips you send out.

2. User Password: This is usually the last four digits of the
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employee’s TIN. Where the employee’s TIN is missing,
it defaults to the value set in the General Options dialog
box. This is the password that employees should use.

You can modify the message that is sent to employees to in-
clude help on the password they will use to open the payslip.

1. Go to Procedure > Email Payslips to open the Email
Payslips dialog box.

2. Click on Options to open the Electronic Payslip Options
dialog box (figure C.6).

Electranic Payslip Options x
Message Print
¥ Include password help W Jab Tike II
™ 1D rumbers Cancel

Sant By

{+ Employee number

" Mame

Layout
[ Ful page
[T Exdended header

Haadings
" Back ¥ Red

(" Geen ( Bue

[T Payment mode
W PAYE breakdown
W Loan breakdown

¢ Empiloyer pension
[ Pension balance
™ Coop balance
W Loan balance

Figure C.6: Electronic Payslip Options dialog box

3. Check the option Include password help.
4. Close the Electronic Payslip Options dialog box.
5. Close the Email Payslips dialog box.
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Appendix D Formulae

Loans

Amortisation

Reducing Balance

The loan payment amount is uniform throughout the repay-
ment period. The portion of the payment amount that goes
towards repaying the principal increases with time as interest
payments reduce.

]
I—(1+r)"

Payment = l

where W = principal amount, n = total number of payments,
r = monthly interest rate (e.g. if annual interest rate is 15%,
r = (15/100)/12 = 0.0125).

The amount paid towards the principal is fixed throughout the
loan duration while interest payments reduce with time. Thus
the total payment amount reduces with time.

1
Payment = W' (/ + 7’)
n

where W’ = outstanding balance, n’ = number of payments
outstanding, » = monthly interest rate.



