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1 Introduction

About Aren Payroll

Getting Started

Installation

Aren Payroll is a payroll program that runs in the Microsoft
Windows environment. It enables you to set up a database
containing pay details of the employees in your organisation.
Data entry is interactive with income tax, loan payments, pen-
sion fund balances and other calculated amounts updated and
displayed as you work.

The system produces several payroll reports such as payslips,
payroll summary, payroll control account, cash and cheque
lists as well as monthly and annual tax returns. All reports
are formatted for A4 paper so there is no need to buy special
stationery.

Access to the system requires a username and a password.
There is one permanent user who has unrestricted access to
the entire system. Other users can be added at any time and
assigned access to those functions they need to use.

The program can be configured to suit the needs of your organ-
isation. For example, you can define an unlimited number of
payments and deductions. You can also update the tables used
for calculating statutory deductions should the need arise.

Aren Payroll supports multiple organisations which is conve-
nient if you need to run the payroll of more than one organisa-
tion on a single computer. A separate licence key is required
for each organisation.

To use Aren Payroll you must first install it and configure it
to suit your needs. The rest of this section shows you how to
begin this process.

To install Aren Payroll:
1. Insert the installation CD in the CD drive.
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2. Run the program Pay825td|Install|setup.eze on the in-
stallation CD.

Waealcome to the Aren Payroll 8.2 Standard Edition |

Setup Wizard =)
Thea inztaller wil guide wou thicugh the steps iequired to instal Arsn Papoll 8.2 Standard Edition on
PO computer.

WARNING: This compubes program it protectad by copsight law and inbemational beaties.
Urnauthonzed duplicaton or disibubion of this program, or ary portion of ik, may result in sevane civil
or cimnal penakes. and vl be prozecuted fo the maamum extent possible under the law

< Back MNewt » Cancal

Figure 1.1: Setup Wizard

3. Follow the on-screen instructions that appear during the
installation process (figure 1.1).

The installation process copies the files required by Aren Pay-
roll to the folder you specify on the hard disk of your com-
puter. It will also add Aren Payroll and its Help file to the
Start menu.

Creating a Data Folder

1. Once the installation process is complete, run Aren Pay-
roll by selecting it from the Start menu.

AREN PAYROLL

Version 8.2
Standard Edtion for Tanzania
= Aren Softwore Lid, 1998-2022

[None]

logn.. |  Cancel || DataFolder. |

Figure 1.2: Start dialog box
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Logging In

2. In the Start dialog box that appears (figure 1.2), click on

Data Folder to open the Data Folders dialog box (figure
1.3).

Data Folders »

Available Folders

Creale. .. Select... Settings. ..

Target Folder
[Flon=]

Figure 1.3: Data Folders dialog box

. Click on Create in the Data Folders dialog to create a

new data folder in which to store Aren Payroll data. The
data folder must be located on the computer running
Aren Payroll, not on a network drive.

Make sure you have unrestricted access to whichever lo-
cation you choose, otherwise the software may not work

properly.

. Close the Data Folders dialog to return to the Start di-

alog.

. Within the Start dialog, click on Login to open the Login

dialog box.

. In the Login dialog box enter the username supervisor

(figure 1.4).

. You will be prompted to enter a password for use in

subsequent logins (figure 1.5). Enter a password of your
choice.

. A message box (figure 1.6) will then appear asking if you

would like to copy sample data. Choose No to proceed
to set up your organisation.
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Figure 1.5: Set Password dialog box

@ ‘Would you like to copy sample data to this data folder?

Mo
Figure 1.6: Sample data message box

5. The New Organisation dialog box is displayed next (fig-
ure 1.7). Type in the name of your organisation and the
month from which you want to start entering data.

mﬂ|l:lumﬂuaml.m

Memth | Jure vI
Year Iﬁ

Lo Cumency |Tnmiu Shiling

Payrol Curency | Tanzania Shiling

Figure 1.7: New Organisation dialog box

6. Close the New Organisation dialog box to begin using



Moving On

Moving On

Aren Payroll.

Before entering employee data you need to finish setting up
the program. Section 2 explains how to do this. To enter
employee data refer to Section 3 which describes the employee
data tables in Aren Payroll.

After entering employee data you can view the reports de-
scribed in Section 4. With the exception of the muster roll
and payroll variance, all reports can be printed out on A4 pa-
per. Use the muster roll to export payroll data to an XML file
in Microsoft Excel format.

To close the current pay period and start a new one, run the
month end procedure described in Section 5. That section
also describes how to back up and restore data and create
bank transfer files.
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Before entering details about employees, use the Organisation
and System menus to configure the program. The Organi-
sation menu options apply only to the organisation that you
are currently working with whereas those of the System menu
apply to all organisations that you define.

Setting up the System

Users

Aren Payroll supports an unlimited number of users. There is
always at least one user, supervisor. The supervisor has access
to all functions including adding and deleting other users and
assigning such users access to program functions. By restrict-
ing users to only those parts of the program they need for their
work, it is possible to enforce separation of duties.

If you wish to add new users at this stage, do the following:

1. Select Users from the System Menu. This displays the
Users dialog box (figure 2.1).

Users X

Add,..

i

Password, .,

il

Claze

Figure 2.1: Users dialog box

2. Click on the Add button which brings up the User Iden-
tity dialog box (figure 2.2).

3. In the User Identity dialog enter the username. You may
also enter the user’s real name to help you identify him
or her in future.
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User Identity ®

Lis=rmame uma

Last Mame Mwanzhamisi

Other Names | Juma
QK I Caniel |

Figure 2.2: User Identity dialog box

4. Close the User Identity dialog and choose Rights from
the Users dialog box. This displays the User Rights di-
alog box (figure 2.3).

User Rights for jurna x
Funchicns
[V Edi emplves dala
¥ Modiy payrol fields Carel

¥ Set up apen organization

¥ Close pay period or morth
[ Aestore from backup

[ Add and delete orgarsabons

¥ Modiy tax tables

Figure 2.3: User Rights dialog box

5. Use this dialog box to specify the functions that you
would like the user to have access to.

6. Close the User Rights dialog box and choose Password
from the Users dialog box. This brings up the Set Pass-
word dialog box (figure 2.4).

Set Password for juma 4
Iﬂsmrd ......... D_{
Canfim [ Cancel
Papsward —

Figure 2.4: Set Password dialog box

7. Enter and confirm the password if you wish. If you do
not enter a password at this stage, the user will be re-
quired to enter one when logging in for the first time.
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8. Close the Set Password dialog box. You can add more
users by repeating the procedure above.

9. Click on Close in the Users dialog box.

Banks

Aren Payroll comes with a comprehensive list of banks and
their branches. You will need this list for employees paid by
bank transfer rather than in cash or by cheque. The list is
shared by all organisations that you create. To review or mod-
ify it, select Banks from the System menu which will bring up
the Bank and Branches dialog box (figure 2.5).

Banks and Branches

: -

+ Akba Commeroal Bank Add Bark...
« Amana Bank

# Azara Bark Add Branch
+ BancABC

+ Bank of Afnca
+ Bank of Baroda
+ Bank of India Fraperteag,.,
+ Canara Bank
# Chira Dasheng Bark Close
# Cribark

+ CRDE Bank

+ DCB Commerdal Bank

+ Diamond Trust Bank

# Ecobank

# Equity Bank

# Exim Bank

+ First National Bank v

x

10T

Figure 2.5: Banks and Branches dialog box

Statutory Deductions Parameters

PAYE is calculated using brackets and rates that are stored in
a table. To view and update this table select PAYE Rates from
the System menu (figure 2.6). Refer to the Tanzania Revenue
Authority (TRA) website for the latest PAYE table.

The calculation of PAYE depends on a number of other parameters—
non-resident tax rate, allowable pension fund contribution and
statutory interest rate. Update these parameters by selecting
System > PAYE Parameters to open the PAYE Parameters
dialog box (figure 2.7).

NSSF and NHIF contributions are percentages of employee
income. To modify these percentages select NSSF Rates or
NHIF Rates from the System menu (figure 2.8).
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| Lower Limt | Upper Limt | Tax Ratery |
) 270000 000 [ et |
7000 520000 800
520001 Te0000 20.00 Dieleta
TED00 1000000 25.00 —J
1000001 - Nane - 30.00 Bt

_ O |

Figure 2.6: PAYE Rates dialog box

Maximum Allwable Pension Fund 200000 IE
Cancel I
Statutory Interest Rate {9
July to December 0.00
Jaruary to June .00
Mon-Resident Tax Rate (%) 15,00

Figure 2.7: PAYE Parameters dialog box

Contribution
Percentage of pensonable pay: %I
Employee 10,00

Emphayer 10.00

Figure 2.8: NSSF Rates dialog box
Working with Organisations

A single installation of Aren Payroll can support up to 99
different organisations. Each organisation requires a separate
licence key. The name of the organisation that is currently
open is displayed in the title bar of the main window.
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Adding a new Organisation

To add a new organisation select Add from the Organisation
menu. Use the New Organisation dialog box that follows (fig-
ure 2.9) to enter the name of the organisation and the month
from which you want to start entering data. On closing the
dialog box, the previous organisation is closed and the new
one opened.

Cancel

»
Mame |:I¢r\-:- Campary Lid OK I
__Cenedl |

Morth [re =]

Year |21:-::'2

Leed Cumerncy |T.-|';'an|.-| Shiling

Payrall Cumeney |T:‘|"IEI'IIEI Shilling

Figure 2.9: New Organisation dialog box

Opening another Organisation

To open a different organisation select Open from the Organ-
isation menu. This will bring up the Open Organisation di-
alog box (figure 2.10) provided there are other organisations
defined. Select the organisation you want to open from the

dialog box.
Open Organisation x
ok | Caneel

Figure 2.10: Open Organisation dialog box
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Deleting an Organisation

You can delete any organisation that is currently not open.
Deleting an organisation causes all its data files and folders to
be deleted. It is strongly recommended that you back up the
organisation’s database file before deleting it (see Section 5).

To delete an organisation:

1. Select Delete from the Organisation menu. To minimise
the risk of accidentally deleting an organisation you will
be required to enter your password (figure 2.11).

Delete Organisation by

Dieleting an anganeaton wil cause al s data
fies i be deleted . You are strongly advised to
l‘ back up thess fil=s before continung
o

i you ane sure you want jo continue, please
erfler your password below

Pasmpword |

Figure 2.11: First Delete Organisation dialog box

2. Next, a list of all organisations in the system, exclud-
ing the one that is open, will be displayed (figure 2.12).
Select the one you want to delete. Note that it is not pos-
sible to delete the organisation that is currently open.

Dielete Organisstion o

Derna Camparry Lid

ok | Caneel

Figure 2.12: Second Delete Organisation dialog box

3. In the two message boxes that follow, confirm that you
want to delete the selected organisation and destroy its
data files.
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4. Aren Payroll will then delete the organisation. A dia-
log box confirming that the deletion is complete will be
displayed.

Setting up an Organisation

To configure the organisation that is currently open, proceed
as follows:

Basic Organisation Information
Open the Basic Organisation Info dialog box (figure 2.13) from

the Organisation menu and enter the organisation’s address
and telephone number.

Basic Organisation Info »

Mame |Demo Restaurant Lid
Status: Mot icersed

Falder: D-\Payroll Data\Pay825td org 01

Morth | June - Year [2022
Addreas
PO Box [123456 Town [Dar 23 Salaam
Pag Cade Telephone (022 555 555
[ ok | Cancel

Figure 2.13: Basic Organisation Info dialog box

Also, confirm that you want to start entering payroll details
in the month and year shown in the dialog box. Once you
run the first month end procedure you will not be able to edit
either of them.

Licensing

Select Licence from the Organisation menu to open the Licence
dialog box (figure 2.14). Type in the licence key supplied by
your dealer. If you do not have a licence key, contact your
dealer or Aren Software Ltd.
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Payroll Info

Jobs

Licence X

Licence Mumber: [047E-4606

| ok | cacd | Heo |

Figure 2.14: Licence dialog box

Open the Payroll Info dialog box (figure 2.15) by selecting
Payroll Info from the Organisation menu. FEnter the bank,

branch and account number for the organisation’s salary ac-
count. Also enter the organisation’s I'T, NSSF, NHIF, HESLB,
WCF and regional code numbers.

Payrell Infa

ID Mumbsars Currences

TIN | [T123456 Local Currency | Tanzania Shilng

MESE Mg, | 555-3333 Payroll Currency |Tanza*1|a shilng
NHIF Mo, | 506789
Banlang

HESLE Mo, | 329008

Bank |St:rlm': Chartered Bank |
WOF Mg, | 300946 Branch |IL'.SC Dlar &5 Salaam ﬂ

Regional Code Mo, |-_’Clli-'355 Account Mo, | 0101253331

Sender ID | 22522

o | Cancel |

Figure 2.15: Payroll Info dialog box

In this dialog box, the Standard File Interchange (SFI) Sender
ID applies to those who submit their payroll to the bank in
electronic form. Leave this field blank if you do not already

have an SFI Sender ID.

To set up the jobs available in the organisation, open the Jobs
dialog box (figure 2.16) by selecting Jobs from the Organisa-
tion menu.



Setting up an Organisation 15

Administrative Units

Stations

Pay Groups

lobs X

~

Asa. Restauram Manager 4
Badender

Bevarage Manager

Chaf Diglets
Cheef Accountant -
Cleaner

Ciok,

Oinng Room Manager
Dimctor Cliosa
Execubive Chef

Head Batender

Head Cleaner

Head Secunty

Head Wailer o

Meaa Sy | —

Praperies...

Figure 2.16: Jobs dialog box

Set up the administrative units (departments, sections, etc) in
your organisation. To do this select Units from the Organisa-
tion menu.

Set up the stations (branches) in your organisation. To do this
select Stations from the Organisation menu.

Pay Groups allow you to filter payment reports according to
how employees in your organisation are paid. For example,
the bank transfer report could be filtered by bank branch or
pay date.

To set up pay groups, select Pay Groups from the Organisation
menu.

Co-operatives and Pension Funds

Insurance Companies

Create co-operative societies that employees in the organisa-
tion belong to by selecting Co-operatives from the Organisa-
tion menu.

Similarly, set up pension funds by selecting Pension Funds
from the Organisation menu.

If you need to deduct and remit insurance premiums, set up
the insurance companies involved by selecting Organisation >
Insurance Companies.
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Employee Profiles

General Options

An employee profile defines attributes that are common to
a group of employees. These attributes are pay frequency,
basic pay type (i.e., salary, daily rate or hourly rate), standard
working hours (per day and per month) and whether overtime
is payable.

To create a profile, select Profiles from the Organisation menu
to open the Profiles dialog box (figure 2.17). If there is an
employee profile marked as default, all new employees added
to the payroll will be assigned this profile.

Ernpleyee Prafiles x
Sttt Add
Diglete
Properties...
ol

Figure 2.17: Profiles dialog box

Selecting Options > General from the Organisation menu opens
the General Options dialog box (figure 2.18). This dialog box
allows you to choose the sort order for employee data entry
forms. It also allows you to activate the Open Table dialog
box used for filtering form data by administrative unit, sta-
tion or pay group.

You can also specify when to purge old reports. Deleting old
reports saves space on the hard disk and reduces the size of
backup files.

In the PDF documents section you can edit the following pass-
words.

1. Owner Password: This password allows you to open any
PDF documents that you send by email. It should not
be disclosed to employees.

2. Default User Password: Employees use the user pass-
word to open PDF documents sent to them. It is usually
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Payroll Options

Diata Entry Forms
Sort [ o ]
* Employee Mumber ™ Last Mame Cancel
[ show Open Table dialog box Help
—Past Reparts

Purpe aﬂzf|_5 yEars

PDF Douments

Owireer Pasgword Iﬂ'ﬁ'l'!f
Defaull Ussr Passeaord Iu:l:r

Figure 2.18: General Options dialog box

set to the last four digits of the employee’s TIN. Where
the TIN is missing, the default value you enter here is
used instead.

Selecting Options > Payroll from the Organisation menu brings
up the Payroll Options dialog box (figure 2.19). Check the op-
tion Taz average monthly pay if you prefer to calculate PAYE
on the average taxable pay in each half of the year.

—PAYE

[¥ Tax average manthly pay
[ Tax emplover pension on employes

[+ Tgnore allowebls pension fmit

‘il

™ allow negatve amourit

Levies

i Pay Skils Development Levy

[~ Pay Warkers Compensaton Fund

—Met Fay
For employes paid in cash:
% Pay exact amount
™ Round down to nearest Tsh l_

Figure 2.19: Payroll Options dialog box
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Logos

Selecting the option Tax employer pension on employee will
cause pension fund contributions made by the employer to be
added to the employee’s taxable pay. It is advisable to check
this option.

When computing taxable pay, an employee’s pension fund con-
tribution is an allowable deduction, but up to a statutory limit.
This limit is set in the PAYE Parameters dialog box (System
> PAYE Parameters). Select the option Ignore allowable pen-
ston limit if you wish to ignore this limit.

With the option to tax average monthly pay set, it is possible
for PAYE to be negative. This indicates that the employee
has already paid more tax than is due and is entitled to a
refund. Switch the option Allow negative PAYE off to limit
the minimum PAYE to zero.

You can also specify whether the employer contributes to SDL
and WCF. Checking the Pay Skills Development Levy option
turns on the SDL report (Report > Monthly Returns > SDL).
Similarly, checking the Pay Workers Compensation Fund op-
tion turns on the WCF report (Report > Monthly Returns
>WCF).

Finally, you can choose to round down net pay for employ-
ees paid in cash by an amount that you specify. The excess
amount is carried forward to the next month.

Selecting Options > Logos from the Organisation menu brings
up the Logos dialog box (figure 2.20). This dialog box allows
you to select image files with the organisation’s logo for use
in payslips. These files must be in the images|logos folder
located within the organisation folder.

For printed payslips you can select a PNG or JPEG file. PNG
images are typically sharper than JPEG ones but they occupy
more space.

Select a JPEG file for payslips that are sent as email attach-
ments in PDF format. Attachments are restricted to 64 KB
so the logo file must be well below that size.
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—Printed Doouments
Bemave I

—Email Attachments
_Renoe |
ok | coe | Hep |

Figure 2.20: Logos dialog box
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3 Data Tables

Data for each employee is stored in two database tables, the
employee master table and the payroll transactions table. This
data is used to create the various report tables from which
reports are printed.

Employee Master Table

The employee master table stores static information about
each employee. It is accessed by selecting Employee from the
File menu. This brings up a data entry form in which you
enter details about each employee (figure 3.1).

Employes Master Table

Record 1 of 45 001 Mbwukou, Charles Shusho
[ Famonal
R Lask Name | Mbuku
Payment
Other Names | Charles Shusha
Basic Pay
Creertime Gender hd
Housing Birth Date [ 5 Aug 1577 =
PAYE
MIDHA Card Ma.
Stabutory Deductions
Co-operatives
Pension Funda Passport Mo.
Dther Werk Permit Na

Figure 3.1: Employee Master Table form

You can add and delete employee records using the Add, Delete
and Terminate commands in the Record menu.

e The Delete command simply deletes an employee record.
It is only available if no month end procedure has been
run since the current employee was added.

e The Terminate command transfers an employee record
from the employee master table to the leavers report ta-
ble. This transfer takes place in the month end procedure
that follows the termination date specified by the user.
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Most of the fields in this table are optional. However, Em-
ployee Number, Last Name, Other Names, Job Title, Admin-
istrative Unit and Station are mandatory. If an employee is
paid by bank transfer, then Bank, Branch and Account Num-
ber are also mandatory. The optional fields are used in various
reports and should therefore not be left blank.

Payroll Transactions Table

The payroll transactions table stores earnings, deductions, ben-
efits, lump sum payments and refunds for each employee for
the current month.

FEarnings (or monthly cash earnings) are those cash payments
that relate to the current month e.g. basic pay or leave al-
lowance.

Benefits are private expenses of an employee that are paid by
the employer e.g. school fees, house rent or telephone bills.
These non-cash benefits are considered as income for tax pur-
poses.

Deductions are those amounts deducted from an employee’s
pay by the employer. Some of these are called statutory de-
ductions because the law requires the employer to deduct them
from the employee’s pay. The statutory deductions are PAYE,
NSSF, NHIF and tax on lump sum payments.

Lump sum payments are those cash payments that do not
relate to the current month alone. Some like gratuity and
bonuses have accrued over past months while others like ter-
minal benefits may relate to past or future months. We make
the distinction between lump sum payments and monthly cash
earnings because the two are treated differently when calcu-
lating income tax.

Refunds are payments made to an employee, e.g. travelling or
subsistence allowances, for business expenses incurred while
on duty. These payments are not income and are therefore
not taxable.

The payroll transactions table is accessed by selecting Payroll
from the File menu. This displays a data entry form (figure
3.2) where you enter earnings, deductions, benefits, lump sum
payments and refunds for each employee.

Statutory deductions and other calculated amounts such as
taxable pay, net pay and gross pay are updated as data is
entered. This makes the calculations more transparent and
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Payroll Transactions Table

Recard 1 of 45 001 Mbuku, Chades Shusha
Deductions Basicray [# [ 1,300,000 J
Beneiia Overtme [~ [ 0 .|
Lump Sum Payments House Alowance [ |
Refunds
Srabutary Deductions l
Summary l
Taxabla Pay |

I
1,495,000

Figure 3.2: Payroll Transactions Table form

helps to reduce data entry errors. The payroll transactions ta-
ble can only include employees present in the employee master
table. Use the Remove command in the Record menu to sus-
pend employees from the payroll. Suspended employees can
be restored at any time using the Record > Add command.

Payroll Fields

At installation, the payroll transactions table has two earn-
ings (Basic Pay and Overtime), three deductions (Rent, Over-
draft Recovery and Rounding C/F), two non-cash benefits
(Employer Pension and Low Interest Loan) and one refund
(Rounding B/F). These fields cannot be deleted but you can
add more according to your needs.

To add, delete or edit fields, select Earnings, Deductions, Ben-
efits, Lump Sum Payments or Refunds from the File menu. A
data entry form will be displayed showing the field attributes
listed below (figure 3.3). To add or delete fields select Add or
Delete from the Field menu.

The following field attributes apply to all fields:

1. Field Name: The name of the field e.g. advance, shift
allowance.

2. Type: This is used to indicate permanent fields (e.g. ba-
sic pay and rent). It is also used to specify fields that
are calculated in a unique way (e.g. hourly pay and
daily pay) and those that are associated with a balance
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Deduchions

Fizld 3of 3

Fiedd Mame [Savers Penaon

Type  |Persion Contrbwon  v|  Parameters.

Amourt | Perceriage of Salary - | Fercantage..

I Preax deduction

Figure 3.3: Deductions form

that is updated and displayed by the system (e.g. loan
repayments and co-operative contributions). The type
advance is used to indicate advance payments so that
appropriate reports can be generated.

. Amount: This attribute specifies how the amount paid

to or deducted from each employee is arrived at. It may
be keyed in, a percentage of salary, a function of the time
worked (basic pay, overtime, hourly pay and daily pay)
or amortised (loan repayments).

. Static: Static fields retain their value when the month

end procedure is run, whereas non-static fields are reset
to their lower limit. This is only important for fields that
are keyed in. It saves you the trouble of having to key
in the amount earned or deducted each time the month
end procedure is run.

. Tazable/Pre-tax deduction: For earnings the taxable at-

tribute specifies whether or not the payment is subject to
PAYE. In general, all cash earnings and most non-cash
benefits are taxable. Refunds are not taxable as they are
not a form of income.

The pre-tax deduction attribute indicates those deduc-
tions to be subtracted from gross income when calculat-
ing PAYE. In Tanzania the only pre-tax deductions are
contributions to registered pension funds.

Refer to the P.7 (Employer’s Guide to Pay As You Earn)
for further information.

. Pensionable: NSSF is calculated on the total pension-

able earnings. Uncheck the pensionable option to ex-
clude any earning from this calculation.
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Depending on the selection for Type and Amount attributes
the following additional attributes may be available:

1. Co-operative: The name of the co-operative associated
with the field (figure 3.4).

Co-operstive x

[LES | Dema Coop -

Figure 3.4: Co-operative dialog box

2. Pension Fund: The name of the pension fund and other
details pertaining to the current field (figure 3.5).

Pension Fund Pararmeters x
MName | Savers - 0K I
Cancel
Employers Coninbution ks

|=aﬂ::ert5qe aof Salary j

Fercantage IW
[ Apply Limke

Lower Limi ]
Upper Limi li

Figure 3.5: Pension Fund Parameters dialog box

3. Insurance: The name of the insurance company associ-
ated with the field.

4. Limits: The upper and lower limits that the amount
paid or deducted should be restricted to (figure 3.6).

Limits o
Lawer Limit ]
Upper Limk 1000000

[ ok | Cancel |

Figure 3.6: Limits dialog box
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Percentage of Salary x
Percentage | 10 K I
Cancel
W Apply Limita
Lewer Limit 0
Upper Limit 500000

Figure 3.7: Percentage of Salary dialog box

5. Percentage: The percentage of monthly salary that should
be paid or deducted (figure 3.7).

6. Hourly Rate: The hourly rate to use for earnings that
are of the type Hourly Pay (figure 3.8).

Haurly Rate b4

% Basic Pay Ratex| D50

7 Key in rabe far sach emplayee

OK I Canced |

Figure 3.8: Hourly Rate dialog box

7. Daily Rate: The daily rate to use for earnings that are
of the type Daily Pay.
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Aren Payroll produces numerous reports as described below.
These reports can be viewed on the screen and printed out.
You can choose to print the entire report, a range of pages, or
just the page that you are currently viewing. Internal reports
can be sorted by either employee number or name.

You can view and print reports for current as well as past
months and years. You can also filter most reports by ad-
ministrative unit, station, pay group, bank, co-operative or
pension fund.

Reports may be printed on any printer connected to your com-
puter either directly or through a local area network. Because
all reports are formatted for A4 paper, the printer must be set
to print on A4.

1. To open a report select it from the Report menu and then
follow the on-screen instructions. For example, selecting
Report > Payslips opens the Open Payslips dialog box

(figure 4.1).
Open Payslips b
Pay Penod _ o
Year |2022 Canced
Momth |,.u-e il Neat |

Oiptions

fi

Figure 4.1: Open Payslips dialog box

2. To print the open report select Print from the File menu
which brings up the Print dialog box (figure 4.2). Use the
Setup button in this dialog box to configure the printer
you want to use.
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Print X

Prirker:

HF Color Lasarlet MFP oK
M&TFdw (435382) on
WSD-2E500dET-1106-248-a 128

Cancel
Fages o pant:
ol :IS&VD
" Curenl Page
™ Pages
From: To:
Mumber of Copies: 1

Figure 4.2: Print dialog box

3. Choose Close from the File menu to close the report.

Nominal Rolls

1. Employees Roll: List of employees who are currently ac-
tive. It shows their job title, administrative unit and
station.

2. Joiners Roll: List of employees who joined the organi-
sation recently. It shows their job title, administrative
unit, station and start date.

3. Leavers Roll: List of employees who left in a given year.
It shows their final job title and administrative unit, the
date they left and the reason for leaving.

Monthly Payroll Reports

The monthly payroll reports relate to a single month. Reports
for the current month are updated as you update the employee
master table and the payroll transactions table. Reports for
previous months can be viewed and printed out, but they can-
not be modified in any way.

Overview Reports

1. Payroll Summary: Summarises earnings and deductions
for all employees.

2. Payroll Control Account: T-account listing total earn-
ings, deductions and net pay for all employees in the
organisation.
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3. Muster Roll: List of employees showing all earnings,
lump sum payments, refunds and deductions for the month.
Records in this report can be grouped by administrative
unit or station.

4. Payroll Variance: List of employees showing the differ-
ences in the payments and deductions made in any two
pay periods. It is essentially the difference between the
muster rolls for the two pay periods.

5. Gross Pay By Unit: List of administrative units showing
the staff count and total gross pay for each.

6. Gross Pay By Station: List of stations showing the staff
count and total gross pay for each.

The muster roll and payroll variance can be viewed on the
screen or saved to an XML file but they cannot be printed
out.

Detail Reports

1. FEarning Report: List showing, for a particular earning,
how much each employee was paid.

2. Deduction Report: List showing, for a particular non-
statutory deduction, how much each employee was de-
ducted. Depending on the type of deduction selected, a
loan or HESLB report may be printed instead.

3. Loan Report: List of employees repaying a specific co-
operative or company loan. It shows the opening and
closing balances and a breakdown of the repayment amount
into interest and principal components.

4. HESLB Report: List showing the HESLB Repayment
Schedule in the required format.

5. Benefit Report: List showing, for a particular non-cash
benefit, how much each employee received.

6. Lump Sum Report: List showing, for a particular lump
sum payment, how much each employee received.

7. Refund Report: List showing, for a particular refund,
how much each employee received.

Payments to Employees

1. Payslips: Slip giving a breakdown of the earnings and
deductions of each employee separately (figure 4.3). The
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Statutory Returns

employer’s pension contribution and the pension fund
balance can be shown in the payslip if required. When
the balance is shown, it includes the employer’s portion
only if the option to print the employer contribution has
been selected.
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Figure 4.3: Payslips

. Cash List: List of employees paid in cash showing their

employee number, name, net pay or advance payment
and a cash analysis of the payment amount.

. Cheque List: List of employees paid by cheque showing

their employee number, name and net pay or advance
payment.

. Bank Transfer Report: List of employees who are paid

by bank transfer showing their name, ID number, bank,
branch, account number and payment amount. The pay-
ment amount may be the net pay, an advance payment
or a bank loan repayment.

. Coinage Summary Report: List showing the number of

coins and notes of each denomination that are required
for workers who are paid in cash. This information is
the same as the totals in the cash list but formatted so

that it can be used when withdrawing the cash from a
bank.

. PAYFE Report: List of employees showing their PAYE

deductions.

. NSSF Report: List of employees showing the total em-

ployee and employer NSSF contributions.
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Other Returns

Annual Payroll Reports

The NSSF return file is available under the Procedure
menu (Procedure > NSSF Return). This generates an
XML file which should be opened with Microsoft Excel
and saved again as an Excel file.

. NHIF Report: List of employees showing NHIF number,

employee contribution, employer contribution and the
total NHIF deduction.

. SDL Report: List showing the SDL payable to the TRA

for each employee.

. WCF Report: List showing the monthly return to the

Workers Compensation Fund (WCF). For each employee
it shows WCF number, ID number, basic pay and gross

pay.

. Lump Sums Tax Report: List showing tax payable on

lump sum payments for each employee.

. Low Interest Benefit Report: List of employees who have

received a particular company loan at an interest rate be-
low the statutory rate. It shows the low interest benefit
these employees have received as a result.

. Co-operative Report: List of members of a particular co-

operative society showing membership number, monthly
contribution and any other payroll deductions to be paid
to that co-operative.

. Pension Report: List of members of a particular pension

fund showing membership number and employer and em-
ployee contributions to that pension fund.

. Insurance Company Return: List of employee premium

deductions to be paid to a particular insurance company.

Annual payroll reports relate to a calendar year and are avail-
able throughout the year. For the current year, the informa-
tion displayed relates to the months that have elapsed so far.
The reports are:

1. Payroll Control Account.
2. Muster Roll.
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Other Reports

Report Tables

3. Annual Pay Sheet: A report that, for each employee,
gives a summary of payments, deductions and benefits
for a whole year.

4. P.9: TRA form titled Tax Deduction Card. Each P.9
gives a breakdown of the income of an employee for each
month of the year and shows the amount of tax deducted.

5. P.10: TRA form titled Employer’s End of Year Cover-
wng Certificate. It shows the total tax deducted by the
employer for each month of the year.

6. ITX215: TRA form titled PAYFE Statement. It lists the
tax deducted for each employee who has paid PAYE in a
given six or twelve month period. It also shows taxable
cash earnings, non-cash benefits, pre-tax deductions and
taxable pay.

7. NSSF Statement: A report that shows the monthly em-
ployee and employer contributions to NSSF for a single
employee for a calendar year.

8. NHIF Statement: A report that shows an employee’s
monthly NHIF deductions for a calendar year.

1. Bank Codes: A listing of banks, bank branches and their
sort codes drawn from the bank data tables.

2. Audit Trail: List that shows the date and time of each
login, backup, month end procedure and any other major
event. It also shows the user responsible for each event.
This report is only available to the supervisor.

Almost all reports are printed from report tables, not directly
from the employee data tables. Briefly, the report tables are:

1. Active employees report table
2. Annual leavers report tables
3. Monthly payroll report tables
4. Annual payroll report tables

Report tables are updated automatically by Aren Payroll. Use
the General Options dialog box (Organisation > Options >
General) to specify how long to keep these tables for.
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Backing Up

If any of your organisation database files is accidentally deleted
or corrupted you could lose all the data for that organisation.
Without an up-to-date backup you would be forced to key in
the data for the current month again. It is also likely that
you would be unable to recreate data for previous months and
years. It is therefore very important that you make regular
backups of your database files.

To back up the database file for the organisation that is cur-
rently open, select Back Up from the Procedure menu. You
will be prompted to specify the name and location of the
backup file to be created (figure 5.1).

G Backup et
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L3 This PC
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. »
File marnes
Seve astype  Beckup Files (kK]
# Hide Foldess Cance

Figure 5.1: Backup dialog box

The backup process copies all data relating to your organi-
sation to the backup file. Should you have set up more than
one organisation, you will need to back up each one separately.
Note that data that is shared by all organisations is not backed
up (e.g. list of banks and statutory deductions parameters).

When running the month end procedure you will be prompted
to back up. Though you can choose to proceed without doing
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so, it is recommended that you back up first. To encourage
regular back ups Aren Payroll prompts you to back up each
time you exit.

Restoring from Backup

In the event that an organisation database file is corrupted or
deleted, you will need to replace it from backup. You can also
use backup files to revert to an earlier month. This is especially
useful if you accidentally run the month end procedure.

To restore an organisation database file from backup, select
Restore from the Procedure menu then follow the on-screen
instructions (figure 5.2).

Restare »

Resgtoring from backup wil replace al the data
for this argarisation with that retreved from the
backup fil=. You are encouraged to back up
lhe argarisaion befare sartinuing

e

i you ane surs you want io conbinue, please
erfler your password below

FPaspword

oK I Caneel Hel

Figure 5.2: Restore dialog box

Creating a Bank Transfer File

A bank transfer file is an electronic version of the bank transfer
report. It is used by banks to process payments for employees
paid by bank transfer in place of the printed bank transfer re-
port. Aren Payroll can create bank transfer files for numerous
banks including Absa, Citibank, Stanbic and Standard Char-
tered.

1. To create a bank transfer file select Bank Transfer File
from the Procedure menu. The Save Bank Transfer File
dialog box appears (figure 5.3).

2. Specify the format of the bank transfer file to create
and the name of the payment field (usually net pay).
Depending on the file format, you may be able to specify
the date you want the bank transfer effected.
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Sawve Bank Transfer File x
Pay Penod
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[

Figure 5.3: Save Bank Transfer File dialog box

3. On closing the Save Bank Transfer File dialog box, a
standard Save As dialog box will appear. Use this dialog
to specify the name and location of the file to be created.

For further details on bank transfer files please contact your
bank.

Terminating an Employee

To terminate an employee, open the employee master table
and display the target employee. Next, select Terminate from
the Record menu. In the Terminate dialog box that appears
(figure 5.4), enter the termination date, the reason for leaving
and, if you like, some brief comments.

Terminate bbuku, Chares Shusha ®
30062022 | Cancel
Reason far Leaving
.Feng'led ad
Remarks

Figure 5.4: Terminate dialog box

The terminated employee will be removed from the employee
data tables in the next month end procedure that is later than



36

5 Procedures

or on the same day as the termination date. Once the employee
is deleted from the employee data tables his record will be
added to the leavers report table.

Termination can be reversed by selecting Record > Undo Ter-
mination as long as the terminated employee has not been
removed from the employee data tables.

Closing the Month

The month end procedure is used to close data entry for the
current month and begin a new one. It applies only to the
organisation that is currently open. It does the following:

1.

Saves all payroll information for the current month to
the monthly and annual report tables.

. Transfers terminated employees from the employee mas-

ter table to the leavers report table.

Deletes the current payroll transactions table and creates
a new one for the coming month.

Deletes any report data that is older than the limit set
in the General Options dialog box.

. Advances the pay period by one month.

. If the new month is July, it creates statutory deduction

tables for the new tax year.

The month end procedure should only be run after all reports
for the current month have been verified since, once it is run,
reports for that month cannot be changed.

To run the procedure:

1.

Select Month End from the Procedure menu. This op-
tion is only available if you have licensed the organisa-
tion.

. After reading the dialog box that appears (figure 5.5),

confirm that you want to close the month by entering
your password.

. You will now be prompted to back up your data and are

strongly encouraged to do so.

Once the back up is complete, the month end proce-
dure will automatically follow. Eventually, a message
box confirming its completion will appear.
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Runining the month end procedure wil coss
data entry for June 2022 Subsequent payroll
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Figure 5.5: Month End Procedure dialog box
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Appendix A Importing Data

File Format

Keying in new employees into the payroll can be very time
consuming especially if there are many of them. As an al-
ternative, you can import employee data into the employee
master table from a text file.

The easiest way to create the input text file is to capture em-
ployee data in a spreadsheet and then save the spreadsheet as
a text file.

The format of the input text file is as follows:

1.

Plain text with data items separated by the tab character
(i.e. a tab-separated text file).

The first row of data is a header with the data items Em-
ployee Number, Last Name, Other Names, 1D Number,
Job Title, Admin Unit, Station, Pay Rate, TIN, NSSF
Number and NHIF Number.

From row two onwards, each row has data for a single
employee, i.e. employee number, last name, other names,
ID number, job title, administrative unit, station, pay
rate, TIN, NSSF number and NHIF number.

Note that:

1.

The first row (file header) is ignored. It is only included
for the convenience of the person preparing the input
file.

A row will not be imported if the employee number
matches that of a record already in the employee master
table.

. A row will also be skipped if any of the following data

items is blank: employee number, last name, other names,
job title, administrative unit, station.

Data will be imported into several data tables—employee
master, payroll transactions, jobs, adminstrative units
and stations.
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How to Import

5. Where a default profile has been defined, it will be ap-
plied to each record added to the employee master table.

1. Back up your data just in case you need to undo the
changes you are about to make (Procedure > Backup).

2. Select Procedure > Import Employees to open the first
Import New Employees dialog box (figure A.1).
Impart Mew Employees b4

mparting employee data from a text file may
modfy several data filea. | is advisable to
!' back up your dats befors cortinuing
o

i you ane surs you want io conbinue, please
erfler your password below

Fasword

ok | Cared Help

Figure A.1: First Import New Employees dialog box

3. Enter your password to open the second Import New
Employees dialog box.

4. Browse to the text file that you want to import data
from and click on Open.

5. Aren Payroll will read the text file and update the data
tables listed above. On completion, a confirmation mes-
sage box will be displayed. Close the message box.

To see which records were updated, refer to the log file im-
port.log located in the payroll data folder. Browse through
the data tables that should have been updated to confirm that
they were updated successfully.
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Aren Payroll can email payslips and P.9s to each of the em-
ployees in the payroll. This provides an alternative to printing
individual payslips or P.9s for each employee. The reports are
sent as password-protected PDF files.

In this section, we explain how to email payslips. Emailing
P.9s works in exactly the same way.

Entering Email Addresses
Start by capturing the email addresses to send reports to.

1. Open the Employee Master Table form (File > Em-
ployee) and select the Other tab (figure B.1).

Employes Master Table
Record 1 of 45 001 Mbukou, Charles Shusho

Personal

Emaloyment Email reports to:

Payment shushoi@demorestaurant.co. iz
Basic Pay

Creertima

Housing

PAYE

Satutary Deductions

Coroperatives

Persion Funids

Cither

Figure B.1: Employee Master Table form

2. For each employee, enter the address to email reports to.

3. Close the Employee Master Table form.

Setting Up Email Account

In order to send email, you need to set up your email account.
For this you require details of the outgoing mail server, also
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known as the SMTP server. Consult your IT department if
necessary or check the settings in the email software you use.

1. Select System > Email Account to open the Email Ac-

count dialog box (figure B.2).

Ernail Account 4

GeEnera

Email Address | nfo@demorestaurant. co.tz
Cance|

™ Copy all emails to self

adi

SMTF Server
Address | mail, demarestaurant. oo, tz
Part [ 25
Timeout |5‘] secands

k¥ Use s=cure cormection

Buthertication
Type |L|:~;r' T|

Account Hame | nfo@demorestaurant.ca.tz

EEREEEEEEE

Passvord |‘ -

Figure B.2: Email Account dialog box

. Email Address: Enter your email address, say info@-

demorestaurant.co.tz or example@gmail.com.

. SMTP Server: Enter the name of the outgoing mail

server, e.g. mail.demorestraurant.co.tz or smtp.gmail-
.com. You can also enter the server’s IP address, e.g.
192.168.0.23.

. SMTP Port: The SMTP port is a unique number that

the mail server has set aside for outgoing mail. The most
common values are 25, 465 and 587. If your server uses
a secure (encrypted) connection, e.g. smip.gmail.com or
smip.mail.yahoo.com, try port 465 or 587. If it does not,
enter 25.

. Timeout: This is length of time the software should wait

for a response from the mail server before giving up.

. Use secure connection: Check this option if the mail

server uses a secure connection.
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10.

Sending Payslips

Authentication: You may select none (no account name
or password required), plain or login (requires account
name and password).

Account Name and Password: Enter the login name and
password for the mail server if you have selected login or
plain authentication.

Copy all emails to self: Check this option if you want to
receive a copy of all the reports you send.

Close the Email Account dialog box.

Now you are ready to email payslips to employees.

1.

Select Procedure > Email Payslips to open the Email
Payslips dialog box (figure B.3).

Ermnail Payslips x
Pay Perod _
OK I
Year |2022 Canced
Month [June -] Wt > |

Il

Options

Figure B.3: Email Payslips dialog box

Choose the pay period that you want then click OK. This
opens the Payslip Messages dialog box (figure B.4).

Click on Send to open the Message Range dialog box
(figure B.5).

Use the Message Range dialog box to send the current
message, all messages or a range of them. On comple-
tion, a message box showing the number of messages sent
will be displayed.

Close the Payslip Messages dialog box when you are
through.
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FesipMeses X
] vemrass [5] 3]

Send To: Id'mam@dmn:-mra'l ootz

Subject: |Paysip for June 2022

e
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Payslip

Employse No.: 0ol
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Pay Period: June 2022

Figure B.4: Payslip Messages dialog box

Send:

P
™ Al Mesgages ﬂ

™ Messages

Fram: I_ Tn:l_

Figure B.5: Message Range dialog box

Details of the last mail session are saved in the log file email.log
located in the payroll data folder. Refer to this file if you have
any difficulty sending messages and to see which messages were
actually sent.

How to Open Payslips

Once a payslip is sent, the recipient will need one of the fol-
lowing passwords to open it.

1. Owner Password: This password is set in the General
Options dialog box (Organisation > Options > General).
Use it to open any payslips you send out.

2. User Password: This is usually the last four digits of the



How to Open Payslips 45

employee’s TIN. Where the employee’s TIN is missing,
it defaults to the value set in the General Options dialog
box. This is the password that employees should use.

You can modify the message that is sent to employees to in-
clude help on the password they will use to open the payslip.

1. Go to Procedure > Email Payslips to open the Email
Payslips dialog box.

2. Click on Options to open the Electronic Payslip Options
dialog box (figure B.6).

Electranic Payslip Options *
Message Print
¥ Include pasaword help B Jab Tite ok I
o Cancel
Son By numbers

[ Paymant mode
k¥ PAYE breakdown

(% Emplovee niimiber

N

e W Loan breakdown
Layout W Employer pension
[ Ful page

[ Pension balance

[™ Edended header [ Coop balance

Haadngs W Loan balance
" Back % Red

" Geen (" Bue

Figure B.6: Electronic Payslip Options dialog box

3. Check the option Include password help.
4. Close the Electronic Payslip Options dialog box.
5. Close the Email Payslips dialog box.
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Appendix C Formulae

Loans

Amortisation

Reducing Balance

The loan payment amount is uniform throughout the repay-
ment period. The portion of the payment amount that goes
towards repaying the principal increases with time as interest
payments reduce.

]
I—(1+r)"

Payment = l

where W = principal amount, n = total number of payments,
r = monthly interest rate (e.g. if annual interest rate is 15%,
r = (15/100)/12 = 0.0125).

The amount paid towards the principal is fixed throughout the
loan duration while interest payments reduce with time. Thus
the total payment amount reduces with time.

1
Payment = W' (/ + 7’)
n

where W’ = outstanding balance, n’ = number of payments
outstanding, » = monthly interest rate.



