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1 Introduction

About Aren Register

Aren Register is an extension of the traditional payroll system
to include some features normally found in personnel systems.
It runs in the Microsoft Windows environment.

Aren Register lets you specify the posts available in your or-
ganisation and then assign existing employees to these posts.
As new employees join they are assigned to the posts you have
speci�ed. Employees are retained in the system until they
leave the organisation. Reports on current and former em-
ployees are provided.

The system will help you to keep track of annual leave days
earned and taken by employees. You will also be able to record
all absence from work. Annual reports on leave and absence
are available.

Aren Register makes it easy to process employee pay. It en-
ables you to specify all payments and deductions that apply
to each employee. Several reports are derived from this data,
including payslips, payroll summary, payroll control account,
monthly and annual returns for PAYE as well as monthly
returns to NSSF and user-de�ned co-operatives and pension
funds.

Access to the system requires a username and a password.
There is one permanent user who has unrestricted access to
the entire system. Other users can be added at any time and
assigned access to those functions they need to use.

A single installation of Aren Register will support multiple or-
ganisations though a separate licence is required for each of
them. For each organisation, four pay frequencies are sup-
ported, viz monthly, weekly, biweekly and irregular. The ir-
regular pay frequency caters for employees who are not paid
at �xed intervals. A comprehensive backup system is also pro-
vided.
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Getting Started

To use Aren Register you need to install it and con�gure it
to suit your needs. The rest of this section shows you how to
begin this process.

Installation

To install Aren Register:

1. Insert the installation CD in the CD drive.

2. Run the program setup.exe on the installation CD.

Figure 1.1: Setup Wizard

3. Follow the on-screen instructions that appear during the
installation process (�gure 1.1).

The installation process copies the �les required by Aren Reg-
ister to the folder you specify on the hard disk of your com-
puter. It will also add Aren Register and its Help �le to the
Start menu.

Creating a Data Folder

1. Once the installation process is complete, run Aren Reg-
ister by selecting it from the Start menu.

2. In the Start dialog box that appears (�gure 1.2), click on
Data Folder to open the Data Folders dialog box (�gure
1.3).
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Figure 1.2: Start dialog box

Figure 1.3: Data Folders dialog box

3. Click on Create in the Data Folders dialog to create a
new data folder in which to store Aren Register data.

You can locate your data folder anywhere you want on
your computer or on a shared folder on another com-
puter. Make sure you have unrestricted access to whichever
location you choose, otherwise the software may not work
properly.

4. Close the Data Folders dialog to return to the Start di-
alog.

5. Within the Start dialog, click on Login to open the Login
dialog box.
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Logging In

1. In the Login dialog box enter the username supervisor
(�gure 1.4).

Figure 1.4: Login dialog box

2. You will be prompted to enter a password for use in
subsequent logins (�gure 1.5). Enter a password of your
choice.

Figure 1.5: Set Password dialog box

3. The New Organisation dialog box is displayed next (�g-
ure 1.6). Type in the name of your organisation and the
month from which you want to start entering data.

4. Close the New Organisation dialog box to begin using
Aren Register.

Moving On

Before entering employee data you need to �nish setting up
the program. Section 2 explains how to do this. To enter
employee data refer to Section 3 which describes the employee
data �les in Aren Register.

After entering employee data you can view the reports de-
scribed in Section 4. With the exception of the muster roll
and payroll variance, all reports can be printed out on A4
paper. Use the muster roll to export payroll data to a text
�le.
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Figure 1.6: New Organisation dialog box

To close the current data entry period and start a new one,
run a period or month end procedure as described in Section
5. That section also describes how to back up and restore data
and create bank transfer �les.
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Before entering details about employees, use the Organisation
and System menus to con�gure the program. The Organi-
sation menu options apply only to the organisation that you
are currently working with whereas those of the System menu
apply to all organisations that you de�ne.

Setting up the System

Users

Aren Register supports an unlimited number of users. There
is always at least one user, supervisor. The supervisor has ac-
cess to all functions including adding and deleting other users
and assigning such users access to program functions. By re-
stricting users to only those parts of the program they need
for their work, it is possible to enforce separation of duties.

If you wish to add new users at this stage, do the following:

1. Select Users from the System Menu. This displays the
Users dialog box (�gure 2.1).

Figure 2.1: Users dialog box

2. Click on the Add button which brings up the User Iden-
tity dialog box (�gure 2.2).

3. In the User Identity dialog enter the username. Enter
and con�rm the password if you wish. If you do not
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Figure 2.2: User Identity dialog box

enter a password at this stage, the user will be required
to enter one when logging in for the �rst time. You may
also enter the user's real name to help you identify him
or her in future.

4. Close the User Identity dialog and choose Rights from
the Users dialog box. This displays the User Rights di-
alog box (�gure 2.3).

Figure 2.3: User Rights dialog box

5. Use this dialog box to select which menu the user should
see: full menu, personnel only or payroll only. Also spec-
ify the functions within the selected menu that you would
like the user to have access to.

6. Close the User Rights dialog box. You can add more
users by repeating the procedure above.
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7. Click on Close in the Users dialog box.

Banks

Aren Register comes with a comprehensive list of banks and
their branches. You will need this list for employees paid by
bank transfer rather than in cash or by cheque. The list is
shared by all organisations that you create. To review or mod-
ify it, select Banks from the System menu which will bring up
the Bank and Branches dialog box (�gure 2.4).

Figure 2.4: Banks and Branches dialog box

Statutory Deductions Parameters

PAYE is calculated using brackets and rates that are stored
in a table. To view and update this table select PAYE Rates
from the System menu (�gure 2.5). Refer to the current P.38
from the Tanzania Revenue Authority (TRA) for an up-to-
date PAYE table.

The calculation of PAYE depends on two other parameters, al-
lowable pension fund contribution and statutory interest rate.
Update these parameters by selecting System > PAYE Param-
eters to open the PAYE Parameters dialog box (�gure 2.6).

Employer and employee contributions to NSSF are percentages
of gross pay. To modify these percentages select NSSF Rates
from the System menu (�gure 2.7).
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Figure 2.5: PAYE Rates dialog box

Figure 2.6: PAYE Parameters dialog box

Figure 2.7: NSSF Rates dialog box

Other Parameters

The employer's contribution to the Skills Development Levy
(SDL) is a percentage of gross pay. To edit this percentage
open the SDL Rate dialog by selecting SDL Rate from the
System menu (�gure 2.8).

You should also review the income brackets that will appear in
the P.10 report by selecting System > Income Brackets (�gure
2.9).
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Figure 2.8: SDL Rate dialog box

Figure 2.9: Income Brackets dialog box

Working with Organisations

A single installation of Aren Register can support up to 99
di�erent organisations. Each organisation requires a separate
licence. The name of the organisation that is currently open
is displayed in the title bar of the main window.

Adding a new Organisation

To add a new organisation select Add from the Organisation
menu. Use the New Organisation dialog box that follows (�g-
ure 2.10) to enter the name of the organisation and the month
from which you want to start entering data. On closing the
dialog box, the previous organisation is closed and the new
one opened.

Opening another Organisation

To open a di�erent organisation select Open from the Organ-
isation menu. This will bring up the Open Organisation di-
alog box (�gure 2.11) provided there are other organisations
de�ned. Select the organisation you want to open from the
dialog box.



12 2 Setting Up

Figure 2.10: New Organisation dialog box

Figure 2.11: Open Organisation dialog box

Deleting an Organisation

You can delete any organisation that is currently not open.
Deleting an organisation causes all its data �les and folders to
be deleted. It is strongly recommended that you back up the
organisation's data �les before deleting it (see Section 5).

To delete an organisation:

1. Select Delete from the Organisation menu. To minimise
the risk of accidentally deleting an organisation you will
be required to enter your password (�gure 2.12).

2. Next, a list of all organisations in the system, exclud-
ing the one that is open, will be displayed (�gure 2.13).
Select the one you want to delete. Note that it is not pos-
sible to delete the organisation that is currently open.

3. In the two message boxes that follow, con�rm that you
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Figure 2.12: First Delete Organisation dialog box

Figure 2.13: Second Delete Organisation dialog box

want to delete the selected organisation and destroy its
data �les.

4. Aren Register will then delete the organisation. A dia-
log box con�rming that the deletion is complete will be
displayed.

Setting up an Organisation

To con�gure the organisation that is currently open, proceed
as follows:

Basic Organisation Information

Open the Basic Organisation Info dialog box (�gure 2.14) from
the Organisation menu and enter the organisation's address
and telephone number.

Also, con�rm that you want to start entering payroll and leave
details in the month and year shown in the dialog box. Once
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Figure 2.14: Basic Organisation Info dialog box

you run the �rst period or month end procedure you will not
be able to edit either of them.

Licensing

Select Licence from the Organisation menu to open the Licence
dialog box (�gure 2.15). Type in the licence number supplied
by your dealer. If you do not have a licence number, contact
your dealer or Aren Software Ltd.

Figure 2.15: Licence dialog box

Payroll Info

Open the Payroll Info dialog box (�gure 2.16) by selecting
Payroll Info from the Organisation menu. Enter the bank,
branch and account number for the organisation's salary ac-
count. Also enter the organisation's PIN, NSSF number and
regional code.

In this dialog box, the Standard File Interchange (SFI) Sender
ID applies to those who submit their payroll to the bank in
electronic form. Leave this �eld blank if you do not already
have an SFI Sender ID.
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Figure 2.16: Payroll Info dialog box

Grades

Aren Register assumes that all jobs that employees may be
assigned to are graded or ranked. To set up the grades for
your organisation select Grade from the Organisation menu.
The Grades dialog box that follows (�gure 2.17) allows you to
specify the name, rank and salary range for each grade.

Figure 2.17: Grades dialog box

If your organisation has no grades, create only one grade called
(None) and enter a salary range that will cater for all employ-
ees.



16 2 Setting Up

Jobs

To set up the jobs available in the organisation, open the Jobs
dialog box by selecting Jobs from the Organisation menu. For
each job you must enter the name of the job and its grade.
You may also enter a brief description of the job for future
reference.

Administrative Units

Set up the administrative units (departments, sections, etc) in
your organisation. To do this select Units from the Organisa-
tion menu.

Posts

A post is a job that is attached to a speci�c administrative
unit. Aren Register does not accept new employees unless
they are attached to previously vacant posts.

In order to create posts you must create grades, jobs and ad-
ministrative units �rst. To add posts select Posts from the
Organisation menu which opens the Posts dialog box (�gure
2.18). For each administrative unit and job you will need to
specify how many permanent, contract, temporary and casual
posts to allow.

Figure 2.18: Posts dialog box

Stations

Set up the stations (branches) in your organisation. To do this
select Stations from the Organisation menu.
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Pay Groups

Pay Groups allow you to �lter payment reports according to
how employees in your organisation are paid. For example,
the bank transfer report could be �ltered by bank branch or
pay date.

To set up pay groups, select Pay Groups from the Organisation
menu.

Co-operatives and Pension Funds

Create co-operative societies that employees in the organisa-
tion belong to by selecting Co-operatives from the Organisa-
tion menu.

Similarly, set up pension funds by selecting Pension Funds
from the Organisation menu.

Employee Pro�les

An employee pro�le de�nes attributes that are common to a
group of employees. These attributes are leave entitlement,
pay frequency, basic pay type (i.e., salary, daily rate or hourly
rate), standard working hours (per day and per pay period)
and whether overtime is payable.

To create a pro�le, select Pro�les from the Organization menu
to open the Employee Pro�les dialog box (�gure 2.19). If there
is an employee pro�le marked as default, all new employees
added to the payroll will be assigned this pro�le.

Figure 2.19: Pro�les dialog box

General Options

Selecting Options > General from the Organisation menu opens
the General Options dialog (�gure 2.20). This dialog is used
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to specify the default pay frequency. This is the pay frequency
that the program defaults to when opening the payroll transac-
tions �le or initialising dialog boxes that display pay frequency.

Figure 2.20: General Options dialog box

The General Options dialog also allows you to choose the sort
order for employee data entry forms. You can also specify
when to purge old reports. Deleting old reports saves space
on the hard disk and reduces the size of backup �les.

In the logo section, you can select a bitmap �le that contains
the company's logo. This logo will be printed at the top of
each payslip.

Payroll Options

Selecting Options > Payroll from the Organisation menu brings
up the Payroll Options dialog (�gure 2.21). By default PAYE
is calculated on the average taxable pay in each half of the
year. Uncheck the option Tax average monthly pay if you pre-
fer to tax each month's pay independently.

Selecting the option Tax employer pension on employee will
cause pension fund contributions made by the employer to be
added to the employee's taxable pay. It is advisable to check
this option.

When computing taxable pay, an employee's pension fund con-
tribution is an allowable deduction, but up to a statutory limit.
This limit is set in the PAYE Parameters dialog box (System
> PAYE Parameters). Select the option Ignore allowable pen-
sion limit if you wish to ignore this limit.



Setting up an Organisation 19

Figure 2.21: Payroll Options dialog box

With the option to tax average monthly pay set, it is possible
for PAYE to be negative. This indicates that the employee
has already paid more tax than is due and is entitled to a
refund. Switch the option Allow negative PAYE o� to limit
the minimum PAYE to zero.

You can also specify whether the employer contributes to SDL.
Checking the Pay Skills Development Levy option turns on the
SDL report (Report > Monthly Returns > SDL).

Finally, you can choose to round down net pay for employ-
ees paid in cash by an amount that you specify. The excess
amount is carried forward to the next month.

Report Options

Selecting Options > Reports from the Organisation menu opens
the Report Options dialog box (�gure 2.22). This enables you
to choose the report options you prefer. You need not specify
them each time you open a report.

Pay Period End Days

If the pay frequency is monthly, the pay period is assumed to
end on the last day of the month. For other pay frequencies
the program requires assistance from the user to determine
when each pay period ends.

For weekly and biweekly pay frequencies, the user is required
to specify the last day of the very �rst pay period. The pro-
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Figure 2.22: Report Options dialog box

gram will work out when subsequent pay periods end. In the
case of employees paid at irregular intervals, the pay period
end day must be entered for each pay period.

To initialise period end days, you need to do the following for
each pay frequency that applies to your organisation (except
monthly):

1. Make it the default pay frequency using the General Op-
tions dialog box (Organisation > Options > General).
The pay frequency selected should appear in the status
bar.

2. Open the Pay Period dialog box (�gure 2.23) from the
Organisation menu and enter the pay period end day for
this pay frequency.

Figure 2.23: Pay Period dialog box

In any given month, the pay period end days for weekly and
biweekly employees can not be edited once the �rst period end
procedure for that pay frequency is run.



3 Data Files

Data for each employee is stored in four database �les�personnel,
payroll master, payroll transactions and absence and leave.
There is a separate payroll transactions �le for each pay fre-
quency. This data is used to create various personnel and
payroll report �les which are then used for report generation.

Personnel File

The personnel �le stores personal information about each em-
ployee, for example name, national ID number, date of birth
and nationality. It also stores information about employees'
jobs such as job title, grade, administrative unit, station and
leave entitlement.

Employees can only be added and removed from the system
through the personnel �le. The employees in this �le automat-
ically appear in the payroll master, payroll transactions and
absence and leave �les.

The personnel �le is accessed by selecting Personnel from the
File menu. This brings up a data entry form in which you enter
data for each employee (�gure 3.1). For easy access the data
entry form is divided into �ve pages, i.e., Personal Details,
Employment Details, Contact Info, Family and Photo.

Figure 3.1: Personnel File form
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Most of the �elds in the �le are optional. However, Em-
ployee Number, Last Name, Other Names, Post and Station
are mandatory. The optional �elds are used in various reports
and should therefore not be left blank.

Adding and Deleting Employees

Employee records are added and removed from the personnel
�le using the Add, Delete and Terminate commands in the
Record menu.

Deleting an employee record is only possible if it has not gone
through a period or month end procedure since it was added.
After deleting a record, no report will retain information relat-
ing to that employee. This option is provided to allow records
added by mistake to be expunged.

Terminating an employee will cause his record to be removed
from the personnel �le in due course. However, various person-
nel and payroll reports will retain details of that employee for
future reference. Section 5 describes the termination process
in detail.

Payroll Master File

The payroll master and the four payroll transaction �les store
employee payroll information. The former maintains informa-
tion that tends to remain the same over time while the latter
maintain information for a single pay period and this tends to
change more frequently.

The data in the payroll master �le includes pay frequency, ba-
sic pay, bank account number, TIN, co-operative membership
and housing status.

To open the payroll master �le, select Payroll Master from the
File menu. This brings up the Payroll Master File data entry
form which is divided into eight pages, i.e., Payment, Basic
Pay, Overtime, Housing, Statutory Deductions, Co-operatives,
Pension Funds and Options (�gure 3.2).

Payroll Transactions Files

Each payroll transactions �le stores earnings, deductions, ben-
e�ts, lump sums payments and refunds for all employees paid
in a particular pay period.
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Figure 3.2: Payroll Master File form

Earnings are those cash payments that relate to the current
pay period, e.g. basic pay or leave allowance. For tax purposes,
all cash earnings for all pay periods falling in a particular cal-
endar month are deemed to be the monthly cash earnings. A
pay period is deemed to fall in a particular month if its last
day falls in that month.

Bene�ts refers to private expenditure of an employee paid by
the employer e.g. school fees, house rent or telephone bills.
These non-cash bene�ts are considered as income for tax pur-
poses.

Deductions are those amounts deducted from an employee's
cash earnings by the employer. Some of these are called statu-
tory deductions because the law requires the employer to deduct
them from the employee's pay. The statutory deductions are
PAYE, NSSF and tax on lump sum payments.

Lump sum payments are those cash payments that do not
relate to the current month alone. Some like gratuity and
bonuses have accrued over past months while others like ter-
minal bene�ts may relate to past or future months. We make
the distinction between lump sum payments and monthly cash
earnings because the two are treated di�erently when calcu-
lating income tax.

Refunds are payments made to an employee, e.g. travelling or
subsistence allowances, for business expenses incurred while
on duty. These payments are not income and are therefore
not taxable.
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The payroll transactions �le is accessed by selecting Payroll
Transactions from the File menu. This displays a data entry
form (�gure 3.3) where you enter earnings, deductions, bene-
�ts, lump sum payments and refunds for each employee.

Figure 3.3: Payroll Transactions File form

Statutory deductions and other calculated amounts such as
taxable pay, net pay and gross pay are updated as data is
entered. This makes the calculations more transparent and
helps to reduce data entry errors.

You can suspend employees from the payroll by deleting them
from the payroll transactions �le (Record > Delete). To re-
store a suspended employee use the Record > Add command.

Payroll Fields

At installation, each payroll transactions �le has two earn-
ings (Basic Pay and Overtime), three deductions (Rent, Over-
draft Recovery and Rounding C/F), two non-cash bene�ts
(Employer Pension and Low Interest Bene�t) and one refund
(Rounding B/F). These �elds cannot be deleted but you can
add more according to your needs.

To add, delete or edit �elds, select Earnings, Deductions, Ben-
e�ts, Lump Sum Payments or Refunds from the File menu. A
data entry form will be displayed showing the �eld attributes
listed below (�gure 3.4). To add or delete �elds select Add or
Delete from the Field menu.

The following �eld attributes apply to all �elds:
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Figure 3.4: Deductions form

1. Field Name: The name of the �eld e.g. advance, shift
allowance.

2. Type: This is used to indicate permanent �elds (e.g. ba-
sic pay and rent). It is also used to specify �elds that
are calculated in a unique way (e.g. hourly pay and
daily pay) and those that are associated with a balance
that is updated and displayed by the system (e.g. loan
repayments and co-operative contributions). The type
advance is used to indicate advance payments so that
appropriate reports can be generated.

3. Amount: This attribute speci�es how the amount paid
to or deducted from each employee is arrived at. It may
be keyed in, a percentage of salary, a function of the time
worked (basic pay, overtime, hourly pay and daily pay)
or amortised (loan repayments).

4. Static: Static �elds retain their value when a period or
month end procedure is run, whereas non-static �elds
are reset to their lower limit. This is only important
for �elds that are keyed in. It saves you the trouble of
having to key in the amount earned or deducted each
time a period or month end procedure is run.

5. Taxable/Pre-tax deduction: For earnings the taxable at-
tribute speci�es whether or not the payment is subject to
PAYE. In general, all cash earnings and most non-cash
bene�ts are taxable. Refunds are not taxable as they are
not a form of income.

The pre-tax deduction attribute indicates those deduc-
tions to be subtracted from gross income when calculat-
ing PAYE. In Tanzania the only pre-tax deductions are
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contributions to registered pension funds.

Refer to the P.7 (Employer's Guide to Pay As You Earn)
for further information.

Depending on the selection for Type and Amount attributes
the following additional attributes may be available:

1. Co-operative: The name of the co-operative associated
with the �eld (�gure 3.5).

Figure 3.5: Co-operative dialog box

2. Pension Fund: The name of the pension fund and other
details pertaining to the current �eld (�gure 3.6).

Figure 3.6: Pension Fund Parameters dialog box

3. Limits: The upper and lower limits that the amount
paid or deducted should be restricted to (�gure 3.7).

Figure 3.7: Limits dialog box
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4. Percentage: The percentage of monthly salary that should
be paid or deducted (�gure 3.8).

Figure 3.8: Percentage of Salary dialog box

5. Hourly Rate: The hourly rate to use for earnings that
are of the type Hourly Pay (�gure 3.9).

Figure 3.9: Hourly Rate dialog box

6. Daily Rate: The daily rate to use for earnings that are
of the type Daily Pay.

Absence and Leave File

The absence and leave �le stores details about employees' ab-
sence from work in the current year. This information is ex-
pressed in terms of absence event records.

In addition, the �le keeps an account of annual leave earned
and used up by each employee during the year. It uses leave
event records to track the leave days brought forward from the
previous year and leave days earned, sold and forfeited since
then. Leave taken is treated as an absence event.

The absence and leave �le can also be used to track employees'
leave bookings.

To edit this �le select Absence and Leave from the File menu
(�gure 3.10). The Absence and Leave window has three pages,
i.e., Absence, Annual Leave and Leave Bookings. To edit or
delete an event in any page, �rst select it and then click on
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the Edit or Delete button. To add a new event, switch to the
appropriate page and then click on Add.

Figure 3.10: Absence and Leave window



4 Reports

Aren Register produces numerous reports as described below.
These reports can be viewed on the screen and printed out.
You can choose to print the entire report, a range of pages, or
just the page that you are currently viewing. Internal reports
can be sorted by either employee number or name.

You can view and print reports for current and previous pay
periods, months or years. You can also �lter most reports by
administrative unit, station, pay group, bank, co-operative or
pension fund.

Reports may be printed on any printer connected to your com-
puter either directly or through a local area network. Because
all reports are formatted for A4 paper, the printer must be set
to print on A4.

1. To open a report select it from the Report menu and then
follow the on-screen instructions. For example, selecting
Report > Payslips opens the Open Payslips dialog box
(�gure 4.1).

Figure 4.1: Open Payslips dialog box

2. To print the open report select Print from the File menu
which brings up the Print dialog box (�gure 4.2). Use the
Setup button in this dialog box to con�gure the printer
you want to use.

3. Choose Close from the File menu to close the report.
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Figure 4.2: Print dialog box

Personnel Reports

1. Posts Reports: List that shows the posts in each admin-
istrative unit of the organisation. You can choose to view
all posts or only those that are vacant.

2. Employees Roll: List of employees who are currently ac-
tive. It shows their job title, administrative unit and
station.

3. Joiners Roll: List of employees who joined the organi-
sation recently. It shows their job title, administrative
unit, station and start date.

4. Leavers Roll: List of employees who left in a given year.
It shows their �nal job title and administrative unit, the
date they left and the reason for leaving.

5. Employee Hierarchy Report: List of employees grouped
according to whom they report to. Employee names are
indented to show the reporting hierarchy. The report
also displays the job title, administrative unit and sta-
tion for each employee.

6. Length of Service Report: List of current employees show-
ing their job title, age and length of service.

7. Master Report: Report that shows the details of a single
employee as entered in the personnel and payroll master
�les. It is available for both current and former employ-
ees.

8. Absence Analysis: List of employees that gives a sum-
mary of all absence from work for a speci�ed year.
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9. Leave Analysis: List of employees that gives a sum-
marised account of leave earned and used up in a given
year.

10. Leave Booked: List of outstanding leave bookings.

11. Absence Sheet: This report lists, for a single employee,
all absence from work in a given year.

12. Annual Leave Sheet: This report gives, for a single em-
ployee, a detailed account of leave earned and used up
in a given year.

Reports on former employees, absence and leave cover a calen-
dar year. Reports for previous years can be viewed and printed
out, but they cannot be modi�ed in any way. Before running
the month end for December make sure that you verify these
reports.

The remaining reports, i.e. those on posts and current em-
ployees, indicate the state of the organisation at the time of
printing.

Pay Period Reports

These are reports for a speci�c pay frequency and cover one
pay period. For a particular pay frequency, reports for the
current pay period are updated as you update the employee
master �le and the appropriate payroll transactions �le. Re-
ports for previous pay periods can be viewed and printed out,
but they cannot be modi�ed in any way.

Overview Reports

1. Payroll Summary: Summarises earnings and deductions
for all employees.

2. Payroll Control Account: T-account listing total earn-
ings, deductions and net pay for all employees in the
organisation.

3. Muster Roll: List of employees showing all earnings,
lump sum payments, refunds and deductions for the pay
period. Records in this report can be grouped by admin-
istrative unit or station.

4. Payroll Variance: List of employees showing the di�er-
ences in the payments and deductions made in any two
pay periods. It is essentially the di�erence between the
muster rolls for the two pay periods.
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The muster roll and payroll variance can be viewed on the
screen or saved to a text �le but they cannot be printed out.

Detail Reports

1. Earning Report: List showing, for a particular earning,
how much each employee was paid.

2. Deduction Report: List showing, for a particular non-
statutory deduction, how much each employee was de-
ducted. If the deduction selected is a loan repayment, a
loan report is printed instead.

3. Loan Report: List of employees repaying a speci�c co-
operative or company loan. It shows the opening and
closing balances and a breakdown of the repayment amount
into interest and principal components.

4. Bene�t Report: List showing, for a particular non-cash
bene�t, how much each employee received.

5. Lump Sum Report: List showing, for a particular lump
sum payment, how much each employee received.

6. Refund Report: List showing, for a particular refund,
how much each employee received.

Payments to Employees

1. Payslips: Slip giving a breakdown of the earnings and
deductions of each employee separately (�gure 4.3). The
employer's pension contribution and the pension fund
balance can be shown in the payslip if required. When
the balance is shown, it includes the employer's portion
only if the option to print the employer contribution has
been selected.

2. Cash List: List of employees paid in cash showing their
employee number, name, net pay or advance payment
and a cash analysis of the payment amount.

3. Cheque List: List of employees paid by cheque showing
their employee number, name and net pay or advance
payment.

4. Bank Transfer Report: List of employees who are paid
by bank transfer showing their name, ID number, bank,
branch, account number and payment amount. The pay-
ment amount may be the net pay, an advance payment
or a bank loan repayment.
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Figure 4.3: Payslips

5. Labels: Envelope labels for employees paid in cash, by
cheque or by bank transfer. For cash employees, the net
pay can be shown on the label if required.

6. Coinage Summary Report: List showing the number of
coins and notes of each denomination that are required
for workers who are paid in cash. This information is
the same as the totals in the cash list but formatted so
that it can be used when withdrawing the cash from a
bank.

Returns

1. Co-operative Report: List of members of a particular co-
operative society showing membership number, monthly
contribution and any other payroll deductions to be paid
to that co-operative.

2. Pension Report: List of members of a particular pension
fund showing membership number and employer and em-
ployee contributions to that pension fund.

Monthly Payroll Reports

The monthly reports relate to a calendar month. They are:

1. Payroll Control Account.

2. Muster Roll.

3. PAYE Report:List of employees showing their PAYE de-
ductions.
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4. NSSF Report: List of employees showing the total em-
ployee and employer NSSF contributions.

5. SDL Report: List showing the SDL payable to the TRA
for each employee.

6. Lump Sums Tax Report: List showing tax payable on
lump sum payments for each employee.

7. Low Interest Bene�t Report: List of employees who have
received a particular company loan at an interest rate be-
low the statutory rate. It shows the low interest bene�t
they have received as a result.

These reports are updated after each period end procedure
and may not be complete until the month end procedure is
run. For the current month, the information displayed covers
the pay periods that have elapsed so far.

Annual Payroll Reports

Annual payroll reports relate to a calendar year and are avail-
able throughout the year. For the current year, the informa-
tion displayed relates to the pay periods that have elapsed so
far. The reports are:

1. Payroll Control Account.

2. Muster Roll.

3. Annual Pay Sheet: A report that, for each employee,
gives a summary of payments, deductions and bene�ts
for a whole year.

4. P.9: TRA form titled Tax Deduction Card. Each P.9
gives a breakdown of the income of an employee for each
month of the year and shows the amount of tax deducted.

At the end of each tax year, the employer should sub-
mit to the TRA a P.9 for each and every employee from
whom PAYE was deducted.

5. P.10: TRA form titled Employer's End of Year Cov-
ering Certi�cate. It shows the total tax deducted by
the employer for each month of the year. The employer
should submit it to the TRA at the end of each year,
together with the P.9s.

6. ITX215: TRA form titled PAYE Statement. It lists the
tax deducted for each employee who has paid PAYE in a
given six or twelve month period. It also shows taxable
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cash earnings, non-cash bene�ts, pre-tax deductions and
taxable pay.

7. NSSF Statement: A report that shows the monthly em-
ployee and employer contributions to NSSF for a single
employee for a calendar year.

Other Reports

1. Bank Codes: A listing of banks, bank branches and their
sort codes drawn from the banks �les.

2. Audit Trail: List that shows the date and time of each
login, backup, month end procedure and any other major
event. It also shows the user responsible for each event.
This report is only available to the supervisor.

Report Files

Almost all reports are printed from report �les, not directly
from the employee data �les. Brie�y, the report �les are:

1. Active employees report �le

2. Annual leavers report �les

3. Annual absence and leave report �les

4. Pay period report �les

5. Monthly payroll report �les

6. Annual payroll report �les

Report �les are updated automatically by Aren Register. Use
the General Options dialog box (Organisation > Options >
General) to specify how long to keep these �les for.
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Backing Up

If your data �les are accidentally deleted or corrupted you
could lose all your data. Without an up-to-date backup you
would be forced to key in the data for the current month again.
It is also likely that you would be unable to recreate data for
previous months and years. It is therefore very important that
you make regular backups of your data �les.

To back up �les for the organisation that is currently open, se-
lect Backup from the Procedure menu. You will be prompted
to specify the name and location of the backup �le to be cre-
ated (�gure 5.1).

Figure 5.1: Backup dialog box

The backup process copies all data relating to the organisation
to the backup �le. Should you have set up more than one
organisation, you will need to back up each one separately.
Note that data that is shared by all organisations is not backed
up (e.g. list of banks and statutory deductions parameters).

When running a period or month end procedure you will be
prompted to back up. Though you can choose to proceed



38 5 Procedures

without doing so, it is recommended that you back up �rst.
To encourage regular back ups Aren Register prompts you to
back up each time you exit.

Restoring from Backup

In the event that your data �les are corrupted or deleted you
will need to recover them from a backup �le. You can also
use backup �les to revert to an earlier period. This is espe-
cially useful if you accidentally run the period or month end
procedure.

To restore an organisation's �les from backup, select Restore
from the Procedure menu then follow the on-screen instruc-
tions (�gure 5.2).

Figure 5.2: Restore dialog box

Creating a Bank Transfer File

A bank transfer �le is an electronic version of the bank transfer
report. It is used by banks to process payments for employees
paid by bank transfer in place of the printed bank transfer
report. Aren Register can create bank transfer �les for numer-
ous banks including Barclays, Standard Chartered, Stanbic
and Citibank.

1. To create a bank transfer �le select Bank Transfer File
from the Procedure menu.

2. In the Bank Transfer File dialog box that appears (�gure
5.3), specify the format of the bank transfer �le to create
and the name of the payment �eld (usually net pay).
Depending on the �le format, you may be able to specify
the date you want the bank transfer e�ected.
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Figure 5.3: Save Bank Transfer File dialog box

3. After closing the Bank Transfer File dialog box, a new
dialog box appears. Use this dialog to specify the name
and location of the �le to be created.

For further details on bank transfer �les please contact your
bank.

Terminating an Employee

To terminate an employee, open the personnel �le and display
the target employee. Next, select Terminate from the Record
menu. In the Terminate dialog box that appears (�gure 5.4),
enter the termination date, the reason for leaving and, if you
like, some brief comments.

Figure 5.4: Terminate dialog box

The terminated employee will be removed from the employee
data �les in the next month end procedure that is later than or
on the same day as his termination date. Once the employee
is deleted from the employee data �les his record will be added
to the leavers report �le.



40 5 Procedures

Termination can be reversed by selecting Record > Undo Ter-
mination as long as the terminated employee has not been
removed from the employee data �les.

Period End Procedure

The period end procedure is used to close data entry for the
current pay period and begin a new one. The procedure does
the following:

1. Saves all payroll information for the current pay period
to the period, monthly and annual payroll report �les.

2. Deletes the existing payroll transactions �le and creates
a new one for the next pay period.

3. Advances the period end day to the last day of the next
pay period.

This procedure should only be run after all reports for the
current pay period have been veri�ed since, once it is run,
reports for this pay period cannot be changed.

To run the procedure:

1. Check that the correct pay frequency is set as default.

2. Select Period End from the Procedure menu. This option
is only available if you have licensed the organisation.

3. After reading the dialog box that appears (�gure 5.5),
con�rm that you want to close the pay period stated by
entering your password.

Figure 5.5: Period End Procedure dialog box

4. You will now be prompted to back up your data and are
strongly encouraged to do so.
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5. Once the back up is complete, the period end procedure
will automatically follow and eventually a message box
con�rming its completion will appear.

Month End Procedure

The month end procedure is used to close data entry for the
current month and begin a new one. It applies only to the
organisation that is currently open. It does the following:

1. Runs the period end procedure for each pay frequency.

2. Advances the date by one month such that all pay peri-
ods end in the following month.

3. If the new month is July, it creates statutory deduction
�les for the new tax year.

4. If the new month is January, it deletes all events in the
absence and leave �le for the previous year. Leave days
brought forward are then added to the �le.

5. Adds leave earned in the new month to the absence and
leave �le.

6. Transfers terminated employees from the personnel �le
to the leavers report �le.

7. Deletes any report �les that have exceeded the maximum
age set in the General Options dialog box.

The procedure can only be run if, for each payroll that has
data, the forthcoming pay period ends in the next calendar
month. This is because, after the procedure is run, all pay
period end days will fall in the new month. In December the
month end procedure cannot be run if there are outstanding
leave bookings for the year that is ending.

To run the procedure:

1. Select Month End from the Procedure menu. This op-
tion is not available if you have not licensed the organi-
sation. It is also not available if the next pay period for
the default pay frequency does not end in the following
month.

2. After reading the dialog box that appears (�gure 5.6),
con�rm that you want to close the month by entering
your password.
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Figure 5.6: Month End Procedure dialog box

3. You will now be prompted to back up your data and are
strongly encouraged to do so.

4. Once the back up is complete, the month end proce-
dure will automatically follow. Eventually, a message
box con�rming its completion will appear.

The Month End Procedure should be run with care since it
cannot be reversed except by restoring from backup. This is
especially true in December when it will close entry of absence
and leave data for the year that is ending.
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Employee Data

Keying in new employees into the payroll can be very time
consuming especially if there are many of them. As an alter-
native, you can import employee data into the personnel �le
from a text �le.

The easiest way to create the input text �le is to capture em-
ployee data in a spreadsheet and then save the spreadsheet as
a text �le.

File Format

The format of the input text �le is as follows:

1. Plain text with data items separated by the tab character
(i.e. a tab-separated text �le).

2. The �rst row of data is a header with the data items
Employee Number, Last Name, Other Names, ID Num-
ber, Job Title, Admin Unit, Station, Pay Rate, TIN and
NSSF Number.

3. From row two onwards, each row has data for a single
employee, i.e. employee number, last name, other names,
ID number, job title, administrative unit, station, pay
rate, TIN and NSSF number.

Note that:

1. The �rst row (�le header) is ignored. It is only included
for the convenience of the person preparing the input
�le.

2. A row will not be imported if the employee number
matches that of a record already in the personnel �le.

3. A row will also be skipped if any of the following data
items is blank: employee number, last name, other names,
job title, administrative unit, station.

4. Data will be imported into several �les�personnel, pay-
roll master, payroll transactions, leave, jobs, adminstra-
tive units and stations.
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5. Where a default pro�le has been de�ned, it will be ap-
plied to each record added to the personnel �le.

How to Import

1. Make sure you are in single-user mode. If not, switch to
this mode by selecting System > Single-User Mode.

2. Back up your data just in case you need to undo the
changes you are about to make (Procedure > Backup).

3. Select Procedure > Import > Employees to open the
�rst Import Employees dialog box (�gure A.1).

Figure A.1: First Import Employees dialog box

4. Enter your password to open the second Import Employ-
ees dialog box.

5. Browse to the text �le that you want to import data
from and click on Open.

6. Aren Register will read the text �le and update sev-
eral data �les�jobs, administrative units, stations, per-
sonnel, payroll master, payroll transactions and leave.
On completion, a con�rmation message box will be dis-
played. Close the message box.

7. To see which records were updated, refer to the log �le
import.log located in the payroll data folder. Browse
through the data �les that should have been updated to
con�rm that they were updated successfully.

Time and Attendance Data

Aren Register can import time and attendance data from a
text �le. This provides a quick way of capturing the data gen-
erated by a clocking system. Because the format of the input
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Employee Name Basic Normal Double

Number Pay Overtime Overtime

001 MBUKU, Charles 0.5 10 3.5

002 KANJA, Benjamin 0 0 8

003 MPEMBE, Agnes 1.5 8 4

004 GONZI, Alice 2 0 0

Table A.1: Time and attendance data format

�le is standard, Aren Register will work with any clocking sys-
tem provided that the data it generates can be converted to
the required format. An input �le can also be created by key-
ing in time and attendance data into a spreadsheet and then
saving it as a text �le.

File Format

The input text �le should have the following format:

1. Plain text with data items separated by the tab charac-
ter.

2. The �rst row of data is a header with the data items
Employee Number, Name, Basic Pay, Normal Overtime
and Double Overtime.

3. From row two onwards, each row has data for a sin-
gle employee, i.e. employee number, name, basic pay
time worked, normal overtime hours and double over-
time hours.

Table A.1 is a simple example of the format required.

Interpretation

The data is interpreted as follows:

1. The �rst row (�le header) and the second column (em-
ployee name) are ignored. They are included for the
convenience of the person preparing the input �le.

2. The employee number in column one determines which
record in the payroll will be updated. It must match the
employee number in the payroll transactions �le exactly,
except for the case which is ignored.

3. The data in column three (basic pay) could be hours
worked, hours absent, days worked or days absent. Its
interpretation depends on the settings for each employee
in the payroll master �le. If an employee is paid a �xed
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salary irrespective of the time worked, this value is ig-
nored.

4. Columns four and �ve contain normal and double over-
time hours, respectively. For a given employee, if over-
time is not enabled the data is ignored.

How to Import

Here is how you import time and attendance data into the
default payroll transactions �le.

1. Make sure you are in single-user mode. If not, switch to
this mode by selecting System > Single-User Mode.

2. Back up your data just in case you need to undo the
changes you are about to make.

3. Select Procedure > Import > Attendance to open the
Import Time and Attendance Data dialog box (�gure
A.2).

4. Browse to the text �le that you want to import data
from and click on Open.

Figure A.2: Import Time and Attendance Data dialog box

5. Aren Register will read the text �le and update the de-
fault payroll transactions �le. On completion, a message
box showing the number of records updated will be dis-
played.

To review the imported data, open the basic pay, normal over-
time and double overtime reports (Report > Breakdown). You
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should also review the log �le import.log located in the payroll
data folder.
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Appendix B Emailing Payslips

Aren Register can email payslips to each of the employees in
the payroll. This provides an alternative to printing individual
payslips for each employee. Payslips are sent as password-
protected PDF �les.

Entering Email Addresses

Start by capturing the email addresses to send employee payslips
to.

1. Open the payroll master �le (File > Payroll Master) and
select the options tab (�gure B.1).

Figure B.1: Payroll Master File form

2. For each employee, enter the address to email payslips
to.

3. Close the payroll master �le.

Setting Up Email Account

In order to send email, you need to set up your email account.
For this you require details of the outgoing mail server, also
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known as the SMTP server. Consult your IT department if
necessary or check the settings in the email software you use.

1. Select System > Email Account to open the Email Ac-
count dialog box (�gure B.2).

Figure B.2: Email Account dialog box

2. Email Address: Enter your email address, say info@-
demorestaurant.co.tz or example@gmail.com.

3. SMTP Server: Enter the name of the outgoing mail
server, e.g. mail.demorestraurant.co.tz or smtp.gmail-
.com. You can also enter the server's IP address, e.g.
192.168.0.23.

4. SMTP Port: The SMTP port is a unique number that
the mail server has set aside for outgoing mail. The most
common values are 25, 465 and 587. If your server uses
a secure (encrypted) connection, e.g. smtp.gmail.com or
smtp.mail.yahoo.com, try port 465 or 587. If it does not,
enter 25.

5. Use secure connection: Check this option if the mail
server uses a secure connection.

6. Authentication: You may select none (no account name
or password required), plain or login (requires account
name and password).

7. Account Name and Password: Enter the login name and
password for the mail server if you have selected login or
plain authentication.
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8. Copy all emails to self: Check this option if you want to
receive a copy of all the payslips you send.

9. Close the Email Account dialog box.

Sending Payslips

Now you are ready to email payslips to employees.

1. Select Procedure > Email Payslips to open the Email
Payslips dialog box (�gure B.3).

Figure B.3: First Email Payslips dialog box

2. Choose the pay period that you want then click OK. This
opens another dialog box with the same title (�gure B.4).

Figure B.4: Second Email Payslips dialog box
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3. Click on Send to open the Message Range dialog box
(�gure B.5).

Figure B.5: Message Range dialog box

4. Use the Message Range dialog box to send the current
message, all messages or a range of them. On comple-
tion, a message box showing the number of messages sent
will be displayed.

5. Close the Email Payslips dialog box when you are through.

Details of the last mail session are saved in the log �le email.log
located in the payroll data folder. Refer to this �le if you have
any di�culty sending messages and to see which messages were
actually sent.

How to Open Payslips

Once a payslip is sent, the recipient will need a password to
open it. Each payslip has two passwords:

1. Owner Password: The last four digits of the organisa-
tion's TIN. For instance, if the organisation's TIN is
012345678, the owner password will be 5678. Should
the organisation's TIN be blank, the default password is
owner.

2. User Password: The last four digits of the employee's
TIN. Where the employee's TIN is missing, the default
password is user. This is the password that employees
should use.

You can modify the message that is sent to employees to in-
clude help on the password they will use to open the payslip.

1. Go to Organistion > Options > Reports to open the
Report Options dialog box (�gure B.6).

2. Select Electronic Payslips and click on Options. This
opens the Electronic Payslips Options dialog box (�gure
B.7).
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Figure B.6: Report Options dialog box

Figure B.7: Electronic Payslips dialog box

3. Check the option Include password help.

4. Close the Electronic Payslip Options dialog box.

5. Close the Report Options dialog box.
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Appendix C Formulae

Loans

Amortisation

The loan payment amount is uniform throughout the repay-
ment period. The portion of the payment amount that goes
towards repaying the principal increases with time as interest
payments reduce.

Payment =
W[

1− (1 + r)−n

r

]

where W = principal amount, n = total number of payments,
r = monthly interest rate (e.g. if annual interest rate is 15%,
r = (15/100)/12 = 0.0125).

Reducing Balance

The amount paid towards the principal is �xed throughout the
loan duration while interest payments reduce with time. Thus
the total payment amount reduces with time.

Payment = W ′
(
1

n′
+ r

)

where W ′ = outstanding balance, n′ = number of payments
outstanding, r = monthly interest rate.


