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1 Introduction

About Aren Payroll

Getting Started

Installation

Aren Payroll is a payroll program that runs in the Microsoft
Windows environment. It enables you to set up a database
containing pay details of the employees in your organisation.
Data entry is interactive with income tax, loan payments, pen-
sion fund balances and other calculated amounts updated and
displayed as you work.

The system produces several payroll reports such as payslips,
payroll summary, payroll control account, cash and cheque
lists, as well as monthly and annual tax returns. All reports
are formatted for A4 paper so there is no need to buy special
stationery.

Access to the system requires a username and a password.
There is one permanent user who has unrestricted access to
the entire system. Other users can be added at any time and
assigned access to those functions they need to use.

The program can be configured to suit the needs of your organ-
isation. For example, you can define an unlimited number of
payments and deductions. You can also update the tables used
for calculating statutory deductions should the need arise.

Aren Payroll supports multiple organisations which is conve-
nient if you need to run the payroll of more than one organi-
sation on a single computer. A separate licence is required for
each organisation.

To use Aren Payroll you must first install it and configure it
to suit your needs. The rest of this section shows you how to
begin this process.

To install Aren Payroll:
1. Insert the installation CD in the CD drive.
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Figure 1.1: Setup Wizard

2. Run the program setup.eze on the installation CD.

3. Follow the on-screen instructions that appear during the

installation process (figure 1.1).

The installation process copies the files required by Aren Pay-
roll to the folder you specify on the hard disk of your com-
puter. It will also add Aren Payroll and its Help file to the
Start menu.

Creating a Data Folder

1. Once the installation process is complete, run Aren Pay-

roll by selecting it from the Start menu (figure 1.2).

Start A

Verson 6.1,1
Standard Uganda Edition
© Aren Software Ltd, 1958-2020

iane]

| Login.... I Cancel | Data Folder.., I

Figure 1.2: Start dialog box
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2. In the Start dialog box that appears, click on Data Folder
to open the Data Folders dialog box (figure 1.3).

Diata Folders e

Aailable Folders

Select... Create. ..

Target Folder
[Floni=]

Clorss

Figure 1.3: Data Folders dialog box

3. Click on Create in the Data Folders dialog to create a
new data folder in which to store Aren Payroll data.

You can locate your data folder anywhere you want on
your computer or on a shared folder on another com-
puter. Make sure you have unrestricted access to whichever
location you choose, otherwise the software may not work

properly.
4. Close the Data Folders dialog to return to the Start di-
alog.

5. Within the Start dialog, click on Login to open the Login
dialog box.

Logging In

1. In the Login dialog box enter the username supervisor
(figure 1.4).

2. You will be prompted to enter a password for use in
subsequent logins (figure 1.5). Enter a password of your
choice.

3. The New Organisation dialog box is displayed next (fig-
ure 1.6). Type in the name of your organisation and the
month from which you want to start entering data.
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Login *
Ulsemame [supervisar
Passward
ok | Cancel | Heb |
Figure 1.4: Login dialog box
Set Password x
Passward [ oK
Carfimn  [ooe Cancel
Fagsward —
Figure 1.5: Set Password dialog box
New Organisation 4
Mame | Deme Restaurant Ltd LI
Cancel
Monlh |December =
Year | 2020
Local Currancy |L|-gan|:|.:|5-iln5
Payrell Currency | Liganda Shillng
Figure 1.6: New Organisation dialog box
4. Close the New Organisation dialog box to begin using
Aren Payroll.
Moving On

Before entering employee data you need to finish setting up
the program. Section 2 explains how to do this. To enter
employee data refer to Section 3 which describes the employee
data files in Aren Payroll.

After entering employee data you can view the reports de-
scribed in Section 4. With the exception of the muster roll
and payroll variance, all reports can be printed out on A4
paper. Use the muster roll to export payroll data to a text
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file.

To close the current pay period and start a new one, run the
month end procedure described in Section 5. That section
also describes how to back up and restore data and create
bank transfer files.
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2 Setting Up

Before entering details about employees, use the Organisation
and System menus to configure the program. The Organi-
sation menu options apply only to the organisation that you
are currently working with whereas those of the System menu
apply to all organisations that you define.

Setting up the System

Users

Aren Payroll supports an unlimited number of users. There is
always at least one user, supervisor. The supervisor has access
to all functions including adding and deleting other users and
assigning such users access to program functions. By restrict-
ing users to only those parts of the program they need for their
work, it is possible to enforce separation of duties.

If you wish to add new users at this stage, do the following:

1. Select Users from the System Menu. This displays the
Users dialog box (figure 2.1).

Users

Clase

(L LLE ]

Figure 2.1: Users dialog box

2. Click on the Add button which brings up the User Iden-
tity dialog box (figure 2.2).

3. In the User Identity dialog enter the username. Enter
and confirm the password if you wish. If you do not
enter a password at this stage, the user will be required
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User |dentity *

| eermame chrisine

Paazwaord Ii

Famod |

L=t Flame Mamazzi

Other Mamea |C"I'B’.i“E'

oK Cancel |
Figure 2.2: User Identity dialog box

to enter one when logging in for the first time. You may
also enter the user’s real name to help you identify him
or her in future.

. Close the User Identity dialog and choose Rights from
the Users dialog box. This displays the User Rights di-
alog box (figure 2.3).

User Rights for christine =
Functiona
¥ Edt employee data fies ILI
¥ Modfy payrol fieids Lancel
¥ Set up apen organisation
¥ Close pay peod or morth
™ Aestors files
[ Add and delete organis aions
¥ Modity teax tables
Figure 2.3: User Rights dialog box

. Use this dialog box to specify the functions that you
would like the user to have access to.

. Close the User Rights dialog box. You can add more
users by repeating the procedure above.

. Click on Close in the Users dialog box.

Banks

Aren Payroll comes with a comprehensive list of banks and
their branches. You will need this list for employees paid by
bank transfer rather than in cash or by cheque. The list is
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shared by all organisations that you create. To review or mod-
ify it, select Banks from the System menu which will bring up
the Bank and Branches dialog box (figure 2.4).

Banks and Branches i
= Bank of Baroda Add Bark... |
= Bank of Uganda

Bardays Bank Add Brandh...

Cairo Internabonal Bank
Centenary Rura Dev Bank
Criibsark

Crane Bank

& Propertes...
= DFCU Bank

Lg
A5

Diamond Trust Bank Claze
Matona Bank of Commerc
Mie Bank
Gment Bank
Stanbac Bank
Standard Chartered Bank
& Transafrica Bank
+ Tropical Africa Bark
& Uganda Commeroal Bank

Figure 2.4: Banks and Branches dialog box

Statutory Deductions Parameters

PAYE and LST are calculated using brackets and rates that
are stored as tables. To view and update these tables select
PAYE Rates or LST Rates from the System menu (figure 2.5).
Refer to the current P7 booklet from the Uganda Revenue
Authority (URA) for an up-to-date PAYE table.

PAYE Rates for 20202021 =
Laweer Limit [ upper Limit | TaxRate (%)
: 235000 0.00
235001 335000 10,00
335001 410000 .00 Delets
410001 10000000 0,00
10000001 - Hione - 20,00 =

Close

Figure 2.5: PAYE Rates dialog box

The calculation of PAYE also depends on the low interest ben-
efit arising from loans made to employees by the organisation.
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To update the statutory interest rates that are used in deter-
mining this benefit, select System > PAYE Parameters. This
will open the PAYE Parameters dialog box (figure 2.6).

PAYE Pararneters for 202002021 4

Statutory Interest Rate {%):

July to December 0.00
Jaruary o June 0.00

0K Cance

Figure 2.6: PAYE Parameters dialog box

Employer and employee contributions to NSSF are percentages
of gross pay. To modify these percentages select NSSF Rates
from the System menu. This opens the NSSF Rate dialog box
(figure 2.7).

N35F Rates fior 202072021 x

Contribuban ok

Percentage of gross pay:
Cance

Employes 5.00

Simp e 10,00

Figure 2.7: NSSF Rates dialog box

Working with Organisations

A single installation of Aren Payroll can support up to 99
different organisations. Kach organisation requires a separate
licence. The name of the organisation that is currently open
is displayed in the title bar of the main window.

Adding a new Organisation

To add a new organisation select Add from the Organisation
menu. Use the New Organisation dialog box that follows (fig-
ure 2.8) to enter the name of the organisation and the month
from which you want to start entering data. On closing the
dialog box, the previous organisation is closed and the new
one opened.
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MNew Qrganisation b4

Mame | Demo Company Lid b I
Cancel

Manth |December =

Year | 2020

Local Curency | Uganda Shilng

Payroll Currency | Uiganda Shillng

Figure 2.8: New Organisation dialog box

Opening another Organisation

To open a different organisation select Open from the Organi-
sation menu. This will bring up the Open Organisation dialog
box (figure 2.9) provided there are other organisations defined.
Select the organisation you want to open from the dialog box.

Open Crganisation x
Dlema Ressuran Lid
ok | Cancel

Figure 2.9: Open Organisation dialog box

Deleting an Organisation

You can delete any organisation that is currently not open.
Deleting an organisation causes all its data files and folders to
be deleted. It is strongly recommended that you back up the
organisation’s data files before deleting it (see Section 5).

To delete an organisation:

1. Select Delete from the Organisation menu. To minimise
the risk of accidentally deleting an organisation you will
be required to enter your password (figure 2.10).
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Delete Organisation =

Dieleting an oarganisation wil cause al ts data
fibeea b be deleted . You are strongly advieed to
back up thess fils before continung

S

I you are sune you want fo continue, please
erer your password below

Pasgword |

Figure 2.10: First Delete Organisation dialog box

2. Next, a list of all organisations in the system, exclud-
ing the one that is open, will be displayed (figure 2.11).
Select the one you want to delete. Note that it is not pos-
sible to delete the organisation that is currently open.

Delete Organication *
| Derma Compary id |
ok | Caneel

Figure 2.11: Second Delete Organisation dialog box

3. In the two message boxes that follow, confirm that you
want to delete the selected organisation and destroy its
data files.

4. Aren Payroll will then delete the organisation. A dia-
log box confirming that the deletion is complete will be
displayed.

Setting up an Organisation

To configure the organisation that is currently open, proceed
as follows:
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Basic Organisation Information

Open the Basic Organisation Info dialog box (figure 2.12) from
the Organisation menu and enter the organisation’s address
and telephone number.

Basic Qrganisation Info e

Hame | Demo Restaurant Lid
Status: Mot ioensed

Felder: D:\Pays115tdlorg0 1

Manth | ecember T| Year | 2020
Address
P.0. Box | 12345 Town | Kampala
Post Cade Teleshons | 5552318
[ o= | Cancel

Figure 2.12: Basic Organisation Info dialog box

Also, confirm that you want to start entering payroll details
in the month and year shown in the dialog box. Once you
run the first month end procedure you will not be able to edit
either of them.

Licensing

Select Licence from the Organisation menu to open the Licence
dialog box (figure 2.13). Type in the licence number supplied
by your dealer. If you do not have a licence number, contact
your dealer or Aren Software Ltd.

Licence x
Licence Humier; | 18363210

| o= |  cancm Helo

Figure 2.13: Licence dialog box

Payroll Info

Open the Payroll Info dialog box (figure 2.14) by selecting
Payroll Info from the Organisation menu. Enter the bank,
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branch and account number for the organisation’s salary ac-
count. Also enter the organisation’s TIN and NSSF number.

Payroll Info *
10 Nurbers
T [Tos7a355 X I
WESF Mo, | FO304 Lancey
Currendes
Local Currency ||_L;.rdu Shiling
Payrall Currency [Lliﬂ"dﬂ Shiling
Banking
Bark [Starderd Chertered Barik |
Branch |I—ead Office LI
Actount No. [ 01234567
Sender 10 [
Figure 2.14: Payroll Info dialog box
In this dialog box, the Standard File Interchange (SFI) Sender
ID applies to those who submit their payroll to the bank in
electronic form. Leave this field blank if you do not already
have an SFI Sender ID.
Jobs

To set up the jobs available in the organisation, open the Jobs
dialog box (figure 2.15) by selecting Jobs from the Organisa-
tion menu.

Jobs

Aeer. Restauranl Manager
Bartendar

Beverage Manager

Chet

|

i

Chied Accouran

Cleaner

ok Properies...
Uining Room Manager
Direclor

Executive Chef

Head Bartendar

it

Head Cleaner

Head Securty

Head Waiter -
e P

Figure 2.15: Jobs dialog box
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Administrative Units

Stations

Pay Groups

Set up the administrative units (departments, sections, etc) in
your organisation. To do this select Units from the Organisa-
tion menu.

Set up the stations (branches) in your organisation. To do this
select Stations from the Organisation menu.

Pay Groups allow you to filter payment reports according to
how employees in your organisation are paid. For example,
the bank transfer report could be filtered by bank branch or
pay date.

To set up pay groups, select Pay Groups from the Organisation
menu.

Co-operatives and Pension Funds

Employee Profiles

General Options

Create co-operative societies that employees in the organisa-
tion belong to by selecting Co-operatives from the Organisa-
tion menu.

Similarly, set up pension funds by selecting Pension Funds
from the Organisation menu.

An employee profile defines attributes that are common to a
group of employees. These attributes are pay frequency, basic
pay type (i.e., salary, daily rate or hourly rate), standard work-
ing hours (per day and per pay period) and whether overtime
is payable.

To create a profile, select Profiles from the Organisation menu
to open the Employee Profiles dialog box (figure 2.16). If there
is an employee profile marked as default, all new employees
added to the payroll will be assigned this profile.

Selecting Options > General from the Organisation menu opens
the General Options dialog (figure 2.17). This dialog allows
you to choose the sort order for employee data entry forms.
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Payroll Options

Ernployes Profiles »
Staff Add.

Delete |

Fropetes |

Figure 2.16: Profiles dialog box

General Cptions *
o =]
% Employes Numbser
5 Canos|
7 Last Mam=
Help
Paest Reports

Purgeaﬁ:et 1D years

Logo

Select,, | Remaye |

Figure 2.17: General Options dialog box

You can also specify when to purge old reports. Deleting old
reports saves space on the hard disk and reduces the size of
backup files.

In the logo section, you can select a bitmap file that contains
the company’s logo. This logo will be printed at the top of
each payslip.

Selecting Options > Payroll from the Organisation menu brings
up the Payroll Options dialog (figure 2.18). The program can
adjust PAYE in June for any overpayment or underpayment
in the course of the tax year. In the Payroll Options dialog
you can specify if the adjusted PAYE value can be negative
(indicating a refund). If this option is not selected then the
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minimum adjusted PAYE will be zero.

Payroll Options

PAYE

I Deduct PAYE before LST .

g

I Alow megative PAYE Cancel

Help
L5T

W DeductLsT

Mel Pay

For employee paid in cash:

¥ Pay axack amounl

¢ Round down fo nearest Ush

Figure 2.18: Payroll Options dialog box

To deduct LST check the option Deduct LST. This option
switches local service tax (LST) on or off for the whole organ-
isation. For LST to be deducted from an employee, it must be
selected here and switched on for the individual employee in
the employee master file.

Check this option for the first four months of the financial year
(July to October) when LST is payable.

Finally, you have the option to round down net pay for em-
ployees paid in cash by an amount that you specify. The excess
amount is carried forward to the next month.

Report Options

Selecting Options > Reports from the Organisation menu opens
the Report Options dialog box (figure 2.19). This enables you
to choose the report options you prefer. You need not specify
them each time you open a report.
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Figure 2.19: Report Options dialog box



3 Data Files

Data for each employee is stored in two database files, the em-
ployee master file and the payroll transactions file. This data
is used to create the various report files from which reports are
printed.

Employee Master File

The employee master file stores static information about each
employee. It is accessed by selecting Employee from the File
menu (figure 3.1). This brings up a data entry form in which
you enter details about each employee.

"Employee Master File
Record 1of 45 DROOY Lbenzem. Stephen Asega
Personal Detals
Pemsonal
m Last Mame | Libarnsrs
__ Pamen |
- GCither Hames |5b:1;h:ﬂ Asega
Basic Pay
== Gender sl -
Heusing Birth Date | 5 Aug 1977 |_|
St Deductions
i ID Ma. | 23545964
Ca-operaives
__Ponfinds | | Feepartie,
Oplions ‘Work Permit Mo,

Figure 3.1: Employee Master File form

You can add and delete employee records using the Add, Delete
and Terminate commands in the Record menu.

e The Delete command simply deletes an employee record.
It is only available if no month end procedure has been
run since the current employee was added.

e The Terminate command transfers an employee record
from the employee master file to the leavers report file.
This transfer takes place in the month end procedure
that follows the termination date specified by the user.
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For easy access the data entry form is divided into ten pages,
i.e., Personal Details, Employment Details, Payment, Basic
Pay, Overtime, Housing, Statutory Deductions, Co-operatives,
Pension Funds and Options.

Most of the fields in this file are optional. However, Employee
Number, Last Name, Other Names, Job Title, Administrative
Unit and Station are mandatory. If an employee is paid by
bank transfer, then Bank, Branch and Account Number are
also mandatory. The optional fields are also used in various
reports and should therefore not be left blank.

Payroll Transactions File

The payroll transactions file stores earnings, deductions, ben-
efits, lump sums payments and refunds for each employee for
the current month.

Earnings (or monthly cash earnings) are those cash payments
that relate to the current month e.g. basic pay or leave al-
lowance.

Benefits are private expenses of an employee that are paid
by the employer, e.g. school fees, house rent or telephone
bills. These non-cash benefits are considered as income for
tax purposes.

Deductions are those amounts deducted from an employee’s
pay by the employer. Some of these are called statutory de-
ductions because the law requires the employer to deduct them
from the employee’s pay. The statutory deductions are PAYE,
NSSF, LST and tax on lump sum payments.

Lump sum payments are those cash payments that do not
relate to the current month alone. Some like gratuity and
bonuses have accrued over past months while others like ter-
minal benefits may relate to past or future months. We make
the distinction between lump sum payments and monthly cash
earnings because the two are treated differently when calcu-
lating income tax.

Refunds are payments made to an employee, e.g. travelling or
subsistence allowances, for business expenses incurred while
on duty. These payments are not income and are therefore
not taxable.

The payroll transactions file is accessed by selecting Payroll
from the File menu. This displays a data entry form (figure
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3.2) where you enter earnings, deductions, benefits, lump sum
payments and refunds for each employee.

" Payroll Transactions File

Recond 1of 44 DROI Liheneern, Stephen Asega
Eamings
B BascPay [ 14,000 |
Deductions Cvertme [ 7 J
Benefis House Allowance [+ 250,000
Luerg Sum P, ]
‘ayment l—
Rifunds:
Statubary Deductions
_ Smay |
Tauable Pay
li
1,670,000

Figure 3.2: Payroll Transactions File form

Statutory deductions and other calculated amounts such as
taxable pay, net pay and gross pay are updated as data is en-
tered. This makes the calculations more transparent and helps
to reduce data entry errors. The payroll transactions file can
only include employees present in the employee master file.
Use the Delete command in the Record menu to suspend em-
ployees from the payroll. Suspended employees can be restored
at any time using the Record > Add command.

At installation, the payroll transactions file has three earnings
(Basic Pay, Overtime and House Allowance), three deductions
(Rent, Overdraft Recovery and Rounding C/F), one non-cash
benefit (Employer Pension) and one refund (Rounding B/F).
These fields cannot be deleted but you can add more according
to your needs.

To add, delete or edit fields, select Earnings, Deductions, Ben-
efits, Lump Sum Payments or Refunds from the File menu. A
data entry form will be displayed showing the field attributes
listed below (figure 3.3). To add or delete fields select Add or
Delete from the Field menu.

The following field attributes apply to all fields:
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Deduchions

Field 2 of 2

Field Hame | Savers Pension

Tyoe [Penson Contrbunon ] | Parameters... |
Amount |Percentage of Sdary | Percentage...

I ¥ Pre-tax deducton
[ oe

Figure 3.3: Deductions form

. Field Name: The name of the field e.g. advance, shift

allowance.

. Type: This is used to indicate permanent fields (e.g. ba-

sic pay and rent). It is also used to specify fields that
are calculated in a unique way (e.g. hourly pay and
daily pay) and those that are associated with a balance
that is updated and displayed by the system (e.g. loan
repayments and co-operative contributions). The type
advance is used to indicate advance payments so that
appropriate reports can be generated.

. Amount: This attribute specifies how the amount paid

to or deducted from each employee is arrived at. It may
be keyed in, a percentage of salary, a function of the time
worked (basic pay, overtime, hourly pay and daily pay)
or amortised (loan repayments).

. Static: Static fields retain their value when the month

end procedure is run, whereas non-static fields are reset
to their lower limit. This is only important for fields that
are keyed in. Tt saves you the trouble of having to key
in the amount earned or deducted each time the month
end procedure is run.

. Tazable/Pre-tax deduction: For earnings the taxable at-

tribute specifies whether or not the payment is subject
to PAYE. Unless prior permission has been given by the
URA, all income (i.e. earnings, non-cash benefits and
lump sum payments) must be taxed. Refunds are not
taxable as they are not a form of income.

The pre-tax deduction attribute indicates those deduc-
tions to be subtracted from gross income before calcu-
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lating PAYE.

Depending on the selection for Type and Amount attributes
the following additional attributes may be available:

1. Co-operative: The name of the co-operative associated
with the field (figure 3.4).

Co-operative e
Mame: -

QK Cancel |

Figure 3.4: Co-operative dialog box

2. Pension Fund: The name of the pension fund and other
details pertaining to the current field (figure 3.5).

Pension Fund Parameters 4

Mame |Savers Penmon d OK

Carcel
Employers Contibution -

|:e-'-:n.=rlag—; af Salary ;l
Percantage 5.00
[ Aoply Limke

Lower Limi 0
Upper Limi Ii

Figure 3.5: Pension Fund Parameters dialog box

3. Limits: The upper and lower limits that the amount
paid or deducted should be restricted to (figure 3.6).

Limniits =
Lower Limit ]
Upper Limit 2000000

[ ox | Cancel |

Figure 3.6: Limits dialog box

4. Percentage: The percentage of monthly salary that should
be paid or deducted (figure 3.7).
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PecemgeotSly X
—

[ Apply Limits Cancel
lowerlmt [ O
Uppsar Limit I_I:-

Figure 3.7: Percentage of Salary dialog box

5. Hourly Rate: The hourly rate to use for earnings that
are of the type Hourly Pay (figure 3.8).

(¥ Basic Pay Rtex | 0.50

" Ky in rata for sach employes

ok | coce |

Figure 3.8: Hourly Rate dialog box

6. Daily Rate: The daily rate to use for earnings that are
of the type Daily Pay.



4 Reports

Aren Payroll produces numerous reports as described below.
These reports can be viewed on the screen and printed out.
You can choose to print the entire report, a range of pages, or
just the page that you are currently viewing. Internal reports
can be sorted by either employee number or name.

You can view and print reports for current as well as past
months and years. You can also filter most reports by ad-
ministrative unit, station, pay group, bank, co-operative or
pension fund.

Reports may be printed on any printer connected to your com-
puter either directly or through a local area network. Because
all reports are formatted for A4 paper, the printer must be set
to print on A4.

1. To open a report select it from the Report menu and then
follow the on-screen instructions. For example, selecting
Report > Payslips opens the Open Payslips dialog box

(figure 4.1).
Open Payslips A
Pay Perod
Year |'“"“' Cancel |
Manth |:|E|CI."I1:I." ﬂ Mant =

Figure 4.1: Open Payslips dialog box

2. To print the open report select Print from the File menu
which brings up the Print dialog box (figure 4.2). Use the
Setup button in this dialog box to configure the printer
you want to use.

3. Choose Close from the File menu to close the report.
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Frint *

Prnber;

Micrasolt Print 1o PDF en
PORTEROMET: [ ok |

Cancsl
Pages to print
. Setup..
= Al
" Cumert Page
(" Pages
Fram To

Number of Copies: | |

Figure 4.2: Print dialog box

Nominal Rolls

1. Employees Roll: List of employees who are currently ac-
tive. It shows their job title, administrative unit and
station.

2. Joiners Roll: List of employees who joined the organi-
sation recently. It shows their job title, administrative
unit, station and start date.

3. Leavers Roll: List of employees who left in a given year.
It shows their final job title and administrative unit, the
date they left and the reason for leaving.

Monthly Payroll Reports

The monthly payroll reports relate to a single month. Reports
for the current month are updated as you update the employee
master file and the payroll transactions file. Reports for pre-
vious months can be viewed and printed out, but they cannot
be modified in any way.

Overview Reports

1. Payroll Summary: Summarises earnings and deductions
for all employees.

2. Payroll Control Account: T-account listing total earn-
ings, deductions and net pay for all employees in the
organisation.

3. Muster Roll: List of employees showing all earnings,
lump sum payments, refunds and deductions for the month.
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Records in this report can be grouped by administrative
unit or station.

4. Payroll Variance: List of employees showing the differ-
ences in the payments and deductions made in any two
pay periods. It is essentially the difference between the
muster rolls for the two pay periods.

The muster roll and payroll variance can be viewed on the
screen or saved to a text file but they cannot be printed out.

Detail Reports

1. Farning Report: List showing, for a particular earning,
how much each employee was paid.

2. Deduction Report: List showing, for a particular non-
statutory deduction, how much each employee was de-
ducted. If the deduction selected is a loan repayment, a
loan report is printed instead.

3. Loan Report: List of employees repaying a specific co-
operative or company loan. It shows the opening and
closing balances and a breakdown of the repayment amount
into interest and principal components.

4. Benefit Report: List showing, for a particular non-cash
benefit, how much each employee received.

5. Lump Sum Report: List showing, for a particular lump
sum payment, how much each employee received.

6. Refund Report: List showing, for a particular refund,
how much each employee received.

Payments to Employees

1. Payslips: Slip giving a breakdown of the earnings and
deductions of each employee separately (figure 4.3). The
employer’s pension contribution and the pension fund
balance can be shown in the payslip if required. When
the balance is shown, it includes the employer’s portion
only if the option to print the employer contribution has
been selected.

2. Cash List: List of employees paid in cash showing their
employee number, name, net pay or advance payment
and a cash analysis of the payment amount.
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Figure 4.3: Payslips

3. Cheque List: List of employees paid by cheque showing
their employee number, name and net pay or advance
payment.

4. Bank Transfer Report: List of employees who are paid
by bank transfer showing their name, ID number, bank,
branch, account number and payment amount. The pay-
ment amount may be the net pay, an advance payment
or a bank loan repayment.

5. Coinage Summary Report: List showing the number of
coins and notes of each denomination that are required
for workers who are paid in cash. This information is
the same as the totals in the cash list but formatted so

that it can be used when withdrawing the cash from a
bank.

Returns

1. IR10: Uganda Revenue Authority (URA) monthly tax
return card. It is a list of employees that shows taxable
income, monthly relief and PAYE for each employee.

2. NSSF Report: List of employees showing the total em-
ployee and employer NSSF contributions.

3. LST Report: List of employees paying local service tax.
For each employee it shows TIN, gross pay and tax payable.

4. Co-operative Report: List of members of a particular co-
operative society showing membership number, monthly
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Annual Payroll Reports

Other Reports

contribution and any other payroll deductions to be paid
to that co-operative.

Pension Report: List of members of a particular pension
fund showing membership number and employer and em-
ployee contributions to that pension fund.

Lump Sums Tax Report: List showing tax payable on
lump sum payments for each employee.

Annual payroll reports relate to a calendar year and are avail-
able throughout the year. For the current year, the informa-
tion displayed relates to the months that have elapsed so far.
The reports are:

1.
2.
3.

Payroll Control Account.
Muster Roll.

Annual Pay Sheet: A report that, for each employee,
gives a summary of payments, deductions and benefits
for a whole year.

P9: URA form titled Taz Deduction Card. Each P9A
gives a breakdown of the income of an employee for each
month of the year and shows the amount of tax deducted.

At the end of each year, the employer should submit to
the URA a P9 for each and every employee from whom
tax was deducted in the course of the year.

P10: URA form titled Employer’s Certificate. 1t shows
the total tax deducted by the employer for each month
of the year. The employer should submit it to the URA
at the end of each year, together with the P10A.

. P10A: URA form titled PAYFE Supporting List for End

of Year Certificate. 1t lists the annual income and total
tax deducted from each employee.

NSSF Statement: A report that shows the employee and
employer contributions to NSSF for a single employee for
a calendar year.

. Bank Codes: A listing of banks, bank branches and their

sort codes drawn from the banks files.



30

4 Reports

Report Files

2. Audit Trail: List that shows the date and time of each
login, backup, month end procedure and any other major
event. It also shows the user responsible for each event.
This report is only available to the supervisor.

Almost all reports are printed from report files, not directly
from the employee data files. Briefly, the report files are:

1. Active employees report file
2. Annual leavers report files
3. Monthly payroll report files
4. Annual payroll report files

Report files are updated automatically by Aren Payroll. Use
the General Options dialog box (Organisation > Options >
General) to specify how long to keep these files for.
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Backing Up

If your data files are accidentally deleted or corrupted you
could lose all your data. Without an up-to-date backup you
would be forced to key in the data for the current month again.
It is also likely that you would be unable to recreate data for
previous months and years. It is therefore very important that
you make regular backups of your data files.

To back up files for the organisation that is currently open, se-
lect Backup from the Procedure menu. You will be prompted
to specify the name and location of the backup file to be cre-
ated (figure 5.1).

AF Bachup =

T v Papl e+ beckup - L Seerch backup

Mame Dzte medfie fype

&F Dropbax
il Crellies
&= ThisPC

¥ Helwnrk

File nzme:

Save as type: | Backup Files [*.bkf)

# Hide Falders Cencel

Figure 5.1: Backup dialog box

The backup process copies all data relating to your organi-
sation to the backup file. Should you have set up more than
one organisation, you will need to back up each one separately.
Note that data that is shared by all organisations is not backed
up (e.g. list of banks and statutory deductions parameters).

When running the month end procedure you will be prompted
to back up. Though you can choose to proceed without doing
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so, it is recommended that you back up first. To encourage
regular back ups Aren Payroll prompts you to back up each
time you exit.

Restoring from Backup

In the event that your data files are corrupted or deleted you
will need to recover them from a backup file. You can also use
backup files to revert to an earlier month. This is especially
useful if you accidentally run the month end procedure.

To restore an organisation’s files from backup, select Restore
from the Procedure menu then follow the on-screen instruc-
tions (figure 5.2).
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n the backup fie. You are encouraged to
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erer your password below
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Figure 5.2: Restore dialog box

Creating a Bank Transfer File

A bank transfer file is an electronic version of the bank transfer
report. It is used by banks to process payments for employees
paid by bank transfer in place of the printed bank transfer
report. Aren Payroll can create bank transfer files for numer-
ous banks including Barclays, Citibank, Stanbic and Standard
Chartered.

1. To create a bank transfer file select Bank Transfer File
from the Procedure menu. The Save Bank Transfer File
dialog box appears (figure 5.3).

2. Specify the format of the bank transfer file to create
and the name of the payment field (usually net pay).
Depending on the file format, you may be able to specify
the date you want the bank transfer effected.
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Figure 5.3: Save Bank Transfer File dialog box

3. After closing the Save Bank Transfer File dialog box, a
standard Save As dialog box appears. Use this dialog to
specify the name and location of the file to be created.

For further details on bank transfer files please contact your
bank.

Terminating an Employee

To terminate an employee, open the employee master file and
display the target employee. Next, select Terminate from the
Record menu. In the Terminate dialog box that appears (figure
5.4), enter the termination date, the reason for leaving and, if
you like, some brief comments.

Terminate Lihenzera, Stephen fsega A
Temination Date | oK
NN22020 - Cancel
Reason far Leaving
Resigned hd

Remarbe:

Figure 5.4: Terminate dialog box

The terminated employee will be removed from the employee
data files in the next month end procedure that is later than or
on the same day as the termination date. Once the employee
is deleted from the employee data files his record will be added
to the leavers report file.
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Termination can be reversed by selecting Record > Undo Ter-
mination as long as the terminated employee has not been
removed from the employee data files.

Closing the Month

The month end procedure is used to close data entry for the
current month and begin a new one. It applies only to the
organisation that is currently open. It does the following:

1.

Saves all payroll information for the current month to
the monthly and annual report files.

Transfers terminated employees from the employee mas-
ter file to the leavers report file.

. Deletes the current payroll transactions file and creates

a new one for the coming month.

Deletes any report files that have exceeded the maximum
age set in the General Options dialog box.

. Advances the pay period by one month.

. If the new month is July, it creates statutory deduction

files for the new year.

The month end procedure should only be run after all reports
for the current month have been verified since, once it is run,
reports for that month cannot be changed.

To run the procedure:

1.

Select Month End from the Procedure menu. This op-
tion is only available if you have licensed the organisa-
tion.

. After reading the dialog box that appears (figure 5.5),

confirm that you want to close the month by entering
your password.

. You will now be prompted to back up your data and are

strongly encouraged to do so.

Once the back up is complete, the month end proce-
dure will automatically follow. Eventually, a message
box confirming its completion will appear.



Closing the Month

35

Runining the manth end procedure wil doss
data entry for Decembear 2020, Subseequent

payroll and persarnel emines wil appear in
f Jaruary 2027

i you ane sune you want fo continue, please
ertler your .

Paswod [
o | cwed | we |

Figure 5.5: Month End Procedure dialog box
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Appendix A Importing Data

File Format

Keying in new employees into the payroll can be very time
consuming especially if there are many of them. As an al-
ternative, you can import employee data into the employee
master file from a text file.

The easiest way to create the input text file is to capture em-
ployee data in a spreadsheet and then save the spreadsheet as
a text file.

The format of the input text file is as follows:

1.

Plain text with data items separated by the tab character
(i.e. a tab-separated text file).

The first row of data is a header with the data items
Employee Number, Last Name, Other Names, ID Num-
ber, Job Title, Admin Unit, Station, Pay Rate, TIN and
NSSF Number.

From row two onwards, each row has data for a single
employee, i.e. employee number, last name, other names,
ID number, job title, administrative unit, station, pay
rate, TIN and NSSF number.

Note that:

1.

The first row (file header) is ignored. It is only included

for the convenience of the person preparing the input
file.

. A row will not be imported if the employee number

matches that of a record already in the employee master
file.

. A row will also be skipped if any of the following data

items is blank: employee number, last name, other names,
job title, administrative unit, station.

Data will be imported into several files—employee mas-
ter, payroll transactions, jobs, adminstrative units and
stations.
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How to Import

. Where a default profile has been defined, it will be ap-

plied to each record added to the employee master file.

. Back up your data just in case you need to undo the

changes you are about to make (Procedure > Backup).

. Select Procedure > Import Employees to open the first

Import Employees dialog box (figure A.1).

Import Mew Employees b
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<
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Figure A.1: First Import Employees dialog box

. Enter your password to open the second Import Employ-

ees dialog box.

. Browse to the text file that you want to import data

from and click on Open.

. Aren Payroll will read the text file and update several

data files—jobs, administrative units, stations, employee
master and payroll transactions. On completion, a con-
firmation message box will be displayed. Close the mes-
sage box.

. To see which records were updated, refer to the log file

import.log located in the payroll data folder. Browse
through the data files that should have been updated to
confirm that they were updated successfully.
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Aren Payroll can email payslips to each of the employees in the
payroll. This provides an alternative to printing individual
payslips for each employee. Payslips are sent as password-
protected PDF files.

Entering Email Addresses

Start by capturing the email addresses to send employee payslips
to.

1. Open the employee master file (File > Employee) and
select the options tab (figure B.1).

" Employee Master File
Recond 1 of 45 DRO0T Lihenzern, Stephen Asega

;F!' Emal payshps to:
Paymerd Imgaﬂdl:mnrc:tm:mt.-:n.l.g

Figure B.1: Employee Master File form

2. For each employee, enter the address to email payslips
to.

3. Close the employee master file.

Setting Up Email Account

In order to send email, you need to set up your email account.
For this you require details of the outgoing mail server, also
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known as the SMTP server. Consult your IT department if
necessary or check the settings in the email software you use.

1. Select System > Email Account to open the Email Ac-
count dialog box (figure B.2).

Ernail Account

Emai Address [l"fc- Edemorestaurant.co.ug K I
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Figure B.2: Email Account dialog box

2. Email Address: Enter your email address, say info@-
demorestaurant.co.ug or example@gmail.com.

3. SMTP Server: Enter the name of the outgoing mail
server, e.g. mail.demorestraurant.co.ug or smtp.gmail-
.com. You can also enter the server’s IP address, e.g.
192.168.0.23.

4. SMTP Port: The SMTP port is a unique number that
the mail server has set aside for outgoing mail. The most
common values are 25, 465 and 587. If your server uses
a secure (encrypted) connection, e.g. smip.gmail.com or
smip.mail.yahoo.com, try port 465 or 587. If it does not,
enter 25.

5. Use secure connection: Check this option if the mail
server uses a secure connection.

6. Authentication: You may select none (no account name
or password required), plain or login (requires account
name and password).

7. Account Name and Password: Enter the login name and
password for the mail server if you have selected login or
plain authentication.
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8. Copy all emails to self: Check this option if you want to
receive a copy of all the payslips you send.

9. Close the Email Account dialog box.

Sending Payslips
Now you are ready to email payslips to employees.

1. Select Procedure > Email Payslips to open the Email
Payslips dialog box (figure B.3).

Email Payslips A
Pay Perod
ear | a0 Cancel
Manth |:|E|CI."I1:I." ﬂ Mant =

Figure B.3: First Email Payslips dialog box

2. Choose the pay period that you want then click OK. This
opens another dialog box with the same title (figure B.4).

3. Click on Send to open the Message Range dialog box
(figure B.5).

4. Use the Message Range dialog box to send the current
message, all messages or a range of them. On comple-
tion, a message box showing the number of messages sent
will be displayed.

5. Close the Email Payslips dialog box when you are through.

Details of the last mail session are saved in the log file email.log
located in the payroll data folder. Refer to this file if you have
any difficulty sending messages and to see which messages were
actually sent.

How to Open Payslips

Once a payslip is sent, the recipient will need a password to
open it. Each payslip has two passwords:
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Payslip Messages
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Figure B.4: Second Email Payslips dialog box
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Figure B.5: Message Range dialog box

1. Owner Password: The last four digits of the organisa-
tion’s TIN. For instance, if the organisation’s TIN is
0123456789, the owner password will be 6789. Should
the organisation’s TIN be blank, the default password is
owner.

2. User Password: The last four digits of the employee’s
TIN. Where the employee’s TIN is missing, the default
password is user. This is the password that employees
should use.

You can modify the message that is sent to employees to in-
clude help on the password they will use to open the payslip.

1. Go to Organistion > Options > Reports to open the
Report Options dialog box (figure B.6).
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Figure B.6: Report Options dialog box

2. Select Electronic Payslips and click on Options. This
opens the Electronic Payslips Options dialog box (figure
B.7).

Electronic Payelips Options %
Meszage

I Inchude password help

Sart By
* Emplayee Number
™ Mame

Figure B.7: Electronic Payslips dialog box

3. Check the option Include password help.
4. Close the Electronic Payslip Options dialog box.
5. Close the Report Options dialog box.
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Appendix C Formulae

Loans

Amortisation

Reducing Balance

The loan payment amount is uniform throughout the repay-
ment period. The portion of the payment amount that goes
towards repaying the principal increases with time as interest
payments reduce.

]
I—(1+r)"

Payment = l

where W = principal amount, n = total number of payments,
r = monthly interest rate (e.g. if annual interest rate is 15%,
r = (15/100)/12 = 0.0125).

The amount paid towards the principal is fixed throughout the
loan duration while interest payments reduce with time. Thus
the total payment amount reduces with time.

1
Payment = W' (/ + 7’)
n

where W’ = outstanding balance, n’ = number of payments
outstanding, » = monthly interest rate.



