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1 Introduction

About Aren Register

Getting Started

Aren Register is an extension of the traditional payroll system
to include some features normally found in personnel systems.
It runs in the Microsoft Windows environment.

Aren Register lets you specify the posts available in your or-
ganisation and then assign existing employees to these posts.
As new employees join they are assigned to the posts you have
specified. Employees are retained in the system until they
leave the organisation. Reports on current and former em-
ployees are provided.

The system will help you to keep track of annual leave days
earned and taken by employees. You will also be able to record
all absence from work. Annual reports on leave and absence
are available.

Aren Register makes it easy to process employee pay. It en-
ables you to specify all payments and deductions that apply
to each employee. Several reports are derived from this data,
including payslips, payroll summary, payroll control account,
returns for PAYE, NSSF and LST as well as monthly returns

to user-defined co-operatives and pension funds.

Access to the system requires a username and a password.
There is one permanent user who has unrestricted access to
the entire system. Other users can be added at any time and
assigned access to those functions they need to use.

A single installation of Aren Register will support multiple or-
ganisations though a separate licence is required for each of
them. For each organisation, four pay frequencies are sup-
ported, viz monthly, weekly, biweekly and irregular. The ir-
regular pay frequency caters for employees who are not paid

at fixed intervals. A comprehensive backup system is also pro-
vided.

To use Aren Register you need to install it and configure it
to suit your needs. The rest of this section shows you how to
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begin this process.

Installation

To install Aren Register:
1. Insert the installation CD in the CD drive.

2. Run the program setup.eze on the installation CD.

2l Aren Register 6.1.1 Premier - O *

Welcome to the Aren Register 6.1.1 Premier Setup
Wizard

Thea inztaller wal guide pou thiough the steps required bo instal Aren Registar 6.1.1 Premies on your
oMLt

WARNING: This compubes program it protectad by coppight law and inbemational bealies
Urnauthonzed duplicaton or disibubion of this program, or ary portion of ik, may result in sevane civil
or cimnal penakes. and vl be prozecuted fo the maamum extent possible under the law

Figure 1.1: Setup Wizard

3. Follow the on-screen instructions that appear during the
installation process (figure 1.1).

The installation process copies the files required by Aren Reg-
ister to the folder you specify on the hard disk of your com-
puter. It will also add Aren Register and its Help file to the
Start menu.

Creating a Data Folder

1. Once the installation process is complete, run Aren Reg-
ister by selecting it from the Start menu (figure 1.2).

2. In the Start dialog box that appears, click on Data Folder
to open the Data Folders dialog box (figure 1.3).

3. Click on Create in the Data Folders dialog to create a
new data folder in which to store Aren Register data.

You can locate your data folder anywhere you want on
your computer or on a shared folder on another com-
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AREN REGISTER

Premier Uganda Edition
12 Aren Software Lid, 1958-2020

[Mare]

Lagin | Cancel || Data Folder.., I

Figure 1.2: Start dialog box

Data Folders x

Aveilable Folders

Select... Create. ..

Target Folder
[Mane]

Clgz

Figure 1.3: Data Folders dialog box

puter. Make sure you have unrestricted access to whichever
location you choose, otherwise the software may not work

properly.
4. Close the Data Folders dialog to return to the Start di-
alog.

5. Within the Start dialog, click on Login to open the Login
dialog box.

Logging In

1. In the Login dialog box enter the username supervisor
(figure 1.4).

2. You will be prompted to enter a password for use in
subsequent logins (figure 1.5). Enter a password of your
choice.



4 1 Introduction

¥ Snplewuser mode
7 Muli-user made

Figure 1.5: Set Password dialog box

3. The New Organisation dialog box is displayed next (fig-
ure 1.6). Type in the name of your organisation and the
month from which you want to start entering data.

Pame | Cemo Restaurant Lid IE

Canel

Manth |December

Year | 2020

Local Currancy |L|gmd.= Silng

Payrall Currency |uuanda§|"1-:l ;I

Figure 1.6: New Organisation dialog box

4. Close the New Organisation dialog box to begin using
Aren Register.
Moving On

Before entering employee data you need to finish setting up
the program. Section 2 explains how to do this. To enter
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employee data refer to Section 3 which describes the employee
data files in Aren Register.

After entering employee data you can view the reports de-
scribed in Section 4. With the exception of the muster roll
and payroll variance, all reports can be printed out on A4

paper. Use the muster roll to export payroll data to a text
file.

To close the current data entry period and start a new one,
run a period or month end procedure as described in Section
5. That section also describes how to back up and restore data
and create bank transfer files.



1 Introduction




2 Setting Up

Before entering details about employees, use the Organisation
and System menus to configure the program. The Organi-
sation menu options apply only to the organisation that you
are currently working with whereas those of the System menu
apply to all organisations that you define.

Setting up the System

Users

Aren Register supports an unlimited number of users. There
is always at least one user, supervisor. The supervisor has ac-
cess to all functions including adding and deleting other users
and assigning such users access to program functions. By re-
stricting users to only those parts of the program they need
for their work, it is possible to enforce separation of duties.

If you wish to add new users at this stage, do the following:

1. Select Users from the System Menu. This displays the
Users dialog box (figure 2.1).

Users

Clase

(L LLE ]

Figure 2.1: Users dialog box

2. Click on the Add button which brings up the User Iden-
tity dialog box (figure 2.2).

3. In the User Identity dialog enter the username. Enter
and confirm the password if you wish. If you do not
enter a password at this stage, the user will be required
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Lisermame chrgine
Pasmword Ii
Caonfirm '7 ......
Fassword

L=t Flame Mamazzi

Cther Names |C"|'a':he

oK Cancel |

Figure 2.2: User Identity dialog box

to enter one when logging in for the first time. You may
also enter the user’s real name to help you identify him
or her in future.

4. Close the User Identity dialog and choose Rights from
the Users dialog box. This displays the User Rights di-
alog box (figure 2.3).

User Rights for christine x
Meru
& Ful menu IL'
™ Persornel only Cangel
" Paymal only
Fundlions

[V Edi emplayee data fles

¥ Modfy payrl fields

¥ Set up open organization

¥ Close pay petod or month
[~ RAestors fikee

[ Add and delete angariaatona
W Modfy tax tables

Figure 2.3: User Rights dialog box

5. Use this dialog box to select which menu the user should
see: full menu, personnel only or payroll only. Also spec-
ify the functions within the selected menu that you would
like the user to have access to.

6. Close the User Rights dialog box. You can add more
users by repeating the procedure above.

7. Click on Close in the Users dialog box.
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Banks

Aren Register comes with a comprehensive list of banks and
their branches. You will need this list for employees paid by
bank transfer rather than in cash or by cheque. The list is
shared by all organisations that you create. To review or mod-
ify it, select Banks from the System menu which will bring up
the Bank and Branches dialog box (figure 2.4).

Banks and Branches

x

= Bank of Baroda Add Bark...
= Bank of Uganda
Bardays Bank Add Branch
Cairo Internabonal Bank
Centenary Rura Dev Bank l=te
Citibark

& Crane Bank Propertes...
& DFCU Banig

daa

Diamond Trust Sank Clage
Matona Bank of Commerc
Mie Bank

& Oment Bank

& Stanbec Bank

& Standard Chartered Bark

& Transafrica Bank

& Tropical Africa Bark

# Uganda Commeroal Bank

Figure 2.4: Banks and Branches dialog box

Statutory Deductions Parameters

PAYE and LST are calculated using brackets and rates that
are stored as tables. To view and update these tables select
PAYE Rates or LST Rates from the System menu (figure 2.5).
Refer to the current P7 booklet from the Uganda Revenue
Authority (URA) for an up-to-date PAYE table.

The calculation of PAYE also depends on the low interest ben-
efit arising from loans made to employees by the organisation.
To update the statutory interest rates that are used in deter-
mining this benefit, select System > PAYE Parameters. This
will open the PAYE Parameters dialog box (figure 2.6).

Employer and employee contributions to NSSF are percentages
of gross pay. To modify these percentages select NSSF Rates
from the System menu (figure 2.7).

Working with Organisations

A single installation of Aren Register can support up to 99
different organisations. Each organisation requires a separate
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PAYE Rates for 2020/2021 x
Lawer Limit [ upper Limit Tax Rate (%)
! 235000 0.00
235001 335000 10,00
335001 410000 .00 Delete
410001 10000000 30,00
10000001 - Hione - .00 =

Close

Figure 2.5: PAYE Rates dialog box

PAYE Pararmeters for 202002021 =

Statutory Interest Rate (%):

July to December Q.00
January o June Q.00

K I Cancel |

Figure 2.6: PAYE Parameters dialog box

MNS5F Rates fior 202072021 x

Cantribution oK

Percentage of gross pay:
Cancel
Employes 5.00

Employer 10,00

Figure 2.7: NSSF Rates dialog box

licence. The name of the organisation that is currently open
is displayed in the title bar of the main window.

Adding a new Organisation

To add a new organisation select Add from the Organisation
menu. Use the New Organisation dialog box that follows (fig-
ure 2.8) to enter the name of the organisation and the month
from which you want to start entering data. On closing the
dialog box, the previous organisation is closed and the new
one opened.
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MNew Qrganisation b4

Mame | Demo Company Lid b I
Cancel

Manth |December =

Year | 2020

Local Curency | Uganda Shilng

Payroll Currency |_I|:|arp:la shiling Ll

Figure 2.8: New Organisation dialog box

Opening another Organisation

To open a different organisation select Open from the Organi-
sation menu. This will bring up the Open Organisation dialog
box (figure 2.9) provided there are other organisations defined.
Select the organisation you want to open from the dialog box.

Open Crganisation x
Dlema Ressuran Lid
ok | Cancel

Figure 2.9: Open Organisation dialog box

Deleting an Organisation

You can delete any organisation that is currently not open.
Deleting an organisation causes all its data files and folders to
be deleted. It is strongly recommended that you back up the
organisation’s data files before deleting it (see Section 5).

To delete an organisation:

1. Select Delete from the Organisation menu. To minimise
the risk of accidentally deleting an organisation you will
be required to enter your password (figure 2.10).
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Delete Organisation =

Dieleting an oarganisation wil cause al ts data
fibeea b be deleted . You are strongly advieed to
back up thess fils before continung

S

I you are sune you want fo continue, please
erer your password below

Pasgword |

Figure 2.10: First Delete Organisation dialog box

2. Next, a list of all organisations in the system, exclud-
ing the one that is open, will be displayed (figure 2.11).
Select the one you want to delete. Note that it is not pos-
sible to delete the organisation that is currently open.

Delete Organication *
| Derma Compary id |
ok | Caneel

Figure 2.11: Second Delete Organisation dialog box

3. In the two message boxes that follow, confirm that you
want to delete the selected organisation and destroy its
data files.

4. Aren Register will then delete the organisation. A dia-
log box confirming that the deletion is complete will be
displayed.

Setting up an Organisation

To configure the organisation that is currently open, proceed
as follows:
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Basic Organisation Information

Licensing

Payroll Info

Open the Basic Organisation Info dialog box (figure 2.12) from
the Organisation menu and enter the organisation’s address
and telephone number.

Basic Qrganisation Info e

Hame | Demo Restaurant Lid
Status: Mot ioensed

Felder: 0:\Regs 11Pmriorgd 1

Manth | ecember T| Year | 2020
Address
P.0. Box | 12345 Town | Kampala
Post Cade Teleshons | 555001
[ o= | Cancel

Figure 2.12: Basic Organisation Info dialog box

Also, confirm that you want to start entering payroll and leave
details in the month and year shown in the dialog box. Once
you run the first period or month end procedure you will not
be able to edit either of them.

Select Licence from the Organisation menu to open the Licence
dialog box (figure 2.13). Type in the licence number supplied
by your dealer. If you do not have a licence number, contact
your dealer or Aren Software Ltd.

Licence x
Licence Mumber; [ 4ECO-0CA

| o= |  cancm Helo

Figure 2.13: Licence dialog box

Open the Payroll Info dialog box (figure 2.14) by selecting
Payroll Info from the Organisation menu. Enter the bank,
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branch and account number for the organisation’s salary ac-
count. Also enter the organisation’s TIN and NSSF numbers.

Payroll Info *
1D Mumbers
TIN | TO573355 o I
NSSF Mo, | FO3042 Cancel
Currenoes
Local 0_|rr|_l-r|c||r |wﬂ“dﬂ 5|'i|i"|l_.'|
Fayrol Currency |L,|;|:|n:a chiling ﬂ
Banking
Bark |Barcays Bark j
Brandh |F-um|:-u|a Road T|
Aecount Ne. | 01334567
Sender ID |
Figure 2.14: Payroll Info dialog box
In this dialog box, the Standard File Interchange (SFI) Sender
ID applies to those who submit their payroll to the bank in
electronic form. Leave this field blank if you do not already
have an SFI Sender ID.
Grades

Aren Register assumes that all jobs that employees may be
assigned to are graded or ranked. To set up the grades for
your organisation select Grade from the Organisation menu.
The Grades dialog box that follows (figure 2.15) allows you to
specify the name, rank and salary range for each grade.

Grades x
Jurior Staff
Manager ﬁ
Professional Staft
Seniar Stalf Delete |

Froperties..

it

Figure 2.15: Grades dialog box
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Jobs

Administrative Units

Posts

If your organisation has no grades, create only one grade called
(None) and enter a salary range that will cater for all employ-
ees.

To set up the jobs available in the organisation, open the Jobs
dialog box by selecting Jobs from the Organisation menu. For
each job you must enter the name of the job and its grade.
You may also enter a brief description of the job for future
reference.

Set up the administrative units (departments, sections, etc) in
your organisation. To do this select Units from the Organisa-
tion menu.

A post is a job that is attached to a specific administrative
unit. Aren Register does not accept new employees unless
they are attached to previously vacant posts.

In order to create posts you must create grades, jobs and ad-
ministrative units first. To add posts select Posts from the
Organisation menu which opens the Posts dialog box (figure
2.16). For each administrative unit and job you will need to
specify how many permanent, contract, temporary and casual
posts to allow.

Posts x

Administrative Units: Pasls in Accounts

_m Accountant (2)

Administralinn Chief Accountart (2) Edr

Housskeeping
Hatehen
[fanagemert
Seculy

Service

Figure 2.16: Posts dialog box
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Stations

Pay Groups

Set up the stations (branches) in your organisation. To do this
select Stations from the Organisation menu.

Pay Groups allow you to filter payment reports according to
how employees in your organisation are paid. For example,
the bank transfer report could be filtered by bank branch or
pay date.

To set up pay groups, select Pay Groups from the Organisation
ment.

Co-operatives and Pension Funds

Employee Profiles

General Options

Create co-operative societies that employees in the organisa-
tion belong to by selecting Co-operatives from the Organisa-
tion menu.

Similarly, set up pension funds by selecting Pension Funds
from the Organisation menu.

An employee profile defines attributes that are common to a
group of employees. These attributes are leave entitlement,
pay frequency, basic pay type (i.e., salary, daily rate or hourly
rate), standard working hours (per day and per pay period)
and whether overtime is payable.

To create a profile, select Profiles from the Organisation menu
to open the Employee Profiles dialog box (figure 2.17). If there
is an employee profile marked as default, all new employees
added to the payroll will be assigned this profile.

Selecting Options > General from the Organisation menu opens
the General Options dialog (figure 2.18). This dialog is used
to specify the default pay frequency. This is the pay frequency
that the program defaults to when opening the payroll transac-
tions file or initialising dialog boxes that display pay frequency.

The General Options dialog also allows you to choose the sort
order for employee data entry forms. You can also specify
when to purge old reports. Deleting old reports saves space
on the hard disk and reduces the size of backup files.
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Payroll Options

Ernployes Profiles »
Staff Add.

Delete |

Fropetes |

Figure 2.17: Profiles dialog box

General Dptions *
Default Pay Frequency Lego
* Monthly ™ Weekdy

[ Bivesskly { Irreguiar

Sart Farms By

& Employes N Select... Femove

[ Last Name

Past Reports

Purge after | 10 years

[ ] cwat | veb |

Figure 2.18: General Options dialog box

In the logo section, you can select a bitmap file that contains
the company’s logo. This logo will be printed at the top of
each payslip.

Selecting Options > Payroll from the Organisation menu brings
up the Payroll Options dialog (figure 2.19). The program can
adjust PAYE in June for any overpayment or underpayment
in the course of the tax year. In the Payroll Options dialog
you can specify if the adjusted PAYE value can be negative
(indicating a refund). If this option is not selected then the
minimum adjusted PAYE will be zero.

To deduct LST check the option Deduct LST. This option
switches local service tax (LST) on or off for the whole organ-
isation. For LST to be deducted from an employee, it must be
selected here and switched on for the individual employee in
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Payroll Dptions

PAYE

I Deduct PAYE before LST

5“;
]
X

I aAlow negative PAYE

Hep
L5T

W DeductLST

Mel Pay

For employee paid in cash:

o Pay exact amaount

" Rpurd down to nearest Ush

Figure 2.19: Payroll Options dialog box

the payroll master file.

Check this option for the first four months of the financial year
(July to October) when LST is payable.

You also have the option to round down net pay for employ-
ees paid in cash by an amount that you specify. The excess
amount is carried forward to the next pay period.

Report Options

Selecting Options > Reports from the Organisation menu opens
the Report Options dialog box (figure 2.20). This enables you
to choose the report options you prefer. You need not specify
them each time you open a report.

Report Options

Absence Sheets
Benefits

Cash List
Chegue List Clos=
Campariy Loan

Caontrol Acoount

Co-pperative Loan

[ Opliane.. .

i

Ceductons

Earmings

Bectroric Payshps

Emplayes Mester

Employees Roll

Haurly Pay

Joirers Rl

Lahels

Leawve Analysis

Leave Booked \.-

Figure 2.20: Report Options dialog box
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Pay Period End Days

If the pay frequency is monthly, the pay period is assumed to
end on the last day of the month. For other pay frequencies
the program requires assistance from the user to determine
when each pay period ends.

For weekly and biweekly pay frequencies, the user is required
to specify the last day of the very first pay period. The pro-
gram will work out when subsequent pay periods end. In the
case of employees paid at irregular intervals, the pay period
end day must be entered for each pay period.

To initialise period end days, you need to do the following for
each pay frequency that applies to your organisation (except
monthly):

1. Make it the default pay frequency using the General Op-
tions dialog box (Organisation > Options > General).
The pay frequency selected should appear in the status
bar.

2. Open the Pay Period dialog box (figure 2.21) from the
Organisation menu and enter the pay period end day for
this pay frequency.

Pay Period x
Week ending

4 December 2020

ok | caneal

Figure 2.21: Pay Period dialog box

In any given month, the pay period end days for weekly and
biweekly employees can not be edited once the first period end
procedure for that pay frequency is run.
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3 Data Files

Data for each employee is stored in four database files—personnel,
payroll master, payroll transactions and absence and leave.
There is a separate payroll transactions file for each pay fre-
quency. This data is used to create various personnel and
payroll report files which are then used for report generation.

Personnel File

The personnel file stores personal information about each em-
ployee, for example name, national ID number, date of birth
and nationality. It also stores information about employees’
jobs such as job title, grade, administrative unit, station and
leave entitlement.

Employees can only be added and removed from the system
through the personnel file. The employees in this file automat-
ically appear in the payroll master, payroll transactions and
absence and leave files.

The personnel file is accessed by selecting Personnel from the
File menu. This brings up a data entry form in which you enter
data for each employee (figure 3.1). For easy access the data
entry form is divided into five pages, i.e., Personal Details,
Employment Details, Contact Info, Family and Photo.

Persannel File

Racord 1 of 45 DR Lhenzem, Slephen Asega
Personal Detals
Parsonal
Last Mame: | Lihergero Tite |Mr -
_Ensloment_|
Cortact Other Mames | Stephen Assga
o Coder e ] o[
L
Birth Diate [ 5 Aug 1577 <] Passortha.
Marital Status [sarried =|  Work Pamsit Mo,
Mationality | Ugandan =]

Figure 3.1: Personnel File form
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Most of the fields in the file are optional. However, Em-
ployee Number, Last Name, Other Names, Post and Station
are mandatory. The optional fields are used in various reports
and should therefore not be left blank.

Adding and Deleting Employees

Payroll Master File

Employee records are added and removed from the personnel
file using the Add, Delete and Terminate commands in the
Record menu.

Deleting an employee record is only possible if it has not gone
through a period or month end procedure since it was added.
After deleting a record, no report will retain information relat-
ing to that employee. This option is provided to allow records
added by mistake to be expunged.

Terminating an employee will cause his record to be removed
from the personnel file in due course. However, various person-
nel and payroll reports will retain details of that employee for
future reference. Section 5 describes the termination process
in detail.

The payroll master and the four payroll transaction files store
employee payroll information. The former maintains informa-
tion that tends to remain the same over time while the latter
maintain information for a single pay period and this tends to
change more frequently.

The data in the payroll master file includes pay frequency, ba-
sic pay, bank account number, TIN, co-operative membership
and housing status.

To open the payroll master file, select Payroll Master from the
File menu. This brings up the Payroll Master File data entry
form which is divided into eight pages, i.e., Payment, Basic
Pay, Overtime, Housing, Statutory Deductions, Co-operatives,
Pension Funds and Options (figure 3.2).

Payroll Transactions Files

Each payroll transactions file stores earnings, deductions, ben-
efits, lump sums payments and refunds for all employees paid
in a particular pay period.
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Payvoll Master File

Co-operatives

Pension Funds Branch | Kampaks Road

Other

Record 1 of 45 DROOT Lihenzer. Stephen Asega
Payment
Paymart
Basic Pay | Pay Freguency |Monthly J
Oreerbime | Payment Mode |Ear|l: Transfer Tl
Housing | Pay Group | “one - Tl
PAYE |
NSSFALST | . —— D

Account Mo, | 1548967532

Figure 3.2: Payroll Master File form

FEarnings are those cash payments that relate to the current
pay period, e.g. basic pay or leave allowance. For tax purposes,
all cash earnings for all pay periods falling in a particular cal-
endar month are deemed to be the monthly cash earnings. A
pay period is deemed to fall in a particular month if its last
day falls in that month.

Benefits refers to private expenditure of an employee paid by
the employer, e.g. school fees, house rent or telephone bills.
These non-cash benefits are considered as income for tax pur-
poses.

Deductions are those amounts deducted from an employee’s
cash earnings by the employer. Some of these are called statu-
tory deductions because the law requires the employer to deduct
them from the employee’s pay. The statutory deductions are
PAYE, NSSF, LST and tax on lump sum payments.

Lump sum payments are those cash payments that do not
relate to the current month alone. Some like gratuity and
bonuses have accrued over past months while others like ter-
minal benefits may relate to past or future months. We make
the distinction between lump sum payments and monthly cash
earnings because the two are treated differently when calcu-
lating income tax.

Refunds are payments made to an employee, e.g. travelling or
subsistence allowances, for business expenses incurred while
on duty. These payments are not income and are therefore
not taxable.
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Payroll Fields

The payroll transactions file is accessed by selecting Payroll
Transactions from the File menu. This displays a data entry
form (figure 3.3) where you enter earnings, deductions, bene-
fits, lump sum payments and refunds for each employee.

" Payroll Transactions File

Recond 1 of 44 DROI Lihenzern, Stephen Asega
Eamings
T Bascpay 7 [ 142,000 .|
Deductions Overtme [ 7 J
Benefits House Allowance [+ 250,000
Luerg Sum Paymerts li
Refunds:
Statubory Deductions
_ Sumay |
Tauable Pay
|—
1,670,000

Figure 3.3: Payroll Transactions File form

Statutory deductions and other calculated amounts such as
taxable pay, net pay and gross pay are updated as data is
entered. This makes the calculations more transparent and
helps to reduce data entry errors.

You can suspend employees from the payroll by deleting them
from the payroll transactions file (Record > Delete). To re-
store a suspended employee use the Record > Add command.

At installation, each payroll transactions file has three earnings
(Basic Pay, Overtime and House Allowance), three deductions
(Rent, Overdraft Recovery and Rounding C/F), one non-cash
benefit (Employer Pension) and one refund (Rounding B/F).
These fields cannot be deleted but you can add more according
to your needs.

To add, delete or edit fields, select Earnings, Deductions, Ben-
efits, Lump Sum Payments or Refunds from the File menu. A
data entry form will be displayed showing the field attributes
listed below (figure 3.4). To add or delete fields select Add or
Delete from the Field menu.

The following field attributes apply to all fields:
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Deduchions

Field 2of 2

Field Hame | Savers Pension

Type  [Penson Contrbuson =]  Parameters...
Amount |Percentage of Sadary | Percentage...

I ¥ Pre-tax deducton
[ oe

Figure 3.4: Deductions form

. Field Name: The name of the field e.g. advance, shift

allowance.

. Type: This is used to indicate permanent fields (e.g. ba-

sic pay and rent). It is also used to specify fields that
are calculated in a unique way (e.g. hourly pay and
daily pay) and those that are associated with a balance
that is updated and displayed by the system (e.g. loan
repayments and co-operative contributions). The type
advance is used to indicate advance payments so that
appropriate reports can be generated.

. Amount: This attribute specifies how the amount paid

to or deducted from each employee is arrived at. It may
be keyed in, a percentage of salary, a function of the time
worked (basic pay, overtime, hourly pay and daily pay)
or amortised (loan repayments).

. Static: Static fields retain their value when a period or

month end procedure is run, whereas non-static fields
are reset to their lower limit. This is only important
for fields that are keyed in. It saves you the trouble of
having to key in the amount earned or deducted each
time a period or month end procedure is run.

. Tazable/Pre-tax deduction: For earnings the taxable at-

tribute specifies whether or not the payment is subject
to PAYE. Unless prior permission has been given by the
URA, all income (i.e. earnings, non-cash benefits and
lump sum payments) must be taxed. Refunds are not
taxable as they are not a form of income.

The pre-tax deduction attribute indicates those deduc-
tions to be subtracted from gross income when calculat-
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ing PAYE.

Depending on the selection for Type and Amount attributes
the following additional attributes may be available:

1. Co-operative: The name of the co-operative associated
with the field (figure 3.5).

Co-operative e
Mame: -

QK Cancel |

Figure 3.5: Co-operative dialog box

2. Pension Fund: The name of the pension fund and other
details pertaining to the current field (figure 3.6).

Pension Fund Parameters 4

Mame |Savers Penmon d OK

Carcel
Employers Contibution -

|:e-'-:n.=rlag—; af Salary ;l
Percantage 5.00
[ Aoply Limke

Lower Limi 0
Upper Limi Ii

Figure 3.6: Pension Fund Parameters dialog box

3. Limits: The upper and lower limits that the amount
paid or deducted should be restricted to (figure 3.7).

Limniits =
Lower Limit ]
Upper Limit 2000000

[ ox | Cancel |

Figure 3.7: Limits dialog box

4. Percentage: The percentage of monthly salary that should
be paid or deducted (figure 3.8).
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| Aoply Limits Cancel
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Figure 3.8: Percentage of Salary dialog box

5. Hourly Rate: The hourly rate to use for earnings that
are of the type Hourly Pay (figure 3.9).

Heurly Rate »

(* Hasic Pay Ratex| 050

" Ky in rata for sach employes
0K Cancel |
Figure 3.9: Hourly Rate dialog box

6. Daily Rate: The daily rate to use for earnings that are
of the type Daily Pay.

Absence and Leave File

The absence and leave file stores details about employees’ ab-
sence from work in the current year. This information is ex-
pressed in terms of absence event records.

In addition, the file keeps an account of annual leave earned
and used up by each employee during the year. It uses leave
event records to track the leave days brought forward from the
previous year and leave days earned, sold and forfeited since
then. Leave taken is treated as an absence event.

The absence and leave file can also be used to track employees’
leave bookings.

To edit this file select Absence and Leave from the File menu
(figure 3.10). The Absence and Leave window has three pages,
i.e., Absence, Annual Leave and Leave Bookings. To edit or
delete an event in any page, first select it and then click on
the Edit or Delete button. To add a new event, switch to the
appropriate page and then click on Add.
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Record 10f 45 DROOT Lihenzero, Stephen Asega
Fram | To | Durstion | Type | 2dd...

13Noy 2020 15Nov 2020 2,00 Sick Leave |_I
iEDec 2020 24Dec 2020 5.00 Anrual Leave Qelete... |

Figure 3.10: Absence and Leave window
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Aren Register produces numerous reports as described below.
These reports can be viewed on the screen and printed out.
You can choose to print the entire report, a range of pages, or
just the page that you are currently viewing. Internal reports
can be sorted by either employee number or name.

You can view and print reports for current and previous pay
periods, months or years. You can also filter most reports by
administrative unit, station, pay group, bank, co-operative or
pension fund.

Reports may be printed on any printer connected to your com-
puter either directly or through a local area network. Because
all reports are formatted for A4 paper, the printer must be set
to print on A4.

1. To open a report select it from the Report menu and then
follow the on-screen instructions. For example, selecting
Report > Payslips opens the Open Payslips dialog box
(figure 4.1).

Open Payslips A

i
- -
Cancel
Pay Period Mt >
* Cumert
7 Previous

Pencd end date

B

Figure 4.1: Open Payslips dialog box

2. To print the open report select Print from the File menu
which brings up the Print dialog box (figure 4.2). Use the
Setup button in this dialog box to configure the printer
you want to use.

3. Choose Close from the File menu to close the report.
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Personnel Reports

Frint *

Prnber;

Micrasolt Print 1o PDF en
PORTEROMET: [ ok |
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Pages to print
. Setup..
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(" Pages
Fram To

Number of Copies: | |

Figure 4.2: Print dialog box

. Posts Reports: List that shows the posts in each admin-

istrative unit of the organisation. You can choose to view
all posts or only those that are vacant.

. Employees Roll: List of employees who are currently ac-

tive. It shows their job title, administrative unit and
station.

. Joiners Roll: List of employees who joined the organi-

sation recently. It shows their job title, administrative
unit, station and start date.

. Leavers Roll: List of employees who left in a given year.

It shows their final job title and administrative unit, the
date they left and the reason for leaving.

. Employee Hierarchy Report: List of employees grouped

according to whom they report to. Employee names are
indented to show the reporting hierarchy. The report
also displays the job tile, administrative unit and station
for each employee.

. Length of Service Report: List of current employees show-

ing their job title, age and length of service.

. Master Report: Report that shows the details of a single

employee as entered in the personnel and payroll master
files. It is available for both current and former employ-
ees.

. Absence Analysis: List of employees that gives a sum-

mary of all absence from work for a specified year.

. Leave Analysis: List of employees that gives a sum-
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marised account of leave earned and used up in a given
year.

10. Leave Booked: List of outstanding leave bookings.

11. Absence Sheet: This report lists, for a single employee,
all absence from work in a given year.

12. Annual Leave Sheet: This report gives, for a single em-
ployee, a detailed account of leave earned and used up
in a given year.

Reports on former employees, absence and leave cover a calen-
dar year. Reports for previous years can be viewed and printed
out, but they cannot be modified in any way. Before running
the month end for December make sure that you verify these
reports.

The remaining reports, i.e. those on posts and current em-
ployees, indicate the state of the organisation at the time of
printing.

Pay Period Reports

Overview Reports

These are reports for a specific pay frequency and cover one
pay period. For a particular pay frequency, reports for the
current pay period are updated as you update the employee
master file and the appropriate payroll transactions file. Re-
ports for previous pay periods can be viewed and printed out,
but they cannot be modified in any way.

1. Payroll Summary: Summarises earnings and deductions
for all employees.

2. Payroll Control Account: T-account listing total earn-
ings, deductions and net pay for all employees in the
organisation.

3. Muster Roll: List of employees showing all earnings,
lump sum payments, refunds and deductions for the pay
period. Records in this report can be grouped by admin-
istrative unit or station.

4. Payroll Variance: List of employees showing the differ-
ences in the payments and deductions made in any two
pay periods. It is essentially the difference between the
muster rolls for the two pay periods.
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The muster roll and payroll variance can be viewed on the
screen or saved to a text file but they cannot be printed out.

Detail Reports

1. Earning Report: List showing, for a particular earning,
how much each employee was paid.

2. Deduction Report: List showing, for a particular non-
statutory deduction, how much each employee was de-
ducted. If the deduction selected is a loan repayment, a
loan report is printed instead.

3. Loan Report: List of employees repaying a specific co-
operative or company loan. It shows the opening and
closing balances and a breakdown of the repayment amount
into interest and principal components.

4. Benefit Report: List showing, for a particular non-cash
benefit, how much each employee received.

5. Lump Sum Report: List showing, for a particular lump
sum payment, how much each employee received.

6. Refund Report: List showing, for a particular refund,
how much each employee received.

Payments to Employees

1. Payslips: Slip giving a breakdown of the earnings and
deductions of each employee separately (figure 4.3). The
employer’s pension contribution and the pension fund
balance can be shown in the payslip if required. When
the balance is shown, it includes the employer’s portion
only if the option to print the employer contribution has
been selected.

2. Cash List: List of employees paid in cash showing their
employee number, name, net pay or advance payment
and a cash analysis of the payment amount.

3. Cheque List: List of employees paid by cheque showing
their employee number, name and net pay or advance
payment.

4. Bank Transfer Report: List of employees who are paid
by bank transfer showing their name, ID number, bank,
branch, account number and payment amount. The pay-
ment amount may be the net pay, an advance payment
or a bank loan repayment.
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Figure 4.3: Payslips

. Labels: Envelope labels for employees paid in cash, by

cheque or by bank transfer. For cash employees, the net
pay can be shown on the label if required.

Coinage Summary Report: List showing the number of
coins and notes of each denomination that are required
for workers who are paid in cash. This information is
the same as the totals in the cash list but formatted so
that it can be used when withdrawing the cash from a
bank.

. Co-operative Report: List of members of a particular co-

operative society showing membership number, monthly
contribution and any other payroll deductions to be paid
to that co-operative.

Pension Report: List of members of a particular pension
fund showing membership number and employer and em-
ployee contributions to that pension fund.

Monthly Payroll Reports

The monthly reports relate to a calendar month. They are:

1.
2.

Payroll Control Account.
Muster Roll.

IR10: Uganda Revenue Authority (URA) monthly tax
return card. It is a list of employees that shows taxable
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income, monthly relief and PAYE for each employee.

4. NSSF Report: List of employees showing the total em-
ployee and employer NSSF contributions.

5. LST Report: List of employees paying local service tax.
For each employee it shows TIN, gross pay and tax payable.

6. Lump Sums Tax Report: List showing tax payable on
lump sum payments for each employee.

7. Low Interest Benefit Report: List of employees who have
received a particular company loan at an interest rate be-
low the statutory rate. It shows the low interest benefit
they have received as a result.

These reports are updated after each period end procedure
and may not be complete until the month end procedure is
run. For the current month, the information displayed covers
the pay periods that have elapsed so far.

Annual Payroll Reports

Annual payroll reports relate to a calendar year and are avail-
able throughout the year. For the current year, the informa-
tion displayed relates to the pay periods that have elapsed so
far. The reports are:

1. Payroll Control Account.
2. Muster Roll.

3. Annual Pay Sheet: A report that, for each employee,
gives a summary of payments, deductions and benefits
for a whole year.

4. P9: URA form titled Taz Deduction Card. Each P9A
gives a breakdown of the income of an employee for each
month of the year and shows the amount of tax deducted.

At the end of each tax year, the employer should submit
to the URA a P9 for each and every employee from whom
PAYE was deducted.

5. P10: URA form titled Employer’s Certificate. It shows
the total tax deducted by the employer for each month
of the year. The employer should submit it to the URA
at the end of each year, together with the P10A.

6. P10A: URA form titled PAYE Supporting List for End
of Year Certificate. It lists the annual income and to-
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Other Reports

Report Files

tal tax deducted for each employee from whom tax was
deducted.

NSSF Statement: A report that shows the monthly NSSF
contributions for a single employee for a calendar year.

. Bank Codes: A listing of banks, bank branches and their

sort codes drawn from the banks files.

. Audit Trail: List that shows the date and time of each

login, backup, month end procedure and any other major
event. It also shows the user responsible for each event.
This report is only available to the supervisor.

Almost all reports are printed from report files, not directly
from the employee data files. Briefly, the report files are:

1.

ek W

Active employees report file

Annual leavers report files

Annual absence and leave report files
Pay period report files

Monthly payroll report files

Annual payroll report files

Report files are updated automatically by Aren Register. Use
the General Options dialog box (Organisation > Options >
General) to specify how long to keep these files for.
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Backing Up

If your data files are accidentally deleted or corrupted you
could lose all your data. Without an up-to-date backup you
would be forced to key in the data for the current month again.
It is also likely that you would be unable to recreate data for
previous months and years. It is therefore very important that
you make regular backups of your data files.

To back up files for the organisation that is currently open, se-
lect Backup from the Procedure menu. You will be prompted
to specify the name and location of the backup file to be cre-
ated (figure 5.1).

-ﬂ Backup =
I « Reglii1Pree 5 Backap wr L Search Back

Creganize = Mew folcer ==l g
Merne [zt modified vpe
s Quick 2coass
o ikems mabch your seerch
Z# Uropbox
i Onellre
I This FC

F Mebsark

File name

Gayve astype  Beckup Files 0.0k

# Hide Folders Cance

Figure 5.1: Backup dialog box

The backup process copies all data relating to the organisation
to the backup file. Should you have set up more than one
organisation, you will need to back up each one separately.
Note that data that is shared by all organisations is not backed
up (e.g. list of banks and statutory deductions parameters).

When running a period or month end procedure you will be
prompted to back up. Though you can choose to proceed
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without doing so, it is recommended that you back up first.
To encourage regular back ups Aren Register prompts you to
back up each time you exit.

Restoring from Backup

In the event that your data files are corrupted or deleted you
will need to recover them from a backup file. You can also
use backup files to revert to an earlier period. This is espe-
cially useful if you accidentally run the period or month end
procedure.

To restore an organisation’s files from backup, select Restore
from the Procedure menu then follow the on-screen instruc-
tions (figure 5.2).

Restore x

Restaring fram backup wil delete al data files
for this argarisation . replacing them with those
n the backup fie. You are encouraged to

j back up these files before continuing

i you ane sune you want fo conbinue, please
erfer your password below

Pazpword

ok | Cared Help

Figure 5.2: Restore dialog box

Creating a Bank Transfer File

A bank transfer file is an electronic version of the bank transfer
report. It is used by banks to process payments for employees
paid by bank transfer in place of the printed bank transfer
report. Aren Register can create bank transfer files for numer-
ous banks including Barclays, Standard Chartered, Stanbic
and Citibank.

1. To create a bank transfer file select Bank Transfer File
from the Procedure menu.

2. In the Bank Transfer File dialog box that appears (figure
5.3), specify the format of the bank transfer file to create
and the name of the payment field (usually net pay).
Depending on the file format, you may be able to specify
the date you want the bank transfer effected.



Terminating an Employee 39

Sawe Bank Transfer File e

Pay Freoquency

(Maresty |

Cancel
:ﬂ'r' PEfD: r‘Eﬂ >
F Cument

" Previous

Period end date

E

Figure 5.3: Save Bank Transfer File dialog box

3. After closing the Bank Transfer File dialog box, a new
dialog box appears. Use this dialog to specify the name
and location of the file to be created.

For further details on bank transfer files please contact your
bank.

Terminating an Employee

To terminate an employee, open the personnel file and display
the target employee. Next, select Terminate from the Record
menu. In the Terminate dialog box that appears (figure 5.4),
enter the termination date, the reason for leaving and, if you
like, some brief comments.

Terminate Lihenzera, Stephen fsega A
Temination Date | oK
NN22020 hd Cancel
Reason far Leaving
Remarke:

Figure 5.4: Terminate dialog box

The terminated employee will be removed from the employee
data files in the next month end procedure that is later than or
on the same day as his termination date. Once the employee
is deleted from the employee data files his record will be added
to the leavers report file.
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Termination can be reversed by selecting Record > Undo Ter-
mination as long as the terminated employee has not been
removed from the employee data files.

Period End Procedure

The period end procedure is used to close data entry for the
current pay period and begin a new one. The procedure does
the following:

1.

This

Saves all payroll information for the current pay period
to the period, monthly and annual payroll report files.

Deletes the existing payroll transactions file and creates
a new one for the next pay period.

. Advances the period end day to the last day of the next

pay period.

procedure should only be run after all reports for the

current pay period have been verified since, once it is run,
reports for this pay period cannot be changed.

To run the procedure:

1.
2.

4.

Check that the correct pay frequency is set as default.

Select Period End from the Procedure menu. This option
is only available if you have licensed the organisation.

. After reading the dialog box that appears (figure 5.5),

confirm that you want to close the pay period stated by
entering your password.

Period End Procedure A

Runining the pesad end procedure wil doss
the payral for the weak ending 4 December

j 2020

i you ane sune you want fo continue, please
erer your password below

FPasword

oK | Canesl Helg

Figure 5.5: Period End Procedure dialog box

You will now be prompted to back up your data and are
strongly encouraged to do so.
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5.

Month End Procedure

Once the back up is complete, the period end procedure
will automatically follow and eventually a message box
confirming its completion will appear.

The month end procedure is used to close data entry for the
current month and begin a new one. It applies only to the
organisation that is currently open. It does the following:

1.
2.

Runs the period end procedure for each pay frequency.

Advances the date by one month such that all pay peri-
ods end in the following month.

If the new month is July, it creates statutory deduction
files for the new tax year.

If the new month is January, it deletes all events in the
absence and leave file for the previous year. A new event
for leave days brought forward is also added to the file.

. Adds leave earned in the new month to the absence and

leave file.

. Transfers terminated employees from the personnel file

to the leavers report file.

Deletes any report files that have exceeded the maximum
age set in the General Options dialog box.

The procedure can only be run if, for each payroll that has
data, the forthcoming pay period ends in the next calendar
month. This is because, after the procedure is run, all pay
period end days will fall in the new month. In December the
month end procedure cannot be run if there are outstanding
leave bookings for the year that is ending.

To run the procedure:

1.

Select Month End from the Procedure menu. This op-
tion is not available if you have not licensed the organi-
sation. It is also not available if the next pay period for
the default pay frequency does not end in the following
month.

. After reading the dialog box that appears (figure 5.6),

confirm that you want to close the month by entering
your password.
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Figure 5.6: Month End Procedure dialog box

3. You will now be prompted to back up your data and are
strongly encouraged to do so.

4. Once the back up is complete, the month end proce-
dure will automatically follow. Eventually, a message
box confirming its completion will appear.

The Month End Procedure should be run with care since it
cannot be reversed except by restoring from backup. This is
especially true in December when it will close entry of absence
and leave data for the year that is ending.
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Employee Data

File Format

Keying in new employees into the payroll can be very time
consuming especially if there are many of them. As an alter-
native, you can import employee data into the personnel file
from a text file.

The easiest way to create the input text file is to capture em-
ployee data in a spreadsheet and then save the spreadsheet as
a text file.

The format of the input text file is as follows:

1.

Plain text with data items separated by the tab character
(i.e. a tab-separated text file).

The first row of data is a header with the data items
Employee Number, Last Name, Other Names, ID Num-
ber, Job Title, Admin Unit, Station, Pay Rate, TIN and
NSSF Number.

From row two onwards, each row has data for a single
employee, i.e. employee number, last name, other names,
ID number, job title, administrative unit, station, pay
rate, TIN and NSSF number.

Note that:

1.

The first row (file header) is ignored. It is only included

for the convenience of the person preparing the input
file.

A row will not be imported if the employee number
matches that of a record already in the personnel file.

. A row will also be skipped if any of the following data

items is blank: employee number, last name, other names,
job title, administrative unit, station.

Data will be imported into several files—personnel, pay-
roll master, payroll transactions, leave, jobs, adminstra-
tive units and stations.
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How to Import

. Where a default profile has been defined, it will be ap-

plied to each record added to the personnel file.

. Make sure you are in single-user mode. If not, switch to

this mode by selecting System > Single-User Mode.

. Back up your data just in case you need to undo the

changes you are about to make (Procedure > Backup).

. Select Procedure > Import > Employees to open the

first Import Employees dialog box (figure A.1).

Imiport Mew Employees e

mpaiting employes data from a text file may
modfy several data filea. k iz advisable to
j back up your data before continuing
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erer your password below

Pasmword [

ok | Carce Help

Figure A.1: First Import Employees dialog box

. Enter your password to open the second Import Employ-

ees dialog box.

. Browse to the text file that you want to import data

from and click on Open.

. Aren Register will read the text file and update sev-

eral data files—jobs, administrative units, stations, per-
sonnel, payroll master, payroll transactions and leave.
On completion, a confirmation message box will be dis-
played. Close the message box.

. To see which records were updated, refer to the log file

import.log located in the payroll data folder. Browse
through the data files that should have been updated to
confirm that they were updated successfully.

Time and Attendance Data

Aren Register can import time and attendance data from a
text file. This provides a quick way of capturing the data gen-
erated by a clocking system. Because the format of the input
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Employee Name Basic Normal Double
Number Pay Overtime Overtime
001 NAGESA, Esther 0.5 10 3.5
002 MAGALA, Richard O 0 8
003 NAMALE, Agnes 1.5 8 4
004 KASANA, Joe 2 0 0

File Format

Interpretation

Table A.1: Time and attendance data format

file is

standard, Aren Register will work with any clocking sys-

tem provided that the data it generates can be converted to
the required format. An input file can also be created by key-
ing in time and attendance data into a spreadsheet and then
saving it as a text file.

The input text file should have the following format:

1.

Plain text with data items separated by the tab charac-
ter.

. The first row of data is a header with the data items

Employee Number, Name, Basic Pay, Normal Ouvertime
and Double Overtime.

From row two onwards, each row has data for a sin-
gle employee, i.e. employee number, name, basic pay
time worked, normal overtime hours and double over-
time hours.

Table A.1 is a simple example of the format required.

The data is interpreted as follows:

1.

The first row (file header) and the second column (em-
ployee name) are ignored. They are included for the
convenience of the person preparing the input file.

. The employee number in column one determines which

record in the payroll will be updated. It must match the
employee number in the payroll transactions file exactly,
except for the case which is ignored.

. The data in column three (basic pay) could be hours

worked, hours absent, days worked or days absent. Its
interpretation depends on the settings for each employee
in the payroll master file. If an employee is paid a fixed
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salary irrespective of the time worked, this value is ig-
nored.

4. Columns four and five contain normal and double over-
time hours, respectively. For a given employee, if over-
time is not enabled the data is ignored.

How to Import

Here is how you import time and attendance data into the
default payroll transactions file.

1. Make sure you are in single-user mode. If not, switch to
this mode by selecting System > Single-User Mode.

2. Back up your data just in case you need to undo the
changes you are about to make.

3. Select Procedure > Import > Attendance to open the
Import Time and Attendance Data dialog box (figure
A2).

4. Browse to the text file that you want to import data
from and click on Open.
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Figure A.2: Import Time and Attendance Data dialog box

5. Aren Register will read the text file and update the de-
fault payroll transactions file. On completion, a message
box showing the number of records updated will be dis-
played.

To review the imported data, open the basic pay, normal over-
time and double overtime reports (Report > Breakdown). You
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should also review the log file tmport.log located in the payroll
data folder.
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Appendix B Emailing Payslips

Aren Register can email payslips to each of the employees in
the payroll. This provides an alternative to printing individual
payslips for each employee. Payslips are sent as password-
protected PDF files.

Entering Email Addresses

Start by capturing the email addresses to send employee payslips
to.

1. Open the payroll master file (File > Payroll Master) and
select the options tab (figure B.1).

Payroll Master File
Record 1 of 45 DRO01 Lihenzern, Stephen Asega

. Emanl payshps to:
Basic Pay
asegai@demorestaurant. co.ug
" owme ||

Figure B.1: Payroll Master File form

2. For each employee, enter the address to email payslips
to.

3. Close the payroll master file.

Setting Up Email Account

In order to send email, you need to set up your email account.
For this you require details of the outgoing mail server, also
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known as the SMTP server. Consult your IT department if
necessary or check the settings in the email software you use.

1. Select System > Email Account to open the Email Ac-
count dialog box (figure B.2).

Ernail Account

Emai Address [l"fc- Edemorestaurant.co.ug K I
Cancel

Help

X

SMTF Seryer | mai.demorestaurant, oo.ug

SMTP Poet | 25

[# Ui secure connecton

Ay thentication | ogin ﬂ

Account Mame | info@demorestaurant.co.ug

EENEEEEEE

Paszword

[T Copy all emais to self

Figure B.2: Email Account dialog box

2. Email Address: Enter your email address, say info@-
demorestaurant.co.ug or example@gmail.com.

3. SMTP Server: Enter the name of the outgoing mail
server, e.g. mail.demorestraurant.co.ug or smtp.gmail-
.com. You can also enter the server’s IP address, e.g.
192.168.0.23.

4. SMTP Port: The SMTP port is a unique number that
the mail server has set aside for outgoing mail. The most
common values are 25, 465 and 587. If your server uses
a secure (encrypted) connection, e.g. smip.gmail.com or
smip.mail.yahoo.com, try port 465 or 587. If it does not,
enter 25.

5. Use secure connection: Check this option if the mail
server uses a secure connection.

6. Authentication: You may select none (no account name
or password required), plain or login (requires account
name and password).

7. Account Name and Password: Enter the login name and
password for the mail server if you have selected login or
plain authentication.
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8. Copy all emails to self: Check this option if you want to
receive a copy of all the payslips you send.

9. Close the Email Account dialog box.

Sending Payslips
Now you are ready to email payslips to employees.

1. Select Procedure > Email Payslips to open the Email
Payslips dialog box (figure B.3).

Email Payslips A

Pay Freguen

i
(T - |

Pay Peiod Mext >

* Cument
': ) F"E'\'DGLE

Pencd end date

B

Figure B.3: First Email Payslips dialog box

2. Choose the pay period that you want then click OK. This
opens another dialog box with the same title (figure B.4).

3. Click on Send to open the Message Range dialog box
(figure B.5).

4. Use the Message Range dialog box to send the current
message, all messages or a range of them. On comple-
tion, a message box showing the number of messages sent
will be displayed.

5. Close the Email Payslips dialog box when you are through.

Details of the last mail session are saved in the log file email.log
located in the payroll data folder. Refer to this file if you have
any difficulty sending messages and to see which messages were
actually sent.

How to Open Payslips

Once a payslip is sent, the recipient will need a password to
open it. Each payslip has two passwords:
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Payslip Messages

x
J J Messape 1 of 45 j ﬂ
Send To; | 2oega@demonas taurant. oo.ug Send.

Subject; | Paysip for December 2020 Choes

Help |
ME‘FEWE': Diear Shepien,

Your payslip for December 2020 s attached. You can save, view
and print it &l your converESnce,

Regards,

Demo Restaurant Lbd

Attachment: |Dems Rastaurant Led

Payslip for December 2020

Employes Number: DROOL

H ammi - Lihenzero, Staphan Asaga
Admin. Unit: AcTounts

Figure B.4: Second Email Payslips dialog box

Message Range

Send:

% Curent Message

&l

Cancel
™ all Messages

" Messages

Fram: I_ Ta: I_

Figure B.5: Message Range dialog box

1. Owner Password: The last four digits of the organisa-
tion’s TIN. For instance, if the organisation’s TIN is
0123456789, the owner password will be 6789. Should
the organisation’s TIN be blank, the default password is
owner.

2. User Password: The last four digits of the employee’s
TIN. Where the employee’s TIN is missing, the default
password is user. This is the password that employees
should use.

You can modify the message that is sent to employees to in-
clude help on the password they will use to open the payslip.

1. Go to Organistion > Options > Reports to open the
Report Options dialog box (figure B.6).
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Report Options

Abgenoe AnayEis -
Absence Sheets

Benefits

Cash List

Chegue List Clos=
Campariy Loan

Caontrol Acoount

[ Opliane.. .

i

Co-pperative Loan
Creductions

Earm EE

il
Emoloves Master
Employees Roll
Haurly Pay
Joirers Rol
Lahels
Leawve Analysis
Leave Booked u-

Figure B.6: Report Options dialog box

2. Select Electronic Payslips and click on Options. This
opens the Electronic Payslips Options dialog box (figure
B.7).

Electronic Payslips Options x
Message

I Inchude password help

Sart By
* Emplayee Number
™ Mame

Figure B.7: Electronic Payslips dialog box

3. Check the option Include password help.
4. Close the Electronic Payslip Options dialog box.
5. Close the Report Options dialog box.
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Appendix C Formulae

Loans

Amortisation

Reducing Balance

The loan payment amount is uniform throughout the repay-
ment period. The portion of the payment amount that goes
towards repaying the principal increases with time as interest
payments reduce.

]
I—(1+r)"

Payment = l

where W = principal amount, n = total number of payments,
r = monthly interest rate (e.g. if annual interest rate is 15%,
r = (15/100)/12 = 0.0125).

The amount paid towards the principal is fixed throughout the
loan duration while interest payments reduce with time. Thus
the total payment amount reduces with time.

1
Payment = W' (/ + 7’)
n

where W’ = outstanding balance, n’ = number of payments
outstanding, » = monthly interest rate.



